Jump to content

Beta - 1080p Samsung Client


Recommended Posts

This might be a stupid question, but does this and the SD-version share code-base? Like, are the same things fixed, and new features added, in both at the same time, so it is only the resolution and the size of images that changes?

Yes, at the moment the code base is mostly the same. That's why the version numbers are similar. 1.0.4 = 2.0.4 in bug fixes for things other than the user interface, like subtitles.

The difference is that not only does 2.x have higher resolution but it no longer has the limitation of supporting D-Series. So we can now add HTML5 and CSS3 features that we could not before. The animated DVD disk for instance.

  • Like 1
Link to post
Share on other sites

Hey

 

Just installed this on my H-series. It is looking beautiful! It does lag a lot, though, but that must be all the waiting for higher resolution images or something. I don't really understand why my TV generally has such bad performance (it's also a bit laggy in some of the native menus), when it has a quad-core processor.

 

That being said, it looks like whenever I switch up/down in the 3-row-views, so a new row becomes visible, it reloads ALL the images, and not just the ones for the new row. It takes about a second to load a new row because of this, and it looks...not good. I can't remember if it was like this in the SD version, or if I just didn't notice because the images were smaller, so it went quicker. It seems like a waste of bandwidth and processing power, to reload everything for each row change.

EDIT: Yeah, SD version does that as well. Much more evident, dealying and annoying on the HD version.

 

Even without it changing rows, it takes about 500-1000ms to move from one title to the next. That's unbearable, so I will be going back to the SD version.

 

Beautiful work on the app, though! It looks fantastic!

Your server is generating and caching new, bigger versions of every image. It gets better after you've spent a little time with it. However, the performance is not as smooth as the lower resolution. I am trying to limit the load on the TV processor and learn to work with it the best we can.

  • Like 3
Link to post
Share on other sites

Thanks for that explanation.

 

Any idea why it is running so poorly on my H-series? Is that just the way it is for everyone on H-series?

Link to post
Share on other sites

Thanks for that explanation.

 

Any idea why it is running so poorly on my H-series? Is that just the way it is for everyone on H-series?

If your timings are accurate then it's much worse than my F-Series where the lag is hardly noticeable. All I see if a slight jagging if it's doing more than one thing at the same time (which I can code out) and the menu open/close is a bit abrupt.

Link to post
Share on other sites

If your timings are accurate then it's much worse than my F-Series where the lag is hardly noticeable. All I see if a slight jagging if it's doing more than one thing at the same time (which I can code out) and the menu open/close is a bit abrupt.

That sounds like how the SD version runs on my H-series.

 

I gotta read up on performance problems with my TVs. They're both H-series, and run the HD version very, very sluggishly.

Link to post
Share on other sites
shorty1483

That sounds like how the SD version runs on my H-series.

 

I gotta read up on performance problems with my TVs. They're both H-series, and run the HD version very, very sluggishly.

The more the HD version is used, the better it gets.

 

Also know what you mean. Even the Smart Hub on my TV is sluggish. The general UI handling is not well done by Samsung, and since smart hub update it's worse.

 

Gesendet von meinem HTC One M8 mit Tapatalk

Link to post
Share on other sites
FrostByte

I noticed mine was a little slower tonight after I installed the cover art plugin.  It was really really slow the first time I went through my collections and got better the second time through after it had cached the images, but it still felt slower than before I added the plugin.  I thought everything was fairly quick before the plugin since cmcg added that change of the menu

Edited by FrostByte
Link to post
Share on other sites

I'm using the E-Series without an Evolution kit, so it only has the Dual Core processor.  I've not noticed it to be much slower than the non-1080 version,  (maybe that's because it was always slow in comparison to the Quad cores and the extra overhead of pulling hi-res images from the server is negligible).

 

Having said that, it is definitely usable without causing a bad user experience, so I'm surprised that you are having such a bad performance on the F-Series.  This makes me think the issue is not the TV performance but more likely the server struggling to remake the images?  There is no way I would consider going back on this model (and loose the spinning disc!)

Link to post
Share on other sites
FrostByte

There is no way I would consider going back on this model (and loose the spinning disc!)

 

Lol, the only reason I loaded the CA plugin was because of the disc.  It just didn't look right popping out of a plain poster

  • Like 1
Link to post
Share on other sites

2.0.5b
New media icons for 3D Side-by-Side and 3D Top-and-Bottom.
Correct 16:9 media icon now used.
Fixed: 3D media icon displayed twice.
Fixed: Spinning disk appears before the cover art.
Fixed: Subtitles truncating letters when text ends with a newline.
Episode details page now shows correct season poster.

 

These changes are mostly the same as 1.0.5 except for a little subtitle fix that was already in the SD version and a tweak to the timing of the backdrops and spinning disk on the item details page that makes it a little smoother and avoids the disk appearing before the poster.

Edited by cmcg
  • Like 5
Link to post
Share on other sites

It's the H-series which are apparently slow. I have quite a powerful server, but only 100mbit switches. But then, my TVs only have 100mbit, unless I am much mistaken.

Link to post
Share on other sites
shorty1483

It's the H-series which are apparently slow. I have quite a powerful server, but only 100mbit switches. But then, my TVs only have 100mbit, unless I am much mistaken.

 

Isn't the latest version much more fluid on you device?

Link to post
Share on other sites

The more the HD version is used, the better it gets.

 

Also know what you mean. Even the Smart Hub on my TV is sluggish. The general UI handling is not well done by Samsung, and since smart hub update it's worse.

 

Gesendet von meinem HTC One M8 mit Tapatalk

Same here........even native samsung menues are a little bit laggy.

Probable is just the H's firmware or something.

 

The HD app is absolutely usable for me. I'm not going back to the sd version. No fu......ing way. :)

 

 

Sent from my iPad using Tapatalk

Edited by fc7
  • Like 4
Link to post
Share on other sites
SilentAssassin

I think someone has mentioned it but the OSD during playback is messed when watching a 3D movie, it's like it is twice the size it should be.

Link to post
Share on other sites
shorty1483

I think someone has mentioned it but the OSD during playback is messed when watching a 3D movie, it's like it is twice the size it should be.

 That's new to me :D I just have it invisible (H-TAB) or in correct position (H-SBS) :D

Link to post
Share on other sites

2.0.6
Show missing icon on the home page.
Fixed: Hang when pressing play on missing items on the home page.
Settings page style updated.
Player tools menu style updated.
Fixed: Italic subtitle size set incorrectly.

 

Fixed a few of your bug reports here and improved some of the UI. I think we'll drop the beta tag. 2.x is no less stable than 1.x.

We'll move 2.x to the stable thread soon, but I'd quite like to still offer the 1.x version for D series users. Does anyone have a webserver with a (reasonably) static IP address that it could live on?

Edited by cmcg
  • Like 4
Link to post
Share on other sites
FrostByte

I like the rounded edges in the app settings pages :)

 

Btw: did the server IP page recently just go to 1080P?  The box is really small and almost hard to see the number you type in the boxes.  Don't recall them being that small in 2.0.5

Link to post
Share on other sites
FrostByte

The pic has a glare from the window so you can't see the text.  I was like 2 feet away from the tv, so the box doesn't look that small from this distance.  I just know I can barely read it form my couch any more it's so small.  Not a biggie, I can live with it.  Thanks

 

569fb9484007b_WP_20160120_003.jpg

Link to post
Share on other sites

Oh yes, I see now. It's to do with the way that I changed inheritance of font sizes when fixing the italic subtitle size bug. I'll have to make a change there in the next update. Thanks for the heads up.

  • Like 1
Link to post
Share on other sites

Looks like that font size bug will show up in quite a few places. Search, Add To Playlist, Upcoming TV.

 

I'll start a thread...

  • Like 1
Link to post
Share on other sites

2.0.7
Note: this release will reset your settings file.
Latest Movies and TV views now respect the user home page setting "Hide watched content from latest media".
Fixed: Some Font Sizes Much Smaller After 2.0.6 Update 
Fixed: TV/Movie genre posters too small.
Fixed: TV/Movie poster image cropped in OSD.

  • Like 3
Link to post
Share on other sites
FrostByte

2.0.7

Latest Movies and TV views now respect the user home page setting "Hide watched content from latest media".

 

Any chance of getting this added to the Server Settings page also?  Thanks

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...