Jump to content

Tvheadend plugin for Emby - Beta 1


Tolotos
 Share

Recommended Posts

freebs

yay!! i finally got it working!!!

 

 Jun  2 23:36:06 HTPC tvheadend[1180]: subscription: 001D: "HTTP" subscribing on channel "106 TVLAND", weight: 100, adapter: "Genpix DVB-S : DVB-S #0", network: "Dish119", mux: "12399R", profile="webtv-h264-aac-mpegts", hostname="127.0.0.1", client="Lavf/56.25.101"

Jun  2 23:36:07 HTPC tvheadend[1180]: libav: Invalid frame dimensions 0x0.
Jun  2 23:36:07 HTPC tvheadend[1180]: message repeated 24 times: [ libav: Invalid frame dimensions 0x0.]
Jun  2 23:36:07 HTPC tvheadend[1180]: libav: ignoring invalid SAR: 20/17
Jun  2 23:36:07 HTPC tvheadend[1180]: libav: warning: first frame is no keyframe
Jun  2 23:36:07 HTPC tvheadend[1180]: libav: using SAR=20/17
Jun  2 23:36:07 HTPC tvheadend[1180]: libav: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX
Jun  2 23:36:07 HTPC tvheadend[1180]: libav: profile Main, level 2.2
Jun  2 23:36:07 HTPC tvheadend[1180]: libav: 264 - core 142 - H.264/MPEG-4 AVC codec - Copyleft 2003-2014 - http://www.videolan.org/x264.html - options: cabac=1 ref=2 deblock=1:0:0 analyse=0x1:0x111 me=hex subme=4 psy=1 psy_rd=1.00:0.00 mixed_ref=0 me_range=16 chroma_me=1 trellis=1 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=0 threads=4 lookahead_threads=4 sliced_threads=1 slices=4 nr=0 decimate=1 interlaced=0 bluray_compat=0 constrained_intra=0 bframes=0 weightp=1 keyint=25 keyint_min=2 scenecut=40 intra_refresh=0 rc=crf mbtree=0 crf=23.0 qcomp=0.60 qpmin=10 qpmax=30 qpstep=4 ip_ratio=1.41 aq=1:1.00
Jun  2 23:36:07 HTPC tvheadend[1180]: libav: muxrate VBR,
Jun  2 23:36:07 HTPC tvheadend[1180]: libav: pcr every 1 pkts, sdt every 200, pat/pmt every 40 pkts
Jun  2 23:36:11 HTPC tvheadend[1180]: http: 127.0.0.1: using ticket AF196D42B13A912C8E09ACA4608BCD0167110703 for /stream/channelid/935325153
Jun  2 23:36:11 HTPC tvheadend[1180]: subscription: 001E: "HTTP" subscribing on channel "106 TVLAND", weight: 100, adapter: "Genpix DVB-S : DVB-S #0", network: "Dish119", mux: "12399R", profile="webtv-h264-aac-mpegts", hostname="127.0.0.1", client="Lavf/56.25.101"
Jun  2 23:36:11 HTPC tvheadend[1180]: webui: Stop streaming /stream/channelid/935325153?ticket=AF196D42B13A912C8E09ACA4608BCD0167110703, muxer reported errors
Jun  2 23:36:11 HTPC tvheadend[1180]: subscription: 001D: "HTTP" unsubscribing from "106 TVLAND", hostname="127.0.0.1", username="Lavf/56.25.101"
Jun  2 23:36:11 HTPC tvheadend[1180]: transcode: 0004: Detected framedrop in audio
Jun  2 23:36:12 HTPC tvheadend[1180]: libav: muxrate VBR,
Jun  2 23:36:12 HTPC tvheadend[1180]: libav: pcr every 1 pkts, sdt every 200, pat/pmt every 40 pkts
Link to comment
Share on other sites

johnodon

TVH Plugin v1.0.5628.29938

 

@@Tolotos

 

Honestly, I am not sure if this is a server plugin issue, a client side issue (HTTP) or a configuration setting that I missed.

 

Is there a way to have the EPG and channel list display subchannels rather than use the parent channel #?  i.e. in the screenshot below, MeTV should be 2.1, Grit should be 2.2, Escape should be 2.3, etc.

This would also help put the channels in proper order by number.

 

In Kodi I can tell it to do this by using channel #s from the backend.

 

 

lHv3ybM.jpg

 

ro7klpR.jpg

Edited by johnodon
Link to comment
Share on other sites

Tolotos

@@johnodon I assume you are using a version of tvheadend higher than 3.4.27. This is the highest version the plugin supports (HTSP version 10).

With HTPS version 13 the ability for <channelNumber>.<channelNumberMinor> was added. 

 

I tried earlier to support the newer unstable versions of tvheadend (higher HTSP versions) but this versions showed strange behaviors as a value which is defined as a integer was delivered as a string in one version. 

This and the fact that questions in the tvheadend forum are not answered makes it impossible for me to support new features of unstable tvheadend versions. 

 

With the additional knowledge that the original author of tvheadend is planning to switch the licence of tvheadend to a licences owned by his new founded company and several co programmers are not agreeing this license change the future of this great piece of software is not really good. 

 

-- Tolotos

  • Like 2
Link to comment
Share on other sites

im85288

@@johnodon I assume you are using a version of tvheadend higher than 3.4.27. This is the highest version the plugin supports (HTSP version 10).

With HTPS version 13 the ability for <channelNumber>.<channelNumberMinor> was added. 

 

I tried earlier to support the newer unstable versions of tvheadend (higher HTSP versions) but this versions showed strange behaviors as a value which is defined as a integer was delivered as a string in one version. 

This and the fact that questions in the tvheadend forum are not answered makes it impossible for me to support new features of unstable tvheadend versions. 

 

With the additional knowledge that the original author of tvheadend is planning to switch the licence of tvheadend to a licences owned by his new founded company and several co programmers are not agreeing this license change the future of this great piece of software is not really good. 

 

-- Tolotos

 

That is a shame, I think the author (adam sutton?) has been a bit dis heartened for quite a while. In the last year or so though he (with co developers) did create a much better kodi plugin (supporting time shift properly etc) and the actual tvheadend server has improved with how it's laid out etc. Personally I love this backend, runs perfectly on network tuners such as MOI and now thanks to your plugin works with Emby so hopefully things get resolved in the tvheadend world.

  • Like 1
Link to comment
Share on other sites

johnodon

@@johnodon I assume you are using a version of tvheadend higher than 3.4.27. This is the highest version the plugin supports (HTSP version 10).

With HTPS version 13 the ability for <channelNumber>.<channelNumberMinor> was added. 

 

I tried earlier to support the newer unstable versions of tvheadend (higher HTSP versions) but this versions showed strange behaviors as a value which is defined as a integer was delivered as a string in one version. 

This and the fact that questions in the tvheadend forum are not answered makes it impossible for me to support new features of unstable tvheadend versions. 

 

With the additional knowledge that the original author of tvheadend is planning to switch the licence of tvheadend to a licences owned by his new founded company and several co programmers are not agreeing this license change the future of this great piece of software is not really good. 

 

-- Tolotos

Correct...

 

HTS Tvheadend 4.1-41~gef5b43a

 

Oh well.  I hope you eventually get some support.  It must be possible as I can get sub-channels in the Kodi plugin.

 

John

Link to comment
Share on other sites

  • 2 weeks later...
im85288

Is it possible to clear the cache of channel icon images? I updated mine recently and for some reason the Emby server is holding onto the old versions :(

Link to comment
Share on other sites

Tolotos

The plugin don't cache the icons. I get the URL from tvheadend and give it to emby without any changes.

Do you use a local proxy which maybe caches the icons? 

@@Luke is Emby caching the channel icons and how can this cache be cleaned?

-- Tolotos

Edited by Tolotos
Link to comment
Share on other sites

im85288

No, there is no local proxy or anything involved. 

 

`The new channel icons are picked up on all other clients (Kodi etc) it's just Emby which has cached the old ones with seemingly no way to refresh them.

 

Hopefully @@Luke knows how to resolve this thanks.

Link to comment
Share on other sites

yes because without a cache it would just download the same ones over and over since there's no way to know if they changed.

Link to comment
Share on other sites

pauld70

Any ideas why my recordings are not shown on the FireTV app or in the web interface. The recording is there when using Kod

 

P1gT5.jpg

 

G1Mpm.jpg

Link to comment
Share on other sites

im85288

yes because without a cache it would just download the same ones over and over since there's no way to know if they changed.

 

Is there a way as a one off I can clear the cache? I do not want to keep seeing the icons that are wrong repeatedly when I'm using Emby. 

Link to comment
Share on other sites

  • 2 weeks later...
draggy

@@gstuartj Please test the new dev version 1.0.5628.29938 in the catalog. There is a new setting for the channel type to use for 'Other'.

But the best way is to set the correct channel type in tvheadend.

-- Tolotos

I also have this issue, plugin version 1.0.5628.29938, emby version 3.0.5641.5, tvheadend version 3.4.28~geb79aee~trusty 

 

I have it set to treat Other as TV in the plugin settings but it still complains about it in the log and won't fill my guide:

2015-06-29 11:25:41.7118 Error - App: [TVHclient] ChannelDataHelper: don't map service type 'Other' - will be ignored.

 

2015-06-29 11:25:41.7118 Error - App: [TVHclient] ChannelDataHelper: unable to detect service-type from service list:

 

I would like to change the channel type in tvheadend, but you can't. It's a read only field and it won't let you change it.

Edited by draggy
Link to comment
Share on other sites

Tolotos

@@draggy

 

Please use the "Channel Tags" page of the tvheadend gui to create the following tags: "SDTV", "HDTV" and "Radio"

In the "Channels" page of the tvheadend gui you can now assign these tags to your channels.

 5592cf6a1e78f_ChannelTags.png

 

5592cf875b512_Channels.png

  • Like 1
Link to comment
Share on other sites

draggy

Thanks, that did the trick. I was looking at the DVB Inputs/Services/Type because the log said "unkown service type"

Link to comment
Share on other sites

blublub

Hi his there any news on the plugin? Are you getting help from TVH?

 

I tried it with TVH 4.1 and it just won't work properly.

Link to comment
Share on other sites

gstuartj

I don't think the situation on newer versions of TvHeadend has changed since this post:

@@johnodon I assume you are using a version of tvheadend higher than 3.4.27. This is the highest version the plugin supports (HTSP version 10).I tried earlier to support the newer unstable versions of tvheadend (higher HTSP versions) but this versions showed strange behaviors as a value which is defined as a integer was delivered as a string in one version... This and the fact that questions in the tvheadend forum are not answered makes it impossible for me to support new features of unstable tvheadend versions.

 

The TVH plugin is pretty functional with the stable 3.x branch.

Link to comment
Share on other sites

blublub

Mhh then we will have to wait till it goes final.....whenever that will happen

Link to comment
Share on other sites

Karbowiak

Hi!

I'm getting a weird error when it's trying to download the logos.

I can fine wget the logos from the server, or load them from the same IP using my desktop, laptop and tablet.
But for some reason, Emby thinks it's banned?!

2015-07-12 00:39:43.0549 Info - App: HttpClientManager GET: http://logos.xmltv.se/two.tv3sport.dk.png
2015-07-12 00:39:43.0870 Error - App: Error getting response from http://logos.xmltv.se/two.tv3sport.dk.png
        *** Error Report ***
        Version: 3.0.5666.8
        Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/mediabrowser -ffmpeg /usr/bin/ffmpeg -ffprobe /usr/bin/ffprobe
        Operating system: Unix 3.18.3.2
        Processor count: 4
        64-Bit OS: True
        64-Bit Process: True
        Program data path: /var/lib/mediabrowser
        Mono: 4.0.1 (tarball Tue Jun  2 13:06:11 UTC 2015)
        Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
        The remote server returned an error: (403) You are banned from this site.  Please contact via a different client configuration if you believe that this is a mistake..
        System.Net.WebException
          at System.Net.HttpWebRequest.CheckFinalStatus (System.Net.WebAsyncResult result) [0x00000] in <filename unknown>:0
          at System.Net.HttpWebRequest.SetResponseData (System.Net.WebConnectionData data) [0x00000] in <filename unknown>:0

Link to comment
Share on other sites

@karbowiak  posted same issue quite some time ago, it was working fine it earlier release of emby/tvheadend plugin.

Link to comment
Share on other sites

Karbowiak

@karbowiak  posted same issue quite some time ago, it was working fine it earlier release of emby/tvheadend plugin.

 

oh, oops, didn't see that :D

Hopefully it's an easy fix tho!

Link to comment
Share on other sites

Tolotos

Hi,

As I wrote in post 92 this issue can not be solved through the plugin. 

Emby code must be changed to send an user agent in the HTTP header. 

http://logos.xmltv.se changed their service to bann requests without this meta data.

-- Tolotos 

Link to comment
Share on other sites

blublub

Hi

 

What profile settings do I need in TVH for my emby user - streaming, advanced streaming etc...

 

thx

Link to comment
Share on other sites

davidhardin

Can someone tell me where the log file for emby is located?

 

I am having an issue with my tuners showing up.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...