Jump to content

Live TV not playing on Kodi


LuxTux
 Share

Go to solution Solved by quickmic,

Recommended Posts

LuxTux

Hello,

im trying to watch live tv via the emby-next-gen addon (6.2.15). Unfortunately this fails. When I select a channel on kodi (19.4), i get a spinning wheel, followed by the error message: One or more items failed to play. Check the log for more information about this message.

when i try and play the same channel on my android phone with the emby app it plays fine. I even installed the kodi app on my phone to see if the behaviour would be different but I get the same error. the same error happens when I install the emby-next-gen addon from the emby beta repository.

I have included the debug kodi log and the debug emby server log. i start the stream at 22:49. sorry i did not find the option in emby-next-gen addon to enable debug logging

embyserver-63790325406.txt kodi.log

Link to comment
Share on other sites

quickmic

There is no option for debug logging for emby plugin. I uses the the setting from Kodi, that's fine.

I see you use hls streams for live TV. SO the live TV seems not coming from a DVR. Looks like you use a internet streams, right? Is this a public m3u playlist you added to Emby server. Can you send me a link for further testing?

Link to comment
Share on other sites

LuxTux

Correct this is m3u list and an xml epg from an internet service. I generated a m3u list for you. ill send it to you via DM.

Link to comment
Share on other sites

quickmic

Thank you, I'll perform some tests with the playlist. Very sure the issue is related to hls streams which is supported by the plugin but I think not for live TV at the moment.

Link to comment
Share on other sites

LuxTux

you mean the live tv on the emby server? weird as it does play in my browser or the emby app without any hickups as you can see in the attached log from the server

embyserver-63790362885.txt

Link to comment
Share on other sites

quickmic
Posted (edited)
4 minutes ago, LuxTux said:

you mean the live tv on the emby server? weird as it does play in my browser or the emby app without any hickups as you can see in the attached log from the server

embyserver-63790362885.txt 138.73 kB · 0 downloads

No, I mean the live TV function on Kodi (plugin). Sure it works on Emby server and the emby app, but the Kodi plugin obviously not at the moment (for live TV).

I wanted to say, hls also works with Kodi plugin but NOT for Kodi plugin AND Live TV.

e.g. hls is used by Kodi plugin for transencoding functionality and there it works. So it's not a general hls issue, it's just just an issue when you play hls in combination with Kodi Live TV.

 

 

Edited by quickmic
Link to comment
Share on other sites

LuxTux

Ok i understand. I can also confirm your theory. when i switch the output of my m3u to MPEG-TS(.ts) it works via the kodi emby-next-gen app.

  • Like 1
Link to comment
Share on other sites

  • Solution
quickmic

Try latest 7.x version, LiveTV should work in this version.

  • Like 1
Link to comment
Share on other sites

I just downloaded the latest 7.x build and I can confirm that the HLS streams now work. Thank you for your amazing work.

I see that the IPTV simple implementation works much better on this version. The initial synchronisation of the tv series and movies was also a lot faster :)

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...