Jump to content

Emby doesn't respect folder location like 4.5.4.0


Recommended Posts

gokuz
Posted (edited)

4.6.2.0 (LATEST)

image.thumb.png.25b6b1280b321824332a41d2b3e058b8.png

 

4.5.4.0 (OLD)

image.thumb.png.ced9ca0a8647d01b734704595a238031.png

=======================================================================================================================================

4.5.4.0 (OLD) [CORRECT]

image.thumb.png.56c7fecfbb5bdf895b3fa1e4542b942d.png

4.6.2.0 (LATEST) [WRONG]

image.thumb.png.1d696b9cb541fa2840478e92f314d6c3.png

DUPLICATE PROBLEMS (4.6.2.0)

image.thumb.png.2412f9a5c609234c7881bd969b3e3aeb.png

=======================================================================================================================================

 

FOLDER STRUCTURE

image.png.d86d95bb44da8478085014a4df69256e.png

image.png.b64a6eef311005ab28f21d1970700904.png

Season 2 FIRST episode in folder

image.png.f7ec059a48bc8d0be9c571c00c61fa1a.png

=======================================================================================================================================

Let me breakdown what you see in the screenshots above for EASY understanding.

  1. Its using Seasons 1, Seasons 2 normal Recommended Folder structure
  2. Season 2 starts with Episode 15, S02E15
  3. 4.6.2.0 doesn't respect this (WRONG)
  4. 4.5.4.0 does respect this (CORRECT)

 

Please refrain from saying I'm doing it wrong and its not supported/intended as Its working well with 4.5.4.0.

Hope you can fix this in 4.6.2.0>. It has broken many of my seasons as I do this for various reasons like yearly seasons, arc seasons etc.

 

Edited by gokuz
Link to post
Share on other sites
gokuz
29 minutes ago, cayars said:

Just saying. :)

Just saying its working well with 4.5.4.0 too.

Link to post
Share on other sites
Luke

What season does a computer murder case belong to?

Link to post
Share on other sites
gokuz
5 minutes ago, Luke said:

What season does a computer murder case belong to?

Its S02E01, but resides in Season 1 Folder.

Season 2 Folder starts with S02E15

Link to post
Share on other sites
Luke
5 minutes ago, gokuz said:

Its S02E01, but resides in Season 1 Folder.

Season 2 Folder starts with S02E15

Why is it in season 1 folder? where is it supposed to show up?

Link to post
Share on other sites
gokuz
4 minutes ago, Luke said:

Why is it in season 1 folder? where is it supposed to show up?

 

8 hours ago, gokuz said:

 

4.5.4.0 (OLD) [CORRECT]

image.thumb.png.56c7fecfbb5bdf895b3fa1e4542b942d.png

 

 

 

Maybe I didn't explain it properly in the first post.

4.5.4.0 is this which is the correct way since folder priority is higher than .NFO. 

4.6.X.X doesn't respect folder at all. 

 

Link to post
Share on other sites
gokuz
Posted (edited)
11 hours ago, gokuz said:

 

4.5.4.0 (OLD) [CORRECT]

image.thumb.png.56c7fecfbb5bdf895b3fa1e4542b942d.png

4.6.2.0 (LATEST) [WRONG]

image.thumb.png.1d696b9cb541fa2840478e92f314d6c3.png

 

 

2 hours ago, Luke said:

where is it supposed to show up?

Edited by gokuz
Link to post
Share on other sites
Luke

Can you please just answer that sort of question with words? The answer is not obvious from your screenshots because it doesn't show the episode I'm asking about in the place that you want it.

  • Agree 1
Link to post
Share on other sites
gokuz
5 minutes ago, Luke said:

Can you please just answer that sort of question with words? The answer is not obvious from your screenshots because it doesn't show the episode I'm asking about in the place that you want it.

Sorry, thought pictures would be better.

The actual video file, S02E01 is in Season 1 folder, this does not change.

In 4.5.4.0, S02E01 shows in Season 1 section which is correct .

 

In 4.6.x.x, S02E01 shows in both Season 1 and Season 2 section in emby. This is wrong. 

Link to post
Share on other sites
Luke

Why do you want a season two episode showing in season one?

Link to post
Share on other sites
gokuz
Just now, Luke said:

Why do you want a season two episode showing in season one?

I want emby to follow the files corresponding with the folder, regardless of seasons. This is how it worked in 4.5.4.0.

Link to post
Share on other sites
Luke

Can you please answer the question? I'm trying to understand the use case.

Link to post
Share on other sites
gokuz
Just now, Luke said:

Can you please answer the question? I'm trying to understand the use case

Season 1 (1997-1998)

Season 2 (1998-1999)

I arrange it by yearly, sometimes by story arc.

Regardless, 4.5.4.0 works. Please fix it.

Link to post
Share on other sites
cayars

That sounds more like 4.5 was broke than 4.6 not handling this correctly.

  • Like 1
  • Agree 1
Link to post
Share on other sites
Deathsquirrel

You have three options with TV series.

  1. Put it in a TV library, enable metadata providers for that library in EMBY, and match the episode naming and numbering to your chosen metadata providers.
  2. Put it in a TV library, disable all metadata providers for the library, and organize things how you like but all metadata will be entered manually.
  3. Put it in a home video library and all metadata will be entered manually.

It sounds like you're mixing 1 and 2.  That won't work.  It never should have in the first place.

  • Agree 1
Link to post
Share on other sites
gokuz
1 hour ago, Deathsquirrel said:

You have three options with TV series.

  1. Put it in a TV library, enable metadata providers for that library in EMBY, and match the episode naming and numbering to your chosen metadata providers.
  2. Put it in a TV library, disable all metadata providers for the library, and organize things how you like but all metadata will be entered manually.
  3. Put it in a home video library and all metadata will be entered manually.

It sounds like you're mixing 1 and 2.  That won't work.  It never should have in the first place.

Doesn't change the fact 4.5.4.0 is working. Used this for a long time now, years. And this sudden change?

Link to post
Share on other sites
Deathsquirrel
17 minutes ago, gokuz said:

Doesn't change the fact 4.5.4.0 is working. Used this for a long time now, years. And this sudden change?

When you do things that aren't intended by the designers they may work or they may not.  When they do work it's often temporary as the code that allowed that is improved in some future update, wiping out the bug or design oversight that allowed it to work in the first place.  You're going to either need to change your expectations and work with the online metadata or change your methods to use your own take on what should be in each season.  What you're doing now was never intended to work.

  • Like 1
Link to post
Share on other sites
gokuz
17 minutes ago, Deathsquirrel said:

When you do things that aren't intended by the designers they may work or they may not.  When they do work it's often temporary as the code that allowed that is improved in some future update, wiping out the bug or design oversight that allowed it to work in the first place.  You're going to either need to change your expectations and work with the online metadata or change your methods to use your own take on what should be in each season.  What you're doing now was never intended to work.

No way this is true.

4.5.4.0 works.

Jellyfin latest works.

4.6.x.x don't work.

There's something in 4.6.x.x that broke and I have made the dev aware of this. This is obviously a bug they did when implementing newer versions. 

Link to post
Share on other sites
Deathsquirrel
1 minute ago, gokuz said:

No way this is true.

4.5.4.0 works.

Jellyfin latest works.

4.6.x.x don't work.

There's something in 4.6.x.x that broke and I have made the dev aware of this. This is obviously a bug they did when implementing newer versions. 

You're right, I forgot option 3: do nothing and be disappointed.

  • Haha 1
Link to post
Share on other sites
gokuz
Just now, Deathsquirrel said:

You're right, I forgot option 3: do nothing and be disappointed.

Again, from my first post. 

Refrain from saying I'm doing it wrong. I'm using custom nfo which is supported by emby.

Any video that's not inside a folder has no business being anywhere else, its illogical.

Link to post
Share on other sites
Deathsquirrel
Just now, gokuz said:

Again, from my first post. 

Refrain from saying I'm doing it wrong. I'm using custom nfo which is supported by emby.

Any video that's not inside a folder has no business being anywhere else, its illogical.

Yeah, I saw the first post.  The request is ridiculous.  You ARE doing something wrong.  You can't enable metadata providers for a library and not match your media to the metadata on said providers and then complain when the results are wrong.  Turn off the metadata providers if you don't want to use their data.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...