Jump to content

Docker


Luke

Recommended Posts

Luke
On 3/19/2021 at 7:50 AM, Jeryd said:

Hi all. I'm running emby on an unRaid docker with NVIDIA pass through. I also have a 10 series i5 powering the server. Is it possible to pass through 2x gpus (NVIDIA + Intel) to emby? (would emby put them to use?)

Hi, yes it is possible, although we don't currently load balance between mulitple GPU's, so you'd have to pick which one you want Emby to use. GPU load balancing is something we're interested in exploring in future updates though. Thanks.

Link to post
Share on other sites
Jeryd
11 hours ago, Luke said:

Hi, yes it is possible, although we don't currently load balance between mulitple GPU's, so you'd have to pick which one you want Emby to use. GPU load balancing is something we're interested in exploring in future updates though. Thanks.

Luke, thanks for the response. Good to know about the load balancing. Ill stick with the Nvidia for now, and test out load balancing if it shows up in the future.

Link to post
Share on other sites
  • 3 weeks later...
Kodi_Newcomer

Hello i need some help.

This a part of my stack file.

    docker-embyserver:
        container_name: docker-embyserver
        image: emby/embyserver
        runtime: nvidia
        network_mode: 'service:docker-ovpnclient'
        depends_on:
            - docker-ovpnclient
        environment:
            - PUID=1000
            - PGID=100
            - GIDLIST=100,44
        volumes:
            - /home/homeserver/Embyserver/config:/config
            - /mnt/Storage1:/mnt/Storage1
            - /mnt/Storage2:/mnt/Storage2
            - /mnt/Storage3:/mnt/Storage3
        devices:
           /dev/dri/renderD128:/dev/dri/renderD128
        restart: unless-stopped

Ports are at a higher place.

But when i will update the stack, it becomes an error.

Quote

compose.yml' is invalid because: services.docker-embyserver.devices contains an invalid type, it should be an array

What i'm doing wrong ?

Edited by Kodi_Newcomer
Link to post
Share on other sites
mastrmind11
3 hours ago, Kodi_Newcomer said:

Hello i need some help.

This a part of my stack file.


    docker-embyserver:
        container_name: docker-embyserver
        image: emby/embyserver
        runtime: nvidia
        network_mode: 'service:docker-ovpnclient'
        depends_on:
            - docker-ovpnclient
        environment:
            - PUID=1000
            - PGID=100
            - GIDLIST=100,44
        volumes:
            - /home/homeserver/Embyserver/config:/config
            - /mnt/Storage1:/mnt/Storage1
            - /mnt/Storage2:/mnt/Storage2
            - /mnt/Storage3:/mnt/Storage3
        devices:
           /dev/dri/renderD128:/dev/dri/renderD128
        restart: unless-stopped

Ports are at a higher place.

But when i will update the stack, it becomes an error.

What i'm doing wrong ?

your devices block is wrong.  remove the renderD128, it's implied.

Link to post
Share on other sites
Kodi_Newcomer
39 minutes ago, mastrmind11 said:

your devices block is wrong.  remove the renderD128, it's implied.

Hm, i have tried it with and without this. Always the same error.

This is the start of my stack file ::

version: '3.4'

services:
    docker-ovpnclient:
        container_name: docker-ovpnclient
        image: dperson/openvpn-client
        cap_add:
            - net_admin
        networks:
            - vpn
        environment:
            PUID: 1000
            PGID: 1000
        ports:
            - 8080:8080
            - 9090:9090
            - 8081:8081
            - 7878:7878
            - 8096:8096
            - 8920:8920
        dns:
xxxx
xxxx
xxxx
        restart: unless-stopped

docker-embyserver:
        container_name: docker-embyserver
        image: emby/embyserver
        runtime: nvidia
        network_mode: 'service:docker-ovpnclient'
        depends_on:
            - docker-ovpnclient
        environment:
            - PUID=1000
            - PGID=100
            - GIDLIST=100,44
        volumes:
            - /home/homeserver/Embyserver/config:/config
            - /mnt/Storage1:/mnt/Storage1
            - /mnt/Storage2:/mnt/Storage2
            - /mnt/Storage3:/mnt/Storage3
        devices:
           /dev/dri:/dev/dri
        restart: unless-stopped

networks:
  vpn:

 

Link to post
Share on other sites
  • 2 weeks later...
delloriane

Hi,

I am running Emby on UnRaid.

I have it installed but I have a problem at the time of including HDHomerun source.

I am using Xteve, witch is running also in unraid but it is running in a different network (br0) than Emby (this is because the only way that I found to detect mi sat>ip by tvheadend was setting it in br0 [nor bridge nor emby network detect it]).

I do no t have to much knowledge on docker but I think what I need is open Emby Homerun reading to host. So the question is, which port uses Emby to charge the homerun? Xteve runs in 192.168.68.20:34400.

Thank you for your support

Edit: Solved with command "docker network connect cdocknet xteve" for xteve, tvheadend and oscam. Running all in the same network.

Edited by delloriane
Link to post
Share on other sites
gnollo

I use UnRaid too, and the Emby Docker. A few unraid servers have been hacked and wiped of all data, I don't expose the unraid server interface, just the emby module, using Cloudflare as per guide below

https://blog.awelswynol.co.uk/2018-01-setting-up-cloudflare-with-emby/

I changed my emby password, and I am the only administrator. If someone was able to hack into my login anway, they coudl delete the files from the interface. I was wondering if there is a way to block data deletion at the docker level, so even an admin profile who connects to emby externally cannot delete any files?

Link to post
Share on other sites
Luke
On 4/22/2021 at 11:15 AM, gnollo said:

I use UnRaid too, and the Emby Docker. A few unraid servers have been hacked and wiped of all data, I don't expose the unraid server interface, just the emby module, using Cloudflare as per guide below

https://blog.awelswynol.co.uk/2018-01-setting-up-cloudflare-with-emby/

I changed my emby password, and I am the only administrator. If someone was able to hack into my login anway, they coudl delete the files from the interface. I was wondering if there is a way to block data deletion at the docker level, so even an admin profile who connects to emby externally cannot delete any files?

Hi, yes I would just setup your mounts as readonly:

https://stackoverflow.com/questions/19158810/docker-mount-volumes-as-readonly/20317879

Or at least the ones that are for your media folders. Keep in mind, if you enable any features that save metadata to media folders, this will cause those features to not work as expected.

Link to post
Share on other sites
  • 2 weeks later...
gnollo
On 4/24/2021 at 1:52 AM, Luke said:

Hi, yes I would just setup your mounts as readonly:

https://stackoverflow.com/questions/19158810/docker-mount-volumes-as-readonly/20317879

Or at least the ones that are for your media folders. Keep in mind, if you enable any features that save metadata to media folders, this will cause those features to not work as expected.

Thanks Luke, I use MCM to download metadata so I might be OK as most is already saved in the drive. Will see if I can understand how to get that working.

Link to post
Share on other sites
Luke

Let us know how you get on. Thanks.

Link to post
Share on other sites
Alefielm

Hi! Can you please check on latest tag for embyserver_arm32v7, it's a 5 month old version, latest on other docker images tagged as latest are version 4.6, for arm still on 4.5

Thanks!

Link to post
Share on other sites
alucryd

No they aren't, all latest tags point to the same version, 4.5.4.0.

Link to post
Share on other sites
Alefielm
Posted (edited)
10 minutes ago, alucryd said:

No they aren't, all latest tags point to the same version, 4.5.4.0.

Thanks, my bad, I thought 4.6 was released out of beta.

Thanks!

Edited by Alefielm
Link to post
Share on other sites
Luke
23 minutes ago, Alefielm said:

Thanks, my bad, I thought 4.6 was released out of beta.

Thanks!

It should be this week.

  • Thanks 1
Link to post
Share on other sites
embilly
On 08/05/2021 at 16:41, Luke said:

It should be this week.

any ideas when the docker stable update would be out?

Link to post
Share on other sites
  • 2 weeks later...
Luke
3 hours ago, rylando said:

Are there any plans to add a healthcheck command to this image?

Hi, yea it's not a bad idea. Thanks for the feedback.

Link to post
Share on other sites
sebasmiles

So what is "latest" on right now in terms of version? I am stuck on version 4.5.4.0, I am not getting an update warning on the docker but inside emby it says a new version 4.6.1.0 is available. Just trying to figure out if its just delayed in updating or if I am having issues on my side with Unraid.

Link to post
Share on other sites
alucryd
11 hours ago, sebasmiles said:

So what is "latest" on right now in terms of version? I am stuck on version 4.5.4.0, I am not getting an update warning on the docker but inside emby it says a new version 4.6.1.0 is available. Just trying to figure out if its just delayed in updating or if I am having issues on my side with Unraid.

You can find the tags here: https://hub.docker.com/r/emby/embyserver/tags?page=1&ordering=last_updated
Latest is up to date with the latest release (4.6.1.0) as indicated inside emby.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...