Jump to content

Emby next gen


quickmic

Recommended Posts

quickmic
1 hour ago, jkasanic said:

I've been having issues lately with Emby Next Gen launching on my 4K Fire TV Stick gen II (the small box version). Keep getting errors loading and it won't connect to my Emby server.  I had upgraded to Kodi 19.4 and noticed the issue with 6.2.11. I tried to ugprade to 6.2.12 but same issue. I then downgraded Kodi to 19.3 and same issues. Edit: I figured out how to get the log file.

kodilog.jpg

kodi.log 35.34 kB · 1 download

This looks like a (file) permission issue. I try to add a workaround in next version.

 

 

Link to comment
Share on other sites

quickmic
2 hours ago, jkasanic said:

I've been having issues lately with Emby Next Gen launching on my 4K Fire TV Stick gen II (the small box version). Keep getting errors loading and it won't connect to my Emby server.  I had upgraded to Kodi 19.4 and noticed the issue with 6.2.11. I tried to ugprade to 6.2.12 but same issue. I then downgraded Kodi to 19.3 and same issues. Edit: I figured out how to get the log file.

kodilog.jpg

kodi.log 35.34 kB · 3 downloads

I've uploaded 6.2.13 to beta repository. Please try this version.

Link to comment
Share on other sites

jkasanic
3 hours ago, quickmic said:

I've uploaded 6.2.13 to beta repository. Please try this version.

That worked. Thanks for the quick turnaround!

  • Like 1
Link to comment
Share on other sites

Hi- i've just noticed that for some reason - i am not having the movies sorted by movie sets.


I can see the movie collections in emby, but they're not being sorted by this movie set name in Kodi?

Is there some setting in emby-next-gen i am missing to make this work?

Link to comment
Share on other sites

quickmic
8 hours ago, zonknz said:

Hi- i've just noticed that for some reason - i am not having the movies sorted by movie sets.


I can see the movie collections in emby, but they're not being sorted by this movie set name in Kodi?

Is there some setting in emby-next-gen i am missing to make this work?

No exactly sure what you are trying to achieve. There are several Kodi options how boxsets are listed. Sorting options are usually located in the list browsing menu (on list windows).

Also it can be skin related. Please elaborate, maybe a screenshot would help.

Link to comment
Share on other sites

I'm seeing an issue with Emby-Next-Gen in Kodi 19.4 where Emby libraries are not populating within the plugin.

I have unique Emby libraries for movies, tv shows, standup, documentaries, etc.  When I install Emby-Next-Gen, I'm able to select these libraries to import as part of the configuration process, but I don't see these libraries populating in the Emby-Next-Gen video plugin, nor do I see them listed under the Video Library section of the menu editor that would allow me to add them as menu widgets. 

My entire library is only listed under Movies and TV Shows within Kodi.  The old Emby plugin in Kodi 18.x showed my libraries within the plugin and in the menu editor.

How can I configure Emby-Next-Gen to recognize my individual Emby libraries in Kodi 19.4?

 

Link to comment
Share on other sites

quickmic
8 hours ago, dberg said:

I'm seeing an issue with Emby-Next-Gen in Kodi 19.4 where Emby libraries are not populating within the plugin.

I have unique Emby libraries for movies, tv shows, standup, documentaries, etc.  When I install Emby-Next-Gen, I'm able to select these libraries to import as part of the configuration process, but I don't see these libraries populating in the Emby-Next-Gen video plugin, nor do I see them listed under the Video Library section of the menu editor that would allow me to add them as menu widgets. 

My entire library is only listed under Movies and TV Shows within Kodi.  The old Emby plugin in Kodi 18.x showed my libraries within the plugin and in the menu editor.

How can I configure Emby-Next-Gen to recognize my individual Emby libraries in Kodi 19.4?

 

You must use the custom nodes for separation. If you use the stock nodes, all the content is under movies.

Link to comment
Share on other sites

Quote

You must use the custom nodes for separation. If you use the stock nodes, all the content is under movies.

I found out the root cause of my issue.   One of my Emby libraries was labeled "News\Documentaries" and the Emby-Next-Gen plugin errored out when building the directory for that library because it interpreted it as a folder.  It appears the rest of my libraries failed to build after that first error occurred.

[Errno 2] No such file or directory: b'/home/kodi/.kodi/userdata/library/video/emby_movies_News/Documentaries/'

After renaming my Emby library to "News & Documentaries", I now see all my libraries populating under the Emby-Next-Gen plugin.

  • Thanks 1
Link to comment
Share on other sites

quickmic
6 minutes ago, dberg said:

I found out the root cause of my issue.   One of my Emby libraries was labeled "News\Documentaries" and the Emby-Next-Gen plugin errored out when building the directory for that library because it interpreted it as a folder.  It appears the rest of my libraries failed to build after that first error occurred.

[Errno 2] No such file or directory: b'/home/kodi/.kodi/userdata/library/video/emby_movies_News/Documentaries/'

After renaming my Emby library to "News & Documentaries", I now see all my libraries populating under the Emby-Next-Gen plugin.

Makes perfectly sense, I put that on the todo list.

  • Like 1
Link to comment
Share on other sites

manutdsoc20

Went from 5.3.4  to 6.2.13 tonight and now CoverArt is not working on my posters.  

Any recommendations?

cheers

Link to comment
Share on other sites

quickmic
Posted (edited)
2 hours ago, manutdsoc20 said:

Went from 5.3.4  to 6.2.13 tonight and now CoverArt is not working on my posters.  

Any recommendations?

cheers

You must enable enhanced artwork in plugin config menu -> interface.

After doing so, you need a database resync or refresh artwork manually (delete existing artwork on Kodi) or using the artwork cache option (reset artwork there)

Edited by quickmic
  • Thanks 1
Link to comment
Share on other sites

upgraded from earlier versions to 6.x and after testing on 3 different devices all have same problem, emby cannot use at all SSL connection, only way around was to enable non ssl connection on server to get use emby at all. so now connection over internet will be plain text.

This log is from macos client, fresh install of kodi 18.4. tried android box same issue and also androidtv box doing same, kodi 19.3 and 19.4 same thing. emby kodi client .12 and .13 same issue, this only happen when using "manually server connect" and there try insert https url, as settings has no more the setting of server this cannot be fixed any way. log show it using http, even i forced to use https.

certificate i use is letsencrypt, and browser / mobile app work fine with it, but emby next gen is only what is not working anymore. on emby server to log comes nothing when client try connect.

 

2022-03-27 21:55:25.881 T:5943156   DEBUG <general>: DEBUG: EMBY.emby.http: --->[ http ] {
                                                       "type": "GET",
                                                       "url": "https://sensored:8920/emby/system/info/public",
                                                       "headers": {
                                                           "Accept": "application/json",
                                                           "Accept-Charset": "UTF-8,*",
                                                           "Accept-encoding": "gzip",
                                                           "X-Application": "Emby-next-gen/6.2.12",
                                                           "Content-type": "application/x-www-form-urlencoded; charset=UTF-8",
                                                           "Authorization": "Emby Client=Emby-next-gen, Device=Kodi%20%28sensored%29, DeviceId=sensored, Version=6.2.12"
                                                       },
                                                       "timeout": 120
                                                   }
2022-03-27 21:55:26.177 T:5943156   ERROR <general>: ERROR: EMBY.emby.http: [ SSL error ]

 

Link to comment
Share on other sites

quickmic
Posted (edited)
49 minutes ago, riku said:

upgraded from earlier versions to 6.x and after testing on 3 different devices all have same problem, emby cannot use at all SSL connection, only way around was to enable non ssl connection on server to get use emby at all. so now connection over internet will be plain text.

This log is from macos client, fresh install of kodi 18.4. tried android box same issue and also androidtv box doing same, kodi 19.3 and 19.4 same thing. emby kodi client .12 and .13 same issue, this only happen when using "manually server connect" and there try insert https url, as settings has no more the setting of server this cannot be fixed any way. log show it using http, even i forced to use https.

certificate i use is letsencrypt, and browser / mobile app work fine with it, but emby next gen is only what is not working anymore. on emby server to log comes nothing when client try connect.

 

2022-03-27 21:55:25.881 T:5943156   DEBUG <general>: DEBUG: EMBY.emby.http: --->[ http ] {
                                                       "type": "GET",
                                                       "url": "https://sensored:8920/emby/system/info/public",
                                                       "headers": {
                                                           "Accept": "application/json",
                                                           "Accept-Charset": "UTF-8,*",
                                                           "Accept-encoding": "gzip",
                                                           "X-Application": "Emby-next-gen/6.2.12",
                                                           "Content-type": "application/x-www-form-urlencoded; charset=UTF-8",
                                                           "Authorization": "Emby Client=Emby-next-gen, Device=Kodi%20%28sensored%29, DeviceId=sensored, Version=6.2.12"
                                                       },
                                                       "timeout": 120
                                                   }
2022-03-27 21:55:26.177 T:5943156   ERROR <general>: ERROR: EMBY.emby.http: [ SSL error ]

 

 

Your url is not a valid tld and therefore also SSL invalid "https://sensored:8920". The other apps just ignores this issue, but Kodi cannot do that as a global setting.

If you access via LAN, use http instead of https or use valid urls.

btw, your invalid tld cannot be accessed via internet by any app -> impossible. Not sure what you entered via manual connect, but seems you really entered "https://sensored" and port 8920.

If not let me know and I'll check -> then it's a bug, but I really doubt that.

Edited by quickmic
Link to comment
Share on other sites

url is valid, i have modified "word sensored" when i posted. server name is valid has been many years, issue is only on 6.x version . if want i can pm to you url address if want to try out

Edited by riku
Link to comment
Share on other sites

quickmic
2 minutes ago, riku said:

url is valid, i have modified "word sensored" when i posted. server name is valid has been many years, issue is only on 6.x version . if want i can pm to you url address if want to try out

Yes please

Link to comment
Share on other sites

quickmic
Posted (edited)
10 hours ago, riku said:

okey done

I did a little research.

This is not a plugin issue or Kodi issue. It's indeed a certificate issue (my current opinion). Not sure how deep you are in the certificate matter, but there seems to be a reason why browsers reports certificate is ok, but the plugin and MORE important, native "curl" (which Kodi also uses) reports expired.

If you have a linux shell access, try that:

curl --verbose https://YOUREMBYURL:1234/emby/system/info/public

 

you'll see the exact same problem is reported.

Probably the reason is:

https://community.letsencrypt.org/t/curl-60-ssl-certificate-problem-certificate-has-expired/161453

Edited by quickmic
Link to comment
Share on other sites

On 21/03/2022 at 18:48, quickmic said:

No exactly sure what you are trying to achieve. There are several Kodi options how boxsets are listed. Sorting options are usually located in the list browsing menu (on list windows).

Also it can be skin related. Please elaborate, maybe a screenshot would help.

Sorry, i figured it out - for some reason something has come along and changed the sort order metadata (radarr i susepct). Corrected this and now working as expected.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
DiabboVerdde
On 3/18/2022 at 1:05 PM, quickmic said:

I also release 6.2.12 today. You can try it, I've backported the skin refresh option.

Ok, it's been a few days and you already released 6.2.13, that's great... I do have some feedback here:

I don't know if you changed anything on the code but some of the "ghost episodes" problem stopped, but not all of it. The ghosts usually show up when I replace an episode or whole season, say old SD versions by 1080p, I ended up with two sets of links: to the new episodes and the "ghosts" pointing to old episodes. It happens sometimes but not every time as before. This info might help you. I didn't change the sync date.

Also, when you backported the skin refresh into 6.2.12 it didn't solve my problem with movie posters within confluence-leia. Nothing seems to solve it and you know what? I'm ok with it. The skin refresh on the other hand seemed to have an undesired side effect: it's messing with the recent added list somehow. On 6.2.11 say I downloaded a new file and I trigger a scan on emby.  Emby finds the new episode, "informs" the plugin and the new episode shows up under "tv shows" and also on the "recently added episodes" list. Immediately. Well, for 6.2.12 and 6.2.13 it goes immediately to tv shows, but it now takes quite some time to show up on the recently added episodes list. Triggering rescans in emby has no effect. Sometimes it takes a long time for the new episodes to show up, sometimes only after restarting Kodi. I think it might have to do with that skin refresh you brought back between 11 and 12, but I may be wrong. This happens in both confluence-leia and confluence-matrix.

I have a somewhat (un)related question for you: The only reason I keep a RPi with Leia around is to be able to use the "TV Show Next Aired" plugin, because it's Python 2 and it doesn't work on Matrix since no one ported it to Python 3 yet. This plugin talks to TVDB and retrieves a list of the TV show episodes that will air in the days to come. It's very practical and we know what to expect and when to look for the episodes. Thing is... Emby has a similar functionality, with the "upcoming" TV shows. Exactly the same thing, but no one developed a plugin that would bring the content of upcoming shows to Kodi. I did some digging and Emby exposes the upcoming shows as part of its REST API (endpoint /emby/Shows/Upcoming), so the information is already gathered and processed by Emby. It would be a matter of building a Kodi plugin that would tap the API, get the data and display it on the the Kodi interface. I wrote some experimental python code calling the API, and it's all there (desktop Python, I don't know a thing about coding for Kodi yet)... So my question is: how hard would it be to create a screen like this as part of the next gen plugin? a screen that gets data from the upcoming API and displays it so we could check the upcoming episodes from Kodi? I guess that adding such a screen to next gen is much easier than developing it from scratch as a standalone plugin because you already have the authentication part coded, the code that talks to the emby REST API and other support code needed to make this happen... It's not a feature request but I am very curious on how hard would be to add such functionality. What can you say about it?

I've been also playing with 7.0.0 experimental, but I didn't had yet the time to deep dive. I'll reserve some time in the next days and come back with some feedback for you.

Edited by DiabboVerdde
Link to comment
Share on other sites

quickmic
3 hours ago, DiabboVerdde said:

I don't know if you changed anything on the code but some of the "ghost episodes" problem stopped, but not all of it. The ghosts usually show up when I replace an episode or whole season, say old SD versions by 1080p, I ended up with two sets of links: to the new episodes and the "ghosts" pointing to old episodes. It happens sometimes but not every time as before. This info might help you. I didn't change the sync date.

 

Nothing changed in the code related to that issue. Seems depending on timing when/how synced.

 

Quote

The skin refresh on the other hand seemed to have an undesired side effect: it's messing with the recent added list somehow.

The skin refresh is optional and can be disabled in plugin config settings. The issue seems not related to next-gen plugin. The skin refresh function just send a single command to Kodi -> refresh skin, that's it. There are no (extra) sync or other operations triggered. All handled via native Kodi.

Quote

On 6.2.11 say I downloaded a new file and I trigger a scan on emby.  Emby finds the new episode, "informs" the plugin and the new episode shows up under "tv shows" and also on the "recently added episodes" list. Immediately. Well, for 6.2.12 and 6.2.13 it goes immediately to tv shows, but it now takes quite some time to show up on the recently added episodes list. Triggering rescans in emby has no effect. Sometimes it takes a long time for the new episodes to show up, sometimes only after restarting Kodi. I think it might have to do with that skin refresh you brought back between 11 and 12, but I may be wrong. This happens in both confluence-leia and confluence-matrix.

Please disable skin refresh an verify if the recently added list behaves differently.

 

Quote

TV Show Next Aired

I don't use this feature. I must check what's Emby's (API) capabilities and what is possible to include in the plugin.

 

 

 

Link to comment
Share on other sites

DiabboVerdde
On 4/6/2022 at 1:11 AM, quickmic said:

Nothing changed in the code related to that issue. Seems depending on timing when/how synced.

True. I'll be replacing more files the next days and I'll pay attention to how it happens. Maybe I can gather more info.

Quote

Please disable skin refresh an verify if the recently added list behaves differently.

I disabled it and new items showed up on the "recently added" list immediately after emby scanned them. My guess is the delay in showing the items is caused by the skin code not the plugin code. The skin refresh must force some code to re-execute before that list gets updated, that would explain the delay.

Quote

I don't use this feature. I must check what's Emby's (API) capabilities and what is possible to include in the plugin.

There's no much on the API really, Emby does the heavy lifting. You call the endpoint /emby/Shows/Upcoming with a GET request passing only api_key as argument and it gives you a json list of the upcoming episodes with the dates they will air and whatever details emby can gather. You know what, I never coded for Kodi before but I do code python so I'll take a look at your plugin code and Kodi's plugin documentation and see if I can come up with a prototype. I just think the next gen plugin is too awesome to not have an "upcoming episodes" functionality :D 

I have another question for you. When exiting Kodi, does Kodi calls anything, like cleanup functions, exit stubs, etc... on next-gen? I am asking because many times when I try to exit Kodi on Android TV it freezes on the exit screen and I have to kill it manually. I am trying to find out what could be delaying Kodi's exit. I noticed that if I leave the TV on with Kodi opened and idle for a long time (say overnight) it looks like next gen "disconnects" from emby (main symptom being an error message if I try to open any video) and I have to restart Kodi to reconnect. One thing might be related to the other, but I'm just speculating here, that's why I am asking you.

 

Link to comment
Share on other sites

quickmic
9 hours ago, DiabboVerdde said:

There's no much on the API really, Emby does the heavy lifting. You call the endpoint /emby/Shows/Upcoming with a GET request passing only api_key as argument and it gives you a json list of the upcoming episodes with the dates they will air and whatever details emby can gather. You know what, I never coded for Kodi before but I do code python so I'll take a look at your plugin code and Kodi's plugin documentation and see if I can come up with a prototype. I just think the next gen plugin is too awesome to not have an "upcoming episodes" functionality :D

API query sounds quite easy, I'll have a look. I'll check how the next aired plugin visualized the info to the user.

The basic Kodi API is not that complicated for basic stuff.

Quote

I have another question for you. When exiting Kodi, does Kodi calls anything, like cleanup functions, exit stubs, etc... on next-gen? I am asking because many times when I try to exit Kodi on Android TV it freezes on the exit screen and I have to kill it manually. I am trying to find out what could be delaying Kodi's exit. I noticed that if I leave the TV on with Kodi opened and idle for a long time (say overnight) it looks like next gen "disconnects" from emby (main symptom being an error message if I try to open any video) and I have to restart Kodi to reconnect. One thing might be related to the other, but I'm just speculating here, that's why I am asking you.

Well, yes and no. All plugins should close its threads, close the database etc.

Next gen does all that on close and I tested many scenarios. No issues but I cannot test each any every case. So maybe you have a special case.

Sometimes I also have unsuccessful shutdowns in Kodi. It was always related to 3rd party plugin which haven't closed their threads correctly.

In the kodi.log is usually a record like -> waiting for thread bla. This is an indicator for a incorrect shutdown. But it's hard to track it to a specific plugin/function.

Also the shutdown can differ on the method used. Shutdown (Kodi exit) from Kodi menu or via systemctl/systemd. Not sure how Android closes Kodi. Can be sort of suspend/hibernate if you switch/focus a different app or really close the Kodi app etc.

My Android tests showed on app change (focus change not actually close Kodi) -> Kodi sends a "sleep" event/notification.

next gen plugin handles sleeps a bit differently -> threads are closed but the Emby server connection is not initiated from scartch. It uses sort of re-connection function which is much faster.

 

Link to comment
Share on other sites

phunzie

i’m sure i had a different reason for my issue, but when i was using Add-on mode, along with the stuttering/glitching i experienced when watching video (as discussed in another thread), i very often had trouble exiting Kodi…it would lock up and stop responding, forcing me to use Windows to force it close….using Native mode i now have neither of those issues 

Link to comment
Share on other sites

quickmic
6 minutes ago, phunzie said:

i’m sure i had a different reason for my issue, but when i was using Add-on mode, along with the stuttering/glitching i experienced when watching video (as discussed in another thread), i very often had trouble exiting Kodi…it would lock up and stop responding, forcing me to use Windows to force it close….using Native mode i now have neither of those issues 

Yes, I'm also quite sure but you can send me a kodi.log for review.

Link to comment
Share on other sites

quickmic
18 hours ago, DiabboVerdde said:

I have another question for you. When exiting Kodi, does Kodi calls anything, like cleanup functions, exit stubs, etc... on next-gen? I am asking because many times when I try to exit Kodi on Android TV it freezes on the exit screen and I have to kill it manually. I am trying to find out what could be delaying Kodi's exit. I noticed that if I leave the TV on with Kodi opened and idle for a long time (say overnight) it looks like next gen "disconnects" from emby (main symptom being an error message if I try to open any video) and I have to restart Kodi to reconnect. One thing might be related to the other, but I'm just speculating here, that's why I am asking you.

 

 

I'll add some sort of upcoming info in next 7.X version. Query the data from Emby server is easy, but designing a proper Kodi view is not a trivial.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...