Jump to content

1080i mpeg2 videos never start playing


Recommended Posts

I just started with Emby last week (server version and all has gone well until I tried to play an OTA recorded video that Emby reports as 1080i mpeg2 on a Roku streaming stick. Other OTA recordings at 720p mpeg2 have played fine. I get a black screen with a progress bar that jumps part way initially, then quickly disappears. Emby appears frozen after this happens and I can only exit by pressing the Home button on the roku remote. I have the video quality in the Emby roku app set at 720p HD 2mbps. Tried changing it to Auto with same result. Also messed with Roku Streaming Stick 3800RW / 9.1.0 video quality settings which is currently on auto detect 1080p, but I have tried 720p as well in an attempt to lessen the load. BTW the video plays fine on Windows 10 server through the Emby web interface.


Here's the activity shown in the web dashboard, even though file did not play and I exited Emby as described above.

Esteban has finished playing PGA Tour Golf_20190818_11001500 on Roku Streaming Stick
9/3/2019, 4:29:54 pm

Esteban is playing PGA Tour Golf_20190818_11001500 on Roku Streaming Stick
9/3/2019, 4:28:54 pm
Thanks for looking at this.


Link to post
Share on other sites

No, it's several. It just so happened that of the 5 files I tried to play 3-1080i ones failed and 2-720p played successfully. I just checked some more 1080i mpeg2 recordings and some of them do play, which I didn't realize before. So I guess I got you off on the wrong track. Sorry.


Note that all 5 files play just fine through the Emby web interface on the server machine. This is only an issue with the Roku app on both the Roku Streaming Stick and the Roku Express.

Link to post
Share on other sites

Here's some further observations after more time and more attempts with different recorded mpeg2s.


I noticed some weak signal spots in one recording where the playback pixelated intermittently. I could still play it on the server though. I repaired it along with some other recordings with project X and then converted them to H264. All of the H264-1080p files play on the computer but only a few play on the rokus.


What I noticed about the ones that would play on the rokus is that they were 2 hours or under. The longer recordings (4 hours +) like football games or golf tournaments all won't play despite format or lack of errors in the original stream. In fact all recordings under 2 hours I've tried to play through the roku app have successfully played.


Maybe there's something to this. This weekend I'll be recording sports events of different lengths and see if the the pattern holds.

Link to post
Share on other sites

How do I post a table of the weekend recordings success/failure? It's in OneNote, and also a screen shot is in ,jpg which was rejected.


Can you export the onenote to plain text? 

Link to post
Share on other sites

Length     File size      format        Roku played

4h 14m    18337     1080p H264     NO                           

4h 14m    25600     1080i Mpeg2    NO

4h 14m    17777     1080p H264     NO

3h 59m    17106     720p Mpeg2    Yes

1h 29m     8983      1080i Mpeg2   Yes

3h 24m    16423     720p Mpeg2    Yes

3h 49m    18366     720p Mpeg2    Yes

3h 18m    10386     1080p H264    Yes

2h 24m     6549      1080p H264    Yes

4h 29m    13611     1080p H264     NO


This is the list of recordings for the past week I've tried to play with the Emby roku app. All played on the Windows 10 server. Clearly the length of the video in combination with the resolution is a factor. Not sure about file size? A 720p 17106 mb file played while a 1080i 13611 mb did not.


Hope this helps.

Link to post
Share on other sites

No ffmpeg log files were generated from the failures; only the successes have ffmgeg log files. Do you want the server log from that time frame?


The activity log shows that the file was played on the Roku. In reality it never started and after a little while I pressed home on the roku remote to quit emby because it won't respond to any other key press.


Esteban is playing NFL Football_20190908_17152030 on Roku Streaming Stick
9/13/2019, 10:18:52 am
Esteban has finished playing NFL Football_20190908_17152030 on Roku Streaming Stick
9/13/2019, 10:19:52 am
This is the third file in the list I posted.
Link to post
Share on other sites

This is similar to the issue I've reported with roku as well. The stream never starts on the roku but from the emby server perspective, the stream continues and finishes successfully

Link to post
Share on other sites

The one starting with 987f was a 720p file that played successfully. The other one starting with 3d28 is the 1080i file that wouldn't play .


@@EstebanUno, are you sure this is the right log? The log starting with 3d28 references a 720p video file. Thanks !

Link to post
Share on other sites

Luke, You're right, it's not the right log; I got confused by the time stamp. I don't think any ffmpeg log files are generated for the failed recordings.


BTW, all 720p files have played successfully with the longest at 3h 59m.



Paint, Do you have any ffmpeg logs generated for the the failed attempts?

Link to post
Share on other sites

yes, I do. 


here it is attached. I removed my domain and the API keys. 




I noticed something however.... roku is trying to access the stream at http://<mydomain>:8096


However, the stream is only available via https://<mydomain>:8920




Edited by Paint
Link to post
Share on other sites

Just seeing this topic, same issues for me and I am recording directly within Emby. 

My thread is here for additional logs/details:



I noticed after reading this thread my issue files all also happen to be 1080i MPEG2, so very possibly related.  I have seen it on 720p MPEG too as well last weekend, but this weekend all affected files were 1080i MPEG2 just like OP.


Newest discovery was that my Roku will play these while recording is still in progress, but once recording is complete it will not play anymore until I convert it.  Files play fine without conversion within the Emby web app.


This is on Emby, Roku Beta and Stable have the same behavior.

Edited by bizarro252
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...