Jump to content
Sign in to follow this  
boggle247

ANSWERED How to update Emby version in Linux?

Recommended Posts

Happy2Play

Thanks for asking. Yes, I just finished a complete new installation of emby-server on debian 10.

There is still a lot to configure, but the basic system is up. I am a bit confused though. With the old version I had to install many dependencies and other stuff like ffmpeg, mono etc. Now I just installed one file, it took like 2 minutes and that's it.

Seems great! Thanks!

I am running new the server in parallel with the old one until everything is setup.

 

QUESTIONS:

- can I use my premiere key on both servers until I delete the old one?

- Does transcoding still depend on ffmpeg?

 

CHEERS

 

Can I use my Emby Premiere key on more than one server

Share this post


Link to post
Share on other sites
acnp77

@@Happy2Play

Thanks for the additional info. And yes, sorry, I should have searched for the answer first :(

Share this post


Link to post
Share on other sites
Przemek

Hello, somebody have experience in update Emby Server in Dietpi? It's safe to download last release from github and install with sudo apt install emby-server....deb? What about my config and SSL?

Regards Przemek

Share this post


Link to post
Share on other sites
Luke

Hello, somebody have experience in update Emby Server in Dietpi? It's safe to download last release from github and install with sudo apt install emby-server....deb? What about my config and SSL?

Regards Przemek

Hi, how did you originally install?

Share this post


Link to post
Share on other sites
Przemek

Hi, how did you originally install?

Hello, I install from dietpi-software.

 

Regards Przemek

Share this post


Link to post
Share on other sites
Luke

Hello, I install from dietpi-software.

 

Regards Przemek

 

Ok, then you should use that to install newer versions.

Share this post


Link to post
Share on other sites
Przemek

Ok, then you should use that to install newer versions.

There is only option to install. So I have two options: 

1. Dowload last release from github

2. Sudo dietpi-software reinstall <ID>

I don't know wchich method is safe for configuration.

Regards

Share this post


Link to post
Share on other sites
Luke

 

 

Dowload last release from github

You can't do this as it's a different installation package. 

 

I don't know how they did the DietPi package. We'll look into it and try to figure out how they packaged it. But for right now my guess is that you need to install the latest version using DietPi, on top of your existing version.

Share this post


Link to post
Share on other sites
Przemek

You can't do this as it's a different installation package. 

 

I don't know how they did the DietPi package. We'll look into it and try to figure out how they packaged it. But for right now my guess is that you need to install the latest version using DietPi, on top of your existing version.

OK, Thanks for help. I ask in Dietpi forum. I think reinstall is good option. I reinstall nextcloud and everything was OK.

Share this post


Link to post
Share on other sites
Przemek

OK, Thanks for help. I ask in Dietpi forum. I think reinstall is good option. I reinstall nextcloud and everything was OK.

Edit. OK. I make that option:

'sudo dietpi-software reinstall 41' and it works great.

Regards Przemek

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...