Jump to content

Docker image of Emby stopped adding movies.


Recommended Posts


Recently my Emby server stopped adding Movies to the library. 

Server version Version

Realtime Monitoring is enabled for both Movies and TV folder.

TV shows are being added to the library and Movies are not.

Just added a new show to the library and it added it and scanned for the new folder. 


Movies are not being added at all however. 

This started to happen at the beginning of February. 

Didn't notice till this week, I use Emby sparingly so it took a bit to notice. 

A manual library scan does not add the movies either.

Using Sonarr and Radarr respectively.


I checked the permissions on the Movie and TV folder and they are different. 

New shows are being added to the server using UID and GID nobody:nogroup.

I have since changed the permission in Radarr to reflect the Server (unRAID) default. 


chmod 777 on Folders, and chmod 666 on files. 

chown nobody:users 



After the above permission changes Emby is still not adding new movies to it's library but is adding TV shows with the same above permissions. 

Content works fine with KODI, no issues there.

What should I be looking for in Emby?

Link to post
Share on other sites

Hi, if you attach the emby server log I'll see if I can spot anything, but this will most likely be permissions related. Thanks.

Link to post
Share on other sites

Just to note that now both folders have the same permissions, and that all containers including Emby run with UID 99 and GID 100 in unRAID. 

All shares on the server have their ownership set to this, and all files have 666 and folders 777 rwx permissions. 

Both Sonarr and Radarr now set the file permissions and ownership to the above. 


At this moment Movies are still not showing up in Emby. 

Edited by Exist2Resist
Link to post
Share on other sites

There are some errors in the log that i've never seen before relating to your movies folder:

IOException: Structure needs cleaning

I did some searching and found this, which you may want to take a look at:



Please let us know if this helps. Thanks.

Link to post
Share on other sites

I think I found the culprits while trying to dump the folder structure into a txt file...


root@Tower:/mnt/user/Movies# ls -Rla >> /mnt/user/Temp/Movies-ls-Rla.txt
/bin/ls: reading directory './Abraham Lincoln Vampire Hunter (2012)': Structure needs cleaning
/bin/ls: reading directory './Brothers (2009)/.actors': Structure needs cleaning
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...