Jump to content
jaspils

SSL on LG Emby app - Does it even work?

Recommended Posts

jaspils

I have had Emby for quite a time now and recently bought Emby Premiere so I could use it on more platforms. I have my Emby server running locally on Debian and can connect remotely through my domain (assume my.domain.com). 

 

Emby works fine (with SSL) on following the devices I tested:

  • Android app
  • iOS app
  • Windows Store app
  • Xbox One app
  • Most PCs web interface

However, I could not get it working with SSL on my LG TV with WebOS 3.5 (LG OLED55B6V if it matters). It did work on a non-secure connection, but when I try to add the server as SSL connection, it simply denies connection like it doesn't even exist. Even when I log onto my Emby Connect account, it simply doesn't show the server, where all other devices do.

 

Now I've read some problems about the SSL certificate (https://emby.media/community/index.php?/topic/57575-lg-emby-app-106-ssl-problem-connecting-to-server/), I'm currently using Comodo PostiveSSL as a certificate, which I have seen at least one other person have problems with as wel. However, I've also seen that some people with Let'sEncrypt have this problem. (https://emby.media/community/index.php?/topic/61481-unable-to-connect-over-https/)

 

There is suggested that LG is simply blocking my certificate, but when I go to my site with the WebOS webbrowser (same certificate), it allows the certificate and shows the site as 'secure'. So somewhere the TV actually does allow the certificate. So I'm not sure where the problem resides.

 

Also, I've shortly tested it on a PS4 from a friend. There was no app, so I used the built-in webbrowser. It also didn't seem to work there, seemed to have the same problem: simply not showing the server. Didn't have much time to test it there, so don't pin me on this.

 

My question is: does anyone have Emby running over SSL with any certificate on LG WebOS 3.5? If so, what certificate do you use?

Share this post


Link to post
Share on other sites
Luke

The question for PS4 is do the devices trust your certificate? As far as the LG app goes, that's interesting that the browser works. We haven't actually spent a whole lot of time on this yet, but it's something we can look into. Thanks.

Share this post


Link to post
Share on other sites
jaspils

Well, the PS4 is the least of my worries, since it's not even my own device. However, I would like it to work on my TV. (It does work without SSL though, but I really prefer SSL).

I'm just very interested if someone at all has Emby working over SSL on LG, and with what certificate, because I might just get that specific certificate (next time). 

Share this post


Link to post
Share on other sites
Luke

@@kwilcox have you looked at SSL in screenplay?

Share this post


Link to post
Share on other sites
jaspils

I've tested Screenplay as well as the Emby app. Both give the same error.

Share this post


Link to post
Share on other sites
SamES

This has come up a few times and I'm not aware of anyone getting it to work successfully.  There is very little on the developer site which suggests it is just not supported.

 

At the very bottom of this page there is reference to 'Trusted Root Certificates in webOS TV' 

 

http://webostv.developer.lge.com/discover/webos-tv-platform/web-engine/

 

Dumping these out gives me this list, but I'm not sure it helps

 

certs.txt

Edited by SamES

Share this post


Link to post
Share on other sites
kwilcox

@@Luke, I have not.  One thing I do know is that screenplay only ever worked when a legitimate (not self signed) cert was installed on Emby Server.  You folks are on the right track by examining the trusted roots installed on the TV.  Probably will need a cert chained to one of those installed.  Lets Encrypt certs did work (at least on WebOS 3.0 and <) but that appears to no longer be the case.

Edited by kwilcox

Share this post


Link to post
Share on other sites
MarshallandConnie

I just bought a LG smart tv and the Emby app on it doesn't work at all I have baconfeet and can't see anything on any of my categories. I contacted LG and what a waste of time they are. Any idea on update

Share this post


Link to post
Share on other sites
Luke

I just bought a LG smart tv and the Emby app on it doesn't work at all I have baconfeet and can't see anything on any of my categories. I contacted LG and what a waste of time they are. Any idea on update

 

Hi there, can you please describe your problem in more detail? Thanks !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...