Jump to content


Photo

Emby Theater stuttering on 1080p content

theater windows 10 stuttering freezing hd 1080p firefox

Best Answer Doofus , 15 December 2018 - 09:09 PM

Set Hardware Acceleration to auto, and try again.

 

Luke, auto should be the default setting on that. None, is what they recommend, but many people won't have CPUs that can handle it. And also, none when using mpv doesn't also have to run the resources that Theater uses. You'd need a substantial CPU for that. 

Go to the full post


  • Please log in to reply
33 replies to this topic

#21 Crossfire0mega OFFLINE  

Crossfire0mega

    Member

  • Members
  • 28 posts
  • Local time: 02:00 PM

Posted 15 December 2018 - 10:31 PM

Ok thanks! I will check it out.



#22 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 12:00 PM

Posted 15 December 2018 - 10:32 PM

One other suggestion is enable refresh rate switching. That will considerably lighten the load

 

5c15b9487285d_Snapshot_111.jpg

 

Just make sure your projector supports that


Edited by Doofus, 15 December 2018 - 10:33 PM.


#23 Crossfire0mega OFFLINE  

Crossfire0mega

    Member

  • Members
  • 28 posts
  • Local time: 02:00 PM

Posted 15 December 2018 - 10:54 PM

One other suggestion is enable refresh rate switching. That will considerably lighten the load

 

5c15b9487285d_Snapshot_111.jpg

 

Just make sure your projector supports that

 

I think it does, this is the projector I have.

 

https://www.optoma.c...roduct/hd27hdr/



#24 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 12:00 PM

Posted 16 December 2018 - 12:45 AM

It looks like it does, but I don't know which rates. Try it, and see.

 

5c15d7fdea182_Snapshot_115.jpg

 

And it also looks like it will support 4k

 

5c15d831cde15_Snapshot_113.jpg



#25 Crossfire0mega OFFLINE  

Crossfire0mega

    Member

  • Members
  • 28 posts
  • Local time: 02:00 PM

Posted 16 December 2018 - 01:16 AM

It looks like it does, but I don't know which rates. Try it, and see.

 

5c15d7fdea182_Snapshot_115.jpg

 

And it also looks like it will support 4k

 

5c15d831cde15_Snapshot_113.jpg

 

I set the variable refresh rate setting and every time i stopped a video the projector would lose the source and glitch out. I turned it back off and it hasn't done it since.

 

Also I am trying another 1080P video file and it started transcoding it and I don't understand why this time.

Attached File  video.jpg   56.12KB   1 downloads

This one is not 4K or HDR btw.

Attached Files



#26 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 12:00 PM

Posted 16 December 2018 - 01:33 AM

Your stats are saying it's exceeded the bitrate limit. Have you changed that setting in the app? Set it to 120Mb/s

 

5c15e331ed23e_Snapshot_116.jpg

 

And for some reason, your hardware acceleration is being turned off. First try setting the network bitrate, and test playback



#27 Crossfire0mega OFFLINE  

Crossfire0mega

    Member

  • Members
  • 28 posts
  • Local time: 02:00 PM

Posted 16 December 2018 - 01:44 AM

Your stats are saying it's exceeded the bitrate limit. Have you changed that setting in the app? Set it to 120Mb/s

 

5c15e331ed23e_Snapshot_116.jpg

 

And for some reason, your hardware acceleration is being turned off. First try setting the network bitrate, and test playback

 

So it was set to 1080P 4Mbps automatically lol, I changed it to 4K 120 and that fixed it thanks.

And yeah I did set hardware acceleration to auto but it shows as off in the stats.

 

Attached File  hw_acc.jpg   27.47KB   2 downloads

Can I set it to one of these options to force it to activate?



#28 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 12:00 PM

Posted 16 December 2018 - 01:52 AM

If you're using windows 8 or later, you can try D3D11. Check your refresh setting in windows. Make sure it isn't stuck on something you don't want. Your stats are saying 24fps.



#29 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 12:00 PM

Posted 16 December 2018 - 01:57 AM

You could probably set your Windows refresh rate to 30Hz. That would likely stop your frame dropping. It just depends on whether your projector is ok with that.


Edited by Doofus, 16 December 2018 - 01:57 AM.


#30 Crossfire0mega OFFLINE  

Crossfire0mega

    Member

  • Members
  • 28 posts
  • Local time: 02:00 PM

Posted 16 December 2018 - 02:24 AM

I set it to 120Hz and it seems to be working fine. I also set D3D11 and it now shows hw acceleration on and I went ahead and turned down the quality to 1080P 60Mbps, Should I be able to play my 4K videos transcoded because even after setting that they direct play and drop frames still, or should I just forget about them till I get a better client box?

 

edit:

I also noticed that after setting all that and trying to play the 4K video again it didn't show hw acceleration on like the 1080P did.


Edited by Crossfire0mega, 16 December 2018 - 02:25 AM.


#31 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 12:00 PM

Posted 16 December 2018 - 02:29 AM

Leave it at 120Mb/s. That tells the server not to transcode anything with a bitrate lower than that. 



#32 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 12:00 PM

Posted 16 December 2018 - 06:55 PM

I also noticed that after setting all that and trying to play the 4K video again it didn't show hw acceleration on like the 1080P did.

 

If you post an mpv log, I can take a look

 

https://emby.media/c...ng-for-theater/

 

But I don't think your GPU supports hardware decoding of HEVC. That would explain why mpv is disabling it.


Edited by Doofus, 16 December 2018 - 07:55 PM.


#33 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131170 posts
  • Local time: 03:00 PM

Posted 16 December 2018 - 06:59 PM

Auto will be the default hwa for the next app update by the way.


  • Doofus likes this

#34 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 11466 posts
  • Local time: 12:00 PM

Posted 16 December 2018 - 07:41 PM

Auto will be the default hwa for the next app update by the way.

 

That will be a good thing







Also tagged with one or more of these keywords: theater, windows 10, stuttering, freezing, hd, 1080p, firefox

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users