Jump to content
Sign in to follow this  
Crossfire0mega

ANSWERED Emby Theater stuttering on 1080p content

Recommended Posts

Crossfire0mega

Hello, I am having an issue with the Theater desktop app. For most hd content I try to play, it stutters at first and sometimes smooths out but usually stutters intermittently. I can see its direct playing from the server. I play the same content through firefox and get no stuttering. I really love the desktop app but have issues playing hd content.

 

For the client I'm running Emby Theater 3.0.5

Windows 10 HP Desktop with 6 GB system ram

AMD Athlon 64 X2 Dual core 4400+

AMD Radeon R9 270x 2GB graphics card

 

And the server is Ubuntu 16.04 running emby 3.5.3.0

AMD FX 8350 8-Core with 24 GB system ram

AMD Radeon R9 270x 2GB graphics card

 

Both connected to 1Gb Ethernet LAN

 

I can access the files directly through samba shares that are setup on the server.

 

I have also tried to play some 4k content but it stutters even worse. The only difference is that it doesn't play any better through the browser.

As far as the 4k is concerned what is the bottleneck, is my hardware just not good enough?

 

Thanks for any and all advice.

RemuxLog1.txt

RemuxLog2.txt

RemuxLog3.txt

ServerLog1.txt

RemuxLog_4k_1.txt

Share this post


Link to post
Share on other sites
Guest asrequested

If it's direct playing, why are there remux logs? And what audio and video settings are you using?

Share this post


Link to post
Share on other sites
Crossfire0mega

It was direct streaming from the browser, it only direct played with theater. I had it set to auto.

Share this post


Link to post
Share on other sites
Guest asrequested

It was direct streaming from the browser, it only direct played with theater. I had it set to auto.

 

You have what set to auto? Can you post a screenshot of your audio and video settings in Theater?

Share this post


Link to post
Share on other sites
Crossfire0mega

You have what set to auto? Can you post a screenshot of your audio and video settings in Theater?

 

Sorry, I have the quality set to auto, video is 1080P audio is Dolby Digital 5.1

5c159f97124f7_screen.jpg

Share this post


Link to post
Share on other sites
Guest asrequested

No, not that. Have you not looked in settings? Top right corner, click on the user icon next to the clock, and go to settings.

Share this post


Link to post
Share on other sites
Crossfire0mega

Everything is default or auto.

post-29324-0-36608300-1544922145_thumb.jpgpost-29324-0-60460400-1544922155_thumb.jpg

Share this post


Link to post
Share on other sites
Guest asrequested

Set Hardware Acceleration to auto, and try again.

 

Luke, auto should be the default setting on that. None, is what they recommend, but many people won't have CPUs that can handle it. And also, none when using mpv doesn't also have to run the resources that Theater uses. You'd need a substantial CPU for that. 

  • Like 1

Share this post


Link to post
Share on other sites
Guest asrequested

Also, are you using a receiver with HDMI?

Share this post


Link to post
Share on other sites
Crossfire0mega

That worked, thanks! However the 4k videos still stutter tremendously, I even tried to setting the quality to 1080P but didn't help.

Share this post


Link to post
Share on other sites
Guest asrequested

That worked, thanks! However the 4k videos still stutter tremendously, I even tried to setting the quality to 1080P but didn't help.

 

Yeah, I imagine your 4k stuff is HDR? mpv tonemaps HDR and renders it to the video. That takes a little more processing. Press ctrl+j when you're watching a 4k. Look at the stats. Is it dropping frames? And if you have a 4k SDR movie, try playing that, and see what happens. 

Share this post


Link to post
Share on other sites
Crossfire0mega

Yeah its HDR, and yeah its dropping frames like crazy. Is the client cpu the sole bottleneck? I was thinking of buying an nvidia shield tv.

Share this post


Link to post
Share on other sites
Guest asrequested

Yeah its HDR, and yeah its dropping frames like crazy. Is the client cpu the sole bottleneck? I was thinking of buying an nvidia shield tv.

 

I have a mini PC I was testing with. It has more resources than yours, and it too was dropping frames with HDR. It's a combination of GPU and CPU. And in with these little units, the CPU just can't keep up. Maybe it'll be more efficient in the future? A shield would be able to play them, it doesn't tonemap. Te emby app does at present have an issue playing cropped HDR videos. The other thing you could try is using an external player like MPC-BE with madVR. That can pass the metadata to your display, and should require less processing. 

 

You have an HDR display, correct?

Edited by Doofus

Share this post


Link to post
Share on other sites
Crossfire0mega

Yeah, I imagine your 4k stuff is HDR? mpv tonemaps HDR and renders it to the video. That takes a little more processing. Press ctrl+j when you're watching a 4k. Look at the stats. Is it dropping frames? And if you have a 4k SDR movie, try playing that, and see what happens. 

I just tried a non HDR 4k video and it still drops a lot of frames as well.

 

 

I have a mini PC I was testing with. It has more resources than yours, and it too was dropping frames with HDR. It's a combination of GPU and CPU. And in with these little units, the CPU just can't keep up. Maybe it'll be more efficient in the future? A shield would be able to play them, it doesn't tonemap. Te emby app does at present have an issue playing cropped HDR videos. The other thing you could try is using an external player like MPC-BE with madVR. That can pass the metadata to your display, and should require less processing. 

 

You have an HDR display, correct?

 

Yes I have an HDR projector but it's only 1080P lol

Share this post


Link to post
Share on other sites
Guest asrequested

I just tried a non HDR 4k video and it still drops a lot of frames as well.

 

 

 

Yes I have an HDR projector but it's only 1080P lol

 

Oh, so you're downscaling. Well that will add to the load.

Share this post


Link to post
Share on other sites
Crossfire0mega

Is there even that much HDR content that's not 4k?

Share this post


Link to post
Share on other sites
Guest asrequested

Is there even that much HDR content that's not 4k?

 

Not that I've found.

 

You should try using MPC-BE with madVR. It might just get you where want to be, for your HDR stuff. It takes a bit of configuring, though.

Share this post


Link to post
Share on other sites
Luke

Yup we can make auto the default. Thanks.

Share this post


Link to post
Share on other sites
Crossfire0mega

Not that I've found.

 

You should try using MPC-BE with madVR. It might just get you where want to be, for your HDR stuff. It takes a bit of configuring, though.

 

Is that setup through the external player setting in Theater?

Share this post


Link to post
Share on other sites
Guest asrequested

Is that setup through the external player setting in Theater?

 

Yes. You can use any player you want, MPC-BE with madVR would be what I suggest. There are a few recent threads about doing that.

  • Like 1

Share this post


Link to post
Share on other sites
Crossfire0mega

Ok thanks! I will check it out.

Share this post


Link to post
Share on other sites
Guest asrequested

One other suggestion is enable refresh rate switching. That will considerably lighten the load

 

5c15b9487285d_Snapshot_111.jpg

 

Just make sure your projector supports that

Edited by Doofus

Share this post


Link to post
Share on other sites
Crossfire0mega

One other suggestion is enable refresh rate switching. That will considerably lighten the load

 

5c15b9487285d_Snapshot_111.jpg

 

Just make sure your projector supports that

 

I think it does, this is the projector I have.

 

https://www.optoma.com/us/product/hd27hdr/

Share this post


Link to post
Share on other sites
Guest asrequested

It looks like it does, but I don't know which rates. Try it, and see.

 

5c15d7fdea182_Snapshot_115.jpg

 

And it also looks like it will support 4k

 

5c15d831cde15_Snapshot_113.jpg

Share this post


Link to post
Share on other sites
Crossfire0mega

It looks like it does, but I don't know which rates. Try it, and see.

 

5c15d7fdea182_Snapshot_115.jpg

 

And it also looks like it will support 4k

 

5c15d831cde15_Snapshot_113.jpg

 

I set the variable refresh rate setting and every time i stopped a video the projector would lose the source and glitch out. I turned it back off and it hasn't done it since.

 

Also I am trying another 1080P video file and it started transcoding it and I don't understand why this time.

post-29324-0-30420100-1544937286_thumb.jpg

This one is not 4K or HDR btw.

ServerLog1.txt

TranscodeLog.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...