Jump to content


Photo

Files and folders deleted - Cause unknown

gone deleted deletion files folders

  • Please log in to reply
7 replies to this topic

#1 Soki OFFLINE  

Soki

    Advanced Member

  • Members
  • 62 posts
  • Local time: 04:59 AM
  • LocationGermany

Posted 28 November 2018 - 09:13 AM

Hello fellow Emby enthusiasts,

 

I have just recognized that several media files have been deleted from the server.

It is not just a database/scanning issue, the actual folders where this media files have been in, are gone. I just found out about the deletion because the collection folder had some movies in it which are not present under the corresponding folders. The media harddrive is raid protected, a manual deletion can be excluded also.

 

 

- Can you guys think of any other possibility which may randomly deleting media folders?

- The option to allow deletion which can be done in user settings, could that have been it maybe?

... and if yes, is there a log which can be searched for this event - and what string should be looked for?

EDIT: searched the logs and couldnt find any deletion - but have to say logs go only back for a couple of days and the deletion could have very well happened several month ago.

 

Thanks.

Soki

 

EDIT: just allowed media deletion for a test account and i was not able to delete any file under any section.

Therefor I assume another situation must have caused the deletions.


Edited by Soki, 28 November 2018 - 09:48 AM.


#2 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2777 posts
  • Local time: 11:59 PM
  • LocationLong Island, NY

Posted 28 November 2018 - 10:28 AM

check your system logs



#3 Soki OFFLINE  

Soki

    Advanced Member

  • Members
  • 62 posts
  • Local time: 04:59 AM
  • LocationGermany

Posted 28 November 2018 - 10:55 AM

check your system logs

For what exactly? Where exactly? There is no user active in the backend so looking in bash history will no bring up anything. And i dont know where to find logs which may show any deletions. Just a phrase like "check system logs" is not really helpful sorry.



#4 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2777 posts
  • Local time: 11:59 PM
  • LocationLong Island, NY

Posted 28 November 2018 - 11:01 AM

I guess it's pretty moot since they could've been deleted months ago and no logs are persisted for that long.  gl



#5 Soki OFFLINE  

Soki

    Advanced Member

  • Members
  • 62 posts
  • Local time: 04:59 AM
  • LocationGermany

Posted 28 November 2018 - 11:24 AM

I guess it's pretty moot since they could've been deleted months ago and no logs are persisted for that long.  gl

true. i can only go back a couple of days.

 

but it is still important if anybody may have experienced something like this before too.

I mean it is not pleasent to have my beloved collection cut in pieces and not being able to find the cause and therefor to prevent another event like this.



#6 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2777 posts
  • Local time: 11:59 PM
  • LocationLong Island, NY

Posted 28 November 2018 - 12:13 PM

true. i can only go back a couple of days.

 

but it is still important if anybody may have experienced something like this before too.

I mean it is not pleasent to have my beloved collection cut in pieces and not being able to find the cause and therefor to prevent another event like this.

Yeah the only time anything similar has happened was when my NAS was offline during a scheduled library scan and I tried playing something and got the "file not found" thing.  Brief moment of panic.  

 

I can't think of any reason/possibility why emby would initiate a delete w/o a manual trigger.  Have you ruled out corrupted disk(s)?



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138263 posts
  • Local time: 11:59 PM

Posted 28 November 2018 - 01:06 PM

If it happened months ago then unfortunately all we can do is speculate. In the past there were defects with older server versions where for example if you delete a movie, it would delete the whole parent folder. Maybe that was it, but unfortunately there's no way to know.

 

If it happens again, then we can dive in and chase it down. Thanks !



#8 schmitty OFFLINE  

schmitty

    Advanced Member

  • Members
  • 488 posts
  • Local time: 02:59 PM
  • LocationMorwell, VIC AU

Posted 29 November 2018 - 10:31 PM

It could possibly be a setting in Sonarr or Radarr


Sent from my iPhone using Tapatalk





Also tagged with one or more of these keywords: gone, deleted, deletion, files, folders

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users