Jump to content


Photo

Emby v3.3.1 (Docker): No Compatible Streams for snome, not all FLAC files

linux docker flac error web interface

  • Please log in to reply
3 replies to this topic

#1 mholloway OFFLINE  

mholloway

    Member

  • Members
  • 12 posts
  • Local time: 10:11 AM

Posted 27 April 2018 - 06:16 PM

Hey Emby Sages, looking for some help figuring out why some flac files play via the web interface and some don't.

Attached File  Emby_Playback_FLAC_Error_Screenshot from 2018-04-27 17-18-00.png   83.23KB   2 downloads
 

The errors are presenting in Firefox 59.02. They do not occur via the Android App and when I download the offending file to the local storage I'm able to play it in the client's OS (Rhythmbox).

 

docker logs -f [container name] doesn't yield anything past the success of the entrypoint script.

 

Is there a way (possibly via attach?) that I can get a better look at what the decoding/encoding error might be?

Thanks in advance

Mike



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 145887 posts
  • Local time: 09:11 AM

Posted 27 April 2018 - 06:32 PM

Hi there, we're sorry to hear about this. Can we please look at an example? Please attach the information requested in how to report a media playback issue. thanks !



#3 mholloway OFFLINE  

mholloway

    Member

  • Members
  • 12 posts
  • Local time: 10:11 AM

Posted 29 April 2018 - 02:16 PM

Hey Luke, thanks for the swift reply

Android App version is 2.9.92

Here's the server log for play attempts on both android app and Firefox web client for FLAC files that produce the error as well as FLAC files that do not.

 

Attached File  Log_flac_err_20180427.server.log   991.55KB   1 downloads

On line

Files like "The Six Parts Seven/The Black Keys/01 A Blueprint of Something Never Finished" play without issue on both the web client and the android app.

Errors in the log look like this:

 

 

677 2018-04-27 18:28:14.994 Error HttpServer: Error in ProcessAccept                                                                                                                                                
 678         *** Error Report ***                                                                                                                                                                                    
 679         Version: 3.3.1.0                                                                                                                                                                                        
 680         Command line: /system/EmbyServer.dll -programdata /config -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3                                                                                  
 681         Operating system: Unix 4.15.17.200                                                                                                                                                                      
 682         64-Bit OS: True                                                                                                                                                                                         
 683         64-Bit Process: True                                                                                                                                                                                    
 684         User Interactive: True                                                                                                                                                                                  
 685         Processor count: 2                                                                                                                                                                                      
 686         Program data path: /config                                                                                                                                                                              
 687         Application directory: /system                                                                                                                                                                          
 688         System.IO.IOException: Authentication failed because the remote party has closed the transport stream.                                                                                                  
 689            at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)                                                                                    
 690            at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)                                                                                                   
 691            at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)                                                                           
 692            at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)                                                                                       
 693            at System.Net.Security.SslState.ProcessReceivedBlob(Byte[] buffer, Int32 count, AsyncProtocolRequest asyncRequest)                                                                                   
 694            at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)                                                                                    
 695            at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)                                                                                                   
 696            at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)               


Files like "Brubeck/The Dave Brubeck Collection/10 Camptown Races.flac" play without issue on the android app and fail to play on the web client.

I'm unable to find any entries from this time in transcoding logs - this appears to confirm that decoding fails client side - I'm interested in finding out why and adjusting it.

Please let me know if you need more info and I'll gladly provide. Thanks!

 



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 145887 posts
  • Local time: 09:11 AM

Posted 29 April 2018 - 04:08 PM

Please try again with the next release of emby server, thanks.







Also tagged with one or more of these keywords: linux, docker, flac, error, web interface

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users