Jump to content


Photo

wmc has focus and can't be killed by remote keys

wmc remote focus autohotkey

  • Please log in to reply
5 replies to this topic

#1 braddles69 OFFLINE  

braddles69

    Advanced Member

  • Members
  • 107 posts
  • Local time: 12:03 PM
  • LocationAustralia

Posted 22 December 2017 - 01:16 AM

Okay, sorry for the extra question, but I have everything working properly with this compro remote (and logitech harmony) except shutdown.

The original remote wakes up the computer through PCIe Bios settings ok (from full off state- which is what I prefer as I have a remote power switch to kill all components TV, HTPC etc.

 

But the power off button only sends a sleep state shutdown, when I want a full power shutdown.

I have got around this by having a shutdown batch cmd, which is shortcut to "num 8" on the original remote and this I have taught the harmony as "Power toggle". This works, as long as it happens from the desktop.

 

But the HTPC uses Emby for WMC plugin, with WMC for Win 10 plugin, as I like this interface, my problem is closing WMC prior to executing the shutdown cmd.

I have Microsoft ME Media Player, and Micorsoft SE Media Player devices in logitech harmony, but the Win + D key (takes win to desktop), doesn't seem to work in Microsoft SE Player through logitech, if I use a physical keyboard...fine, I can go to desktop and then the "Power toggle" button works to shutdown.

 

So my problem is how to execute win + D through logitech, or how to assign it to a num 9 key in the remote,I even have a batch cmd to shutdown WMC, but again can't be activated while in WMC?

 

I can't assign complex keyboard shortcuts to the compro remote, but it does have the possibility to assign an exe program, so I tried assigning cmd.exe cmd /c "c:\WMC_Shutdown\WMC_Shutdown.cmd" to * key on remote but no go.

 

Just need a way to close WMC through remote key that can be mapped to logitech, so I can then execute shutdown bat that is already assigned and works when desktop is in focus.

 

Any ideas would be much appreciated, though I couldn't really get my head around eventghost or autohotkey...seem quite complex.

 

Thanks again, I tried all yesterday with a thousand diffferent configurations  ;) but keep getting stuck on the "go to desktop" problem.

 

TIA

 

Tried various combinations, batch file is there to run and kill ehshell.exe but when WMC is fullscreen, nothing short of a physical keyboard (Win+D) will minimise it, which I need to do before I can run proper shutdown, if WMC has focus my power toggle key isn't recognised and I go to a soft sleep, then when it wakes...no remote.

 

I am tearing my hair out, I have used autohotkey, and still when WMC has focus, it can't be minimised by remote keys, only by keyboard.

 

 

Suggestions anyone???


Edited by braddles69, 22 December 2017 - 02:51 AM.


#2 jachin99 ONLINE  

jachin99

    Advanced Member

  • Members
  • 626 posts
  • Local time: 10:03 PM

Posted 22 December 2017 - 11:36 AM

Go to contro panel -  Hardware and Sound - Power Options.  From here look on the far left side of the screen and click choose what the power buttons do.  Change when i press the power button and when I press the sleep button to shut down, and see what happens.  You shouldn't really need batch scripts to wake/sleep/power on and off the PC.  You should just need a remote button press that tells windows what to do through these settings. 



#3 jachin99 ONLINE  

jachin99

    Advanced Member

  • Members
  • 626 posts
  • Local time: 10:03 PM

Posted 22 December 2017 - 11:59 AM

Is this on a laptop or a desktop and how many devices are plugged into your USB port. It sounds like you a few different programs all trying to do the same task. It might help if you consolidated all your tasks to one program. You have an RF remote or an IR remote? I have a 9 port powered USB hub and I have a TON of controllers/ remotes that I can use on my machine. I also don't put my machine to sleep much.

#4 braddles69 OFFLINE  

braddles69

    Advanced Member

  • Members
  • 107 posts
  • Local time: 12:03 PM
  • LocationAustralia

Posted 22 December 2017 - 08:19 PM

Thanks @jachin99, This is a continuation of this problem, just new problem.

 

https://emby.media/c...erly-in-win-10/

 

This a HTPC, that has mobo Asus P8B75M, i5 2400K, 8gb Ram, and now uses Compro VideoMate E750 Tuner with remote and power patch cable attached to mobo PW Switch header so this tuner can wake the PC via remote.

 

see http://www.compro.co.../e750/e750.html Though Compro is no longer an operating company.

 

The power options offer change when I press the sleep button 1) Do Nothing 2) Sleep, I have changed them but no difference. The Power buttons offer 1) do nothing 2) Shut down 3) Sleep 4) Turn Off Display. Again changed them but no difference to the remote key power press, if WMC has focus the HTPC goes to sleep.

 

There is not much connected to the USB ports, a logitech USB keyboard mouse combo K260, and Asus BT400 bluetooth.

 

Not many programs are used System Mechanic, and WMC w Emby, this is a HTPC, turn on watch something from the server.

 

This seems to be a peculiar hardware issue with the remote, it wakes the PC fine but sends it to sleep with the same remote power button, obviously designed for scheduled recording. 

 

I don't think it is a bios issue as my batch command works fine from desktop to send the PC to full power off.

 

I know the previous tuner remote (Dvico Fusion remote) had a different  hardware issue with remote button it need to be pressed twice within 5 secs to confirm full power off.

 

This is why I am trying for a workaround.

 

 

On a sidenote, the compro software wouldn't load until I made it work with Windows 7 compatability



#5 braddles69 OFFLINE  

braddles69

    Advanced Member

  • Members
  • 107 posts
  • Local time: 12:03 PM
  • LocationAustralia

Posted 23 December 2017 - 11:35 PM

So to answer my own question, after lots of trial and error, I solved my problem by doing this.

 

1) Created a shutdown batch command and assigned it to num 8 (which can be sent from remote - both original and logitech harmony)

 

2) Found that Alt+F4 closes WMC, and using autohotkey, created a simple script to assign this to * button (also sendable from remote)

 

3) Pasted a shortcut of this autohotkey script in the start up folder - so this script starts when the PC starts.

 

 Couldn't use eventghost as my remote plugin was not available.

 

 So the new commands from logitech harmony go like this:-

 

1) Press *, therefore closing WMC

 

2) Wait 1 sec

 

3) Press Num 8, initiate batch command and shut down HTPC fully.

 

Hope this will help anyone else who has a funky remote that doesn't want to fully power down a HTPC



#6 jachin99 ONLINE  

jachin99

    Advanced Member

  • Members
  • 626 posts
  • Local time: 10:03 PM

Posted 26 December 2017 - 11:55 AM

Glad you got it figured out anyway
  • braddles69 likes this





Also tagged with one or more of these keywords: wmc, remote, focus, autohotkey

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users