Jump to content

Search the Community

Showing results for tags 'autohotkey'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support


  • Emby Blog


There are no results to display.

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...

Found 1 result

  1. Okay, sorry for the extra question, but I have everything working properly with this compro remote (and logitech harmony) except shutdown. The original remote wakes up the computer through PCIe Bios settings ok (from full off state- which is what I prefer as I have a remote power switch to kill all components TV, HTPC etc. But the power off button only sends a sleep state shutdown, when I want a full power shutdown. I have got around this by having a shutdown batch cmd, which is shortcut to "num 8" on the original remote and this I have taught the harmony as "Power toggle". This works, as long as it happens from the desktop. But the HTPC uses Emby for WMC plugin, with WMC for Win 10 plugin, as I like this interface, my problem is closing WMC prior to executing the shutdown cmd. I have Microsoft ME Media Player, and Micorsoft SE Media Player devices in logitech harmony, but the Win + D key (takes win to desktop), doesn't seem to work in Microsoft SE Player through logitech, if I use a physical keyboard...fine, I can go to desktop and then the "Power toggle" button works to shutdown. So my problem is how to execute win + D through logitech, or how to assign it to a num 9 key in the remote,I even have a batch cmd to shutdown WMC, but again can't be activated while in WMC? I can't assign complex keyboard shortcuts to the compro remote, but it does have the possibility to assign an exe program, so I tried assigning cmd.exe cmd /c "c:\WMC_Shutdown\WMC_Shutdown.cmd" to * key on remote but no go. Just need a way to close WMC through remote key that can be mapped to logitech, so I can then execute shutdown bat that is already assigned and works when desktop is in focus. Any ideas would be much appreciated, though I couldn't really get my head around eventghost or autohotkey...seem quite complex. Thanks again, I tried all yesterday with a thousand diffferent configurations but keep getting stuck on the "go to desktop" problem. TIA Tried various combinations, batch file is there to run and kill ehshell.exe but when WMC is fullscreen, nothing short of a physical keyboard (Win+D) will minimise it, which I need to do before I can run proper shutdown, if WMC has focus my power toggle key isn't recognised and I go to a soft sleep, then when it wakes...no remote. I am tearing my hair out, I have used autohotkey, and still when WMC has focus, it can't be minimised by remote keys, only by keyboard. Suggestions anyone???
  • Create New...