Jump to content


Photo

Emby server not finding any folder/share (Raspberry PI 3)

folder network share detect cifs usb raspberry pi path docker library

  • Please log in to reply
2 replies to this topic

#1 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 56 posts
  • Local time: 10:18 AM
  • LocationFrance

Posted 29 May 2017 - 06:09 AM

Hello,

 

 

I installed Emby server on my Raspberry PI 3 recently (Docker official method).

 

It was a little difficult (linux noob inside :P ) but now all seems to be OK.

 

 

But,

i'm now trying to add a library, but there's a problem as i can't find any folder or share hosted / mounted on the RPi :  (as you can see there's nothing but default paths)

 

592bf0c8eaac2_1.jpg

 

 

 

(network choice empty too) :

 

592bf0d58fbbc_2.jpg

 

 

 

How Emby detects disks and network shares ?

 

Here is what i have and would want to choose  :  1 usb hdd (ext4) + 1 network share (cifs) :

 

592bf1735905b_3.jpg

 

 

If it must be set in Docker, how can i do it  (and would it be kept if Emby image is updated ?)

 

 

Thanks a lot for your assistance.

 

Best regards,

 

 



#2 hurricanehrndz OFFLINE  

hurricanehrndz

    Advanced Member

  • Developers
  • 1249 posts
  • Local time: 02:18 AM

Posted 29 May 2017 - 10:01 AM

Emby within docker only list volumes you mount within the container. When you ran the docker wrapper script "emby-sever" it should have prompted you on the commandline for which directories you wanted the container to have access to. CIFS is still a feauter being implemented. Please mount the share on your host and answer the prompts​ appropriately. If you have already answered the question, remove the existing volume file (.emby.docker.volumes or something​ close). In terms of keeping the image up to date, it is all documented on the hub. Please visit hub.docker.com/r/emby/embyserver. Please read through the documentation, all the information you have requested should be there.

Sent from my ONEPLUS A3000 using Tapatalk

#3 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 56 posts
  • Local time: 10:18 AM
  • LocationFrance

Posted 30 May 2017 - 03:30 AM

Hi hurricanehrndz,

 

 

You are right  :) .

 

i must have bypassed by mistake the prompt of the 1st Emby-Server launch.

I deleted  /home/<USER>/.emby-server/.emby-server.volumes  then restarted emby-server.

 

All is now working concerning paths   :D

 

Thanks a lot.

 

Best regards,


  • hurricanehrndz likes this





Also tagged with one or more of these keywords: folder, network, share, detect, cifs, usb, raspberry pi, path, docker, library

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users