Jump to content
SuperPotatoMen

Ombi for Emby

Recommended Posts

SuperPotatoMen

qQsN78U.png

Ombi for Emby


Ombi allows you to host your own user management, request and notification system.
If you are sharing your Emby server with other users, allow them to request new content using an easy to manage interface!
Manage all your requests for Movies and TV with ease, leave notes for the user and get notification when a user requests something.
Allow your users to post issues against their requests so you know there is a problem with the audio etc.
Even automatically sent them weekly newsletters of new content that has been added to your Emby server!


Report a bug Do a feature Request Github (download)


Printscreen

moviesearch.png


Features

Here some of the features Ombi has:
  • All your users to Request Movies, TV Shows (Whole series, whole seaons or even single episodes!) and Albums
  • Easily manage your requests
  • User mangement system (supports Emby, Plex.tv accounts and local accounts)
  • Sending newsletters
  • Fault Queue for requests (Buffer requests if Sonar/Couchpotato/SickRage is offline)
  • Allow your users to report issues and manage them seperatl
  • A landing page that will give you the availability of your media server and also add custom notification text to inform your users of downtime.
  • Allow your users to get notifications!
  • Secure authentication so you don't have to worry about those script kiddies
  • We check to see if the request is already in your media server, if it's already there then why you requesting it?!
  • We have allowed the ability for a user to add a custom note on a request
  • It automatically update the status of requests when they are available on your media server
  • Slick, responsive and mobile friendly UI
Integration
We integrate with the following applications:
  • Plex server 1.2 (and higher)
  • Emby In beta (pleas download the EAP branch!!)
  • Sonarr
  • SickRage
  • CouchPotato
  • Radarr
  • Watcher
  • Headphones
  • Notifications

Supported notifications:
  • SMTP Notifications (Email)
  • Pushbullet
  • Pushover
  • Slack
  • Weekly Recently Added email notification to all of your media server Users!
You can find the .zip here: https://ci.appveyor.com/project/tidusjar/requestplex/branch/eap/artifacts

Install instructions are in the wiki: https://github.com/tidusjar/Ombi/wiki

Official Ombi forums: https://forums.ombi.io

. Edited by CBers
  • Like 14

Share this post


Link to post
Share on other sites
SuperPotatoMen

Emby support is still in development branch and not ready yet for using it. But @@tidusjar did already a lot of work. We hope we can release it in the new version  :)

Edited by SuperPotatoMen
  • Like 2

Share this post


Link to post
Share on other sites
Diedrich

Wow, super cool! This is exactly what I need. Would love to give it a go.

Share this post


Link to post
Share on other sites
MSattler

This is now in the Early Access Preview (Beta) branch.

 

You can find the .zip here: https://ci.appveyor.com/project/tidusjar/requestplex/branch/eap/artifacts

 

Install instructions are in the wiki: https://github.com/tidusjar/Ombi/wiki

For the setup, when you enter server, port, and API key there should be some input validation to ensure the user actually puts in a port.  Else it just spins and spins =)

  • Like 1

Share this post


Link to post
Share on other sites
MSattler

So here is a short coming I see.  In Sonarr I setup my content to go to a couple of different places.  Due to volume I have a few mounts:

 

/mnt/TV-Series  \\tower1\TV-Series

/mnt/TV-Series2 \\Tower2\TV-Series

/mnt/Kids-TV \\tower2\KidsTV

 

I do this because I have more than 1 server for content, and because I like to seperate Kids from Adult stuff.

 

The issue I run into is that I can only have 1 option for where to throw the content.  So right now it all goes to /mnt/TV-Series2 since it has the most space, but I have to move kids content over manually.  Any thought for a work around?

Share this post


Link to post
Share on other sites
Waseh

I can't seem to search for anything - the search screen doesn't actually contain a search bar for me

Edited by Waseh

Share this post


Link to post
Share on other sites
tidusjar

So here is a short coming I see.  In Sonarr I setup my content to go to a couple of different places.  Due to volume I have a few mounts:

 

/mnt/TV-Series  \\tower1\TV-Series

/mnt/TV-Series2 \\Tower2\TV-Series

/mnt/Kids-TV \\tower2\KidsTV

 

I do this because I have more than 1 server for content, and because I like to seperate Kids from Adult stuff.

 

The issue I run into is that I can only have 1 option for where to throw the content.  So right now it all goes to /mnt/TV-Series2 since it has the most space, but I have to move kids content over manually.  Any thought for a work around?

 

That is just the default, if a request comes in for a series, there is a dropdown option on the request to specify a different path for that request.

 

I can't seem to search for anything - the search screen doesn't actually contain a search bar for me

Really?

 

I've never had that  one before, can you log it on Github?

Share this post


Link to post
Share on other sites
SuperPotatoMen

I can't seem to search for anything - the search screen doesn't actually contain a search bar for me

You need to enable a backend system (like Sonarr, sickrage , CP ectr) otherway it not showing a search bar

Edited by SuperPotatoMen

Share this post


Link to post
Share on other sites
Waseh

I've enabled both sonarr and couchpotato. Both succeed the connectivity test.

 

In the logs I'm also getting failed to obtain emby libraries but I'm guessing that's something to do with the open issue on GitHub?

Edited by Waseh

Share this post


Link to post
Share on other sites
SuperPotatoMen

I've enabled both sonarr and couchpotato. Both succeed the connectivity test.

 

In the logs I'm also getting failed to obtain emby libraries but I'm guessing that's something to do with the open issue on GitHub?

 

Hmm okay, 

 

Did you enable Search for Movies and Search  TV Shows  in the  Plex Request Settings page?

Edited by SuperPotatoMen

Share this post


Link to post
Share on other sites
Waseh

Aah that's where the problem was! Search bar is now present! :) Cheers

 

Edit: it's working perfectly so far! Very pleased and incredibly impressed with the speed this progressed at!

Edited by Waseh
  • Like 1

Share this post


Link to post
Share on other sites
Jdiesel

Instructions for those would would like to install on Ubuntu 16.04 and using systemd to autostart the service as the HTPC Guide linked in the Ombi wiki is stilling using an init.d script. Since you require Mono to run Emby this assumes you already have Mono installed. If you plan to run Ombi on a different server you will need to install Mono first.

 

 

Create the installation directory. Change user:user to the username and group your would like to run Ombi as.

sudo mkdir /opt/ombi
sudo chown -R user:user /opt/ombi

Create a configuration folder in your home directory. Change the user to to the one you will run the service as.

sudo mkdir /home/user/.config/ombi
sudo chown -R user:user /home/user/.config/ombi

Download the latest release of Ombi from Github to a temporary directory.

cd /tmp
wget https://github.com/tidusjar/Ombi/releases/download/v2.1.0/Ombi.zip

Extract the package and move it to the install directory.

unzip Ombi.zip
rm Ombi.zip
cd /tmp/Release
mv * /opt/ombi/

Create a new systemd called ombi.service

sudo nano /lib/systemd/system/ombi.service

Copy the following text into the ombi.service systemd. Change the user and group to the same as you selected for the installation folder. Also change the working directory to the one your created above.

[Unit]
Description=Ombi
After=network.target

[Service]
User=user
Group=user

Type=simple
WorkingDirectory=/home/user/.config/ombi
ExecStart=/usr/bin/mono /opt/ombi/Ombi.exe -p 3579
Restart=always
TimeoutStopSec=30

[Install]
WantedBy=multi-user.target

Enable the systemd.

sudo systemctl enable ombi.service

Start the service. You can check if the service is running by running the status command.

sudo systemctl start ombi.service
sudo systemctl status ombi.service
Edited by Jdiesel
  • Like 1

Share this post


Link to post
Share on other sites
CBers

I followed the instructions for Windows installation above, but Ombi keeps crashing.

 

I've just rebooted the PC to see if that's the issue.

 

Everything seemed to install OK:

 

Capture1147.JPG

 

Ombi log here.

 

If/when it runs OK, how do I access it ??

 

Is it http://localhost:3579 ??

Share this post


Link to post
Share on other sites
MSattler

I followed the instructions for Windows installation above, but Ombi keeps crashing.

 

I've just rebooted the PC to see if that's the issue.

 

Everything seemed to install OK:

 

Capture1147.JPG

 

Ombi log here.

 

If/when it runs OK, how do I access it ??

 

Is it http://localhost:3579 ??

http://localhost:3579/ yup!

 

And check to see if you have .net installed.

Share this post


Link to post
Share on other sites
MSattler

Plex Requests.Net requires the .NET framework 4.5 which should be included in all versions of Windows after Vista.

  • Like 1

Share this post


Link to post
Share on other sites
CBers

Plex Requests.Net requires the .NET framework 4.5 which should be included in all versions of Windows after Vista.

 

OK, didn't realise that OMBI NEEDED 4.5, as I thought as Emby had installed 4.6.2, then that would be OK.

 

Installing 4.5 now :)

Share this post


Link to post
Share on other sites
tidusjar

.Net Framework is backwards compatible so 4.6 will be fine.

 

The problem is that windows has blocked some of the assemblies. Can you please unblock the zip file (right click properties) and then extract it.

Share this post


Link to post
Share on other sites
CBers

.Net Framework is backwards compatible so 4.6 will be fine.

 

The problem is that windows has blocked some of the assemblies. Can you please unblock the zip file (right click properties) and then extract it.

 

OK, I'll try that, but comments on the install page says that's no longer needed.

Share this post


Link to post
Share on other sites
tidusjar

What install page is that? One on github or external?

Share this post


Link to post
Share on other sites
CBers

What install page is that? One on github or external?

 

I only saw the EXTERNAL one - didn't realise there were 2 sets on that page.

 

Using your one now :)

 

EDIT: Your link, links though to the external one anyway.

Edited by CBers

Share this post


Link to post
Share on other sites
Jdiesel

What install page is that? One on github or external?

 

The installation guide on the Github page that links to the HTPC Guide. 

 

Edit: I see the internal guide now on the wiki. I missed it at first and went straight to the external guide linked in the README.md.

Edited by Jdiesel

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...