Jump to content

H/W Transcoding on Evansport (DS415play/DS214play) Machines


solabc16
 Share

Recommended Posts

benjibarnicals

Hey all, I'm running a DS415Play with the latest DSM and Emby (4.4.3.0), and did the ffmpeg hack, though all I get when trying to transcode files (files written in h264 AAC2.0) is after about 5 seconds "No compatible streams are currently available". They will play Direct Play fine. I've got a Premiere license, I view my content on an LG WebOS3.5 TV using the Emby Theatre app (latest version). When I did the hack to turn it on, I stoped/started the Emby package.

And secondly, I can't run the disable method as I get the error:

Validating Version   : FAILED
ERROR: Switch component returned an error, exiting script.

I don't know what "version" I should use, as I can't find out what version it had originally before the hack.

Any ideas on why the hacked method isn't working (ie. giving me the stream error) or why.I can't revert ffmpeg back, as now I can no longer play videos I tried to transcode as it will automatically try to transcode that video next time I try to play it, and won't allow me to select Direct Play.

I've attached a log, hope this helps.

 

 

EDIT: I've fixed the switchcomp issue, I found the latest version was ffmpeg 4.3.0 so it successfully switched it back to this version. So, the main issue is now why when I enable the hack does none of my media videos hardware transcode and throws up the No Streams error?

ffmpeg-transcode-615bf978-284b-4e2d-bb4f-e03813bf71ff_1.txt

Edited by benjibarnicals
Link to comment
Share on other sites

26 minutes ago, benjibarnicals said:

Hey all, I'm running a DS415Play with the latest DSM and Emby (4.4.3.0), and did the ffmpeg hack, though all I get when trying to transcode files (files written in h264 AAC2.0) is after about 5 seconds "No compatible streams are currently available". They will play Direct Play fine. I've got a Premiere license, I view my content on an LG WebOS3.5 TV using the Emby Theatre app (latest version). When I did the hack to turn it on, I stoped/started the Emby package.

And secondly, I can't run the disable method as I get the error:

Validating Version   : FAILED
ERROR: Switch component returned an error, exiting script.

I don't know what "version" I should use, as I can't find out what version it had originally before the hack.

Any ideas on why the hacked method isn't working (ie. giving me the stream error) or why.I can't revert ffmpeg back, as now I can no longer play videos I tried to transcode as it will automatically try to transcode that video next time I try to play it, and won't allow me to select Direct Play.

I've attached a log, hope this helps.

 

 

EDIT: I've fixed the switchcomp issue, I found the latest version was ffmpeg 4.3.0 so it successfully switched it back to this version. So, the main issue is now why when I enable the hack does none of my media videos hardware transcode and throws up the No Streams error?

ffmpeg-transcode-615bf978-284b-4e2d-bb4f-e03813bf71ff_1.txt 8.34 kB · 0 downloads

Hi there, I would suggest taking a look at this:

 

Link to comment
Share on other sites

benjibarnicals
20 minutes ago, Luke said:

Hi there, I would suggest taking a look at this:

 

Ok, and would that be installing the BETA 4.5.0 version? As I already have the most recent stable 4.4.3.

Edited by benjibarnicals
Link to comment
Share on other sites

benjibarnicals
15 minutes ago, Luke said:

That or you can wait for the upcoming 4.5 stable release.

Ahhh cheers, any idea when the stable release is out?

Link to comment
Share on other sites

patje57
14 hours ago, benjibarnicals said:

Ok, and would that be installing the BETA 4.5.0 version? As I already have the most recent stable 4.4.3.

DS415play/DS214play are 32bit and require specific installer, i don't see that on the page Luke refers too. The Syno package made available there won't install on these machines.

Maybe i overlooked something, if so Luke will certainly tell

Link to comment
Share on other sites

  • 7 months later...
flashls82

Sorry if this has been answered elsewhere, but couldn't find a clear answer on this thread. I've got a DS214play (Evansport architecture). Is there still no way for Emby to access the hardware acceleration codecs on these models (i.e. the h264-smd codecs in the version in Synology's stock ffmpeg)? Logs suggest Emby is choosing the software encoder even though I've got an active premiere subscription and hardware acceleration is enabled in settings. 

Link to comment
Share on other sites

On 3/27/2021 at 5:23 AM, flashls82 said:

Sorry if this has been answered elsewhere, but couldn't find a clear answer on this thread. I've got a DS214play (Evansport architecture). Is there still no way for Emby to access the hardware acceleration codecs on these models (i.e. the h264-smd codecs in the version in Synology's stock ffmpeg)? Logs suggest Emby is choosing the software encoder even though I've got an active premiere subscription and hardware acceleration is enabled in settings. 

Hi there, we're more than happy to help. Please see how to report a problem. Thanks !

Link to comment
Share on other sites

flashls82
4 hours ago, Luke said:

Hi there, we're more than happy to help. Please see how to report a problem. Thanks !

I guess my question is whether this is actually a "problem"--is hardware transcoding supposed to be supported for Synology devices running the Evansport architecture? I know it's generally been very tricky for third-party apps to take advantage of it. But if the "how to report a problem" is the right place to go to get an answer there, I can certainly try. 

Link to comment
Share on other sites

1 hour ago, flashls82 said:

I guess my question is whether this is actually a "problem"--is hardware transcoding supposed to be supported for Synology devices running the Evansport architecture? I know it's generally been very tricky for third-party apps to take advantage of it. But if the "how to report a problem" is the right place to go to get an answer there, I can certainly try. 

It should work and utilize what the hardware supports, so that's why we should look at it from the beginning.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...