Jump to content

H/W Transcoding on Evansport (DS415play/DS214play) Machines


solabc16

Recommended Posts

Is it possible that the official synologyy media server package installed this version? I installed it after emby server. Because I thought it was maybe needed for HW transcoding.

Link to post
Share on other sites
solabc16

Hello @@wzzly

 

The h/w transcoding available on 'evansport' based Synology systems, is essentially proprietary. The FFmpeg changes needed to support the transcoding h/w available did not find their way back into the open source project.

 

I've discussed this elsewhere, for example : https://emby.media/community/index.php?/topic/43282-hw-transcoding-on-evansport-ds415playds214play-machines/?p=443715

 

So this 'workaround' / 'hack' was developed in response to user demand, as you'll see through the evolution of this thread amongst others.

 

It's certainly not clean and there are probably steps we could take to improve it, but it really is a 'best efforts'.

 

Essentially what the instructions mentioned here do, is allow the version of FFmpeg being used by Emby Server to be switched on the fly, so if you have content that can take advantage of the h/w transcoding capabilities offered by the 'evansport' based systems you can try it out and see if it works for you.

 

From Emby Server's perspective, the platform does not provide h/w transcoding support through any of the typical interfaces, which on Synology means the VA-API.

 

Best

- James

Link to post
Share on other sites
  • 2 months later...

Hi, I have installed Emby Server onto my Synology DS214play to try out your hardware transcoding, and have two questions please:

 

Does this require a Emby Premiere License to work?

 

Does DTS sound playback with this?

 

Thank you.

Link to post
Share on other sites
Luke

Hi, I have installed Emby Server onto my Synology DS214play to try out your hardware transcoding, and have two questions please:

 

Does this require a Emby Premiere License to work?

 

Does DTS sound playback with this?

 

Thank you.

Hi, for hardware transcoding yes, and yes, dts sound is supported.

  • Like 1
Link to post
Share on other sites

Hi, for hardware transcoding yes, and yes, dts sound is supported.

 

Hi again and thanks for your reply,

 

I have been trying it out without a Premier License and DTS is not playing back unless I disable the H/W transcoding, is that supposed to happen?

Link to post
Share on other sites
Luke

Hi again and thanks for your reply,

 

I have been trying it out without a Premier License and DTS is not playing back unless I disable the H/W transcoding, is that supposed to happen?

 

No, let's look at an example. Please see how to report a media playback issue. thanks !.

Link to post
Share on other sites

Hi, I am having no problems playing back my music files, some of my films play back with sound (aac files) but none of my DTS & some AC3 films will playback with sound, the picture quality is perfect.

 

Everything played back perfectly before doing the H/W Transcoding

 

I am including the ffmpeg-remux log...I hope that is correct?

 

ffmpeg remux log.rtf

 

 

Link to post
Share on other sites
sonny_life

Nothing from anybody, so I am assuming it is a no go on my Synology DS214Play?

As far as I remember there is no DTS sound with emby and H/W transcoding enabled.

Link to post
Share on other sites

Nothing from anybody, so I am assuming it is a no go on my Synology DS214Play?

 

Didn't get the H/W transcoding workaround working with DTS sound on DS415play either. So indeed a no go on DS214play / DS415play. All other formats are working well with the H/W transcoding workaround thou.

There may other work arounds avaible, i stopped googling as DTS isn't really an issue for me. I'm good with this solution.

Link to post
Share on other sites

As far as I remember there is no DTS sound with emby and H/W transcoding enabled.

 

This isn't true, that is mis-information, and that log isn't using hardware acceleration anyway so even then it would be inapplicable.

Link to post
Share on other sites

Hi, I am having no problems playing back my music files, some of my films play back with sound (aac files) but none of my DTS & some AC3 films will playback with sound, the picture quality is perfect.

 

Everything played back perfectly before doing the H/W Transcoding

 

I am including the ffmpeg-remux log...I hope that is correct?

 

attachicon.gifffmpeg remux log.rtf

 

What Emby app are you playing from here?

Link to post
Share on other sites
sonny_life

This isn't true, that is mis-information, and that log isn't using hardware acceleration anyway so even then it would be inapplicable.

Sorry to disappoint you, but I already reported DTS playback issues on page 2 in this thread. DTS sound never worked with my DS214play in any of the versions that I tried.

Link to post
Share on other sites

Hi, I have Ember Server 4.1.1.0-1 on my Synology DS214play and hear no sound when playing back files on either my web browser (Safari & Chrome Emby mobile 4.1.1.0) or on my Apple TV4K.

 

As I wrote earlier, no problems before doing the H/W transcoding workaround.

Link to post
Share on other sites

I would suggest trying again with the next release as there is another round of hardware transcoding improvements. Thanks.

  • Like 1
Link to post
Share on other sites

I would suggest trying again with the next release as there is another round of hardware transcoding improvements. Thanks.

 

Luke, are you saying you're considering enabling standard H/W transcoding on Evansport?

At least this is how i tend to understand your answer.

I've always understood neither Emby nor the others have that on their list, I believe due to the processor not supporting VAAPI

Link to post
Share on other sites
  • 5 months later...
jmassaro87

Hi there, have you checked out our hardware acceleration setup guide:

https://github.com/MediaBrowser/Wiki/wiki/Hardware-Acceleration-Overview

?

I Have. Not even sure what my device falls under. Linux i know but thats about it. Running a test right now. Streaming a movie from work. It is transcoding, NAS CPU is right at about 40% so doesn't seem to be over taxing. Might not need to do anything?

Link to post
Share on other sites

I Have. Not even sure what my device falls under. Linux i know but thats about it. Running a test right now. Streaming a movie from work. It is transcoding, NAS CPU is right at about 40% so doesn't seem to be over taxing. Might not need to do anything?

 

Can we look at an example? thanks.

Link to post
Share on other sites

Is this still necessary? Or are we to a  point where it is built in to the SW package? Just got my DS418play up and running.

 

The workaround is normally not needed for DS418play.

The DS418play doesn't have an Evansport type processor, but later generation Intel Celeron J3355 (same as in the DS218+) which should support HW transcoding out of the box, at least it does on DS218+.

 

BR, Pat

Edited by patje57
  • Like 1
Link to post
Share on other sites
  • 7 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...