Jump to content

Kodi addon subtitle special character problem


cassioac
 Share

Recommended Posts

cassioac

When I try to stream videos from my emby server (latest stable version) through kodi addon using http (didn't try through UNC paths), special characters appears with ? instead of the characters.

 

 

27hIIAvT.png

 

 

Also that only happens with emby/emby addon/kodi, plex/plexbmc/kodi works fine with the same subs...

 

Subtitles are Brazilian Portuguese.

 

Is there any fix for that or only converting the subtitle to UTF-8 would solve it?

 

I have a script that downloads the subtitles automatically, and I really wouldn't like to have this extra step of fixing subtitles after downloading them...

 

Thanks

 

Cassio

 
 
EDIT: Please let me know if I should provide any log file
Edited by cassioac
Link to comment
Share on other sites

Angelblue05

I don't have this issue, I tried via direct play and direct stream and they display correctly. Could you possibly provide the srt for more testing? Otherwise you will have to either convert or redownload them. The server has an option to download subs for you, maybe you can give it a try to see if it saves you time?

Link to comment
Share on other sites

Angelblue05

Ok, I took a quick glance at the file and it looks fine to me.

 

Can you go in Kodi settings > Videos > Subtitles > Font to use for text subtitles and make sure it's set to arial.ttf to make sure it's able to display the special characters correctly?

If you do not see the option, make sure the settings level is set to at least Standard.

 

Edit: Don't forget to restart Kodi.

Edited by Angelblue05
Link to comment
Share on other sites

cassioac

Ok, I took a quick glance at the file and it looks fine to me.

 

Can you go in Kodi settings > Videos > Subtitles > Font to use for text subtitles and make sure it's set to arial.ttf to make sure it's able to display the special characters correctly?

If you do not see the option, make sure the settings level is set to at least Standard.

 

 

Yes, arial.ttf is selected (default installation...).

 

Also I've just tried over the internet (on firefox) and it also displays incorrectly.

 

Did you run this subtitle and it appeared correctly for you????

 

I've already tried in at least 3 different clients, multiple subtitles has the same problem...

Link to comment
Share on other sites

Angelblue05

I'm not sure what it could be sorry. At this point, I would ask in the server section of the forums. If you wish, I can move this thread there. What platform do you use? Windows?

Edited by Angelblue05
Link to comment
Share on other sites

cassioac

I'm not sure what it could be sorry. At this point, I would ask in the server section of the forums. If you wish, I can move this thread there. What platform do you use? Windows?

 

Ubuntu for the server:

 

Linux plex 3.16.0-53-generic #72~14.04.1-Ubuntu SMP Fri Nov 6 18:17:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

 

Please move the thread, thanks

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...