Jump to content

keep getting kicked back to login screen


Crossfire0mega
 Share

Go to solution Solved by twistedLucidity,

Recommended Posts

Crossfire0mega

Hello, I have a newly installed EMBY server running on Ubuntu 14.04.3 x86 server. I have gone through the install process and I was just trying to setup the media locations which are local directories and whenever I try to enter the location in it kicks me back out to the login screen. I have only one account setup and I created the local folders for my media with the same account as for emby. I also tried to change the server cache files path from the default under advanced settings and the same thing happened, kicked right back out to the login page. I don't know what's causing this, any help would be great.

 

Thanks.

 

 

p.s. I also have samba installed and have made my media folders into shared network folders open to guest and tried the network paths in the media locations settings and it still kicked me back to the login screen then too.

Edited by Crossfire0mega
Link to comment
Share on other sites

the fact you're getting bounced is a bug and is resolved for the next release. the true problem is that the server does not have access to the paths you're trying to use. i believe for the ubuntu package it's running under a user called emby, so you might have to configure access for it.

  • Like 1
Link to comment
Share on other sites

Hello, I have a newly installed EMBY server running on Ubuntu 14.04.3 x86 server. I have gone through the install process and I was just trying to setup the media locations which are local directories and whenever I try to enter the location in it kicks me back out to the login screen. I have only one account setup and I created the local folders for my media with the same account as for emby. I also tried to change the server cache files path from the default under advanced settings and the same thing happened, kicked right back out to the login page. I don't know what's causing this, any help would be great.

 

Thanks.

 

 

p.s. I also have samba installed and have made my media folders into shared network folders open to guest and tried the network paths in the media locations settings and it still kicked me back to the login screen then too.

I have no idea why you are being bounced, but with Linux you have to 'mount' the share even if it's a samba share, you can do this by adding an entry into fstab to auto mount the share at boot. By doing this you can browse for the share from within Emby.

 

I have samba shares on a NAS box but Emby runs on Ubuntu server, I have added an fstab entry which creates a mount point for the share on Ubuntu (a symlink) and you would have to do the same even though the shares are on the same machine. It's a constraint of Linux/Unix, but once you have done this it will work.

 

Good luck, hope you get it sorted.

  • Like 1
Link to comment
Share on other sites

Crossfire0mega

Ok, so I changed the permissions on the media directory to user:emby and still when I tried to add the local path in the emby server settings it kicked me back to the login screen. I then tried to auto mount the samba shares in fstab and when I did a reboot the system hanged. Here is what I entered into fstab "//[server_name]/anime /home/crossfire/media/anime username=crossfire,password=[password] 0 0"

In order to get it back up I had to go into recovery, mount / as read/write and comment out that line in fstab. My goal is to have the media directories as network shares and be linked to the emby server. I would have at least expected the local paths to work once I changed the permissions though. And what seems to be wrong with the string i entered into fstab?

Link to comment
Share on other sites

Ok, so I changed the permissions on the media directory to user:emby and still when I tried to add the local path in the emby server settings it kicked me back to the login screen. I then tried to auto mount the samba shares in fstab and when I did a reboot the system hanged. Here is what I entered into fstab "//[server_name]/anime /home/crossfire/media/anime username=crossfire,password=[password] 0 0"

In order to get it back up I had to go into recovery, mount / as read/write and comment out that line in fstab. My goal is to have the media directories as network shares and be linked to the emby server. I would have at least expected the local paths to work once I changed the permissions though. And what seems to be wrong with the string i entered into fstab?

Start with a simple thing like manually mounting the samba shares locally. Once you have that working move on and figure out the permissions problem you seem to suffer too. And then once you get that figured out too and Emby is working fine start looking into fstab mounting or autofs.

 

Just my two cents.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Ok, so I changed the permissions on the media directory to user:emby and still when I tried to add the local path in the emby server settings it kicked me back to the login screen. I then tried to auto mount the samba shares in fstab and when I did a reboot the system hanged. Here is what I entered into fstab "//[server_name]/anime /home/crossfire/media/anime username=crossfire,password=[password] 0 0"

In order to get it back up I had to go into recovery, mount / as read/write and comment out that line in fstab. My goal is to have the media directories as network shares and be linked to the emby server. I would have at least expected the local paths to work once I changed the permissions though. And what seems to be wrong with the string i entered into fstab?

First install cifs-utils....sudo apt-get install cifs-utils

 

Then browse in the file system to either mnt or media, I have created mine under media, create a folder, lets say movies, using nemo or nautilus you should be able to change permissions.....mine is set to guest, browsable so that anyone can access it as my server is for internal home use.

 

Then edit your fstab to point to that share;

 

//<server name or ip address>/<samba share name>   /media/movies   cifs    user,users      0       0 

 

note the spaces, and by using user,users I do not need to create a credentials file, the other plus factor is if you move your samba shares to a NAS box you'll only need to edit the //<server name or ip address>/<samba share name> reboot after adding the fstab entry.

 

Now in Emby to add the path browse to /media and select the movies folder, this should now populate and you should see the contents of that move folder.

 

Don't forget you'll need to add an fstab entry for each share you want Emby to access.

 

BTW this is how I set mine up thanks to another user giving me some pointers.

 

Good luck.

Edited by geaves
  • Like 1
Link to comment
Share on other sites

  • Solution
twistedLucidity

Samba will have no effect on Emby as it won't be accesing the files that way (why have the server access internal files over SMB? Does't make much sense.

 

Run "ls -al /path/to/your/media" and check the permits as well as user/group ownership. If the folder is owned by "foo:bar" with permits 744 then Emby won't be able to see the files, even if it's in group "bar". For directories you need "Execute" to see their contents, so 745 would work in this example.

 

As you know how to alter ownership, I'm sure a few minutes spent checking the permits will yeild the answer.

 

I've just dumped Emby on Ubuntu Server 14.0.4.3 with media files in a user's home folder (I'm just testing at the moment) and I used directory permit 755 and file permit 744. Works fine.

  • Like 1
Link to comment
Share on other sites

Crossfire0mega

I created a new directory in home called emby and changed the ownership from root to emby:emby and created a media subdirectory in there with all my media files and folders. I also changed the perms on those to emby:emby as well and then just entered the local paths into the server settings and that seemed to work. I never went back to edit the fstab but still created the samba shares from within the smb.conf file. I am able to access the folders from my windows now as well.

 

Thanks guys for all your help!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...