Jump to content

Search the Community

Showing results for tags 'login'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 51 results

  1. lhamanda

    Logging in to Dashboard

    I cannot login into dashboard. The TV apps work fine even with login. But I can't login into dashboard for updates or adding/removing users, data and such. How can this be remedied.
  2. jonyskids

    Emby Select User

    When ever I turn on my TV to Kodi it asks me to login in to Emby. If I pause a show for a bit, when I go to start it again it plays for 20 seconds and the goes back to the home screen and ask me to login again. How do I stop this?
  3. BossRFC86

    Accesos (display-login)

    Buen día Me acerco con ustedes para saber si existe alguna forma de modificar la pantalla de logeo del sistema emby, Esto con la finalidad de accesar por medio de terceros (wordpress para ser específicos). He estado explorando varios topicos y se acercan mucho a lo que busco, pero no visualizo una solución como la que varios solicitamos. Sin mas por el momento, quedo pendeinte de sus valiosos comentarios. Saludos Cordiales. ____________________________________________________________________________________________________________________ good day I am approaching you to find out if there is any way to modify the emby system login screen, This with the modification of access through third parties (wordpress to be specific). I've been exploring various topics and they are very close to what I'm looking for, but I don't see a solution like the one we requested. Without further ado for the moment, I remain pending your valuable comments. Best regards.
  4. johnsonb

    Cannot log into Emby

    Hello. Some how I messed up my Emby account on the Roku box. It was working fine and then I removed the pwd and that is when the trouble started. I go into it now and a pin-wheel spins for a few seconds, and I am bounced right back out. I tried adding a pwd back to the account however no luck. If that account is the last one I used, is it ok if I delete it and create a new one? I do not want to mess this up any more. thanks guys.
  5. Lameslime

    Picture as login background

    Started using Emby couple days ago, problems here and there, but this is something I can't solve. As the title says I'd like to change the color grey in login screen into a picture of my choice. I have no experience with css so if I had to do it myself I wouldn't know where to start. Thanks in advance.
  6. wolflarson

    ANSWERED how do I skip Emby Connect?

    Hello, How do I skip emby connect and just login to my server with url / user+pw? I dont see any way to skip emby connect it just goes back and forth between "OK" and using a pin to login. This is my second apple tv and the first one works just fine but I don't remember how setup went with it. They are both on the same subnet. Thanks, Wolf Larson
  7. LanternMyWilly

    [API] Login with external form

    Hi! I'm trying to create a webform where you can create an account and login into Emby without having to login in 'https://domain.com/web/index.html#!/startup/login.html?serverId=123'. I've noticed that when you authenticate a user, this user stays authenticated throughout the entire browser. So I thought if I did a '/Users/AuthenticateByName' call in the form, this would would authenticate the user like it would when you normally login but it doesn't. So basically I call '/Users/AuthenticateByName' with my desired username and password I want to login, this does the job but when I go to the same url as provided in the api call, it still asks me to login. Both in the same browser. My code to authenticate the user: function userAuthenticate($username,$password) { $dataArray = array("Username"=>$username, "Pw"=>$password); $dataString = http_build_query($dataArray); $url= 'https://domain.com/emby/Users/AuthenticateByName?api_key=123456789&'; $ch = curl_init($url); curl_setopt($ch, CURLOPT_POST, true); curl_setopt($ch, CURLOPT_POSTFIELDS, $dataString); curl_setopt($ch, CURLOPT_RETURNTRANSFER, true); $response = curl_exec($ch); curl_close($ch); $responseDecoded = json_decode($response,true); echo $responseDecoded["AccessToken"]; } The code above does always succeed but doesn't do what I want (that is authenticating the user in https://domain.com/web). Now I'm wondering if it is possible to accomplish what I just described. Thanks in advance! (I'm sorry if I didn't describe my problem very well, I didn't really know how to ) Greetings!
  8. I am unable to login to Open Subtitles on my Emby installation, on my Synology DS218+ NAS. I am an Emby Premiere member, and have checked that my login/password details for Open Subtitles are correct. When I click 'save', I get a spinning circle symbol that appears and nothing further happens. Any ideas how to fix this? Screenshot attached. Thanks!
  9. dadofhgnadn

    ANSWERED Android Emby connect

    I recreated and opened ports however in android using emby connect I am stuck in a loop with no idea or prompt concerning what the fault is. See attached images: 01: I Choose Emby Connect 02: I enter my credentials 03: I am brought back to the first screen again. Am i missing something obvious? I will also attach a log. embyserver.txt
  10. EduardoSantos

    User data on toggling server

    Hi, New to the AndroidTV app. Very good work, good ideas and some very beautiful screens. My regards to developers. Is there a means to snapshot from Emby's the current screen? That would make it a lot easier to post issues here... Anyway, this issue relates to the toggling server mechanism. I do not use Emby Connect so this is about direct connections. When toggling from one server to another the app seems to forget user data (name/password) already provided. I have to re-enter it on each and every toggling to already known servers. Also, but seems of least importance, on the toggling screen servers are presented with their name (url) but with the LAN IP address below. This is kind of akward when some servers are remote. I tried to set LAN parms on server configuration but it the app still shows the LAN IP. Though that does not prevent actual connections it could be a security issue...
  11. I'm setting up a new box with Kodi and Emby and found out that, when using Emby Connect, the plugin seems to "forget" the login details every time it starts. It asks to log in every time then. 2019-09-10 20:26:04.176 T:3850568576 NOTICE: EMBY.entrypoint.service -> --->>>[ EMBY ] 2019-09-10 20:26:04.177 T:3850568576 NOTICE: EMBY.entrypoint.service -> Version: 4.1.14 2019-09-10 20:26:04.177 T:3850568576 NOTICE: EMBY.entrypoint.service -> KODI Version: 18.4 Git:48c0b53aae7b0647d1f5a0a9cdb6ad5b1ebb9407 2019-09-10 20:26:04.187 T:3850568576 NOTICE: EMBY.entrypoint.service -> Platform: Linux 2019-09-10 20:26:04.197 T:3850568576 NOTICE: EMBY.entrypoint.service -> OS: CoreElec/1988MB 2019-09-10 20:26:04.197 T:3850568576 NOTICE: EMBY.entrypoint.service -> Python Version: 2.7.16 (default, Sep 7 2019, 02:36:38) 2019-09-10 20:26:04.208 T:3850568576 NOTICE: EMBY.entrypoint.service -> Using dynamic paths: False 2019-09-10 20:26:04.209 T:3850568576 NOTICE: EMBY.entrypoint.service -> Log Level: 1 When logging in: 2019-09-10 20:27:12.502 T:3607085952 NOTICE: Emby.emby.core.connection_manager -> Begin connectToServers, with 3 servers 2019-09-10 20:27:12.503 T:3607085952 NOTICE: Emby.emby.core.connection_manager -> testing connection mode 2 with server Media.Server.net 2019-09-10 20:27:12.504 T:3607085952 NOTICE: Emby.emby.core.connection_manager -> tryConnect url: http://{server-ip}:8096/emby/system/info/public 2019-09-10 20:27:12.558 T:3607085952 NOTICE: Emby.emby.core.connection_manager -> calling onSuccessfulConnection with connection mode 2 with server Media.Server.net 2019-09-10 20:27:12.675 T:3607085952 NOTICE: Emby.emby.client -> User is authenticated. And then on next startup again: 2019-09-10 20:27:48.767 T:3808338816 NOTICE: Emby.emby.core.connection_manager -> Begin connect 2019-09-10 20:27:49.775 T:3808338816 NOTICE: Emby.emby.core.connection_manager -> Found Servers: [] 2019-09-10 20:27:49.775 T:3808338816 NOTICE: Emby.emby.core.connection_manager -> Begin connectToServers, with 0 servers Attached is a complete Emby log from installing the plugin to restarting it and being asked to log in again. If I log in manually, all is fine. emby.log
  12. Hello good afternoon. I am in need of help, to customize the user startup. Create a custom CSS file for user input, now you need to contact the Emby Server Database. Can someone help me. thank you in advance for everything. regards ELTANO4D
  13. I think the current login is kinda lackluster. For users with no Emby Connect account, there is no way to handle password resets on their own. There is a "Forgot password" link but since emal adresse is not registered, the email with reset password form does not arrive to user. So my request is 2-parted: 1: Add the options to ad an email address for users without require to create an Emby Connect account. 2: Give to posibility to costumize the login page so I, as an admin could better help users that forgot their password.
  14. PRodwell84

    Header Login Failure

    Hi I have a quick query i'm hoping someone can help me with. I have an Emby Server up and running and can access the content via the device where the apps are installed (Nvidia Shield), however when trying to log in via other devices, when using the Emby connect method I am getting the following error message. 'HeaderLoginFailure - Invalid username or password. Please try again'. I am familiar with media servers in general and know my username and password are 100% correct, I have reset the password on multiple occasions thinking it was a simple password issue and can log in on the Shield but am still unable to log in elsewhere. I have also set up an additional user linked to my account to see if it is an issue with the user profile and allowing remote access is enabled in the advanced config but I'm still getting this error message. I do occasionally have a VPN in use to change the IP address and have tried connecting with the VPN on and off but it has not worked. One of the other devices I am trying to connect with is an Android mobile phone. The curious thing is I have been able to connect via the phone previously, if it has never worked I'd put it down to user error but am now stumped, does anyone have any suggestions?
  15. I have the http route redirect to https with a reverse proxy, Since I'm on the https of 'https://app.emby.media' the client sends a request to: 'http://foobar.media:8096/emby/system/info/public' which results in a 'Connection Failure'. It should automatically default to https, not http when calling the 'system/info/public' route.
  16. Doebert

    Emby shows unknown users

    All of a sudden I can no longer get into Emby?? When I start Emby in windows 10 it shows 2 unknown users. 1-computerguyiptv and 2-doom. I have no idea who they are? When I try to log in with my credentials it doesn't recognize my account. I first noticed a problem when I was trying to access it on Roku and it showed my server name with addition info after that "LIVETV VOD AND MORE". I have no idea where that came from either?? So........what should I do to resolve this without losing all my media? Thanks in advance.
  17. tinskip

    Manual Login Borkiness

    I chose to not display my admin account, requiring manual login. However, on my Android TV (Sony Bravia 2017), selecting Manual Login brings up the Password prompt. I can then select "Next", same prompt (no changes, nor does the entry box clear), then "Done" and then nothing. There is no prompt for the username. Am I doing something wrong (not much to do wrong afaict) or is it not working correctly? Anyone else experience this?
  18. Checked the WebSocket wiki page. It shows to connect to a WebSocket you will require an API key and device ID I'm trying to get the device ID as soon as any user logs in to the server. Till now I got no response after WebSocket connection. here's my python code websocket.enableTrace(True) host = "xxx.xx.xx.xx" port = 8096 api_key = "xxxxxx" device_id = "xxxx" ws = websocket.create_connection("ws://{}:{}/embywebsocket?api_key={}&deviceId={}".format(host, port, api_key, device_id)) result = ws.recv() print('Result: {}'.format(result)) result = ws.recv() print('Result: {}'.format(result)) # Trying something from community... ws.send(json.dumps([json.dumps({'msg': 'connect', 'version': '1', 'support': ['1', 'pre2', 'pre1']})])) result = ws.recv() print('Result: {}'.format(result)) Result: --- request header --- GET /embywebsocket?api_key=xxxxxxxx&deviceId=a7650139abe6b220 HTTP/1.1 Upgrade: websocket Connection: Upgrade Host: xxx.xx.xx.xx:8096 Origin: http://xxx.xx.xx.xx:8096 Sec-WebSocket-Key: mHuOCG3yyL41uB7gk7fK8g== Sec-WebSocket-Version: 13 ----------------------- --- response header --- HTTP/1.1 101 Switching Protocols Connection: Upgrade Upgrade: websocket Sec-WebSocket-Accept: Ta03Qfon0bEHLCQKG+0BtGNZXjQ= ----------------------- send: b'\x8a\x80\x93\tf\xe1' send: b'\x8a\x80\x13\xf8qB' send: b'\x8a\x80\xa3\xf3\xa1b' send: b'\x8a\x80\xa9\x87\xad\x9e' send: b'\x8a\x80@\x19\xa7\xa7' These send messages came after some time of no response. These are not proper Hex codes. IDK what they are. Requesting EMBY gurus to help me on this. I think I don't even know much about WebSockets
  19. I'm going to attach pictures but Enmby android TV clients fails to remember password and it seriouly annoy and certainly takes away from the user experience. Who the hell wants to keep having to login on a remote with no qwerty all the time. So unless the account is deleted or disable the client needs to remember the login forever and until the end of time, right now it only remembers for about a day I don't know what the trigers are that pushes it to stop remember but this issue is 100 percent reproducible as a friend of mine with same equipment is having same issue as well. other than what i provide don't ask for any further information as I have other things to do and don't have time to do any follow ups. Just test and fix on your own.
  20. Hello, I noticed many times when I login as non-admin user that Emby web app does not ask me to save my password. And instead, proposes me the password of the admin user (I manage both users). As other web sites work just fine, I guess emby does something different about the user and password field. Do others have this issue as well? Emby 3.5.3.0 Many thanks
  21. Hello, I've been with Emby a couple of months now. And I like it. But I have always had trouble with the login page. All of the accounts except my account (admin) can never login, if they are shown at the login screen. When they click on their name there is always an immediate prompt that says somehting like "log fail, wrong username or password. please try again" I always found that a little strange since these accounts don't get a chance to type in any password. So up until now I just told everybody to click on login manualy and so on. For me it always works. Ican klick on my icon and I get asked for my password and I can sign in without any problems. At the beginning I always thought my users just forgot their passwords, since a reset usually helped. But today I was trying to setup a client with a user I created myself. But now I can't even login with this new user manualy. I am sure I have the right password because I can sign into the forums with it. I always get a message that tells me to make sure I have proper connection and so on. But I do since I can also sign in with my admin account from this client. I have these problems across all the client I use (Theater desktop, firetv, web app, android, ios). I always check on the dashboard if the users are there and I can also see the failed login attempts I just don't know how to fix this. Am I doing something wrong?
  22. TheBrainninja

    How to Force User to Log Out

    Hey all, I have an uncomfortable social situation I'd like to avoid passively, if possible. My partner logged into her Emby Connect account on her old roommate's Xbox, so she could access my server while she lived there; she's moved out and isn't on the best of terms with them now, and I'd prefer to disconnect her account from that Xbox without contacting the roommate directly. I've reset her password on the server, but it isn't forcing her to sign back in when she launches the app on devices she controls. I've restricted devices that have access to the server, but that also isn't ideal as the device list doesn't seem to list every device the account has connected from - it requires some babysitting to enable/disable the devices I want/don't want to connect. I realize this is more of a social problem than a technical one, but it would make my life a lot easier if I could solve it technically; is there some way to force her account to simply re-authenticate before it can access my server? She says she's reset her Emby Connect password already, and I've searched around to see if someone's addressed this before. Thanks in advance.
  23. Hi, I've discovered today Emby and I'm trying to configure it on an old lapop with Ubuntu Mate. I've the server up, working and tested with other laptops on the same LAN. But I've noticed a problem, on Windows the server appears on "Network" as a "Multimedia Device". That's not the problem, the problem it's that if double click on it, I can enter on the library folder, or If I go to "Properties" and clic on the URL (for example): 192.168.0.13:8091, I open the web interface on and automatically logs with my server user with all access. My question it's how I can set a login screen when someone wants to enter on the server, even if it's me from other laptop. I have my admin account linked with Emby Connect, I don't know if this detail helps with my problem. Regards EDIT 1: Ok, searching a bit more on this forum I've found this thread: https://emby.media/community/index.php?/topic/59893-require-pin-for-accessing-user-accounts/ and on a comment: Hi. If you want to be able to switch between users (accounts) on the same app, then you don't want to use Emby Connect. Connect is designed as an easy way to directly connect an app/device to a single user without having to know/type in the server address and credentials for the user. If you want to have two accounts with different access, then you want to create two normal accounts on the server (not by email address), setup their access and passwords how you like, and then any local device should automatically find your server and present those two users as options at log-in. Please let us know if this answers your question. Thanks. So, my first problem to ask for login it's solved. But I'm still able to access the folder via "Network" as the server it's listed as a "Multimedia Device" and if I do double click, I enter on the folder and see all the downloads. How I can restrict the folder of the library on the LAN?
  24. Hobbyc

    Require PIN for accessing user accounts

    Hi - I would like to setup user accounts for 'parents' and 'kids'. I want to have some control in place so that my kids can't select the 'parents' or default admin account and immediately get access to all of the content on the server. I have not been able to find a way to set a PIN for the users. Here is what I've done so far: - Installed the server and setup a default admin account. I've linked this account to Emby Connect - Subscribed to Emby Premier (again with my default email linked to Emby Connect and the default admin account) - Created a local user and attempted to associated with my Emby Connect account (this fails every time - I've sent an email mentioned in the error message and have received a response). - Installed the app on iOS and logged in with my Emby Connect account (which is also the local admin account) - When launching the app - I can select either user and I am not prompted to 'login', the content is available without any restriction I know I can restrict content via ratings or keywords, but neither option will prevent someone from launching an account that has access to all of the media. Here is what I would like to happen (if I have a step wrong, please set me on the right path): - Install the app (iOS, AppleTV, Roku, etc...) login to connect my Emby Connect & Premier account - launch the app and have the choice of which user to 'login' as - be prompted to enter a PIN for each user (or in the case of my Kids - no PIN) - get access to the content based on the users settings (either library access, keywords, or ratings restrictions) Any help is appreciated.
  25. fc7

    Hardening Emby login

    After using Emby for a while I'm so happy with it that I decided to publish it to the Internet so I can listen to my music when I'm away, without needing to VPN home. I'm publishing Emby behind a Squid reverse proxy, using SSL termination. Meaning: Internet Client -----HTTPS SSL connection-----> | Squid reverse-proxy -----PLAIN HTTP-----> Emby | INTERNET | LAN Now I have a couple of questions/features requests regarding publishing Emby to the "evil" Internet: Is there any known issue/concern that I should be aware off that is not too relevant while Emby is only visible in the LAN but that can be dangerous if Emby is visible from the Internet? I'm worried about brute force attacks. Is it possible to enable a captcha on the login screen so for example after 3 failed logins the user will need to validate the captcha to try to login again? About the login screen: would it be posible to have a configuration parameter in Emby to "harden" the login form like for example disabling autocomplete on the username field? Is it possible to enable a configuration parameter to hide all users from the login screen, server wide, instead of doing it on user basis only? How does the "in-network sign-in" with the easy pin code works? How does Emby know that the user is logging in from the LAN or from the Internet? What happen if the user is in the Internet but Emby is behind a reverse-proxy in the LAN (all requests comes from the LAN IP of the proxy)? Would Emby check the X-Forwarded-For HTTP header if the reverse-proxy provides it? I know these are a lot of questions and some things may not be even implemented right now, but if they are not, maybe they can be a good idea to implement in the near future since they can help us to protect our server for the "evil" Internet. Cheers
×
×
  • Create New...