Jump to content

HDHomeRun Live TV Stopped Working with Emby server


Sam865
 Share

Recommended Posts

I have a HDHomerun Prime 3-tuner device that had been running flawlessly with Emby until a couple of days ago. I run Emby Server at startup (not as a Windows service) and I subscribe to Schedules Direct. I have the Emby TV plugin and have successfully recorded live TV in the past. I have three Roku 3 devices and they were all able to play live TV (Charter Cable is my cablecard provider). I could also watch Live TV by opening the Emby Server in a Chrome browser on any PC or Tablet device in my house. There were no streaming /stuttering issues. Suddenly, within the past two days, I can no longer watch live TV at all (not even at the Emby Server host PC, not on Roku, or anywhere else on my network). I can open the SiliconDust HDHomeRun View app and it plays live TV flawlessly from any device on my network.

 

I've rebooted the host computer, restarted the HDHomeRun Prime Tuner, tried running Emby as a service, etc., but nothing seems to work. I'm running Windows 10 64-bit on a very capable Dell XPS 8-core PC and everything related to Live TV from the Emby server just stopped.

 

Any ideas on what could have caused everything to stop working? I have attached a recent log server-63576952823.txt. I'm too new at this game to interpret what the logs mean.

 

Link to comment
Share on other sites

I dont think you need the emby tv plug in anymore because the newer primes are directly supported by emby server.  You might to reconfigure your live tv settings to work with the new server integration.

  • Like 1
Link to comment
Share on other sites

Thanks for the help with this issue. I did not realize that I needed to uninstall the Emby TV when I upgraded to current server version. I had been using the Beta version for several days with no apparent problems with Live TV. If anyone else runs into this, you should probably start by uninstalling Emby TV and restarting the server. I didn't see immediate results when I did this. In fact, "everything" related to live TV stopped working. After waiting for over an hour I finally noticed that my Schedules Direct had not been refreshed for several hours, and that my zip code / cable provider information was missing. I added this back and did a manual refresh of the Guide information. When it was complete, I restarted once again and all my live TV channels were back and working properly. This may be a very uncommon problem, but it might be worth an administrator's time to post some instructions for those who currently have Emby TV installed and try to upgrade to the latest Emby server version.

Edited by Sam865
Link to comment
Share on other sites

This blog post (also referenced from the most recent blog post) details that you need to uninstall the current plug-in and then do the set-up with the core.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...