Jump to content

Movie Theme Videos Plugin Questions and Support Thread


radeon

Recommended Posts

With the new versions of movie/tv themes, the existing themes are not showing in the filters section of either plugin. Do I have to delete them all and re-download? Or have to figure out which ones have themes and then add to the filter? What's the advised method?

Link to comment
Share on other sites

With the new versions of movie/tv themes, the existing themes are not showing in the filters section of either plugin. Do I have to delete them all and re-download? Or have to figure out which ones have themes and then add to the filter? What's the advised method?

 

Hi @@Erik

 

It all depends on what you are trying to achieve. As you have already run the tool before the upgrade, you're right, those downloaded wont be in the filters.

 

That's absolutely fine if you are happy with all of the themes that are there.

 

However, If there are some themes you don't want in your collection, i would suggest deleting them from your movies, then running the scheduled task again. Once thats done, the filters will be added for those movies, all you will have to do then, is delete them from your collection again.

 

Or, just add the filters manually to the list for the shows you don't want, then delete the themes you dont want from your collection.

 

All the best,

Link to comment
Share on other sites

DarkKniyt (John)

radeon,

How do we submit/post/add themes for use with these plug-ins?

I have quite a few I've found, created.

Link to comment
Share on other sites

Thanks Radeon, I was attempting to use the filters more as a was to keep track of what items had themes already and which I was trying to find ones for, as At the moment I have to either view each one in MBT or browser to each folder and look for the hidden folder. Unless I've missed a better way?

Link to comment
Share on other sites

Thanks Radeon, I was attempting to use the filters more as a was to keep track of what items had themes already and which I was trying to find ones for, as At the moment I have to either view each one in MBT or browser to each folder and look for the hidden folder. Unless I've missed a better way?

 

@@Erik

 

If all the themes came from my plugins and you haven't manually added some, id just do a windows search for "backdrops", delete all the backdrop folders that come up then just run the task again, that will create the filters for you (then any new ones you can find, you can send to me to add to the database :-D).

 

All the best,

Edited by radeon
Link to comment
Share on other sites

 

@@JDizzy, what frontend client are you using? MBC, MBT, Win8 app?

 

The Movie theme videos plugin only downloads the themes and stores them in your movie/tv show folder, it has nothing to do with how the theme video is played. That my friend is governed by the frontend client.  

 

The problem is with your request is, most theme videos are downloaded in mp4 format and if you have movies in mp4 format, you are basically telling the external player that you want the external player to handle mp4's when you select/add that option.  So the external player doesn't give any thought to the context of what the media is, it just looks at the extension and says..... ooooo that's me, i'm up and launches external play for that extension.

 

 

I am using MBT.

I understand all of this but am trying to think out loud of a workaround to allow using an external player while coexisting  with the Themes plugin playing mp4 movies. 90% of my movies are in the mp4 format. Thanks

Edited by JDizzy
Link to comment
Share on other sites

I am using MBT.

I understand all of this but am trying to think out loud of a workaround to allow using an external player while coexisting  with the Themes plugin playing mp4 movies. 90% of my movies are in the mp4 format. Thanks

Unfortunately, you are stuck. Re-encode to a container thats not in your library.

 

Hellish idea but i would say thats your only option.

Link to comment
Share on other sites

 

I am using MBT.

I understand all of this but am trying to think out loud of a workaround to allow using an external player while coexisting  with the Themes plugin playing mp4 movies. 90% of my movies are in the mp4 format. Thanks

 

 

Unfortunately, you are stuck. Re-encode to a container thats not in your library.

 

Hellish idea but i would say thats your only option.

 

 

Perhaps a feature request for mbt? to not play themes in the external player? Sounds more like a bug to me

Edited by radeon
Link to comment
Share on other sites

Perhaps a feature request for mbt? to not play themes in the external player? Sounds more like a bug to me

 

Already mentioned in MBT thread. - Thanks

Link to comment
Share on other sites

This is one of my favorite things about mb3/mbt.

 

Is there an easy way for user to upload videos? Also directions for users who may not understand how they can contribute? I wish it was 3 months sooner when i was converting all my movies from bluray folders to mkv, i had about 200 blurays in bluray folder structure and it would have been very easy to grab the mt2s file used for bluray backgrounds. I have some left I can add but their in 1080p and a bit to large as i grabbed them right from the bluray however and because they are about 180 mb they take about 2 seconds or so to load and i can see why you chose 720p quick loading encoded backdrops. 

 

I think we can get a fantastic database  going, someone with a large blu ray folder collection who is willing to add alot from his library could be a gold mine. I seen someone on avsforum for instance collecting and adding themes on his own, but unless he is under a different username i dont know if hes adding any to the collection. If we can make it clear and easy how to contribute and encourage contributions in the plugin description and on here, and perhaps recruiting users to participate as well I think we can get alot more added. 

Edited by Ghostm
  • Like 1
Link to comment
Share on other sites

Would love to see the audio normalization also included in Movie Theme Videos so all the themes could have the same volume!

Link to comment
Share on other sites

Would love to see the audio normalization also included in Movie Theme Videos so all the themes could have the same volume!

 

It's already on the map. It just depends on how well it beds in with the tv themes! :-D

 

Could you post your findings on the requests thread here if you have used the tv theme vids version? just so i can get an indication of its stability

 

Cheers,

Link to comment
Share on other sites

Movie Theme Videos 1.0.4.0 Released!


Added Audio Normalisation features.

Configure it through the Plugins Configuration Page

The lower the number the quieter it will be. So -30 is really quiet, -15 is normal, 0 is really loud!


audionorm.png

Link to comment
Share on other sites

Hi Radeon,

 

Thanks for another great update.

 

One request for the future, could there be an button/option to clear all the filters within the plug-in so that if a future release requires a full delete/reload (like the audio normalization) we don't have to clear the filter on each movie/tv series.

 

Thanks

Link to comment
Share on other sites

Hi Radeon,

 

Thanks for another great update.

 

One request for the future, could there be an button/option to clear all the filters within the plug-in so that if a future release requires a full delete/reload (like the audio normalization) we don't have to clear the filter on each movie/tv series.

 

Thanks

Its being considered,

 

in the meantime, just delete the config xml file from C:\Users\{your-username}\AppData\Roaming\MediaBrowser-Server\plugins\configurations.

Link to comment
Share on other sites

Thanks Radeon. I'll remember that for next time.

 

Cheers

Just fyi, if you do delete the config, that will reset your target max volume to -15 too, so just set that back to whatever you had it at (if you changed it) before you re run the task :-D

Link to comment
Share on other sites

I removed Avatar (as it played very loud and I wanted to try the new normalization feature) from the plugin and from my drive (theme.mp4).  I clicked save and it is definitely not listed in the plugin anymore.  I have re-run the plugin twice, but it is not downloading it again.

 

Any thoughts?

 

EDIT: Just tried again and it picked up Avatar.  Weird.

Edited by foghat
Link to comment
Share on other sites

I removed Avatar (as it played very loud and I wanted to try the new normalization feature) from the plugin and from my drive (theme.mp4).  I clicked save and it is definitely not listed in the plugin anymore.  I have re-run the plugin twice, but it is not downloading it again.

 

Any thoughts?

 

EDIT: Just tried again and it picked up Avatar.  Weird.

Hmm, that is strange.

 

Could you send me over a zip of your logs from that time period if you have debug logging enabled please? Logs are everything when trying to diagnose issues like these and whilst I realise you have the theme now, I'd still like to know what's going on.

 

Cheers

Link to comment
Share on other sites

I removed Avatar (as it played very loud and I wanted to try the new normalization feature) from the plugin and from my drive (theme.mp4).  I clicked save and it is definitely not listed in the plugin anymore.  I have re-run the plugin twice, but it is not downloading it again.

 

Any thoughts?

 

EDIT: Just tried again and it picked up Avatar.  Weird.

@@foghat  and anyone else for that matter.  There is a slight bug (that we know about) where the directorywatchers are not as efficient or immediate as they used to be, it will be fixed soon (however there is a lot of work going on for other clients that needs to be addressed before this fix).

 

So please ensure that after you delete any files that you manually run the library scan prior to running the scheduled Tasks any of @@radeon Theme downloaders.

Edited by Cheesegeezer
  • Like 1
Link to comment
Share on other sites

@@foghat  and anyone else for that matter.  There is a slight bug (that we know about) where the directorywatchers are not as efficient or immediate as they used to be, it will be fixed soon (however there is a lot of work going on for other clients that needs to be addressed before this fix).

 

So please ensure that after you delete any files that you manually run the library scan prior to attempting to use any of @@radeon Theme downloaders.

Haha, I know that! Why didn't I just say it?! Half asleep! Hahaha

  • Like 1
Link to comment
Share on other sites

@@foghat and anyone else for that matter. There is a slight bug (that we know about) where the directorywatchers are not as efficient or immediate as they used to be, it will be fixed soon (however there is a lot of work going on for other clients that needs to be addressed before this fix).

 

So please ensure that after you delete any files that you manually run the library scan prior to attempting to use any of @@radeon Theme downloaders.

Thanks @cheesecake ;-) Edited by radeon
  • Like 1
Link to comment
Share on other sites

Haha, I know that! Why didn't I just say it?! Half asleep! Hahaha

Because you're a mong!! ;)  It's ok, uncle Cheese will look after you hahaha

Edited by Cheesegeezer
Link to comment
Share on other sites

Hmm, that is strange.

 

Could you send me over a zip of your logs from that time period if you have debug logging enabled please? Logs are everything when trying to diagnose issues like these and whilst I realise you have the theme now, I'd still like to know what's going on.

 

Cheers

 

Hi.  Sorry, I did not have logging enabled at the time.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...