Jump to content

Movie Theme Videos Plugin Questions and Support Thread


radeon

Recommended Posts

Radeon, 

            I have installed the trial, but can't get it to work on any of the clients.  It says I'm up to date.  I think I've blown through my trial period, but I never could get it to work.  Can you help me work through this?  After I can confirm it works, I'll purchase.  Thanks.

Link to comment
Share on other sites

Radeon, 

            I have installed the trial, but can't get it to work on any of the clients.  It says I'm up to date.  I think I've blown through my trial period, but I never could get it to work.  Can you help me work through this?  After I can confirm it works, I'll purchase.  Thanks.

hey @@irengineer

 

How do you mean you cant get it to work on any of the clients? This a server metadata plugin which downloads the videos to your collections.

 

Because they are recognised by the server any client can choose to use them, much like backdrops, disc images etc.

 

With MediaBrowser Classic (MBC), another plugin, ThemeVideo Backdrops which is free, needs to be installed from the mbc configurator. Once installed, it needs to be configured to play theme backdrops via the plugins config within the mbc configurator.

 

With MediaBrowser Theatre (MBT), the theme backdrops are supported as standard.

 

The Movie Theme Videos plugin downloads only those films beginning with the letter A if available when in trial mode, such as Avatar, Alien, A good day to die hard, After earth, Armageddon, etc.

 

It will download a theme.mp4 to a backdrops folder (which is hidden) to each of your movies. If they are there for some of your A movies then you know its working as designed.

 

What clients have you been trying to use?

 

Cheers, Radeon

Link to comment
Share on other sites

Ahh, there's the problem.  I must have missed that only the "A"'s are downloaded on the trial.  I just check a good day to die hard and it works.  My apologies...

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

@@radeon what is the expected duration for this plugin to check themes and download the missing ones.

 

I have run both the movie and TV video plugins and they both only ran for 3 seconds according to the dashboard. Both versions are 1.0.4.3.

 

Cheers

Yogi

Edited by Yogi
Link to comment
Share on other sites

@@radeon what is the expected duration for this plugin to check themes and download the missing ones.

 

I have run both the movie and TV video plugins and they both only ran for 3 seconds according to the dashboard. Both versions are 1.0.4.3.

 

Cheers

Yogi

 

Hey @@Yogi.

 

It's actually stupidly fast now, especially since 1.0.4.2. I rewrote the entire API mechanism in that release and the performance increase was epic. The best way to check it's working is just to delete a theme from your collection and the filter list, don't forget to click save, then run the tool again. If the theme downloads, you know it's working fine.

 

I actually had to question it myself yesterday as it's missing lookup is soo much faster! :-D

  • Like 1
Link to comment
Share on other sites

Hey @@Yogi.

 

It's actually stupidly fast now, especially since 1.0.4.2. I rewrote the entire API mechanism in that release and the performance increase was epic. The best way to check it's working is just to delete a theme from your collection and the filter list, don't forget to click save, then run the tool again. If the theme downloads, you know it's working fine.

 

I actually had to question it myself yesterday as it's missing lookup is soo much faster! :-D

 

Nice work matey,you have done a great job on the plugin.

 

I did what you said and deleted a theme and it was super quick in finding it again.

 

Cheers

Yogi

  • Like 1
Link to comment
Share on other sites

Nice work matey,you have done a great job on the plugin.

 

I did what you said and deleted a theme and it was super quick in finding it again.

 

Cheers

Yogi

 

Thanks! :-D

 

I was just reworking the method the other day, 1 to speed things up, 2 to reduce server load and 3 because I was bored and wanted to make it generally better.

 

I thought the original method was more than acceptable, but I like to enhance things where I can.

 

Ooh! I forgot to mention, I added around another 30 TV Themes yesterday, so you may well get some new ones through, obviously depending on your collection matching new ones.

  • Like 1
Link to comment
Share on other sites

Hey @@Yogi.

 

It's actually stupidly fast now, especially since 1.0.4.2. I rewrote the entire API mechanism in that release and the performance increase was epic. The best way to check it's working is just to delete a theme from your collection and the filter list, don't forget to click save, then run the tool again. If the theme downloads, you know it's working fine.

 

I actually had to question it myself yesterday as it's missing lookup is soo much faster! :-D

 

I too found it super fast.  Like takes 1 second.  So I tried removing Cowboys and Aliens.  Removed from plugin (and saved) and deleted theme from collection.  It still runs in about a second, but does not find it again.

 

server 3.0.5099.2102

plugin: 1.0.4.4

 

I've attached the log.

server-63523060207.log

Link to comment
Share on other sites

I too found it super fast.  Like takes 1 second.  So I tried removing Cowboys and Aliens.  Removed from plugin (and saved) and deleted theme from collection.  It still runs in about a second, but does not find it again.

 

server 3.0.5099.2102

plugin: 1.0.4.4

 

I've attached the log.

 

Hey @@foghat

 

1 second is more than reasonable now with the new api. :)

 

You log doesn't include a request for Cowboys and Aliens so that implies MBS still thinks the theme is in your collection. Just run a library refresh scan first to make sure its picked up that its actually missing, then run my plugin task again.

Edited by radeon
Link to comment
Share on other sites

Hey @@foghat

 

1 second is more than reasonable now with the new api. :)

 

You log doesn't include a request for Cowboys and Aliens so that implies MBS still thinks the theme is in your collection. Just run a library refresh scan first to make sure its picked up that its actually missing, then run my plugin task again.

 

Rescan did it. Very fast.  Impressive.  nice work!

  • Like 1
Link to comment
Share on other sites

Thanks for this add-on Radeon! its superb!

One thing to report:

 

 

"Fight Club" theme starts with "Never been kissed" theme and then pixelates into "Fight Club".

 

Thanks for your work!

Link to comment
Share on other sites

Thanks for this add-on Radeon! its superb!

One thing to report:

 

 

"Fight Club" theme starts with "Never been kissed" theme and then pixelates into "Fight Club".

 

Thanks for your work!

 

@@altramarine

 

Hahaha, I wondered if anyone would pick this up, It is actually the official version from the 10th Anniversary disc, nothing wrong with the plugin! I promise! haha

Link to comment
Share on other sites

  • 2 weeks later...

I just received an alert in my MediaBrowser dashboard that my tiral expired, but I paid back on 12/05/2013 (have my paypal receipt too).  I am using the same hardware and install that I was back when I paid for it and I haven't installed it on any other server. 

 

The changes today were:

Updating MB server to 3.0.5112.40848

Updating the Trailers plugin to the latest 1.0.5112.41026

Rebooted the server (which is when the error came up about the trial expiring).

 

Please advise.

 

Thanks.

Hey @@nickbuol,

 

Just check in the plugin catalog in the dashboard to see if you're registered. Go into the catalog, click on one of my plugins you're meant to be registered for and make sure it says "You are currently registered for this feature" under the registration section. It's likely that mbs had trouble checking your licence info for some reason. If it says you are registered then you can just ignore the notification.

 

Also, just confirm you have your supporter key installed in mbs.

Edited by radeon
Link to comment
Share on other sites

I just received an alert in my MediaBrowser dashboard that my tiral expired, but I paid back on 12/05/2013 (have my paypal receipt too).  I am using the same hardware and install that I was back when I paid for it and I haven't installed it on any other server. 

 

The changes today were:

Updating MB server to 3.0.5112.40848

Updating the Trailers plugin to the latest 1.0.5112.41026

Rebooted the server (which is when the error came up about the trial expiring).

 

Please advise.

 

Thanks.

Link to comment
Share on other sites

I''d like to register your plugins Radeon but for some reason I can't find the paypal button under "Registration" in the plugins menu. All it says under that section is the following "This is a premium plugin.

It will require a supporter key in order to register after the 14-day free trial." No way to click to register or pay for anything. How do I go about registering your plugins for full-version features? I already have an MB3 supporter key.

 

Thanks

Link to comment
Share on other sites

I''d like to register your plugins Radeon but for some reason I can't find the paypal button under "Registration" in the plugins menu. All it says under that section is the following "This is a premium plugin.

 

It will require a supporter key in order to register after the 14-day free trial." No way to click to register or pay for anything. How do I go about registering your plugins for full-version features? I already have an MB3 supporter key.

 

Thanks

Hey @@Yoda

 

It sounds like your mb3 supporter key hasn't been entered into the mbs dashboard under Help > Supporter Key. Can you just confirm that it is and you should be fine from then on.

Link to comment
Share on other sites

@@radeon, I haven't tried this plugin as I assume it downloads the theme videos to the respective movies/tv shows directory and not the MBS cache.

If this is the case then as I browse my collection every disc that hosts the content I am browsing through at the time will spin up on my unRAID server. Is it possible to host these files elsewhere? I doubt I have enough storage on my MBS SSD but I have a USB3 drive which would be perfect for this.

Link to comment
Share on other sites

@@radeon, I haven't tried this plugin as I assume it downloads the theme videos to the respective movies/tv shows directory and not the MBS cache.

If this is the case then as I browse my collection every disc that hosts the content I am browsing through at the time will spin up on my unRAID server. Is it possible to host these files elsewhere? I doubt I have enough storage on my MBS SSD but I have a USB3 drive which would be perfect for this.

 

Yes the theme video's are stored in the respective movie dirtory (in a folder called backdrops).  the video does not play as you scroll through and browse movies from whatever view you are using.  The video does start to play however, once you select a movie/tv show to view its details.

 

The files are not very big - the few I checked ranged from 5 to 30 or so MB, so unless you are really tight on space, it shouldn't be an issue.

  • Like 2
Link to comment
Share on other sites

Yes the theme video's are stored in the respective movie dirtory (in a folder called backdrops).  the video does not play as you scroll through and browse movies from whatever view you are using.  The video does start to play however, once you select a movie/tv show to view its details.

 

The files are not very big - the few I checked ranged from 5 to 30 or so MB, so unless you are really tight on space, it shouldn't be an issue.

Thanks for the prompt reply @@foghat. The storage is not the issue, it is the act of spinning up drives. I have 30TB of storage across 15 drives in my array, every movie I view the details for will spin up the drive the movie is stored on if I enable this feature. When I am being indecisive that can end up being quite a few movies. The speed of the fans in my server are modulated based on the highest drive temp (fan control script) which during summer (41° Celsius/106° Fahrenheit today) can make it rather noisy if too many drives are spun up.

Edited by cylon
Link to comment
Share on other sites

Thanks @@foghat :-D

 

@@cylon, the location of the themes is actually dictated by MBS not me. I just abide by the library structure MBS requires. If a feature was implemented by mbs core to enable a custom location of to cache the files somewhere then i could potentially change my plugins to give the option of using that new custom location but unless that was to happen, there isnt really much point in me changing the plugins.

Link to comment
Share on other sites

@@radeon, thanks, that makes sense. I think my scenario is very unusual so I won't bother pursuing it any further.

 

Edit - I just had a bit more of a think about this. If MBS allowed theme videos to be cached then that would overcome this issue. It would dramatically increase the size of the cache though.

Edited by cylon
Link to comment
Share on other sites

Thanks for the prompt reply @@foghat. The storage is not the issue, it is the act of spinning up drives. I have 30TB of storage across 15 drives in my array, every movie I view the details for will spin up the drive the movie is stored on if I enable this feature. When I am being indecisive that can end up being quite a few movies. The speed of the fans in my server are modulated based on the highest drive temp (fan control script) which during summer (41° Celsius/106° Fahrenheit today) can make it rather noisy if too many drives are spun up.

 

Aren't the drives currently spinning up anyways?  For the backdrops and such?  Or or do these get cached?  Plus, keep in mind there will not be a video for all of you movies, so probably won't spin up nearly as much as you think.  For my 583 movies, I have about 191 theme videos.

Link to comment
Share on other sites

Hi, I was just curious as to the method used in grabbing the Theme Videos. I love the plugin, and for the titles it finds, they look amazing! But it doesn't seem to be grabbing videos for very many of my titles. It's only managed to find theme videos for 17.7% of my Movie collection (156/883 titles), and 55% of my Television collection (68/123 series).

 

I know some titles are probably extremely difficult to find videos for, but the bulk of my collection doesn't consist of any titles that are too abstract, or rare, to make it unlikely they wouldn't have any blu ray menus or other kind of video for the plugin to use.

 

I don't know what your method is for getting videos for the plugin, and I'm aware that like all MB plugins, it is a work in progress, and would like to congratulate you on a great plugin @@radeon! Just thought I'd throw this out there, because I'd love to see more titles with theme videos! They look amazing in MBT.

 

Thanks,

 

Patrick

Link to comment
Share on other sites

@@radeon Thanks for the reply. Turns out there is an issue with supporter keys not being saved in MB. That's why I couldn't see the option to register even after entering the supporter key multiple times. I think Luke is looking into it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...