Jump to content

Recommended Posts

M_L

Hello @all,

I have an Upload speed of 6mbps but Emby only uses 4mbps no matter what transcoding and playback settings I choose.
So, I tried a lot, including VPN access to the LAN, prioritisation of process and traffic but nothing worked so far.

The google chrome browser is the culprit, it uses only half of the available bandwith of the media browser server!

When using firefox it uses the whole bandwidth and so I have no annoying stuttering anymore.
Anyone here who had the same problem?

Thanks @EmbyTeam - You are the best!
 

Edited by M_L

Share this post


Link to post
Share on other sites
M_L

So, the problem is still not solved :(
The Mediabrowser-server uses the full internet-upload at first and after a few seconds it uses only 50%, no matter which media-app the client uses.

5519d42c8622c_6mpsTo4mbps.png

Help is very very appreciated! :)

Share this post


Link to post
Share on other sites
pir8radio

I'm a bit confused, your first post said the problem goes away with firefox?   Your second post says no matter what the client it still has this issue?    You sure its not just buffering....    what is the bitrate of your video (bottom of the movie page) should look like this:   Under Settings/Playback/Transcoding, what is your setting there?   after the video starts are you clicking the gear in the top left of the player screen and changing the stream rate there?    Just trying to get more info.

 

Video
CodecMPEG2VIDEO
ProfileMain
Level8
Resolution720x480
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate29.97003
Bitrate5184 kbps
Bit depth8 bit
Pixel formatyuv420p
Audio
CodecAC3
Layout5.1
Bitrate437 kbps
Sample rate48000 khz
DefaultNo
Subtitle
Languageeng
CodecSRT
DefaultNo
ForcedNo
ExternalYes

Share this post


Link to post
Share on other sites
JeremyFr79

Looks to me to be traffic shaping by your ISP, most use the wonderful words "up to" when they claim a speed, and give you a "speed boost" where for the first part it runs full steam ahead, then their traffic shaping kicks in and throttles you back.  I doubt this is anything to do with Emby.

  • Like 1

Share this post


Link to post
Share on other sites
M_L

@@pir8radio
Sorry, I thought the problem is solved, because it went well for a larger amount of time, but I was wrong :/
So the facts are: 
- My movies have a bitrate ~10mbps
- The client profile is configured to use 6mbps max. All tests are made with @6mbps
- Transcoding quality is on Auto (CPU is an Intel Ivy Quad @4Ghz, so no problem there)

- I tried the Emby Android App on an Nexus 4 and 5. It does not stutter (in some high motion scenarios a bit) and it uses the full bandwith over a long time. So the playback works very good.
551ae050327f3_MB_Android_App.png551ae057d01bc_MB_Android_App2.png


- The Emby Web Playback has problems. I asked some friends to try it and they all said it stutters on @6mbps and yes it stutters a lot!
So when I click on a movie and play it from the beginning it stutters and the server uses only 50% of the available upload bandwith.
551ae14b3c950_MB_Webapp.png


-When I resume a movies the server uses the full upload bandwith for some tim (15sec to 2min) and then continues to use only 50%.
551ae1cc4a89f_MB_Webapp_Resume.png


@@JeremyFr79
I don't think my ISP does such a thing. Normally I can use the full Upload Speed like here. Tested here http://testmy.net
551aca1119d6f_fullUpload2.png

Share this post


Link to post
Share on other sites
pir8radio

what happens when trans-coding is set to best?  i don't know what the emby logic does on auto...  just to eliminate any variables...  I'm curious. 

Share this post


Link to post
Share on other sites
JeremyFr79

what happens when trans-coding is set to best?  i don't know what the emby logic does on auto...  just to eliminate any variables...  I'm curious. 

I will second this, I can say when I originally started I found I always had stuttering using "auto" I found that it just wasn't using all 8 cores on my server to it's full potential.  Since I've got the dedicated horsepower I switched to "higher quality" and haven't had an issue since.  I believe it defaults to auto because they figure many people will be using Emby Server on hardware that will be doing other tasks as well i.e. typically on their main computer not a dedicated server.  So the Auto setting tries to use "as much as necessary" so as to not affect other things you may be doing like browsing the web, or playing a game while it's transcoding content for other machines/devices  Changing the setting to Higher Quality or Maximum essentially removes the throttling and allows it to nearly max your CPU for transcoding thus buffering faster than you can playback "of course this all depends on your server hardware"  IF this is a dedicated machine then I'd highly recommend changing the quality setting.  If it's not you still can but be forwarned everything else will come to a near standstill while any transcoding may be taking place.

Share this post


Link to post
Share on other sites
M_L

Auu, sry for repling so late. Thought I would  automatically follow the topic....

@@pir8radio
With Max Transcoding Quality I get much more quality for the same bandwith (And I was running it on max. for most of the time). But it has no influence on the problem, the upload usage is exactly the same.
Isn't it kinda strange, that the upload speed is exactly the same and that is is constantly using exactly this bandwith? 
- When using the android app as client the upload graph is very dynamic and sometimes uses the full upload speed.

- When I change the streaming bitrate in the web-client the upload speeded is at maxium for ~15-60sec then it falls back to the 4000kbps as always....

Thanks for helping!:)

Edited by M_L

Share this post


Link to post
Share on other sites
Tranquil

I think the bandwith will not be limited by the Server at the beginning and, for me, it is more a feature then a bug.This allows to start the playback much earlier on a device, as the inputbuffer has to fill up and you will have the ability to prebuffer some seconds which hopefully brings a smoother playback if you connection is laggy (on mobile devices for example).

 

YouTube is doing it the same way. You can see it if you try downloading a video from youtube. At the beginning, the download is fast and then it drops down to the avg bitrate of the video.

 

Edit: Could ii depend on the buffersize of the client? Maybe the app is prebuffering as much as it can and if your ffmpeg instance is fast enough to serve your complete bandwith, it will use it. This should be managed by the server, maybe FR for the future.

Edited by Tranquil

Share this post


Link to post
Share on other sites
pir8radio

@@M_L what program are you using to monitor your bandwidth, ill try it on mine.

Edited by pir8radio

Share this post


Link to post
Share on other sites
M_L

@pir8radio The screens above are taken from my router interface, it's an AVM7390. I also used the build in Windows Performance Monitor to monitor the network interfaces outgoing traffic. But I'm sure there are many good tools out there. Would be great if you could test it!

Updates concerning the problem: 
- The Website on Android utilizes the full upload speed of the server

- Internet Explorer also utilizes full upload speed, but sometimes it drops and the movie stutters, than I have to change the bitrate a few times and then it works again.

- Interesting is, my internet upload is max 6mbps and when playing movies @8mbps it utilizes the whole 6mbps all the time, no matter what. Of course the playback stutters but when I pause it a bit the movie runs fine afterwardsd and the upload bandwith is fully used. So the problem is only present when using lower playback bitrates then the server upload speed.

Edited by M_L

Share this post


Link to post
Share on other sites
M_L

So, I found out how to solve the problem. I had to use the https address instead of the normal http one. When I do so, the movies don't stutter anymore because my server utilizes the full Uploadbandwith. Don't know why it causes such a problem, but.. Hey, it works now!! :)

Share this post


Link to post
Share on other sites
Deathsquirrel

So, I found out how to solve the problem. I had to use the https address instead of the normal http one. When I do so, the movies don't stutter anymore because my server utilizes the full Uploadbandwith. Don't know why it causes such a problem, but.. Hey, it works now!! :)

 

Sounds like someone's ISP doesn't like him serving up media and is throttling the unencrypted connection. ;)

  • Like 2

Share this post


Link to post
Share on other sites
M_L

No, it's not my ISP's fault. Now I'm really pissed. The problem was solved and today I noticed that it's back!
What have you done emby team? Have you changed something in the transcoding or playback code or why the heck are the movies constantly buffering.
I'm sorry ppl, but what the hell! Why can't this just work??

Share this post


Link to post
Share on other sites
Deathsquirrel

No, it's not my ISP's fault. Now I'm really pissed. The problem was solved and today I noticed that it's back!

What have you done emby team? Have you changed something in the transcoding or playback code or why the heck are the movies constantly buffering.

I'm sorry ppl, but what the hell! Why can't this just work??

 

Emby has absolutely no control over the speed of your internet connection, traffic shaping applied by your ISP, or the power of your server.  Those things, most likely the ISP-side ones, are the most probable causes of performance issues that are specific to uploading video over the internet.

 

You can confirm your server is able to keep up with transcoding duties by making the same connection entirely inside your home network.  If the server can't keep up then, the ISP isn't the issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...