Jump to content
Luke

Debian

Recommended Posts

lamero

DLNA doesn't work form me. I am on Debian 8 and I installed ffmpeg by adding deb-multimedia.org repository.

This is the server log:

2015-09-03 11:56:25.2252 Info - App: /usr/bin/ffmpeg -fflags +genpts -i file:"/media/usb0/myfilm.mkv" -map 0:0 -map 0:1 -map -0:s -codec:v:0 copy -bsf:v h264_mp4toannexb -map_metadata -1 -threads 0 -codec:a:0 aac -strict experimental -ab 320000 -af "aresample=async=1" -y "/var/lib/emby-server/transcoding-temp/d10da27b6dd6f7f97bdecb69faa8f892.ts"
2015-09-03 11:56:27.3687 Error - App: Error streaming media. The client has most likely disconnected or transcoding has failed.
2015-09-03 11:56:27.3693 Error - HttpServer: Error in HttpListenerResponseWrapper: Write failure
        *** Error Report ***
        Version: 3.0.5724.3
        Command line: /usr/lib/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /usr/bin/ffmpeg -ffprobe /usr/bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh
        Operating system: Unix 3.16.0.4
        Processor count: 4
        64-Bit OS: True
        64-Bit Process: True
        Program data path: /var/lib/emby-server
        Mono: 4.0.3 (Stable 4.0.3.20/d6946b4 Wed Aug 19 11:59:01 UTC 2015)
        Application Path: /usr/lib/emby-server/MediaBrowser.Server.Mono.exe
        Write failure
        System.IO.IOException
          at System.Net.Sockets.NetworkStream.Write (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0
          at SocketHttpListener.Net.ResponseStream.InternalWrite (System.Byte[] buffer, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0
          at SocketHttpListener.Net.ResponseStream.Close () [0x00000] in <filename unknown>:0
          at MediaBrowser.Server.Implementations.HttpServer.SocketSharp.Extensions.CloseOutputStream (SocketHttpListener.Net.HttpListenerResponse response, ILogger logger) [0x00000] in <filename unknown>:0
        InnerException: System.Net.Sockets.SocketException
        The socket has been shut down
          at System.Net.Sockets.Socket.Send (System.Byte[] buf, Int32 offset, Int32 size, SocketFlags flags) [0x00000] in <filename unknown>:0
          at System.Net.Sockets.NetworkStream.Write (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0


2015-09-03 11:56:27.3693 Error - HttpAsyncTaskHandler: Error occured while Processing Request: Write failure
        *** Error Report ***
        Version: 3.0.5724.3

This is the transcode log (no errors):

[...]
Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (ac3 (native) -> aac (native))
Press [q] to stop, [?] for help
frame=  266 fps=0.0 q=-1.0 size=    1453kB time=00:00:10.96 bitrate=1085.3kbits/s
frame=  563 fps=562 q=-1.0 size=    2621kB time=00:00:22.74 bitrate= 944.2kbits/s
frame=  873 fps=581 q=-1.0 size=    4026kB time=00:00:35.09 bitrate= 939.8kbits/s
frame= 1155 fps=576 q=-1.0 size=    5726kB time=00:00:46.44 bitrate=1010.1kbits/s
frame= 1345 fps=537 q=-1.0 size=    6121kB time=00:00:54.05 bitrate= 927.6kbits/s
frame= 1538 fps=512 q=-1.0 size=    6674kB time=00:01:01.67 bitrate= 886.4kbits/s
frame= 1625 fps=503 q=-1.0 Lsize=    7133kB time=00:01:05.02 bitrate= 898.6kbits/s

 

Share this post


Link to post
Share on other sites
Sek0n

I just did a fresh install on a new server I moved to, and am having a dependency problem.

 

Everything seemed to install aside from 'libmediainfo0.'

The following packages have unmet dependencies:
 emby-server : Depends: libmediainfo0 but it is not installable
E: Unable to correct problems, you have held broken packages.
liam@orion:~$ sudo apt-get install libmediainfo0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libmediainfo0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libmediainfo0v5

E: Package 'libmediainfo0' has no installation candidate

It doesn't work with v5 installed either.

 

Will I need to install it from a different source, or will this possibly be fixed?

 

(I'm on Debian Sid, btw. May be the problem, but it did work before.)

Share this post


Link to post
Share on other sites
Sek0n

Just wanted to update on my last post and say I got it working by changing my source for mediainfo to testing, as it's still using libmediainfo0 for now.

Share this post


Link to post
Share on other sites
Luke

yes

Share this post


Link to post
Share on other sites
lamero

Which ffmpeg do you use? How You installed it?

Was a problem with DLNA profile. I used this profile this profile and now DLNA works

Edited by lamero

Share this post


Link to post
Share on other sites
Ben Z

I have a problem with my mediainfo. Media infos are inexistant in all of my library. The scan seems to not work properly.


 


I only have "container" and "path"  in media info on ALL of my videos. I tried to refresh and advance refresh. I even tried to delete my paths, library.db, refreshinfo.db and mediainfo.db, restarting the server and adding again the paths. Nothing works...


 


My emby server is on raspberry pi 2 raspbian jessie.


 


I never had this issue from my windows emby server.


 


Any help please?


 

  • Like 1

Share this post


Link to post
Share on other sites
hurricanehrndz

I just did a fresh install on a new server I moved to, and am having a dependency problem.

 

Everything seemed to install aside from 'libmediainfo0.'

The following packages have unmet dependencies:
 emby-server : Depends: libmediainfo0 but it is not installable
E: Unable to correct problems, you have held broken packages.
liam@orion:~$ sudo apt-get install libmediainfo0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libmediainfo0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libmediainfo0v5

E: Package 'libmediainfo0' has no installation candidate

It doesn't work with v5 installed either.

 

Will I need to install it from a different source, or will this possibly be fixed?

 

(I'm on Debian Sid, btw. May be the problem, but it did work before.)

Thank you for this. I will try and address the issue. I can see a couple of postings in the forum in regards to this.

Share this post


Link to post
Share on other sites
aviceda

Wonder if someone can help? I used the shell instructions on the site to try and install Emby on my Debian 8.2 but made a huge stuff-up and mistakenly added the Deb7 version (which obviously didn't work)

How can I reverse this process and 'uninstall' the incorrect files, whenever I run apt-get update I get this message

 

"Reading package lists... Done
W: Duplicate sources.list entry http://download.opensuse.org/repositories/home:/emby/Debian_7.0/  Packages (/var/lib/apt/lists/download.opensuse.org_repositories_home:_emby_Debian%5f7.0_Packages)
W: You may want to run apt-get update to correct these problems
"

 

Am a bit 'challenged' with the CLI....can anyone come to my rescue?

 

Tom
 

Share this post


Link to post
Share on other sites
Kseon

@@aviceda

You got duplicate entry of source look at /etc/apt/sources.list.d/

and delete emby-server.list also look in /etc/apt/sources.list

 

Then just do aptitude update ; aptitude upgrade and you should be fine.

 

Can`t install emby-server on Debian testing missing libmediainfo0.

Any suggestion what to do ?

Is there any chance emby-server package will come in Debian repo.

root-> install emby-server
The following NEW packages will be installed:
  emby-server{b} gamin{a} libgamin0{a} libgdiplus{a} libmono-2.0-dev{a}
  libmono-accessibility4.0-cil{a} libmono-c5-1.1-cil{a}
  libmono-cairo4.0-cil{a} libmono-cecil-private-cil{a} libmono-cil-dev{a}
  libmono-codecontracts4.0-cil{a}
  libmono-compilerservices-symbolwriter4.0-cil{a}
  libmono-cscompmgd0.0-cil{a} libmono-csharp4.0c-cil{a}
  libmono-custommarshalers4.0-cil{a} libmono-data-tds4.0-cil{a}
  libmono-db2-1.0-cil{a} libmono-debugger-soft4.0a-cil{a}
  libmono-http4.0-cil{a} libmono-i18n-cjk4.0-cil{a}
  libmono-i18n-mideast4.0-cil{a} libmono-i18n-other4.0-cil{a}
  libmono-i18n-rare4.0-cil{a} libmono-i18n4.0-all{a} libmono-ldap4.0-cil{a}
  libmono-management4.0-cil{a} libmono-messaging-rabbitmq4.0-cil{a}
  libmono-messaging4.0-cil{a} libmono-microsoft-build-engine4.0-cil{a}
  libmono-microsoft-build-framework4.0-cil{a}
  libmono-microsoft-build-tasks-v4.0-4.0-cil{a}
  libmono-microsoft-build-utilities-v4.0-4.0-cil{a}
  libmono-microsoft-build4.0-cil{a} libmono-microsoft-csharp4.0-cil{a}
  libmono-microsoft-visualc10.0-cil{a}
  libmono-microsoft-web-infrastructure1.0-cil{a} libmono-oracle4.0-cil{a}
  libmono-parallel4.0-cil{a} libmono-peapi4.0a-cil{a}
  libmono-posix4.0-cil{a} libmono-rabbitmq4.0-cil{a}
  libmono-relaxng4.0-cil{a} libmono-sharpzip4.84-cil{a}
  libmono-simd4.0-cil{a} libmono-sqlite4.0-cil{a}
  libmono-system-componentmodel-composition4.0-cil{a}
  libmono-system-componentmodel-dataannotations4.0-cil{a}
  libmono-system-configuration-install4.0-cil{a}
  libmono-system-core4.0-cil{a}
  libmono-system-data-datasetextensions4.0-cil{a}
  libmono-system-data-entity4.0-cil{a} libmono-system-data-linq4.0-cil{a}
  libmono-system-data-services-client4.0-cil{a}
  libmono-system-data-services4.0-cil{a} libmono-system-data4.0-cil{a}
  libmono-system-design4.0-cil{a} libmono-system-drawing-design4.0-cil{a}
  libmono-system-drawing4.0-cil{a} libmono-system-dynamic4.0-cil{a}
  libmono-system-enterpriseservices4.0-cil{a}
  libmono-system-identitymodel-selectors4.0-cil{a}
  libmono-system-identitymodel4.0-cil{a}
  libmono-system-io-compression-filesystem4.0-cil{a}
  libmono-system-io-compression4.0-cil{a}
  libmono-system-json-microsoft4.0-cil{a} libmono-system-json4.0-cil{a}
  libmono-system-ldap-protocols4.0-cil{a} libmono-system-ldap4.0-cil{a}
  libmono-system-management4.0-cil{a} libmono-system-messaging4.0-cil{a}
  libmono-system-net-http-formatting4.0-cil{a}
  libmono-system-net-http-webrequest4.0-cil{a}
  libmono-system-net-http4.0-cil{a} libmono-system-net4.0-cil{a}
  libmono-system-numerics4.0-cil{a} libmono-system-reactive-core2.2-cil{a}
  libmono-system-reactive-debugger2.2-cil{a}
  libmono-system-reactive-experimental2.2-cil{a}
  libmono-system-reactive-interfaces2.2-cil{a}
  libmono-system-reactive-linq2.2-cil{a}
  libmono-system-reactive-observable-aliases0.0-cil{a}
  libmono-system-reactive-platformservices2.2-cil{a}
  libmono-system-reactive-providers2.2-cil{a}
  libmono-system-reactive-runtime-remoting2.2-cil{a}
  libmono-system-reactive-windows-forms2.2-cil{a}
  libmono-system-reactive-windows-threading2.2-cil{a}
  libmono-system-runtime-caching4.0-cil{a}
  libmono-system-runtime-durableinstancing4.0-cil{a}
  libmono-system-runtime-serialization-formatters-soap4.0-cil{a}
  libmono-system-runtime-serialization4.0-cil{a}
  libmono-system-runtime4.0-cil{a}
  libmono-system-servicemodel-activation4.0-cil{a}
  libmono-system-servicemodel-discovery4.0-cil{a}
  libmono-system-servicemodel-routing4.0-cil{a}
  libmono-system-servicemodel-web4.0-cil{a}
  libmono-system-servicemodel4.0a-cil{a}
  libmono-system-serviceprocess4.0-cil{a}
  libmono-system-threading-tasks-dataflow4.0-cil{a}
  libmono-system-transactions4.0-cil{a}
  libmono-system-web-abstractions4.0-cil{a}
  libmono-system-web-applicationservices4.0-cil{a}
  libmono-system-web-dynamicdata4.0-cil{a}
  libmono-system-web-extensions-design4.0-cil{a}
  libmono-system-web-extensions4.0-cil{a}
  libmono-system-web-http-selfhost4.0-cil{a}
  libmono-system-web-http-webhost4.0-cil{a}
  libmono-system-web-http4.0-cil{a} libmono-system-web-mvc3.0-cil{a}
  libmono-system-web-razor2.0-cil{a} libmono-system-web-routing4.0-cil{a}
  libmono-system-web-services4.0-cil{a}
  libmono-system-web-webpages-deployment2.0-cil{a}
  libmono-system-web-webpages-razor2.0-cil{a}
  libmono-system-web-webpages2.0-cil{a} libmono-system-web4.0-cil{a}
  libmono-system-windows-forms-datavisualization4.0a-cil{a}
  libmono-system-windows-forms4.0-cil{a} libmono-system-windows4.0-cil{a}
  libmono-system-xaml4.0-cil{a} libmono-system-xml-linq4.0-cil{a}
  libmono-system-xml-serialization4.0-cil{a} libmono-tasklets4.0-cil{a}
  libmono-webbrowser4.0-cil{a} libmono-webmatrix-data4.0-cil{a}
  libmono-windowsbase4.0-cil{a} libmono-xbuild-tasks4.0-cil{a}
  libmonoboehm-2.0-1{a} libmonoboehm-2.0-dev{a} libnunit-cil-dev{a}
  libnunit-console-runner2.6.3-cil{a} libnunit-core-interfaces2.6.3-cil{a}
  libnunit-core2.6.3-cil{a} libnunit-framework2.6.3-cil{a}
  libnunit-mocks2.6.3-cil{a} libnunit-util2.6.3-cil{a} mono-csharp-shell{a}
  mono-devel{a} mono-mcs{a} mono-xbuild{a} sqlite3{a}
0 packages upgraded, 140 newly installed, 0 to remove and 16 not upgraded.
Need to get 36.1 MB of archives. After unpacking 146 MB will be used.
The following packages have unmet dependencies:
 emby-server : Depends: libmediainfo0 but it is not installable.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     emby-server [Not Installed]                        



Accept this solution? [Y/n/q/?]
Distributor ID:	Debian
Description:	Debian GNU/Linux testing (stretch)
Release:	testing
Codename:	stretch

Share this post


Link to post
Share on other sites
hurricanehrndz

Sorry obs doesn't support bring in testing sources so we can not build for testing. There is a builder available where you can easily make your packages. I have made this available in the forms, please run a search for stretch or willy and my name.

Share this post


Link to post
Share on other sites
nicheplayer

I just tried to install on a remote server running Debian 7 using the instructions at the Emby site and got as far as

 

sudo apt-get install emby-server

 

before hitting this:

Errors were encountered while processing:
 /var/cache/apt/archives/libembymagickcore-6.q8-2_8%3a6.9.2-8_amd64.deb
 /var/cache/apt/archives/libembymagickwand-6.q8-2_8%3a6.9.2-8_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thoughts? Thanks!

Share this post


Link to post
Share on other sites
hurricanehrndz

I will have to do more testing on debian 7. thanks for the info.

Edited by hurricanehrndz
  • Like 1

Share this post


Link to post
Share on other sites
hurricanehrndz

You might have to uninstall the old version of imagemagick we supplied first. 

Share this post


Link to post
Share on other sites
nicheplayer

You might have to uninstall the old version of imagemagick we supplied first. 

I already had Plex Media Server installed on this machine; I believe it installs imagemagick, too. Maybe that's causing the trouble. That would be ironic, as I was hoping to test Emby as a replacement for Plex. Are you saying that you currently have an old version of imagemagick in the Debian 7 Emby install? Or that I have an older version installed already that needs to be updated or removed?

 

Thanks for your time. I really appreciate it.

Share this post


Link to post
Share on other sites
hurricanehrndz

This is a clean install? You don't need it for testing images will load up slower on wan connections but it will work. We are in the process of ensuring that our imagemaick is non conflicting, I guess there.is still some work that needs be done. Use no install recommends

 

Sent from my D6603 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
nicheplayer

This is a clean install? 

Yup. So you're saying I should just ignore the error and proceed with 

 

sudo service emby-server start

Share this post


Link to post
Share on other sites
hurricanehrndz

Yes you can remove those two packages for now as well. I will get it fixed and post once it's done. Emby will work fine without it for the most part.

 

Sent from my D6603 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
nicheplayer

Yes you can remove those two packages for now as well. 

 

Thanks so much! Since I'm a Linux newbie, maybe I'll skip the pkg removal part for now, unless it's super easy?

Share this post


Link to post
Share on other sites
hurricanehrndz

Yeah no worries. Debian 7 seems like an odd place to start

 

Sent from my D6603 using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
nicheplayer

Debian 7 seems like an odd place to start

 

Sent from my D6603 using Tapatalk

 

Yeah, well, it was what came pre-installed on my VPS, so....  :unsure: I didn't have much say in the matter.  :D

Share this post


Link to post
Share on other sites
duna4

Hi, I've tried to install emby with no luck.

Seems that I have some dependencies issues with imagemagick & mono.

 

First I've checked that imagemagick is not installed, and I've tried to install Emby:

 

 

root@nas:/# dpkg -l | grep imagemagick
root@nas:/# apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 libmagickcore-6.q8-2 : Depende: libc6 (>= 2.14) pero 2.13-38+deb7u8 va a ser instalado
                        Depende: libfftw3-double3 pero no es instalable
                        Depende: libfontconfig1 (>= 2.11) pero 2.9.0-7.1 va a ser instalado
                        Depende: libjpeg62-turbo (>= 1.3.1) pero no es instalable
                        Depende: libtiff5 (>= 4.0.3) pero no va a instalarse
                        Depende: libwebp5 pero no es instalable
 mono-runtime : Depende: mono-runtime-sgen (= 4.2.1.102-0xamarin1) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
root@nas:/#

 

 

Any one can help me to fix, I would be grateful.

 

Thanks in advance.

 

================================================================

 

Finally I managed to fix it with aptitude
Long live Emby

 

duna4

Edited by duna4

Share this post


Link to post
Share on other sites
nicheplayer

Yes you can remove those two packages for now as well.

 

dpkg -l shows me this:

ii  imagemagick-6.q8       8:6.9.1-2     amd64        image manipulation programs -- quantum depth Q8
ii  imagemagick-common     8:6.9.1-2     all          image manipulation programs -- infrastructure

Are those the two pkgs I should uninstall? Thanks again!

Edited by nicheplayer

Share this post


Link to post
Share on other sites
hurricanehrndz

Did you have emby-sever installed before?

 

Sent from my D6603 using Tapatalk

Share this post


Link to post
Share on other sites
nicheplayer

Did you have emby-sever installed before?

 

I did not. Only thing like it on the server was Plex Media Server.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...