Jump to content

Ubuntu


Luke

Recommended Posts

Please provide the Emby Server log from this. Thanks.

 

Dear Luke,

 

If FFmpeg is not installed before emby, the emby server crash without any logs...

Link to comment
Share on other sites

Dear Luke,

 

If FFmpeg is not installed before emby, the emby server crash without any logs...

 

The startup wizard will give you a chance to configure it.

Link to comment
Share on other sites

Hi guys im trying to install ffmpeg on ubuntu serevr 16.04 

 

im getting this erroe each time and i cant find the correct dependencies for this 

 

Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-21-generic x86_64)
 
 
E: Package 'ffmpeg' has no installation candidate
root@3:~# sudo gedit /etc/apt/sources.list
sudo: gedit: command not found
root@3:~#
root@3:~#
Link to comment
Share on other sites

 

Hi guys im trying to install ffmpeg on ubuntu serevr 16.04 

 

im getting this erroe each time and i cant find the correct dependencies for this 

 

Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-21-generic x86_64)
 
 
E: Package 'ffmpeg' has no installation candidate
root@3:~# sudo gedit /etc/apt/sources.list
sudo: gedit: command not found
root@3:~#
root@3:~#

 

Does Ubuntu 16.04 not come with ffmpeg 2.8.10 installed by default? I know that I've never needed to install it manually to use Emby. What is the output when you run "ffmpeg" in the terminal?

  • Like 1
Link to comment
Share on other sites

I've never had to do it manually either. You could also type "which ffmpeg" to get an idea of where it resides.

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Guest plexman

 

Hi guys im trying to install ffmpeg on ubuntu serevr 16.04 

 

im getting this erroe each time and i cant find the correct dependencies for this 

 

Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-21-generic x86_64)
 
 
E: Package 'ffmpeg' has no installation candidate
root@3:~# sudo gedit /etc/apt/sources.list
sudo: gedit: command not found
root@3:~#
root@3:~#

 

 

Just:

sudo apt-get update
sudo apt-get install ffmpeg

If not, then:

sudo add-apt-repository ppa:jonathonf/ffmpeg-3
sudo apt-get update
sudo apt-get install ffmpeg
Link to comment
Share on other sites

 

Just:

sudo apt-get update
sudo apt-get install ffmpeg

If not, then:

sudo add-apt-repository ppa:jonathonf/ffmpeg-3
sudo apt-get update
sudo apt-get install ffmpeg

Unless things have changed you do not want to install ffmpeg 3.2 from that repository as ffmpeg 3.2 was causing lots of issues with transcoding. Ubuntu 16.04 comes with ffmpeg 2.8 by default which works well with Emby.

Edited by Jdiesel
Link to comment
Share on other sites

Unless things have changed you do not want to install ffmpeg 3.2 from that repository as ffmpeg 3.2 was causing lots of issues with transcoding. Ubuntu 16.04 comes with ffmpeg 2.8 by default which works well with Emby.

For me it is the opposit : ffmpeg 3.2 works well and 2.8 creates a lot of issues on transcoding.

Ubunutu 16.04

Link to comment
Share on other sites

Try sudo apt update. Then sudo apt upgrade.

If that doesn't work try sudo apt-get dist-upgrade.

 

Edit- I messed that all up. Fixed now.

 

Sent from my phone!

Edited by thatoneguy99
Link to comment
Share on other sites

  • 2 weeks later...

OK, this time I get slowly impatient with emby...

So I tried to update again and ran only into issue... finally I got clean from the emby-service and all and want now to install again from scratch.

I am running Ubuntu 16.04 and used the instructions:

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/ /' > /etc/apt/sources.list.d/emby-server.list"
sudo apt-get update
sudo apt-get install emby-server

but already when I do the apt-get update I get the following issue:

Get:10 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release [1,009 B]
Err:11 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release.gpg
  Bad header line Bad header data [IP: 195.135.221.134 80]
Hit:12 http://ppa.launchpad.net/numix/ppa/ubuntu xenial InRelease              
Hit:13 https://deb.opera.com/opera-stable stable InRelease                     
Get:14 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Packages [35.9 kB]
Hit:15 http://ppa.launchpad.net/tista/adapta/ubuntu xenial InRelease           
Fetched 241 kB in 7s (30.6 kB/s)                                               
Reading package lists... Done
W: The repository 'http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.gpg  Bad header line Bad header data [IP: 195.135.221.134 80]

Of course when I then try to run

apt-get install emby-server

I get:

E: Unable to locate package emby-server
 

Getting a bit frustrated here as there seems to be always issues when trying to update, last time I somehow had a dev version that didnt want to update and now this...

I start to wonder if it was really worth to pay for this :(

Edited by Driesner
Link to comment
Share on other sites

Ubuntu 16.04 emby-server is not installable.

 

- 16.04 emby-server specifically requires the emby repository's version of mono-devel (4.6, while 4.2 is installed from Ubuntu repo)

- the emby repository's version of mono requires libc 2.24 

- libc 2.24 is not available, 2.23 is installed.

 

 

user@Host:~$ sudo apt install emby-server
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
emby-server : Depends: libc6 (>= 2.24) but 2.23-0ubuntu5 is to be installed or
                       libc6.1 (>= 2.24) but it is not installable or
                       libc0.1 (>= 2.24) but it is not installable
              Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed
              Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed
              Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
              Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
              Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed
              Depends: mono-devel (>= 4.6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

 

user@Host:~$ dpkg --list |grep mono
ii  ca-certificates-mono                            4.2.1.102+dfsg2-7ubuntu4                   all     
    Common CA certificates (Mono keystore)
ii  fonts-noto-mono                                 20160116-1                                 all     
    "No Tofu" monospaced font family with large Unicode coverage
ii  fonts-tlwg-mono                                 1:0.6.2-2.1                                all     
    Thai TlwgMono font (dependency package)
ii  fonts-tlwg-mono-ttf                             1:0.6.2-2.1                                all     
    Thai TlwgMono TrueType font
ii  libmono-corlib4.5-cil                           4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono core library (for CLI 4.5)
ii  libmono-i18n-west4.0-cil                        4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono I18N.West library (for CLI 4.0)
ii  libmono-i18n4.0-cil                             4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono I18N base library (for CLI 4.0)
ii  libmono-security4.0-cil                         4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono Security library (for CLI 4.0)
ii  libmono-system-configuration4.0-cil             4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono System.Configuration library (for CLI 4.0)
ii  libmono-system-security4.0-cil                  4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono System.Security library (for CLI 4.0)
ii  libmono-system-xml4.0-cil                       4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono System.Xml library (for CLI 4.0)
ii  libmono-system4.0-cil                           4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono System libraries (for CLI 4.0)
ii  mono-4.0-gac                                    4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono GAC tool (for CLI 4.0)
ii  mono-gac                                        4.2.1.102+dfsg2-7ubuntu4                   all     
    Mono GAC tool
ii  mono-runtime                                    4.2.1.102+dfsg2-7ubuntu4                   amd64   
    Mono runtime - default version
ii  mono-runtime-common                             4.2.1.102+dfsg2-7ubuntu4                   amd64   
    Mono runtime - common files
ii  mono-runtime-sgen                               4.2.1.102+dfsg2-7ubuntu4                   amd64   
    Mono runtime - SGen
ii  ubuntu-mono                                     14.04+16.04.20161024-0ubuntu1              all     
    Ubuntu Mono Icon theme
user@Host:~$ cat /etc/apt/sources.list.d/emby.list  
deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10/ /

 

Link to comment
Share on other sites

A un recommended possible solution would be to install mono-complete.

sudo apt install mono-complete

 

 

Sent from my phone!

Link to comment
Share on other sites

hurricanehrndz

Ubuntu 16.04 emby-server is not installable.

 

- 16.04 emby-server specifically requires the emby repository's version of mono-devel (4.6, while 4.2 is installed from Ubuntu repo)

- the emby repository's version of mono requires libc 2.24

- libc 2.24 is not available, 2.23 is installed.

 

 

user@Host:~$ sudo apt install emby-server

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

 

The following packages have unmet dependencies:

emby-server : Depends: libc6 (>= 2.24) but 2.23-0ubuntu5 is to be installed or

libc6.1 (>= 2.24) but it is not installable or

libc0.1 (>= 2.24) but it is not installable

Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed

Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed

Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed

Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed

Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed

Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed

Depends: libmono-system-xml-linq4.0-cil (>= 3.0.6) but it is not going to be installed

Depends: mono-devel (>= 4.6) but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

 

user@Host:~$ dpkg --list |grep mono

ii ca-certificates-mono 4.2.1.102+dfsg2-7ubuntu4 all

Common CA certificates (Mono keystore)

ii fonts-noto-mono 20160116-1 all

"No Tofu" monospaced font family with large Unicode coverage

ii fonts-tlwg-mono 1:0.6.2-2.1 all

Thai TlwgMono font (dependency package)

ii fonts-tlwg-mono-ttf 1:0.6.2-2.1 all

Thai TlwgMono TrueType font

ii libmono-corlib4.5-cil 4.2.1.102+dfsg2-7ubuntu4 all

Mono core library (for CLI 4.5)

ii libmono-i18n-west4.0-cil 4.2.1.102+dfsg2-7ubuntu4 all

Mono I18N.West library (for CLI 4.0)

ii libmono-i18n4.0-cil 4.2.1.102+dfsg2-7ubuntu4 all

Mono I18N base library (for CLI 4.0)

ii libmono-security4.0-cil 4.2.1.102+dfsg2-7ubuntu4 all

Mono Security library (for CLI 4.0)

ii libmono-system-configuration4.0-cil 4.2.1.102+dfsg2-7ubuntu4 all

Mono System.Configuration library (for CLI 4.0)

ii libmono-system-security4.0-cil 4.2.1.102+dfsg2-7ubuntu4 all

Mono System.Security library (for CLI 4.0)

ii libmono-system-xml4.0-cil 4.2.1.102+dfsg2-7ubuntu4 all

Mono System.Xml library (for CLI 4.0)

ii libmono-system4.0-cil 4.2.1.102+dfsg2-7ubuntu4 all

Mono System libraries (for CLI 4.0)

ii mono-4.0-gac 4.2.1.102+dfsg2-7ubuntu4 all

Mono GAC tool (for CLI 4.0)

ii mono-gac 4.2.1.102+dfsg2-7ubuntu4 all

Mono GAC tool

ii mono-runtime 4.2.1.102+dfsg2-7ubuntu4 amd64

Mono runtime - default version

ii mono-runtime-common 4.2.1.102+dfsg2-7ubuntu4 amd64

Mono runtime - common files

ii mono-runtime-sgen 4.2.1.102+dfsg2-7ubuntu4 amd64

Mono runtime - SGen

ii ubuntu-mono 14.04+16.04.20161024-0ubuntu1 all

Ubuntu Mono Icon theme

user@Host:~$ cat /etc/apt/sources.list.d/emby.list

deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10/ /

@@Phezz Perhaps using the right repo for your distribution would solve your issue. Try the 16.04 repo instead of the 16.10 repo. Please let us know if this helps. Thanks !

 

Sent from my ONEPLUS A3000 using Tapatalk

Link to comment
Share on other sites

@@Phezz Perhaps using the right repo for your distribution would solve your issue. Try the 16.04 repo instead of the 16.10 repo. Please let us know if this helps. Thanks !

 

Sent from my ONEPLUS A3000 using Tapatalk

And that is what totally fails for me due to

W: The repository 'http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04 Release' is not signed.

N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.

Link to comment
Share on other sites

hurricanehrndz

Perhaps following the instructions about adding the key would solve that issue.

 

Sent from my ONEPLUS A3000 using Tapatalk

Link to comment
Share on other sites

hurricanehrndz

Ps the instructions to install the key so that the repository is trusted is right below the instructions on how to add the repo. Please report back once your issue has been resolved

 

Sent from my ONEPLUS A3000 using Tapatalk

Link to comment
Share on other sites

Just to clarify, the download page on our website will always have the most up to date installation instructions:

 

https://emby.media/linux-server.html

 

Currently, when you click Ubuntu, it will link you to our open build service and will provide the exact instructions. Let us know if this helps. Thanks !

Link to comment
Share on other sites

Adding the key , which I did before of course already does not help at all:

user@ubuntu1:~$ wget http://download.opensuse.org/repositories/home:emby/xUbuntu_16.04/Release.key
--2017-02-20 13:55:30--  http://download.opensuse.org/repositories/home:emby/xUbuntu_16.04/Release.key
Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.134, 2001:67c:2178:8::13
Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.key [following]
--2017-02-20 13:55:31--  http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.key
Reusing existing connection to download.opensuse.org:80.
HTTP request sent, awaiting response... Read error (Connection reset by peer) in headers.
Retrying.

--2017-02-20 13:55:32--  (try: 2)  http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.key
Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1089 (1.1K) [application/pgp-keys]
Saving to: ‘Release.key’

Release.key                   100%[================================================>]   1.06K  --.-KB/s    in 0s      

2017-02-20 13:55:32 (130 MB/s) - ‘Release.key’ saved [1089/1089]

user@ubuntu1:~$ sudo apt-key add - < Release.key
OK
user@ubuntu1:~$ sudo apt-get update
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease                                                     
Hit:2 http://archive.canonical.com/ubuntu xenial InRelease                                                            
Hit:3 http://id.archive.ubuntu.com/ubuntu xenial InRelease                                                          
Hit:4 http://ppa.launchpad.net/font-manager/staging/ubuntu xenial InRelease                    
Hit:5 http://id.archive.ubuntu.com/ubuntu xenial-updates InRelease                             
Ign:6 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  InRelease
Hit:7 http://ppa.launchpad.net/moka/daily/ubuntu xenial InRelease       
Hit:8 http://ppa.launchpad.net/noobslab/themes/ubuntu xenial InRelease
Get:9 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release [1,009 B]
Err:10 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release.gpg
  Bad header line Bad header data [IP: 195.135.221.134 80]
Hit:11 https://deb.opera.com/opera-stable stable InRelease
Hit:12 http://ppa.launchpad.net/numix/ppa/ubuntu xenial InRelease         
Get:13 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Packages [35.9 kB]
Hit:14 https://packagecloud.io/gyazo/gyazo-for-linux/ubuntu xenial InRelease
Hit:15 http://ppa.launchpad.net/tista/adapta/ubuntu xenial InRelease
Fetched 36.9 kB in 4s (7,905 B/s)
Reading package lists... Done
W: The repository 'http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.gpg  Bad header line Bad header data [IP: 195.135.221.134 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

You werent helpful at all so far but assumed I am not able to read instructions before posting here :(

Link to comment
Share on other sites

hurricanehrndz

Adding the key , which I did before of course already does not help at all:

user@ubuntu1:~$ wget http://download.opensuse.org/repositories/home:emby/xUbuntu_16.04/Release.key
--2017-02-20 13:55:30--  http://download.opensuse.org/repositories/home:emby/xUbuntu_16.04/Release.key
Resolving download.opensuse.org (download.opensuse.org)... 195.135.221.134, 2001:67c:2178:8::13
Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.key [following]
--2017-02-20 13:55:31--  http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.key
Reusing existing connection to download.opensuse.org:80.
HTTP request sent, awaiting response... Read error (Connection reset by peer) in headers.
Retrying.

--2017-02-20 13:55:32--  (try: 2)  http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.key
Connecting to download.opensuse.org (download.opensuse.org)|195.135.221.134|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1089 (1.1K) [application/pgp-keys]
Saving to: ‘Release.key’

Release.key                   100%[================================================>]   1.06K  --.-KB/s    in 0s      

2017-02-20 13:55:32 (130 MB/s) - ‘Release.key’ saved [1089/1089]

user@ubuntu1:~$ sudo apt-key add - < Release.key
OK
user@ubuntu1:~$ sudo apt-get update
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease                                                     
Hit:2 http://archive.canonical.com/ubuntu xenial InRelease                                                            
Hit:3 http://id.archive.ubuntu.com/ubuntu xenial InRelease                                                          
Hit:4 http://ppa.launchpad.net/font-manager/staging/ubuntu xenial InRelease                    
Hit:5 http://id.archive.ubuntu.com/ubuntu xenial-updates InRelease                             
Ign:6 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  InRelease
Hit:7 http://ppa.launchpad.net/moka/daily/ubuntu xenial InRelease       
Hit:8 http://ppa.launchpad.net/noobslab/themes/ubuntu xenial InRelease
Get:9 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release [1,009 B]
Err:10 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release.gpg
  Bad header line Bad header data [IP: 195.135.221.134 80]
Hit:11 https://deb.opera.com/opera-stable stable InRelease
Hit:12 http://ppa.launchpad.net/numix/ppa/ubuntu xenial InRelease         
Get:13 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Packages [35.9 kB]
Hit:14 https://packagecloud.io/gyazo/gyazo-for-linux/ubuntu xenial InRelease
Hit:15 http://ppa.launchpad.net/tista/adapta/ubuntu xenial InRelease
Fetched 36.9 kB in 4s (7,905 B/s)
Reading package lists... Done
W: The repository 'http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04/Release.gpg  Bad header line Bad header data [IP: 195.135.221.134 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.

You werent helpful at all so far but assumed I am not able to read instructions before posting here :(

I'm sorry you feel that way, the errors you have presented though would usually suggest that and so we try and help everyone no matter what their issue is. Anyhow, seems to me you are having trouble connecting  to the repo, I believe the key you downloaded might be corrupt. Also, if you visit the index of the repository you will see Release.gpg is there and is the signed file for the repository.  I would check your internet connection before proceeding, it seems to me like it is having a hard time connecting to our repository. Does the country you live in do any censorship of the internet?

 

Please confirm the release key is the same as the one below:

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v2.0.15 (GNU/Linux)

mQENBFVVBkABCACWEEmKmOYBKgKsEtOuh27n4iG11vGAuOcAtlWxj6K/zeDXQKKi
sbEAX7itvmcGBTmfs1zCimPFdYsA5/yKgLmUOnsvnrycKsC7jpoKnrvCeEueLZqp
cTyXhlfM1LqWw8+sFJLPXyNp44ow55IydJISyhsAR4wEVPubuO+VlLHTlGk3iIG4
V/D9mFEpqL+iKjI57N5nu4IrH7PR3Lp7unh3a18AG+UTaBVsLA5Osxcc8yEoOecs
xLCK1hVxImmrfy04WhDlHff6A49yarVdYjVxhwlu5X9WEOw5MZBu2Flj9srrbbB2
8ZDAr1IN4lm7fvoe4Y9nl5Ws2OStxt28JQtfABEBAAG0NGhvbWU6ZW1ieSBPQlMg
UHJvamVjdCA8aG9tZTplbWJ5QGJ1aWxkLm9wZW5zdXNlLm9yZz6JAT4EEwECACgF
AlVVBkACGwMFCQQesAAGCwkIBwMCBhUIAgkKCwQWAgMBAh4BAheAAAoJEApQb3Eq
fYooSv8H/2mWdeOCj4jucUlWKoAHI4203fk90s5BnTY7gMj8J8h72kTzDcXyazLW
fKjlfCO2IVORqgQRu25em4EcO7AinKZnSTaqpyypkuGwd0Rkm4kZiWhNrPR7SiWk
Mu/tqZpz7MVMrRW2DnMzCskdBrgUHwwg0ILjZOm4R0+agJRVeDgC2ypmmcKNW4I3
6Z1HUYV72hsLpPOrJx4++Wc13gr0IiWUCBcmGEEZr0WHSG4DCOxyicZOZPu94Ipk
ooPXhTzeXppq6ZRY+BTSRKL/65B/WSkjla3KiHqiVKu5PzCSMJ1Sc09lce/GPGg1
FBrKElKMJ/j/R6oiwHA2paXAV0Mo8c6IRgQTEQIABgUCVVUGQAAKCRA7MBG3a51l
Ixy3AKC0iLk3uIgwx6oz7lZ5zxpdtJuaFgCghmuiviB5ootAWh8uFEQbnxTllpM=
=+h6Z
-----END PGP PUBLIC KEY BLOCK-----

This is a test of me hitting the repo, on a fresh vm.

root@232cee3fa661:/# cat /etc/issue
Ubuntu 16.04.1 LTS \n \l

root@232cee3fa661:/# apt-key list | grep emby -B1 
pub   2048R/2A7D8A28 2015-05-14 [expires: 2017-07-22]
uid                  home:emby OBS Project <home:emby@build.opensuse.org>
root@232cee3fa661:/# apt update
Hit:1 http://archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Ign:3 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  InRelease
Hit:4 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release
Get:6 http://archive.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Fetched 204 kB in 1s (141 kB/s)    
Reading package lists... Done
Building dependency tree       
Reading state information... Done
22 packages can be upgraded. Run 'apt list --upgradable' to see them.

Edited by hurricanehrndz
Link to comment
Share on other sites

OK, here is what the Release.gpg I download looks like:

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iQEVAwUAWKqcoApQb3EqfYooAQhNEAf/bAbOCuWp2rHrvmsb53qVkNH7w4AZg9tJ
TCtUZJ7knt22FHanz+KztO7XmmTnrf6H7RDJWlCHhjmdOSpECLiarWlldaQthYWN
5WiTPDxHxY9JZc+je+5oV9nfI6Kfy4VSOhLmvSVBrt9rtELzPCwDFk43gZvzHk9x
CCLuNTTtd9n95YqBpCzxmjkJKtlH1ZX6LbXFyx/gCQE1XfMsp9yVGTXdQ7dIvnTn
CUjKEG41spvsfQtULHXY1POVxJT+Giz9MSSGRDK7v9ms8IGB0mPV2MPayGiIEgTI
ABT7ShYRPfaPxSCLoU8xH3SgALPXkgeJyEzqnZVuhDysodAyqh9a/w==
=y4BH
-----END PGP SIGNATURE-----

Yes, there is censorship where I am, but I think it is mainly done by DNS filtering as far as I know.

 

So I used a browser which uses VPN to download the file but it looks exactly the same.

 

Release.key :

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v2.0.15 (GNU/Linux)

mQENBFVVBkABCACWEEmKmOYBKgKsEtOuh27n4iG11vGAuOcAtlWxj6K/zeDXQKKi
sbEAX7itvmcGBTmfs1zCimPFdYsA5/yKgLmUOnsvnrycKsC7jpoKnrvCeEueLZqp
cTyXhlfM1LqWw8+sFJLPXyNp44ow55IydJISyhsAR4wEVPubuO+VlLHTlGk3iIG4
V/D9mFEpqL+iKjI57N5nu4IrH7PR3Lp7unh3a18AG+UTaBVsLA5Osxcc8yEoOecs
xLCK1hVxImmrfy04WhDlHff6A49yarVdYjVxhwlu5X9WEOw5MZBu2Flj9srrbbB2
8ZDAr1IN4lm7fvoe4Y9nl5Ws2OStxt28JQtfABEBAAG0NGhvbWU6ZW1ieSBPQlMg
UHJvamVjdCA8aG9tZTplbWJ5QGJ1aWxkLm9wZW5zdXNlLm9yZz6JAT4EEwECACgF
AlVVBkACGwMFCQQesAAGCwkIBwMCBhUIAgkKCwQWAgMBAh4BAheAAAoJEApQb3Eq
fYooSv8H/2mWdeOCj4jucUlWKoAHI4203fk90s5BnTY7gMj8J8h72kTzDcXyazLW
fKjlfCO2IVORqgQRu25em4EcO7AinKZnSTaqpyypkuGwd0Rkm4kZiWhNrPR7SiWk
Mu/tqZpz7MVMrRW2DnMzCskdBrgUHwwg0ILjZOm4R0+agJRVeDgC2ypmmcKNW4I3
6Z1HUYV72hsLpPOrJx4++Wc13gr0IiWUCBcmGEEZr0WHSG4DCOxyicZOZPu94Ipk
ooPXhTzeXppq6ZRY+BTSRKL/65B/WSkjla3KiHqiVKu5PzCSMJ1Sc09lce/GPGg1
FBrKElKMJ/j/R6oiwHA2paXAV0Mo8c6IRgQTEQIABgUCVVUGQAAKCRA7MBG3a51l
Ixy3AKC0iLk3uIgwx6oz7lZ5zxpdtJuaFgCghmuiviB5ootAWh8uFEQbnxTllpM=
=+h6Z
-----END PGP PUBLIC KEY BLOCK-----

So I tried again... but sadly still the same issue:

user@ubuntu1:~$ apt-key list | grep emby -B1 
pub   2048R/2A7D8A28 2015-05-14 [expires: 2017-07-22]
uid                  home:emby OBS Project <home:emby@build.opensuse.org>

user@ubuntu1:~$ sudo apt update
.
.
.
Get:14 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release [1,009 B]                          
Err:15 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release.gpg                          
  Bad header line Bad header data [IP: 195.135.221.134 80]
.
.
.
Reading package lists... Done                                                                                         
E: The repository 'http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04  Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

All other repos I use have no issue

Edited by Driesner
Link to comment
Share on other sites

hurricanehrndz

I'm not sure what to say, could be flagged because it's a gpg file. Which means encrypted. The 16.10 repo does not present that issue though?

 

Sent from my ONEPLUS A3000 using Tapatalk

Link to comment
Share on other sites

I use:

https://packagecloud.io/gyazo/gyazo-for-linux/ubuntu

https://deb.opera.com/opera-stable

and some from ppa.launchpad.net, for example http://ppa.launchpad.net/noobslab/themes/ubuntu

So I tried with the 16.10 repo and get the same issue:

Ign:12 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10  InRelease
Get:13 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10  Release [1,009 B]
Err:14 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10  Release.gpg
  Bad header line Bad header data [IP: 195.135.221.134 80]
Get:15 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10  Packages [35.9 kB]
Fetched 36.9 kB in 6s (5,483 B/s)                                              
Reading package lists... Done
W: The repository 'http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10  Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10/Release.gpg  Bad header line Bad header data [IP: 195.135.221.134 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...