Jump to content

Ubuntu


Luke

Recommended Posts

i also noticed the same thing on my machine. it does consume cpu at least 1% of the time. I know there are lots of scheduled tasks. i also have the file watch feature turned on. I would guess that has something to do with it. Other than that I'm not sure. Im sure someone can answer that though. Im not very familiar with mono apps.

Link to post
Share on other sites

You just need to install ffmpeg. The service script will find the system binaries for ffmpeg and use those instead. 

 

franky384,

 

Has been kind enough to have already compiled ffmpeg for arm.

 

You can download it here: https://www.dropbox.com/s/vitj7bk9ho6acgb/ffmpeg_build.tar.gz?dl=0

All you should need to do, is install that and start emby with the service script.

 

I have the same 'ffmpeg unvailable' problem.

I'm new to ubuntu and i can't seem to figure out how to install the compiled ffmpeg.tar. Do i extract the files to a specific location? What steps do i need to do to get the ffmpeg library and get Emby working?

 

thanx!

Link to post
Share on other sites

I get this error when I try to install on my linux Mint 17 build

 

haeffnkr@wy1450 ~ $ sudo apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 mediainfo : Depends: libmediainfo0 (>= 0.7.52) but it is not going to be installed
             Depends: libzen0 (>= 0.4.23) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 
 
Can someone please help?
thanks Kevin
Link to post
Share on other sites
stephen_d_hill

i also noticed the same thing on my machine. it does consume cpu at least 1% of the time. I know there are lots of scheduled tasks. i also have the file watch feature turned on. I would guess that has something to do with it. Other than that I'm not sure. Im sure someone can answer that though. Im not very familiar with mono apps.

Disabling the file watch setting does not change this.

Link to post
Share on other sites
hurricanehrndz

I get this error when I try to install on my linux Mint 17 build

 

haeffnkr@wy1450 ~ $ sudo apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

 

The following packages have unmet dependencies:

mediainfo : Depends: libmediainfo0 (>= 0.7.52) but it is not going to be installed

Depends: libzen0 (>= 0.4.23) but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

 

 

Can someone please help?

thanks Kevin

I would use docker in your situation

 

Sent from my D6603 using Tapatalk

Link to post
Share on other sites
hurricanehrndz

Disabling the file watch setting does not change this.

This is question best answered by Luke I think. Hopefully this will draw his attention.

Link to post
Share on other sites
hurricanehrndz

 

I get this error when I try to install on my linux Mint 17 build

 

haeffnkr@wy1450 ~ $ sudo apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 mediainfo : Depends: libmediainfo0 (>= 0.7.52) but it is not going to be installed
             Depends: libzen0 (>= 0.4.23) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 
 
Can someone please help?
thanks Kevin

 

Have you tried apt-get -f install?

Link to post
Share on other sites

Can anyone please help me. i have emby on my Linux server (ubuntu 15.04) i have noticed that when i apply update throught the emby server site address it installs the update and then when it restarts it crashes and wont restart. this happens even if i just do a restart and the only way to start emby back up is through comand line. 
Can someone please help me to fix this problem as i would like to be able to just restart server directly from emby.

Link to post
Share on other sites
hurricanehrndz

Are you talking about plugins and having the server restart after a plugin is installed? If that is the case, I wasn't aware that the restart function was not working in 15.04.

Link to post
Share on other sites
thefirstofthe300

Probably due to the systemd implementation.  You will need to check the version number and run systemctl restart emby-server if it is 15.04.

Link to post
Share on other sites

 

I get this error when I try to install on my linux Mint 17 build

 

haeffnkr@wy1450 ~ $ sudo apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 mediainfo : Depends: libmediainfo0 (>= 0.7.52) but it is not going to be installed
             Depends: libzen0 (>= 0.4.23) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 
 
Can someone please help?
thanks Kevin

 

Kevin, I got the same error the first time I tired to install. Linux Mint 17 is based on Ubuntu 14.04. I made the mistake of trying to install on Ubuntu 14.10. Make sure your /etc/apt/sources.list.d/emby-server.list indicates xUbuntu_14.04. That should resolve the dependency problems.

Link to post
Share on other sites

I made a pretty dumb mistake and upgrade to 15.10 without checking if Emby was ready for it.

 

Does anyone have an ETA? Would it be a good idea for me to switch to Docker?

Link to post
Share on other sites

I hope to have it done by Sunday. Can you please share the error you got during install

 

Sent from my D6603 using Tapatalk

 

No error per se, Ubuntu just warned me that the third party source would be disabled.

 

I tried enabling it again but I got an error that libmediainfo0 is needed but wouldn't be installed. If I tried installing it manually I got

dagur@nuc:~$ sudo apt install libmediainfo0
[sudo] password for dagur:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libmediainfo0 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libmediainfo0v5:i386 libmediainfo0v5

E: Package 'libmediainfo0' has no installation candidate

Link to post
Share on other sites

Perfect, yes that will be fixed.

 

Sent from my D6603 using Tapatalk

Hello Hurricane....

 

I am new here, I also found out that after upgrading to ubuntu 15.10 this very nice piece of software was broken.

 

Is the fix still planned for today or in the very near future?

 

This was my error:

sudo apt-get -f install emby-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 emby-server : Depends: libmediainfo0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

thanks already. And keep up the good work.

 

Best regards,

Vincent

Link to post
Share on other sites

Hi:  Thanks... am in same boat.  Upgraded from perfectly functioning 15.04 to 15.10.  I should know better.

 

Keep up the great work by the way, am really enjoying Emby.

Edited by jbc
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...