Jump to content

Ubuntu


Luke

Recommended Posts

  • 2 weeks later...

I am having the same issue that was posted about last page, where whenever I try to upload an image it says "The requested value 'Images' was not found". This happens for my profile and when I want to add custom pictures to my metadata. Did anyone figure it out? Here is my log:

 

EDIT: Issue goes away if I hit the server using /mediabrowser/ in the URL instead of /emby/

        *** Error Report ***
        Version: 3.0.5621.4
        Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server
        Operating system: Unix 3.13.0.54
        Processor count: 4
        64-Bit OS: True
        64-Bit Process: True
        Program data path: /var/lib/emby-server
        Mono: 4.0.1 (tarball Tue Jun  2 13:22:02 UTC 2015)
        Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
        The requested value 'Images' was not found.
        System.ArgumentException
        at System.Enum.Parse (System.Type,string,bool) <0x0013e>
        at MediaBrowser.Api.Images.ImageService.Post (MediaBrowser.Api.Images.PostUserImage) <0x00062>
        at (wrapper dynamic-method) object.lambda_method (System.Runtime.CompilerServices.Closure,object,object) <0x00074>
        at ServiceStack.Host.ServiceExec`1/<>c__DisplayClass6<MediaBrowser.Api.Images.ImageService>.<CreateExecFn>b__5 (object,object) <0x0002d>
        at ServiceStack.Host.ServiceRunner`1<MediaBrowser.Api.Images.PostUserImage>.Execute (ServiceStack.Web.IRequest,object,MediaBrowser.Api.Images.PostUserImage) <0x00438>


2015-06-13 11:55:32.1961 Error - HttpServer: Error processing request for /emby/Users/5b3bd8cf15fc4f23a81ef3b845e02f97/Images/Primary
        *** Error Report ***
        Version: 3.0.5621.4
        Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server
        Operating system: Unix 3.13.0.54
        Processor count: 4
        64-Bit OS: True
        64-Bit Process: True
        Program data path: /var/lib/emby-server
        Mono: 4.0.1 (tarball Tue Jun  2 13:22:02 UTC 2015)
        Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
        The requested value 'Images' was not found.
        ServiceStack.HttpError
        No Stack Trace Available
Edited by Fayth
Link to post
Share on other sites

Hi,

 

I tried instaling Emby on fresh installs of Ubuntu 10.04.01 (and Debian 7.0) and I have failed each time.

It's probably me. Here is what I did.

wget -qO - http://download.opensuse.org/repositories/home:emby/xUbuntu_14.04/Release.key | apt-key add -
sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04/ /' >> /etc/apt/sources.list.d/emby-server.list"
apt-get update
apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2
apt-get install emby-server

When there is a prompt for a username to run Emby, I just pressed Enter (another time I typed "emby").

Then I get this:

 * EmbyServer: started but exited rightaway, please check logs in /var/lib/emby-server/logs
invoke-rc.d: initscript emby-server, action "start" failed.
dpkg: error processing package emby-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up udisks2 (2.1.3-1) ...
Setting up gvfs-daemons (1.20.3-0ubuntu1.1) ...
Setting up gvfs:i386 (1.20.3-0ubuntu1.1) ...
Setting up dmsetup (2:1.02.77-6ubuntu2) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for libc-bin (2.19-0ubuntu6.5) ...
Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
Errors were encountered while processing:
 emby-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I went to get the logs, they are attached to this post. "emby_logs_1.txt"

 

Then I ran service emby-server start, because I noticed the log file had a warning added when doing this. I also attached the second log file. "emby_logs_2.txt"

 

I am probably doing something stupid with this. If anyone has any idea, I'll take it!

emby_log_2.txt

emby_log_1.txt

Link to post
Share on other sites
hurricanehrndz

Please do a purge of the install and run the following command:

echo PURGE | debconf-communicate emby-server

Then reinstall and please report back. 

Link to post
Share on other sites

Hi hurricanehernandez,

 

Thank you for your help!

 

So I did just that.

 

The purge showed me this:

(Reading database ... 37122 files and directories currently installed.)
Removing emby-server (3.0.5641.4) ...
 * EmbyServer: not running
Purging configuration files for emby-server (3.0.5641.4) ...
/var/lib/dpkg/info/emby-server.postrm: 41: [: missing ]
dpkg: error processing package emby-server (--purge):
 subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
 emby-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Then I ran echo PURGE | debconf-communicate emby-server which showed me "0".

 

When installing again, I got the same messages:

 * EmbyServer: started but exited rightaway, please check logs in /var/lib/emby-server/logs
invoke-rc.d: initscript emby-server, action "start" failed.
dpkg: error processing package emby-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 emby-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
Link to post
Share on other sites

I install respetary 

wget -qO - http://download.opensuse.org/repositories/home:emby/xUbuntu_14.04/Release.key | sudo apt-key add -
sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04/ /' >> /etc/apt/sources.list.d/emby-server.list"
sudo apt-get update
sudo apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2
sudo apt-get install emby-server

I got this error 

Setting up emby-server (3.0.5641.5) ...
 * EmbyServer: started but exited rightaway, please check logs in /var/lib/emby-server/logs
invoke-rc.d: initscript emby-server, action "start" failed.
dpkg: error processing package emby-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 emby-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also I cannot start the service 

 

Logs attached
 
OS is Ubuntu 14.04 arm on odroid-u2

 

I try to run emby with root user but got same error 

server-63570547634.txt

unhandled_51d0fb85-54fb-4145-a3a2-2440fe3871ba.txt

Edited by abayoumy
Link to post
Share on other sites

I install respetary 

wget -qO - http://download.opensuse.org/repositories/home:emby/xUbuntu_14.04/Release.key | sudo apt-key add -
sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04/ /' >> /etc/apt/sources.list.d/emby-server.list"
sudo apt-get update
sudo apt-get install mono-runtime mediainfo libsqlite3-dev imagemagick-6.q8 libmagickwand-6.q8-2 libmagickcore-6.q8-2
sudo apt-get install emby-server

I got this error 

Setting up emby-server (3.0.5641.5) ...
 * EmbyServer: started but exited rightaway, please check logs in /var/lib/emby-server/logs
invoke-rc.d: initscript emby-server, action "start" failed.
dpkg: error processing package emby-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 emby-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also I cannot start the service 

 

Logs attached
 
OS is Ubuntu 14.04 arm on odroid-u2

 

I try to run emby with root user but got same error 

 

i don't believe the package currently supports arm, but you can manually set it up. you need to install ffmpeg, then start the server from the command line

 

ffmpeg unvailable. Please install it and start the server with two command line arguments: -ffmpeg "{PATH}" and -ffprobe "{PATH}"
Link to post
Share on other sites
hurricanehrndz

 

i don't believe the package currently supports arm, but you can manually set it up. you need to install ffmpeg, then start the server from the command line

 

ffmpeg unvailable. Please install it and start the server with two command line arguments: -ffmpeg "{PATH}" and -ffprobe "{PATH}"

 

You just need to install ffmpeg. The service script will find the system binaries for ffmpeg and use those instead. 

 

franky384,

 

Has been kind enough to have already compiled ffmpeg for arm.

 

You can download it here: https://www.dropbox.com/s/vitj7bk9ho6acgb/ffmpeg_build.tar.gz?dl=0

All you should need to do, is install that and start emby with the service script.

Edited by hurricanehernandez
  • Like 1
Link to post
Share on other sites

I'm not sure if this is the correct place to post this, however I just upgraded to the newest release.  Everything was working correctly.  Now the server starts but no matter what device I connect from, all I get is the art background and the video never starts.  I attempted to purge and reinstall, same thing.  I am sure I am missing something or not doing something correctly, I just don't know what it could be.  

Link to post
Share on other sites
hurricanehrndz

I'm not sure if this is the correct place to post this, however I just upgraded to the newest release.  Everything was working correctly.  Now the server starts but no matter what device I connect from, all I get is the art background and the video never starts.  I attempted to purge and reinstall, same thing.  I am sure I am missing something or not doing something correctly, I just don't know what it could be.  

Logs would be helpful.

Link to post
Share on other sites

Logs would be helpful.

no problem, where do I locate them?

 

UPDATE:

 

I just realized that I can play certain file types. But certain movies of the same file type will play and others will not.  All of them played however prior to the update

Edited by slyder33
Link to post
Share on other sites

You just need to install ffmpeg. The service script will find the system binaries for ffmpeg and use those instead. 

 

franky384,

 

Has been kind enough to have already compiled ffmpeg for arm.

 

You can download it here: https://www.dropbox.com/s/vitj7bk9ho6acgb/ffmpeg_build.tar.gz?dl=0

All you should need to do, is install that and start emby with the service script.

thank you working :)

Link to post
Share on other sites

Any chance someone could help me understand why these videos aren't playing?  I did attach the logs as requested.  Everything played without issue prior to the last update.

 

Thanks!!

Link to post
Share on other sites
strikegun

HI,

I am running Ubuntu 14.04 and emby-server-beta.

it takes 1:13 minutes until the movies starts. 1080p

until it starts a ffmpeg process is running.

at starting (from beginning or resume, doesn't matter) then there are 6 processes of ffmpeg.

 

and my cpu is at 200% (dual core)

That is to high. I am using at the moment still plex, because I am running the server a few of clients, but if the emby server uses already for 1 movie the full cpu, then I am still keeping plex :-(

Hope you can help.

 

here is the log:

transcode-74588eb1-91bc-47b9-a0d2-49f50583fefb.txt

 

 

Update:

the waiting time till 1:13 mins is the log only written til line :283.

then it says: 

 

Successfully opened the file.

Parsing a group of options: output file /var/lib/emby-server/transcoding-temp/0248df2a5a275d5552a7c62edd04ed90.webm.
seems that ffmpeg first opens the file and in my test case its a file of 14Gigs. that takes a while.
can't ffmpeg do it on the fly?
Edited by strikegun
Link to post
Share on other sites

were there any transcoding logs for those attempts?

Yes, and as soon as I read that I looked at them and realized it was a permissions issue. So I'm chalking this up as a PINIC error  :rolleyes:

 

Thanks for the response! It made me look where I overlooked the first time!! :D

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...
slyder33

I was wondering if anyone could take a look at the logs, or maybe tell me where else to look.  Every time I stream a video from my server after a short time the server locks up and I have to power down to get it to come back up.  Nothing else causes it to freeze only when streaming Emby.  Any assistance would be greatly appreciated. This is the last log I have when it froze the last time. not sure if it will be helpful or not, but hopefully its a start

 

https://www.dropbox.com/s/3gt1bphtxz7k2pc/server-63571392000.txt?dl=0

Link to post
Share on other sites
strikegun

for me on ubuntu its playing. but you have to wait.

For me that is not usable.

I look in the logs and ffmpeg loads first the full movie-file and first after that it starts with the streaming.

my movies are 10.000kbit/s bitrate. So, the files are big and ffmeg needs a lot of time. Is there a different ffmpeg for transcoding on the fly?

And how do I set to direct stream? I want the direct video and audio stream? Is that not possible? in emby you can modify a lot, but that not?

Link to post
Share on other sites
  • 2 weeks later...

Installed and works fine on "Ubuntu 14.04.1 LTS server". Even library stop hangs MD. Thx.

I've had nothing but problems and hangups installing emby on Ubuntu 14.04 LTS. Have sought help here but haven't gotten any. I give up. Can I get some help totally uninstalling it and cleaning it off my system please?

Link to post
Share on other sites
hurricanehrndz

May I ask why you didn't run it from Docker also, if you are running it using 14.04 lts you have to upgrade your kernel to something above 4.

Link to post
Share on other sites

Installation Instructions

 

See http://mediabrowser.tv/download/

 

Let's all thank @

 

54620be0631e3_logoubuntu_st_noblack_oran

 

 

The leading platform for scale-out computing, Ubuntu Server helps you make the most of your infrastructure. Whether you want to deploy an OpenStack cloud, a Hadoop cluster or a 50,000-node render farm, Ubuntu Server delivers the best value scale-out performance available.

Please help. I just want to get rid of emby completely

It did not work on my Ubuntu

tons of errors with libsdl2-2.0-0 and kodi dependencies, ffmpeg did not work, could not do any updates.

 

I would have been happy if at least someone could have given be a bit of help on this forum, but ZERO, so I'm trying to move on to something else.

Link to post
Share on other sites

Please help. I just want to get rid of emby completely

It did not work on my Ubuntu

tons of errors with libsdl2-2.0-0 and kodi dependencies, ffmpeg did not work, could not do any updates.

 

I would have been happy if at least someone could have given be a bit of help on this forum, but ZERO, so I'm trying to move on to something else.

 

Just so that others can see in case they ever need help, we have attempted to help you but haven't heard back after we offered suggestions or asked questions. You only posted for help twice.

 

I responded within 30 minutes here:

 

http://emby.media/community/index.php?/topic/22510-m4a-aac-direct-play-without-transcoding-through-webinterface/?p=229215

 

And I responded within 90 minutes here:

 

http://emby.media/community/index.php?/topic/18043-web-client-will-not-play-anything/?p=229235

 

In both cases I never heard back. If you would like help we are here to help. If you would like to uninstall then you should be able to uninstall just as with any other ubuntu package.

Link to post
Share on other sites

May I ask why you didn't run it from Docker also, if you are running it using 14.04 lts you have to upgrade your kernel to something above 4.

I'm not sure if you were asking me, but I just followed the instructions straight from the emby site and Wiki. I didn't see anything about having to upgrade my kernel. Would have been nice to know, then I would have gone some other way.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...