Jump to content
khodges747

XBox 360 Extender interface lag

Recommended Posts

khodges747

Hi guys,

As another long time MB user who just recently upgraded to MB3 and MBC, I find I have a disappointing problem. My PC is more than powerful enough to run MBC just fine, but when I run it through my XBox 360 extender on a wired connection (not wifi) the interface slows down (lags) so much that it is unuseable. This happens with the 4 themes I have: Classic, Subdued, Chocolate and Xenon. I don't have any other plugins installed.

 

The only solution I have found so far is to turn off all backdrops, everywhere. This makes it useable, but still slow. On my PC, there is no problem using backdrops. All of my files play just fine, with no lagging or stuttering, both on thed PC and the extender. It's only the interface that is laggy over the extender. BTW, all my artwork is from metadata, not custom stuff. MB2 ran all of this just fine.

 

I hope there's a solution to this problem, because it seems a shame to have the possibility of a beautiful interface with lots of nice artwork, but be required to shut it off to make it useable.

 

I'm not a programmer, but it seems illogical to me that MBC can stream HD video files to my extender correctly, but lags when it has to handle a bunch of 0.5 MB jpg files.

 

Can this have anything to do with the fact that I enabled chapters for all my files?

 

I can't post the log file because it's too big (36 MB, is that normal?).

 

Any help would be appreicated.

Keith

 

 

Share this post


Link to post
Share on other sites
ebr

Your MBC log is 36MB?  Sound like lots of errors but I don't think that would be the cause of your issue.

 

But, those images aren't actually .5MB jpg files when they are displayed on your machine.  That is a compressed format.

 

Also, playing video is really easy compared to graphical manipulation.  That's why a streaming stick can play HD video but you need a water-cooled PC to play some games :).

 

But, all that is digression.  I would test your network connection with the 360 to be sure it is up to snuff.  It only supports 100MB but be sure you are at least getting that.

Share this post


Link to post
Share on other sites
ebr

The next release of MBC will do a couple things that may help improve this.

 

1) It will reduce the default size of backdrops that are retrieved from the server.  This may help navigation speed on extenders.

2) if that doesn't do it, then it will also expose some advanced configuration options to allow you to reduce these image sizes even further.  You should play with them to see if it helps.  While logged in with an admin account on the extender, go to the Advanced config panel and reduce the maximum size of the backdrops (and maybe other images).

  • Like 1

Share this post


Link to post
Share on other sites
Macburp

Interface lag has always been a problem with extenders. I noticed it when I was using MB2, and I've found that MB3 is about the same.

Share this post


Link to post
Share on other sites
khodges747

@@Macburp

I only had this problem on MB2 when I tried to sxet it up to do composite wallpaper in the Subdued theme (I don't remember what it's called exactly, but it makes a composite backdrop using images from every movie our TV show in the folder). That made MB2 lag terribly on the extender. With just normal backdrops, it worked fine.

 

@@ebr

Yes, one of my log files is 36 MB. But the ones from yesterday are smaller (16.5 MB). Attached is the one for the end of the day. If you see anything I can correct, please tell me.

 

Also, for the network speed, I don't know how to test it. I know it works fine to stream Netflix from an account setup on the XBox 360 to the TV, and once I start watching a movie on MBC it works fine. But if you can tell me what tool to use to test the speed I will try it.

 

Thanks for your help.

server-63550955872.zip

Share this post


Link to post
Share on other sites
ebr

That's a server log not an MBC one.  It being that large is no big deal.

Share this post


Link to post
Share on other sites
ebr

That's okay, the log isn't going to tell me anything with regard to this issue.  I was just surprised when you said it was 65MB.

 

You should try the dev version and see if it helps.  You can also reduce the size of the backdrops that are retrieved with that new version.

Share this post


Link to post
Share on other sites
khodges747

FYI, I tested the network connection today, and according to the XBox, the throughput is high enough for HD video streaming. Microsoft doesn't show any numbers, just a graph.

 

I also reconfigured the XBox to use a wifi connection, and the results were about the same, but in both cases (wired ethernet and wifi) MBC is very laggy. Even with all backdrops turned off it can take a couple of seconds to react to inputs. With the backdrops on it takes several seconds (like 15 to 20) for any command to take effect.

 

And finally, I tried to install the beta version of MBC, but it only reinstalls the stable version again, even when I set the config to accept beta versions.

 

There must be a config problem somewhere in my system. I sure wish somebody could point me in the right direction.

Share this post


Link to post
Share on other sites
apexcrewz

I don't think you have a config problem.  I think it's just life on an extender...at least with MB3.  I have the same experience.  With backdrops on, MBC isn't really useable on my Xbox 360...unless you're okay with scrolling a list with a lag of 2-3 seconds in between each movemement.  So not very useable.  Turning off backdrops makes things okay...not snappy, but okay.

Share this post


Link to post
Share on other sites
khodges747

Thanks for your input. I'm glad to know I'm not alone.

I have 2 systems in 2 different places. The older one runs MB2 and works well. The new one, with the same setup on the Xbox, same theme, same library, etc., runs MB3 and MBC, with the results you're experiencing.

Makes me want to revert to MB2 on the new system, too, but I guess it's too late for that.

If you ever find a trick to speed up navigation on MBC over an extender, please post back here.

Share this post


Link to post
Share on other sites
ebr

Please try the new beta version of MBC.  First just try it stock.  If it is still the same, try lowering the size of the images in the advanced config panel.

Share this post


Link to post
Share on other sites
khodges747

I tried this the other day after you first suggested it and couldn't get the beta to install. It just defaulted to the stable release. But today as soon as I started up MBC it offered me the beta, so I tried it.

 

Sorry, it's still not good. It seems somewhat faster, but not enough to be useable.

 

Keep trying though, I appreciate the help and suggestions.

Share this post


Link to post
Share on other sites
ebr

And did you try reducing the image sizes on the extender?

Share this post


Link to post
Share on other sites
khodges747

Yeah, sure. That was the whole point, right? :rolleyes:  I cut all the sizes in half, except the backdrops, which I set at 800.

 

I'll play with it some more over the next few days and let you know if I can find something that suits me.

Share this post


Link to post
Share on other sites
khodges747

@@ebr

I spoke too quickly when I said it didn't help to use the beta version of MBC and setting reduced image sizes. It does help, quite a bit.

 

I'm running the Subdued theme over a wired connection to an Xbox 360 extender. With the beta version of MBC (3.0.237.0) and using the Images Sizes option on the Advanced tab in the configuration, I have been able to make it lag lots less than before and I can now use MBC it fairly well. If I reduce all images to the absolute minimum it runs fairly quickly, but the quality of thumbnails is pretty bad. By playing with image size limits, I can get it to work.

 

There is one thing however, that is still extremely slow: when moving from a second level folder back to the top level folder structure, the lag is usually 5-6 seconds, and sometimes 10 seconds (timed by counting, not with a stopwatch). Navigating the other way, from top level to a second level, is not so slow.

 

This is still not perfect, and noticeably slower than on my PC, but I can use it. It's a pain to change the image size limits, too. I would prefer a text input, rather than the +/- buttons, but maybe you can do that for a future release.

 

In any case, thanks for the help, and please continue to work on the problem. I still like to imagine that my extender will some day run MBC almost as fast as my PC.

Share this post


Link to post
Share on other sites
Cheesegeezer

@@ebr

I spoke too quickly when I said it didn't help to use the beta version of MBC and setting reduced image sizes. It does help, quite a bit.

 

I'm running the Subdued theme over a wired connection to an Xbox 360 extender. With the beta version of MBC (3.0.237.0) and using the Images Sizes option on the Advanced tab in the configuration, I have been able to make it lag lots less than before and I can now use MBC it fairly well. If I reduce all images to the absolute minimum it runs fairly quickly, but the quality of thumbnails is pretty bad. By playing with image size limits, I can get it to work.

 

There is one thing however, that is still extremely slow: when moving from a second level folder back to the top level folder structure, the lag is usually 5-6 seconds, and sometimes 10 seconds (timed by counting, not with a stopwatch). Navigating the other way, from top level to a second level, is not so slow.

 

This is still not perfect, and noticeably slower than on my PC, but I can use it. It's a pain to change the image size limits, too. I would prefer a text input, rather than the +/- buttons, but maybe you can do that for a future release.

 

In any case, thanks for the help, and please continue to work on the problem. I still like to imagine that my extender will some day run MBC almost as fast as my PC.

there is some legacy code in Subdued from the original Author, that i havent got round to changing, and think it would be a lot of work to remove and reinstate properly.  My other theme Xenon was really designed for use with extenders and speed of navigation and may be more suitable. 

Share this post


Link to post
Share on other sites
khodges747

I have Xenon installed and use it on my PC. To be honest, it seemed to run slower than Subdued on the extender, but maybe I had it set up poorly. I'll give it a try again.

 

Thanks for your interest, and you themes!!

  • Like 1

Share this post


Link to post
Share on other sites
rkr87

I've had these problems for the duration of my extender using life! I had the same issues with MB2 and also when I just used the WMC built-in streaming stuff.

 

I did do some research in to the issue a couple of years ago to see if I could fix it and I found all sorts of stuff from people blaming Windows 7, type of network adapter/drivers etc. I tried tons of fixes before giving up and accepting that WMC will never run smoothly on an/my Extender(s).

 

Like you I just disabled all backdrops and edited the ehshell.dll of my media center install to make a simplistic yet still sylish background for all levels - I also find subdued to be the quickest theme (by quite a big margin).

 

I've actually come to prefer my setup over the ever changing backgrounds found in browsing other people's libraries :P Maybe I've just convinced myself it's better this way! :D

 

I am looking forward to playing around with these image size adjustments, though. While I don't suffer from too much lag now (maybe .5 seconds per item move), maybe I can get down to a smooth experience with a few adjustments to the image sizes! :)

 

 

Share this post


Link to post
Share on other sites
grizlyadams
khodges747, on 18 Nov 2014 - 03:20 AM, said:

I have Xenon installed and use it on my PC. To be honest, it seemed to run slower than Subdued on the extender, but maybe I had it set up poorly. I'll give it a try again.

 

Thanks for your interest, and you themes!!

a little late to the thread - apologies for that.

 

with MB2 the only theme I found to work with the 360 was Pearl, every other theme made it too slow to use. I've never messed around with backdrop sizes or anything else as Pearl just worked for me (and I like it in the "detail" view - I prefer lists that give me more info over coverflow with nice pics that I have to scroll thru to find what I want) . I've  only just installed MB3 (on a freenas box) with MBC and haven't really experimented with the 360 yet (I'm still enduring and somewhat regretting, the pain of getting it all working to a point that even closely resembles what I had with MB2 on WMC) but just a suggestion that may work for you.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...