Jump to content


Photo

TV Theme Videos Plugin Questions and Support Thread

Theme Videos TV Theme Videos Plugin Radeon

  • Please log in to reply
309 replies to this topic

#61 radeon OFFLINE  

radeon

    Advanced Member

  • Developers
  • 1215 posts
  • Local time: 01:41 AM

Posted 05 December 2013 - 09:20 AM

TV Theme Videos 1.0.3.0 Released!


Added Custom Maximum Volume for Audio Normalisation features.

Configure it through the Plugins Configuration Page

The lower the number the quieter it will be. So -30 is really quiet, -15 is normal, 0 is really loud!


audionorm.png



#62 newfiend OFFLINE  

newfiend

    Advanced Member

  • Members
  • 112 posts
  • Local time: 09:41 PM
  • LocationEarth

Posted 07 December 2013 - 04:44 PM

Radeon, love this plugin.. Any chance in a future update you could add the ability to delete all downloaded TV Theme Videos? In case we want to start fresh. That way we don't have to manually hunt each one down to delete..

Thx,

newfiend


Edited by newfiend, 07 December 2013 - 04:46 PM.


#63 radeon OFFLINE  

radeon

    Advanced Member

  • Developers
  • 1215 posts
  • Local time: 01:41 AM

Posted 08 December 2013 - 05:36 AM

Radeon, love this plugin.. Any chance in a future update you could add the ability to delete all downloaded TV Theme Videos? In case we want to start fresh. That way we don't have to manually hunt each one down to delete..

Thx,

newfiend

 

It has been considered, I'm always just a bit weary of deleting peoples media/metadata. I mean, would it have to go through and just delete all themes in their collection, or would it only delete those in the filter list?

 

If its to delete all, It surely Isn't good to be deleting ones people have manually added to their own collections - I would imaging people would hunt me down! haha

 

If its to only delete from the filter, the filter isn't an original feature so not all themes my plugin downloaded will be on that list for some.

 

It's one that needs some thought.

 

The manual side to this is for those who do want to delete all and re-download, just search from the route of your media for "backdrops" and delete those folders. then just delete the filters from the plugin page, or even the config.xml file from C:\Users\{you-username}\AppData\Roaming\MediaBrowser-Server\plugins\configurations.

 

Then just restart mbs and off you go.



#64 mentasm OFFLINE  

mentasm

    Advanced Member

  • Members
  • 358 posts
  • Local time: 12:11 PM
  • LocationAdelaide, Australia

Posted 02 January 2014 - 06:22 PM

hi,I

 

 seem to be getting an incorrect theme video for 'The Fall"

 

I'm seeing a video that seems to be for some western with either really bad sound or it badly re-encoded halfway through.  Instead I should be seeing lots of Gillian Anderson.

 

Can you check on the vid that is uploaded for this TV series?  I've tried deleting and redownloading and it comes back the same



#65 radeon OFFLINE  

radeon

    Advanced Member

  • Developers
  • 1215 posts
  • Local time: 01:41 AM

Posted 03 January 2014 - 05:37 AM

hi,I

 

 seem to be getting an incorrect theme video for 'The Fall"

 

I'm seeing a video that seems to be for some western with either really bad sound or it badly re-encoded halfway through.  Instead I should be seeing lots of Gillian Anderson.

 

Can you check on the vid that is uploaded for this TV series?  I've tried deleting and redownloading and it comes back the same

 

Hey, @metasm

 

Not sure what that one is! :-/ I have removed and added what i think should be the correct one. Give that a shot :-D


  • mentasm likes this

#66 newfiend OFFLINE  

newfiend

    Advanced Member

  • Members
  • 112 posts
  • Local time: 09:41 PM
  • LocationEarth

Posted 04 January 2014 - 03:18 PM

Hey radeon,

 Hope you guys are doing better.. I noticed that the Audio theme for a TV show called Golden Boy (2013) http://thetvdb.com/?...id=259093&lid=7

is or/was downloading theme music for Golden Boy TVDB http://thetvdb.com/?...&id=72408&lid=7

 

I also have a video theme for Golden Boy (2013) I can share if you need it.

 

Take Care,

newfiend~



#67 mentasm OFFLINE  

mentasm

    Advanced Member

  • Members
  • 358 posts
  • Local time: 12:11 PM
  • LocationAdelaide, Australia

Posted 04 January 2014 - 05:01 PM

The vid for the Fall looks right now.  Thanks



#68 Erik OFFLINE  

Erik

    Advanced Member

  • Members
  • 874 posts
  • Local time: 09:41 PM
  • LocationOntario, Canada

Posted 16 January 2014 - 11:15 AM

Hi Radeon,

 

Again, thanks for the great plugin. Just wondered if for a future release could the filter list be alphabetical (TV and Movie plugins)? I use it to compare against my folders for which I need theme videos for and it would be easiler than jumping all over the place in the list.

 

Thanks,

Erik


  • radeon likes this

#69 radeon OFFLINE  

radeon

    Advanced Member

  • Developers
  • 1215 posts
  • Local time: 01:41 AM

Posted 17 January 2014 - 06:54 AM

Hi Radeon,

 

Again, thanks for the great plugin. Just wondered if for a future release could the filter list be alphabetical (TV and Movie plugins)? I use it to compare against my folders for which I need theme videos for and it would be easiler than jumping all over the place in the list.

 

Thanks,

Erik

 

Hey @Erik

 

More than happy to do that,

 

Its already in the next release which will be available when the next MBS Beta comes out. :-D


  • Erik likes this

#70 Erik OFFLINE  

Erik

    Advanced Member

  • Members
  • 874 posts
  • Local time: 09:41 PM
  • LocationOntario, Canada

Posted 17 January 2014 - 08:05 PM

Thanks!

#71 radeon OFFLINE  

radeon

    Advanced Member

  • Developers
  • 1215 posts
  • Local time: 01:41 AM

Posted 18 January 2014 - 05:10 PM

Hey @Erik

 
1.0.4.5 of my plugins have just been release and adds the alphabet sorting (may require a CTRL+F5 on the plugin config page on first use)


  • Erik likes this

#72 lolwut OFFLINE  

lolwut

    Advanced Member

  • Members
  • 73 posts
  • Local time: 01:41 AM

Posted 18 January 2014 - 09:23 PM

Nice plugin, loved it, 

 

Although, More Options please:

 

-Option to close the looping. So after initial play, regular backgrounds are showed.

 

-Option to show theme background only on Series page, not while within seasons.

 

Thanks a lot for the great plugin again



#73 lolwut OFFLINE  

lolwut

    Advanced Member

  • Members
  • 73 posts
  • Local time: 01:41 AM

Posted 18 January 2014 - 09:36 PM

Nice plugin, loved it, 

 

Although, More Options please:

 

-Option to close the looping. So after initial play, regular backgrounds are showed.

 

-Option to show theme background only on Series page, not while within seasons.

 

Thanks a lot for the great plugin again

 

I just realized that both this options should be implemented under MBT not within your Plugin, ... so @Luke :)



#74 Erik OFFLINE  

Erik

    Advanced Member

  • Members
  • 874 posts
  • Local time: 09:41 PM
  • LocationOntario, Canada

Posted 19 January 2014 - 02:06 AM

Thanks @radeon!

That makes things easier. Great plugin as always.

#75 Guest_virtualtinker_* OFFLINE  

Guest_virtualtinker_*
  • Guests

Posted 10 February 2014 - 09:23 PM

Looks like the Dollhouse video link no longer works.  I had it prior but decided to delete and re-download in case the video had changed for some reason.  After it didn't re-download, I noticed in the logs that the video you were pulling from has since been marked as private.

 

Doing a quick search on YouTube, I see the original video you had, and a bunch of spoofs of what season 3's opening credits could have been, so there seems to be good source material for repopulating this.



#76 darbid OFFLINE  

darbid

    Member

  • Members
  • 14 posts
  • Local time: 02:41 AM

Posted 14 February 2014 - 07:46 AM

I am using Win 7 64 - Mediabrowser 3 Server with Mediabrowser 3 Classic.

 

I downloaded this plugin last night so I have the latest version. ** I am using the trial **  and thus understand it will do the "A"s.

 

I have the standard structure of a Folder for each movie eg. "Adore (2013)" is the folder name and in this folder I have the movie "Adore (2013).mkv" and 1 folder named "Trailers" where the trailer is and it is named "Adore (2013)-trailer.mov".  This is how all my movies are set up.  And TV is set up with as well with Series name and then a Season folder for each season.

 

When I got to an A movie or A TV show I hear nothing.

 

I have the other Video plugin installed so my Trailers all play as a backdrop when I go to a movie.

 

When I go to this movie in Mediabrowser 3 Classic some audio is heard, but I dont see in this folder where the Theme music is added - it is also not hidden as I have turned on this Folder option in Windows.

 

So my first question is where are the themes saved?

In the web interface for MediaBrowser and this pluging it says something like "these tv themes have been downloaded" sorry I am not in front of it right now.  I dont have a list at all, but this might just be because it is a trial version.

 

Edit: Sorry this is wrong:

Next I have mixed results from my Movies with "A"s.  This is my experience...

 

1 movie plays the trailer - which is what happened before I added this plugin.

1 movie plays the audio - and the backdrop is black

1 movie plays the audio with the normal backdrop

1 movie does nothing.  (I assume it did not find a theme, but there is a trailer there which it normaly would play)

 

I have in my TV section "Arrow" and "Anger Management" and I dont get or see any changes to these.  I am sure both these are popular enough that you have them.

 

Can you please help?  If you refer to a log in your answer can you please let me know where this log should by default be located and if I need to turn on logging first.


Edited by darbid, 14 February 2014 - 01:59 PM.


#77 radeon OFFLINE  

radeon

    Advanced Member

  • Developers
  • 1215 posts
  • Local time: 01:41 AM

Posted 14 February 2014 - 03:49 PM

Hey @darbid
 
Im going to reply inline with your post as there is quite a lot and I may need some things clarified before i can give a good answer but I might be able to get it in one.  :-D
 
I am using Win 7 64 - Mediabrowser 3 Server with Mediabrowser 3 Classic. cool!
 
I downloaded this plugin last night so I have the latest version. ** I am using the trial **  and thus understand it will do the "A"s. OK, so, "this plugin", can you just confirm which one you mean? I realise we are in the TV Theme Videos Support Thread but below you make references to the TV Videos, Movie Videos and Audio which could imply you are using as many as all 4 of my plugins, 1)TV Theme Videos (MBS Plugin), 2)Movie Theme Videos(MBS Plugin), 3)TV Theme Songs (MBS Plugin) and 4)Theme Video Backdrops (MBC Plugin)
 
I have the standard structure of a Folder for each movie eg. "Adore (2013)" is the folder name and in this folder I have the movie "Adore (2013).mkv" and 1 folder named "Trailers" where the trailer is and it is named "Adore (2013)-trailer.mov".  This is how all my movies are set up.  And TV is set up with as well with Series name and then a Season folder for each season.
 
When I got to an A movie or A TV show I hear nothing.
 
I have the other Video plugin installed so my Trailers all play as a backdrop when I go to a movie. This sounds like you may well have ThemeVideo Backdrops (MBC plugin) installed which is perfect, and may well be where the issue lies but im not going to assume just yet! :-D. Can you just take a look in the Theme Video Backdrops (MBC Plugin) config settings within the MediaBrowser Classic Configurator and make sure you have set the Backdrop Sources Dropdown as it will likely be set to just Local Trailers. If you want to make use out of the ThemeVideos, you need to select one of the options which includes Theme Backdrops as shown here:
2014_02_14_19h22_24.png
 
When I go to this movie in Mediabrowser 3 Classic some audio is heard, but I dont see in this folder where the Theme music is added - it is also not hidden as I have turned on this Folder option in Windows.
 
So my first question is where are the themes saved? In a hidden folder named "backdrops" in each of the folders. I.e. "c:\TV\Friends\backdrops"
In the web interface for MediaBrowser and this pluging it says something like "these tv themes have been downloaded" sorry I am not in front of it right now.  I dont have a list at all, but this might just be because it is a trial version. You Just need to make sure you have ran the scheduled task to download the themes. Assuming you have a good chunk of TV shows beginning with "A", you should have some download. Some examples of those available are: Awkward, Alcatraz, According to Jim, Adam-12, Alphas, Alias, An Idiot Abroad, Arrow, Anger Management
 
Edit: Sorry this is wrong:
Next I have mixed results from my Movies with "A"s.  This is my experience...
 
1 movie plays the trailer - which is what happened before I added this plugin.
1 movie plays the audio - and the backdrop is black
1 movie plays the audio with the normal backdrop
1 movie does nothing.  (I assume it did not find a theme, but there is a trailer there which it normaly would play)
 
I have in my TV section "Arrow" and "Anger Management" and I dont get or see any changes to these.  I am sure both these are popular enough that you have them. Yep, they are on the list,  sounds like the scheduled task may not have been run
 
Can you please help?  If you refer to a log in your answer can you please let me know where this log should by default be located and if I need to turn on logging first.
 
Let me know how you get on and what you find! :-D
 
Cheers, Radeon



#78 darbid OFFLINE  

darbid

    Member

  • Members
  • 14 posts
  • Local time: 02:41 AM

Posted 15 February 2014 - 02:13 AM

First thank you for replying and for dealing with my mess of a post.  I will try to have this one more ordered.

 

I do have the ThemeVideo Backdrops v. 1.0.0.4 installed.  Thanks to you I now know about its config which I had wrongly set.  I now have it on "Local Trailers / Then Theme Backdrops" with the second combo set to "Limit to first found source for each item".

 

Next I have TV Theme Songs plugin installed according to the Mediabrowser 3 server web GUI.

 

Me Confused: MBC Configurator / MBC Plugins in the Config Menu in WMC / Mediabrowser 3 Server web GUI;

 

I think i have it now but just in case you can install and configure ThemeVideo Backdrop in the MBC Configurator.  You can also install it from the MBC Plugins in the Config Menu but not configure it.  You can only find it in the Mediabrowser Server GUI.

 

As for TV Theme Songs - It is not in the MBC Configurator nor is it in the MBC Plugins in the Config Menu in WMC but can be only installed and configured in the Mediabrowser Server GUI. 

 

Scheduled Task - I set it to run "On Application Startup" and re-started the server.  It ran for 1sec.  No list in the plugins section and no new folders.   I have my folders for TVs named "Arrow (2012)" and "Anger Management (2012)" this is ok?  Does the TV Theme Song need its own permission to go through a firewall or does it use Mediabrowsers permissions?

 

Next I have another confusing thing.  I have read that Mediabrowser 3 supports a folder "theme-music"  with any valid audio file in it.  What is that and when do they play and do they interfere with ThemeVideo Backdrops? (I will probably ask this else where in the forum as well as I think this has little to do with your plugin)

 

Because I still have not got the scheduled task to run I want to test it manually, so I have manually created a folder "backdrops" (in a non A TV Series) and put an mp3 file in it.  But this does not play.  I am assuming then I still do not have my settings for ThemeVideo Backdrops set right?


Edited by darbid, 15 February 2014 - 02:19 AM.


#79 Cheesegeezer OFFLINE  

Cheesegeezer

    Theme Dev

  • Developers
  • 2582 posts
  • Local time: 01:41 AM
  • LocationOn an Oil Rig somewhere

Posted 15 February 2014 - 05:28 AM

First thank you for replying and for dealing with my mess of a post.  I will try to have this one more ordered.
 
I do have the ThemeVideo Backdrops v. 1.0.0.4 installed.  Thanks to you I now know about its config which I had wrongly set.  I now have it on "Local Trailers / Then Theme Backdrops" with the second combo set to "Limit to first found source for each item".
 
Next I have TV Theme Songs plugin installed according to the Mediabrowser 3 server web GUI.
 
Me Confused: MBC Configurator / MBC Plugins in the Config Menu in WMC / Mediabrowser 3 Server web GUI;
 
I think i have it now but just in case you can install and configure ThemeVideo Backdrop in the MBC Configurator.  You can also install it from the MBC Plugins in the Config Menu but not configure it.  You can only find it in the Mediabrowser Server GUI.

I havent finished moving the options to the MBC config yet in WMC, so please continue to use MBC configurator to set the options for this plugin.


 

As for TV Theme Songs - It is not in the MBC Configurator nor is it in the MBC Plugins in the Config Menu in WMC but can be only installed and configured in the Mediabrowser Server GUI. 
 
Scheduled Task - I set it to run "On Application Startup" and re-started the server.  It ran for 1sec.  No list in the plugins section and no new folders.   I have my folders for TVs named "Arrow (2012)" and "Anger Management (2012)" this is ok?  Does the TV Theme Song need its own permission to go through a firewall or does it use Mediabrowsers permissions?

This is a server plugin which means its part of your library managemnet and not client specific, so all information is stored in the server side.

Arrow and Anger Management may not have theme songs available yet. I have Arrow and dont have a theme song in my folder, so thats probably why
 

Next I have another confusing thing.  I have read that Mediabrowser 3 supports a folder "theme-music"  with any valid audio file in it.  What is that and when do they play and do they interfere with ThemeVideo Backdrops? (I will probably ask this else where in the forum as well as I think this has little to do with your plugin)
 
Because I still have not got the scheduled task to run I want to test it manually, so I have manually created a folder "backdrops" (in a non A TV Series) and put an mp3 file in it.  But this does not play.  I am assuming then I still do not have my settings for ThemeVideo Backdrops set right?

It is just a recognised structure for different clients to use, you as the user shouldn't be affected by this. The themevideo backdrop plugin will play either structure for music. The backdrops folder you are referring to is for videos only.

Hope i've managed to tie up some loose ends for you.

Cheese :D
  • radeon likes this

#80 bigjohn OFFLINE  

bigjohn

    Edge Case

  • Administrators
  • 972 posts
  • Local time: 08:41 PM
  • LocationArkansas, USA

Posted 15 February 2014 - 12:51 PM

Arrow and Anger Management may not have theme songs available yet. I have Arrow and dont have a theme song in my folder, so thats probably why
 

 

Another possibility is the theme music is available but not being pulled by the plugin due to file naming on the televisiontunes site.  I've had that happen with several shows so I just went and downloaded the file myself, named it theme.mp4 and put it in the right folder.  Looks like Arrow has a theme available there (and it is named "Arrow"), so not sure about that one.

 

@darbid, if you want to test with a series that has is known to work, create yourself an empty folder called "Arrested Development" and put a "Season 1" folder inside it.  I know the theme works for that series.


  • radeon, Cheesegeezer and adamb like this





Also tagged with one or more of these keywords: Theme Videos, TV Theme, Videos, Plugin, Radeon

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users