Jump to content

TV Theme Music Plugin Questions and Support Thread


radeon

Recommended Posts

Hey buddy! My apologies! I fell off the edge of the world for a little bit there! Had a close relative pass away and had a load family stuff to sort.

 

If you're playing around with one manually with the setting change then only that one would be affected by the normilisation, but it should be reflected in the playback when you go back to it within your client. If it's still playing back loud then something is wrong.

 

A couple of things to start. 

 

Firstly, delete one of the themes and use that as your test base.

Then you'll need to make sure you delete the theme from the plugins filter options. 

Turn off audio normilisation and make sure you save on the plugin configuration page. 

Run up the scheduled task and give that a test. see what the volume is like and if you can, get a debug log of all of that and name it so we know which log is which. oh, also grab a copy of that theme.mp3 file.

 

Then do all of the above again but re enable the audio normilisation, but this time set it to the standard -15 and see how that is, also taking another log copy and theme.mp3

 

Then finally do it all again, but set to something like -30 and grab the log and theme.mp3.

 

Then if you can chuck them all over in a zip or something, I'll be able to take a look and really see whats going on. 

 

If my shitty paraphrasing isn't enough detail then let me know and I'll write more details steps. I'm just a little pushed for time and very conscious I hadn't come back to you in a while! 

 

Apologies for the delay in replying buddy. Cheers!

Link to post
Share on other sites
  • 1 year later...
MindBullet

Hello there,

 

I just bought the full version, but in my Plug-in section it's still the test version. Could anybody help me please? Do I have to update something?

 

EDIT: Bought it again, because I thought "Let's have a 2nd try". Nope, didn't work either :(

Edited by GodOnEmby
Link to post
Share on other sites

Hello there,

 

I just bought the full version, but in my Plug-in section it's still the test version. Could anybody help me please? Do I have to update something?

 

EDIT: Bought it again, because I thought "Let's have a 2nd try". Nope, didn't work either :(

 

Hey, drop me a pm with your email and licence details and I'll check the status of your licence. 

 

A few other things to check, have you restarted your emby server instance, also, the licences can take a little propagate through so you might just need to wait a while.  

Link to post
Share on other sites
MindBullet

Hey, drop me a pm with your email and licence details and I'll check the status of your licence. 

 

A few other things to check, have you restarted your emby server instance, also, the licences can take a little propagate through so you might just need to wait a while.  

 

 

Oh holy moly, I think it worked now, as it's downloading something now, when I manually start the download theme task. Ffs I didn't know that I needed to restart the server......Bought it 3 times now. Don't know whether to cry or to laugh :D I'll PM you right away! Thank you for your quick support <3

Link to post
Share on other sites

Hey! How is everyone finding the theme songs plugin? I'm loving it. A new source was added which has some nice quality media so I'm pretty pleased with it!

Link to post
Share on other sites
HostileJava

I registered a few hours ago and have restarted the server a few times.  It will only download the A's.  when viewing the plugin I see this message:

 

"You are registered for this feature, and will be able to continue using it with an active Emby Premiere subscription."

 

But in the logs when i run it i get this:

 

"2018-07-29 16:50:18.909 Info App: Theme Songs - Trial Mode - During the trial, only shows with the name beginning with the letter 'A' will be downloaded. Please register for all names to be processed

2018-07-29 16:50:18.909 Info TaskManager: Download Local TV Theme Songs Completed after 0 minute(s) and 2 seconds"

Link to post
Share on other sites

I registered a few hours ago and have restarted the server a few times.  It will only download the A's.  when viewing the plugin I see this message:

 

"You are registered for this feature, and will be able to continue using it with an active Emby Premiere subscription."

 

But in the logs when i run it i get this:

 

"2018-07-29 16:50:18.909 Info App: Theme Songs - Trial Mode - During the trial, only shows with the name beginning with the letter 'A' will be downloaded. Please register for all names to be processed

2018-07-29 16:50:18.909 Info TaskManager: Download Local TV Theme Songs Completed after 0 minute(s) and 2 seconds"

 

Hey! Drop me a message with your email address for paypal and for your emby premier sub if different and I'll look into it for you. :)

Link to post
Share on other sites
HostileJava

Thanks for working with me on this!!!!  Very responsive and resolved quickly.  Love the Plugin!

 

Hey! Drop me a message with your email address for paypal and for your emby premier sub if different and I'll look into it for you. :)

Link to post
Share on other sites
MindBullet

Just wanted to tell you @@radeon that all of your 4 plugins make the difference for me between just a media browser (like Plex) or a full mega-cool-media-library super experience. I'm freakin' lovin the plugins and they're worth every penny!!!

  • Like 1
Link to post
Share on other sites

Just wanted to tell you @@radeon that all of your 4 plugins make the difference for me between just a media browser (like Plex) or a full mega-cool-media-library super experience. I'm freakin' lovin the plugins and they're worth every penny!!!

Thanks man! I really appreciate your comments! Makes it worth doing! :D

  • Like 2
Link to post
Share on other sites
MindBullet

Thanks man! I really appreciate your comments! Makes it worth doing! :D

 

 

Any time! I'm not even exaggerating, I really mean it. The plugins turn Emby into a superior experience compared to Plex. I can really say that as a long-term Plex user  :wub:  Even though you have the theme music at Plex too, but firstly only for TV shows and 2ndly there's no TV show or Movie Video enhancement. This finally convinced me to stick to Emby  :P If you're planning on releasing further plugins I'm sure you have at least 1 happy buyer :)

  • Like 1
Link to post
Share on other sites
annisman

Probably a stupid question but 99% of my Emby content is movies, does your plug-in do movie theme music or just TV show music ? Thx

Link to post
Share on other sites
MindBullet

Probably a stupid question but 99% of my Emby content is movies, does your plug-in do movie theme music or just TV show music ? Thx

 

 

There's 4 plugins total. TV theme music/TV theme videos; Movie Theme music/Movie Theme videos. 5$ each, worth every penny and all 4 work with every client

  • Like 1
Link to post
Share on other sites
annisman

There's 4 plugins total. TV theme music/TV theme videos; Movie Theme music/Movie Theme videos. 5$ each, worth every penny and all 4 work with every client

 

Awesome, even Emby for WMC ?

Link to post
Share on other sites

Awesome, even Emby for WMC ?

  

I'm not sure about that, @@radeon?

Last time i checked it was all still available in wmc. Man i miss wmc!! Not looked back since android tv but i do love it!!

Link to post
Share on other sites
annisman

@@radeon, I'd like to purchase and use your plug-in, can you give me a very basic step by step guide on how to buy it and set it up ? Most of this thread seems to be about troubleshooting advanced problems, so though I've searched through many pages I can't seem to get those answers. Maybe there is a YT video somewhere about initial setup ? Thx

Link to post
Share on other sites

@@radeon, I'd like to purchase and use your plug-in, can you give me a very basic step by step guide on how to buy it and set it up ? Most of this thread seems to be about troubleshooting advanced problems, so though I've searched through many pages I can't seem to get those answers. Maybe there is a YT video somewhere about initial setup ? Thx

There isn't really anything to setup. You download the plugins from the catalog, restart your emby server then run the scheduled tasks. Each client is different in terms of theme playback but they all tend to have a section within their local config for how you want it to work. Wmc has one of the best functionalities for theme media imo. I used to maintain a sperate plugin with a legendary co dev @@Cheesegeezer for wmc then it was integrated directly into the wwc client so no plugin was required.

Link to post
Share on other sites
annisman

Awesome got it working. My library has a few duplicates in it, such as a bd and 4K copy of Pacific rim, two separate folders. Is there a reason why the BD file updated with a theme song but the 4K file did not ? They are both named Pacific Rim

Link to post
Share on other sites
MindBullet

Awesome got it working. My library has a few duplicates in it, such as a bd and 4K copy of Pacific rim, two separate folders. Is there a reason why the BD file updated with a theme song but the 4K file did not ? They are both named Pacific Rim

 

 

Hey there. To get this right I'd suggest you stick to the official way for multi-version movies and place all versions of a movie in the same folder. After that the plugins will work as expected. Please see this thread on how to name multi-version movies

 

EDIT: And my guess why these plugins don't work for both files is the nature of the plugin. It can only handle one file for 1 folder. If you have < 1 folder for the same movie, the plugins's logic is, that "Pacific Rim" has already a Movie Theme/Movie Video

Edited by GodOnEmby
  • Like 1
Link to post
Share on other sites
annisman

Hey there. To get this right I'd suggest you stick to the official way for multi-version movies and place all versions of a movie in the same folder. After that the plugins will work as expected. Please see this thread on how to name multi-version movies

 

EDIT: And my guess why these plugins don't work for both files is the nature of the plugin. It can only handle one file for 1 folder. If you have < 1 folder for the same movie, the plugins's logic is, that "Pacific Rim" has already a Movie Theme/Movie Video

Hi, it was recommended to me by Luke and EBR not to follow the official naming scheme for my movies, as emby for WMC behaves differently than the other apps.

 

https://emby.media/community/index.php?/topic/61353-help-with-multi-version-movies/?fromsearch=1

 

Can I just copy/paste the 'theme' file to the folder I want (the 4K one) I don't care if the blu ray version is missing the audio file. If I do that will I run into any problems do you think ?

Link to post
Share on other sites
MindBullet

Hi, it was recommended to me by Luke and EBR not to follow the official naming scheme for my movies, as emby for WMC behaves differently than the other apps.

 

https://emby.media/community/index.php?/topic/61353-help-with-multi-version-movies/?fromsearch=1

 

Can I just copy/paste the 'theme' file to the folder I want (the 4K one) I don't care if the blu ray version is missing the audio file. If I do that will I run into any problems do you think ?

 

Oh okay, I didn't know about WMC

 

No, I don't think this would be a problem at all. Just go ahead and try it, if it doesn't bring the desired result you can still delete the copied version. Anyways I think this will work pretty damn well :)

 

Also did you try to name it the recommended way? I don't know about WMC, but maybe this will work too? You could test it with 1 movie (e.g. Pacific Rim), run the scheduled tasks of the plug in and see results.

But anyways I think what I said first will work pretty well too :)

 

EDIT: If you have the theme movies for shows/movies too, don't forget to copy the hidden "backdrop" folder too :)

 

EDIT 2: Tell me which worked and which didn't :) I'm curious  :rolleyes:

Edited by MindBullet
Link to post
Share on other sites

hang on, there are a couple of assumptions being made here which are wrong.

 

My plugins have a really simplistic filter in place to stop themes from being redownloaded a second time if they have been deleted. This was just implemented to help those where a theme had been downloaded which they didn't like and wanted to prevent it from being downloaded again. 

 

All you have to do is delete those items from the filter list that have duplicates and re run the scheduled task again. That will just redownload a second time. 

 

You can access the plugin configuration by going into the Plugins section of the server dashboard and clicking on one of the plugins. 

  • Like 1
Link to post
Share on other sites
MindBullet

hang on, there are a couple of assumptions being made here which are wrong.

 

My plugins have a really simplistic filter in place to stop themes from being redownloaded a second time if they have been deleted. This was just implemented to help those where a theme had been downloaded which they didn't like and wanted to prevent it from being downloaded again. 

 

All you have to do is delete those items from the filter list that have duplicates and re run the scheduled task again. That will just redownload a second time. 

 

You can access the plugin configuration by going into the Plugins section of the server dashboard and clicking on one of the plugins. 

 

Sorry :( Dev knowing > assuming :D <3

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...