Jump to content
radeon

TV Theme Music Plugin Questions and Support Thread

Recommended Posts

Kemosabe

Hello.  I very much want to use this plugin and donate, however I'm using MBC and I can't find the "ThemeVideo Backdrops" plugin anywhere and fear that I won't be able to use it without that plugin.  I've looked within the configuration in the MBC client, and in the plug-ins section as an admin in the server dashboard.  Is it still available?

Share this post


Link to post
Share on other sites
Cheesegeezer

Hello.  I very much want to use this plugin and donate, however I'm using MBC and I can't find the "ThemeVideo Backdrops" plugin anywhere and fear that I won't be able to use it without that plugin.  I've looked within the configuration in the MBC client, and in the plug-ins section as an admin in the server dashboard.  Is it still available?

Its now part of MBC core so there is not plugin required anymore.

  • Like 1

Share this post


Link to post
Share on other sites
ebr

Is there some documentation that needs to be updated?

Share this post


Link to post
Share on other sites
Kemosabe

Oh terrific!  I'll start donating this morning and get it going.  I was a MB 2 user for a long time - I'll be happy to donate to this project.  Remarkable work on the 3rd version - I waited too long to upgrade.

Share this post


Link to post
Share on other sites
radeon

AH yea, my plugin descriptions need updating all over the place.

 

Sorry about that. Just all over the country at the minute in my real world work so had little time to give to media browser at the minute. I'll get those descriptions updated over the next week but as @@Cheesegeezer kindly pointed out, its all in the core now. :-)

Share this post


Link to post
Share on other sites
Florux

FEATURE REQUEST: User-configurable storage path for "theme.mp3"

 

Would it be possible to add an option to store the TV theme files together with metadata / images instead of directly in the media data directory along side the video files?

 

The reason is the added security that comes with mounting the video data drives ReadOnly on the Media Browser server. That way, no bug or security incident can lead to unintended and total loss of data, and the themes can be stored on the local drive together with all the other metadata collected.

 

Since there already is a well-functioning option to store all metadata in a separate (in my case, local) folder, perhaps the Plugin could just read that folder and store the file there, if this proposed new option is enabled from within the plugin?

 

 -Florux 

Share this post


Link to post
Share on other sites
radeon

FEATURE REQUEST: User-configurable storage path for "theme.mp3"

 

Would it be possible to add an option to store the TV theme files together with metadata / images instead of directly in the media data directory along side the video files?

 

The reason is the added security that comes with mounting the video data drives ReadOnly on the Media Browser server. That way, no bug or security incident can lead to unintended and total loss of data, and the themes can be stored on the local drive together with all the other metadata collected.

 

Since there already is a well-functioning option to store all metadata in a separate (in my case, local) folder, perhaps the Plugin could just read that folder and store the file there, if this proposed new option is enabled from within the plugin?

 

 -Florux 

Hey @@Florux

 

I can't actually change the location of the theme media as I have to place it in a location that MBS will find it. My plugins are purely a metadata provider but dont control the playback or indexing of the files.

 

If mbs would allow for them to be found in the alternate metadata location then technically i could change the plugin to cater for that setup. There was quite a long thread about this exact thing and I dont think it will ever be very high up on the feature list for the head developers and in all honesty, I have a few reservations of my own about storing metadata in separate folder anyway so im not yet sure if it would become available in the plugins.

 

Cheers,

Share this post


Link to post
Share on other sites
Florux

Thanks for quick and thorough response @@radeon, much appreciated!

 

One thing I didn't quite catch, and was hoping to understand. As MBS already allows metadata to be found in a local, dedicated metadata folder, how does that prohibit it from searching for the mp3 files within the same folders?

 

Apart from that I fully agree it is not a very high priority, but it would be really good to be able to mount the storage system read-only from the dedicated server. 

 

 -Florux

Share this post


Link to post
Share on other sites
radeon

Whilst mbs it supports metadata for the images and synopsis etc in a separate folder, it doesn't support lookups for theme media placed elsewhere.

 

The following GitHub Wiki article lists the supported locations:

 

https://github.com/MediaBrowser/Wiki/wiki/Theme%20songs%20&%20videos

 

I could only ever change the location if MBS supported it too. Sorry I cant give you a better answer than that. :-(

  • Like 1

Share this post


Link to post
Share on other sites
Luke

I think we will eventually do it. Same for subtitles as well. But when is really based on demand, and up until this point it just hasn't been high enough for us to say yea we need to do this now.

  • Like 1

Share this post


Link to post
Share on other sites
Florux

I think we will eventually do it. Same for subtitles as well. But when is really based on demand, and up until this point it just hasn't been high enough for us to say yea we need to do this now.

 

That's all right. Expecting userbase to grow pretty fast, so it's only a question of time then :-) Thanks!

Share this post


Link to post
Share on other sites
paulcdb

Hi,

 

I bought the media pack on Wednesday but it still shows as trial and not had anything to say it's been added to my supporter key. - Sorted

 

So just wondering if maybe alien abduction? Holiday to North Korea? Hopefully nothing as serious as Wife Earache though? 

:P

Edited by paulcdb

Share this post


Link to post
Share on other sites
radeon

Hi,

 

I bought the media pack on Wednesday but it still shows as trial and not had anything to say it's been added to my supporter key.

 

So just wondering if maybe alien abduction? Holiday to North Korea? Hopefully nothing as serious as Wife Earache though? 

 

:P

 

Yo @@paulcdb, drop me a pm with your email and supporter key and a fresh full embyS log (restart EmbyS, wait to initialise, run scheduled tasks 1 by 1 and wait to finish (not all at the same time), upload log to dropbox and pm link)  and ill check your licence for you.

 

scrap that, found your details anyway. sending pm, 

Edited by radeon
  • Like 1

Share this post


Link to post
Share on other sites
paulcdb

scrap that, found your details anyway. sending pm, 

 

I was never any good at hide and seek!  :ph34r:

  • Like 1

Share this post


Link to post
Share on other sites
paulcdb

Why can't all support queries be resolved as quick as this? 

 

Took me longer to figure out an emby update overwrote the /etc/default/emby-server settings and could no longer write to the network share. Back to playtime!

 

Thanks Radeon

  • Like 1

Share this post


Link to post
Share on other sites
strikegun

Hi, I bought today the pack, but my paypal account is a different email as my emby account.

I am asking, because the plugins does nothing. It is installed but there is no series or movie in the plugin page.

 

Thanks

 

PS:

I change my email in the account. How long does it take until the plugin load the themes? Can I force a scan?

Edited by strikegun

Share this post


Link to post
Share on other sites
radeon

Hi, I bought today the pack, but my paypal account is a different email as my emby account.

I am asking, because the plugins does nothing. It is installed but there is no series or movie in the plugin page.

 

Thanks

 

PS:

I change my email in the account. How long does it take until the plugin load the themes? Can I force a scan?

 

Hey, the licences are tied to your supporter key. Drop me a PM/Email with your details (the two email addresses you had) and I'll make sure you're fully licenced up.

 

And yeah, you can just run the scheduled tasks from the EmbyS Dashboard.

Share this post


Link to post
Share on other sites
strikegun

I understand. Got next problem.

Many downloads don't work. Only two from 15 series are downloaded.

 

2015-06-23 22:17:06.6625 Error - App: Error downloading tv theme song for Forever

        *** Error Report ***
        Version: 3.0.5641.5
        Command line: /opt/emby-server/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server
        Operating system: Unix 3.13.0.53
        Processor count: 2
        64-Bit OS: True
        64-Bit Process: True
        Program data path: /var/lib/emby-server
        Mono: 4.0.1 (tarball Tue Jun  2 13:22:02 UTC 2015)
        Application Path: /opt/emby-server/MediaBrowser.Server.Mono.exe
        Access to the path is denied.
        System.UnauthorizedAccessException
          at System.IO.File.Move (System.String sourceFileName, System.String destFileName) [0x00000] in <filename unknown>:0
          at MediaBrowser.Plugins.ThemeSongs.Search.LocalThemeSongDownloader+<DownloadThemeSongForItem>d__1.MoveNext () [0x00000] in <filename unknown>:0
        --- End of stack trace from previous location where exception was thrown ---
          at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x00000] in <filename unknown>:0
          at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x00000] in <filename unknown>:0
          at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00000] in <filename unknown>:0
          at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00000] in <filename unknown>:0
          at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () [0x00000] in <filename unknown>:0
          at MediaBrowser.Plugins.ThemeSongs.ScheduledTasks.LocalThemeSongDownloadTask+<Execute>d__8.MoveNext () [0x00000] in <filename unknown>:0

This is the error I have in the logs.

Edited by strikegun

Share this post


Link to post
Share on other sites
radeon
Access to the path is denied

 

That'll be your problem.

 

Looks like have folder permission issues on the path the files are being written to.

Share this post


Link to post
Share on other sites
strikegun

Short explain where the themes are get written?

Share this post


Link to post
Share on other sites
radeon

If you have a movie here:

M:\Movies\Die Hard (1988)\Die Hard.mkv

 

Then the theme video would be

M:\Movies\Die Hard (1988)\backdrops\theme.mp3

 

The theme song would be 

M:\Movies\Die Hard (1988)\theme.mp3

 

For TV, if you had:

T:\TV Shows\24\Season 01\24 - S01E01.mkv

 

Then the theme video would be 

T:\TV Shows\24\backdrops\theme.mp3

 

The theme song would be 

T:\TV Shows\24\theme.mp3

Share this post


Link to post
Share on other sites
gillmacca

Just installed the movie & TV theme song plug-ins, and I am fully registered.

Movie theme songs are downloading and working fine, but for some reason, no tv theme songs are being downloaded.

I have run the scheduled task.

In the TV Theme Song Configuration, I only have 'Download filters' and 'Audio Normalisation'. Download filters never populated.

Here is a small portion of the server log:

 
2015-07-15 16:59:13.3479 Info - App: Executing Download Local TV Theme Songs
2015-07-15 16:59:13.3635 Info - App: HttpClientManager GET: http://ballingtons.com/s/?n=Two and a Half Men&t=72227
2015-07-15 16:59:14.0017 Info - App: HttpClientManager GET: http://www.televisiontunes.com/T-theme-songs.html
Edited by radeon

Share this post


Link to post
Share on other sites
radeon

 

Just installed the movie & TV theme song plug-ins, and I am fully registered.

Movie theme songs are downloading and working fine, but for some reason, no tv theme songs are being downloaded.

I have run the scheduled task.

In the TV Theme Song Configuration, I only have 'Download filters' and 'Audio Normalisation'. Download filters never populated.

Here is a small portion of the server log:

 
2015-07-15 16:59:13.3479 Info - App: Executing Download Local TV Theme Songs
2015-07-15 16:59:13.3635 Info - App: HttpClientManager GET: http://ballingtons.com/s/?n=Two and a Half Men&t=72227
2015-07-15 16:59:14.0017 Info - App: HttpClientManager GET: http://www.televisiontunes.com/T-theme-songs.html

 

 

Looks like they have changed their site somewhat, I'll have to make some changes to reflect and release a new build. :-)

Share this post


Link to post
Share on other sites
radeon

@@gillmacca,

 

Give that a shot now matey, all should be fixed. :-D

Share this post


Link to post
Share on other sites
gillmacca

Working like a charm now. Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...