Jump to content

TV Theme Music Plugin Questions and Support Thread


radeon

Recommended Posts

MBT fails to play hidden theme.mp3s?

right now they are the only metadata that I cant hide in the folders.

 

Hey @@lolwut,

 

I'm a little lost? Are you saying there is a problem with my plugin? My plugin downloads the theme.mp3 but doesnt hide them as per the requirements of MBS. MBS dictates the structure required which is why they're not hidden.

Link to post
Share on other sites

I actually dont know MBT, MBS or the plugin that is causing this behaviour.

I have a lot of metadata there xmls, pictures, theme videos ..etc, and when I browse my folder structure manually, I only want to see actual tv or movie videos.

That is why all those are hidden, and MBT, MBS handles them correctly today, WMC and MBC handled them correctly in the past, except theme.mp3s, dont know why but when they are hidden, they are not recognized...

BTW, I am aware your plugin only downloads and manages them, and do not interfere how clients handle them (i have custom theme mp3s and they have the same problem),

So hmm, should I have posted on MBS or MBT forum ? since its related to theme.mp3 s only, I thought this the right place to post this issue.

Link to post
Share on other sites

Hey @@lolwut,

 

I'm a little lost? Are you saying there is a problem with my plugin? My plugin downloads the theme.mp3 but doesnt hide them as per the requirements of MBS. MBS dictates the structure required which is why they're not hidden.

BTW, I am not saying your plugin should hide them or not, it is my choice to hide all my metadata.

Link to post
Share on other sites

I actually dont know MBT, MBS or the plugin that is causing this behaviour.

I have a lot of metadata there xmls, pictures, theme videos ..etc, and when I browse my folder structure manually, I only want to see actual tv or movie videos.

That is why all those are hidden, and MBT, MBS handles them correctly today, WMC and MBC handled them correctly in the past, except theme.mp3s, dont know why but when they are hidden, they are not recognized...

BTW, I am aware your plugin only downloads and manages them, and do not interfere how clients handle them (i have custom theme mp3s and they have the same problem),

So hmm, should I have posted on MBS or MBT forum ? since its related to theme.mp3 s only, I thought this the right place to post this issue.

 

Right, i see, Yeah, this is a MBS question as that's the one doing the detecting. This thread is for those problems related to the actual download/normalisation of the media. :-D

 

Its more of a feature request than anything else. If it does change, ill just have to update my tool to hide the themes in future. :-D

Edited by radeon
Link to post
Share on other sites
  • 1 month later...

Hi,

first great Plugin thanks :-)

 

Now my question:

What is the download source for the theme songs? Is t a service like thetvdb.com?

The "problem" is the plugin doesn't download songs for german series like Stromberg. Do you have any solution for this?

 

Thanks for your work

Link to post
Share on other sites
  • 2 weeks later...
rumred85

First, thank you for making an amazing plugin.  It is really cool having the music play when browsing the shows.

 

Is there a way to figure out why the plugin is not downloading music for some tv shows?  As an example on of the shows I have is The King of Queens which has a series.xml file but for whatever reason the theme.mp3 is not downloading.  This is happening for several shows that I am certain there is theme mp3s available but I am at a loss as to why they are not downloading..

 

Link to post
Share on other sites
  • 3 months later...

Hi

 

Was wanting to try this out and see how it goes and what it's like before purchasing but when I go to the plugin section to install it there is a message saying that the trial period for the feature has expired. Reading the description it seems the limitation on the plugin was that it would only do shows starting with A and not on a time basis.

 

Has this changed ?

Link to post
Share on other sites

Hi

 

Was wanting to try this out and see how it goes and what it's like before purchasing but when I go to the plugin section to install it there is a message saying that the trial period for the feature has expired. Reading the description it seems the limitation on the plugin was that it would only do shows starting with A and not on a time basis.

 

Has this changed ?

 

I cant seem to find the page on the plugin catalog but it used to state that All premium plug-ins have 14-day trial periods.That's all controlled by the licence infrastructure MB supplies to the plugin developers. However, at the very start, I added the additional limit to only download shows beginning with A because a trial mode on this sort of plugin with unlimited use for the first 14 days is a little bit pointless as and given user, would install, download everything then not need to use again.

 

That said, I'm pretty sure that the trial period only starts once the plugin has been installed. So assuming you installed it and ran the scheduled task or let it run itself at 2am, it would have downloaded any available A shows for you.

 

I hope that helps!

Link to post
Share on other sites
  • 2 weeks later...

If it downloads the wrong song, how do I choose another song? I can download the right one manually from http://www.televisiontunes.com/, but then it wouldnt process the audio normalization right?

 

At the minute, there isnt a way/ If you have the wrong one downloading and really want it to pass through the audio normilization, renaming your show to match the right one from television tunes temporarily, running the schedule then renaming back should work. Also, if you let me know of a few examples where its wrong, ill see if i can improve the naming lookups. :-)

Link to post
Share on other sites
  • 1 month later...

In my case it's downloading the theme for the correct show, but it seems to be truncated. The clip is only 7 seconds long and it cuts off too early. Is there anything that can be done about that? The show is "Community".

Link to post
Share on other sites

In my case it's downloading the theme for the correct show, but it seems to be truncated. The clip is only 7 seconds long and it cuts off too early. Is there anything that can be done about that? The show is "Community".

Hey! Give it another shot now, I've had some hosting outages due to some maintenance over the past 2 hours which may have caused it. I have just added the show to my collection to get it to download and it was absolutely fine.

 

let me know how you get on! :-)

  • Like 1
Link to post
Share on other sites

I'm not sure if this is where you're grabbing them from, but the main theme title at televisiontunes.com is only 6 seconds (which is what I was experiencing). I downloaded the one titled "Community - 30 seconds" and placed it in the series folder and it works great now.

Link to post
Share on other sites
  • 1 month later...

Ah, it looks like a dependency has changed in mbs core which is stopping the plugin. I'm away from home until weds but I already know the fix so ill have a release as soon as i can on weds!

Link to post
Share on other sites

Cou

Ah, it looks like a dependency has changed in mbs core which is stopping the plugin. I'm away from home until weds but I already know the fix so ill have a release as soon as i can on weds!

Could this be my problem as well? I've a separate post, which ebr has been asking questions about. I have two installations of MBC 3.0.238 (with Subdued) on different Windows 7 PC's. One plays both theme backdrop videos and theme songs, the other only plays theme songs. They're identical in almost every respect, and I've double checked all the settings. Driving me a bit nuts. Like to get this one resolved.

Edited by tman
Link to post
Share on other sites

Cou

Could this be my problem as well? I've a separate post, which ebr has been asking questions about. I have two installations of MBC 3.0.238 (with Subdued) on different Windows 7 PC's. One plays both theme backdrop videos and theme songs, the other only plays theme songs. They're identical in almost every respect, and I've double checked all the settings. Driving me a bit nuts. Like to get this one resolved.

 

No, Unfortunately not. Its just a check for the file being a valid video/audio file which is failing. Ebr wont be doing anything like this to play the video files.

 

Are they both running from the same mbs instance? And out of curiosity, have you tried disabling the new method in mbc and installing the old theme backdrops plugin, just to see if that works? Just as a process of elimination.

Link to post
Share on other sites

Thanks radeon. Yes, they are both using the same MBS instance, so I know it's not the server. I don't mind trying the dedicated MBC plugin, but it's no longer listed in the catalog. Guess it was pulled when MBC added native support. I'm stumped. Don't know if the logfiles will give anything away. The movie I was trying was 'Life of Pi'. This has both theme music and background. It's my main HTPC that's not playing the backgrounds, and that's where I wanted them!

MBClassic-working-client.log

MBClassic-non-working-client.log

Link to post
Share on other sites

Thanks ebr

 

Sorry all, I've been away for the last week or so and just got back today. The plugins are all fixed and released. 1.1.1.1 is the version you need for the latest mbs release.

Link to post
Share on other sites
  • 2 months later...

G'day

A day ago I purchased and installed the TV/Movie Theme Pack. When the scheduled task runs for both packs, I am only getting the "A" named shows. Checking the logs I see that I am in trial mode but I am a registered MB3 supporter. Pls Help.

 

Log File Info :

 

2015-02-26 10:24:28.2137 Info - App: TV Theme Songs Registration Status - Registered?: False | Is in Trial : True  | Registration Is Valid : True 

 

2015-02-26 10:24:43.8295 Info - App: TV Theme Songs - Trial Mode - During the trial, only shows with the name beginning with the letter 'A' will be downloaded. Please register for all names to be processed
 
Thx
Link to post
Share on other sites

 

G'day

A day ago I purchased and installed the TV/Movie Theme Pack. When the scheduled task runs for both packs, I am only getting the "A" named shows. Checking the logs I see that I am in trial mode but I am a registered MB3 supporter. Pls Help.

 

Log File Info :

 

2015-02-26 10:24:28.2137 Info - App: TV Theme Songs Registration Status - Registered?: False | Is in Trial : True  | Registration Is Valid : True 

 

2015-02-26 10:24:43.8295 Info - App: TV Theme Songs - Trial Mode - During the trial, only shows with the name beginning with the letter 'A' will be downloaded. Please register for all names to be processed
 
Thx

 

 

 

Hey, Can you pm/email me you mb supporter key, mb supporter email address and paypal email address and we'll get you sorted out.

Edited by radeon
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...