Jump to content

Search the Community

Showing results for tags 'systemd'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 5 results

  1. Guest

    Stop autostart of server

    Hi there, I went through the service scripts for the emby-server service, both on the systemd and the /etc/init side, but I haven't found any option where to disable the emby-server service completely, because I want to start my own emby-server instance manually without any need for a service. Other services have an "FOO_ENABLE=0" or something similar in an /etc/service.conf file, is there such an option for emby? Thank you
  2. Hello, using the latest versions (if I mistake not from 3.2 onwards) of Emby on Debian Jessie, if I use the command "systemctl stop emby-server" Emby does not stop gracefully and "Main" process remains alive. The only way to stop Emby is killing the process with the "kill" command. This problem is related to how systemd stops the processes and probably in the last updates you have been changed the start script "/usr/bin/emby-server" or systemd unit configuration file "/lib/systemd/system/emby-server.service". Sorry for my bad English. Thank you for your wonderful work. Carlo
  3. thatoneguy99

    Emby-Server upgrade

    Good morning. I do not use an init.d script to run Emby. I use a systemd script to autostart my server. The problem is during an upgrade. Post installation script for Emby tries to run update-rc.d but since I do not have an startup script in the init.d folder I get an error that the install failed. How can i make the post installation script complete? Is there a way to turn off this functionality of the upgrade process? Any information is helpful! Thank you!
  4. Hi all, I noticed a while back that emby-server isn't starting automatically in systemd for me and I finally had some time to troubleshoot. I'm running Fedora 25 and I've made sure dnf / yum are up to date and made sure I'm using the repos from this post in the Fedora thread: https://emby.media/community/index.php?/topic/13398-fedoracentos-rpm/page-15 emby-server does run if I start manually as sudo, but if I try to enable the service, I get the following error: systemctl status emby-server -l ● emby-server.service - Emby Media Server Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: disabled) Active: failed (Result: exit-code) since Wed 2017-02-01 07:19:08 CST; 27min ago Process: 26742 ExecStopPost=/usr/lib/emby-server/emby-server.sh clear (code=exited, status=0/SUCCESS) Process: 26718 ExecStart=/usr/lib/emby-server/emby-server.sh start (code=exited, status=127) Main PID: 26718 (code=exited, status=127) Feb 01 07:19:08 mythtv systemd[1]: Started Emby Media Server. Feb 01 07:19:08 mythtv emby-server.sh[26718]: /usr/lib/emby-server/emby-server.sh: line 118: exec: su: not found Feb 01 07:19:08 mythtv systemd[1]: emby-server.service: Main process exited, code=exited, status=127/n/a Feb 01 07:19:08 mythtv systemd[1]: emby-server.service: Unit entered failed state. Feb 01 07:19:08 mythtv systemd[1]: emby-server.service: Failed with result 'exit-code'. Doing a Google search on status=127, I found this on Github, but it's a status 126: https://github.com/MediaBrowser/Emby/issues/1419 From that thread, if I run: #!/bin/bash MAGICK_LIBRARY_PATH=$(find /usr/lib/emby-server/ -maxdepth 1 -mindepth 1 -type d| grep -v bin) MONO_EXEC_ENV="$MONO_ENV LD_LIBRARY_PATH=${MAGICK_LIBRARY_PATH}${LD_LIBRARY_PATH:+:}$LD_LIBRARY_PATH" echo "$MONO_EXEC_ENV" I get: [pcutler@[member="mythtv"] ~]$ echo "$MONO_EXEC_ENV" LD_LIBRARY_PATH=/usr/lib/emby-server/etc /usr/lib/emby-server/lib64 So I don't think it's embymagick as I see: Package embymagick-6.9.6+6-7.2.x86_64 is already installed. Since I'm able to run it as sudo normally, I don't see anything in the latest log file. At the top I see: 2017-02-01 07:27:03.3492 Info Main: Emby Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 4.8.16.300 64-Bit OS: True 64-Bit Process: True Mono: 4.6.2 (Stable 4.6.2.16/ac9e222 Tue Jan 3 11:51:14 UTC 2017) Processor count: 4 Program data path: /var/lib/emby-server Application directory: /usr/lib/emby-server/bin 2017-02-01 07:27:03.6990 Info ImageMagick: ImageMagick version: ImageMagick 6.9.6-6 Q8 x86_64 2016-12-12 http://www.imagemagick.org 2017-02-01 07:27:04.6188 Info App: Application version: 3.1.5.0 2017-02-01 07:27:04.7586 Info App: Application configuration: Any hints of what I should be looking for or trying to fix systemd? Is it related to the su not found message? (I'm not sure how to fix that). Thanks in advance. Paul
  5. harisund

    ANSWERED CentOS7 / systemd script broken

    Here's the situation. I am installing the latest server on Cent OS 7. First, there's a file called /etc/default/emby-server. This contains actual values. Second, there's a file called /etc/emby-server.conf . This is fully commented out. Then, there's /usr/lib/emby-server/emby-server.sh. This file begins by sourcing "/etc/default/emby-server", and then over riding it by sourcing /etc/emby-server.conf. So far so good. If a user wants to over ride values, he/she edits /etc/emby-server.conf and everything is dandy. Now, the /usr/lib/systemd/system/emby-server.service is where everything breaks. The systemd service descriptor has the following -> EnvironmentFile=/etc/emby-server.conf This is bad. SystemD supports drop-in functionality where this can be over ridden. I over rode this with a drop-in config file that contained the line EnvironmentFile=/home/harisund/systemd_confs/emby-server.conf. Guess what happened? SystemD changed the environment file to the above file which had all my settings, but the /usr/lib/emby-server/emby-server.sh decided to completely ignore this file, and simply used what's in /etc/default/emby-server.conf followed by /etc/emby-server.conf. Took me a while to figure out the "EnvironmentFile" value in the SystemD init script is totally being ignored by the shell script. Here's the work around. Instead of using EnvironmentFile, use something like Environment=EMBY_CONF_FILE=foo. Then in the /usr/lib/emby-server/emby-server.sh, change lines 18 through 21 to use EMBY_CONF_FILE instead of CONF_FILE and totally remove line 9.
×
×
  • Create New...