Jump to content

Search the Community

Showing results for tags 'fedora'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 6 results

  1. FemoTheDon

    Fedora 29 Install of Emby Server fails

    Hello guys, I have just installed emby-server on my fedora server # lsb_release -a LSB Version: :core-4.1-amd64:core-4.1-noarch Distributor ID: Fedora Description: Fedora release 29 (Twenty Nine) Release: 29 Codename: TwentyNine as directed on the website: # dnf install https://github.com/MediaBrowser/Emby.Releases/releases/download/4.2.1.0/emby-server-rpm_4.2.1.0_x86_64.rpm When I opened this in a browser http://localhost:8096/ it fails. I assumed it was the firewall, I opened it still no joy. On checking the status is failed and starting or restarting it doesn't do anything. # systemctl status emby-server.service ● emby-server.service - Emby Server is a personal media server with apps on just about every device. Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: disabled) Active: failed (Result: core-dump) since Thu 2019-10-17 18:59:59 BST; 10s ago Process: 7764 ExecStart=/opt/emby-server/bin/emby-server (code=dumped, signal=ABRT) Main PID: 7764 (code=dumped, signal=ABRT) Oct 17 18:59:58 TServer emby-server[7764]: --- End of inner exception stack trace --- Oct 17 18:59:58 TServer emby-server[7764]: at System.IO.FileSystem.CreateDirectory(String fullPath) Oct 17 18:59:58 TServer emby-server[7764]: at System.IO.Directory.CreateDirectory(String path) Oct 17 18:59:58 TServer emby-server[7764]: at Emby.Server.Implementations.Logging.FileLogger..ctor(String path) Oct 17 18:59:58 TServer emby-server[7764]: at Emby.Server.Implementations.Logging.SimpleLogManager.ReloadLogger(LogSeverity severity, CancellationToken cancellationToken) Oct 17 18:59:58 TServer emby-server[7764]: --- End of inner exception stack trace --- Oct 17 18:59:58 TServer emby-server[7764]: at System.Threading.Tasks.Task.WaitAllCore(Task[] tasks, Int32 millisecondsTimeout, CancellationToken cancellationToken) Oct 17 18:59:58 TServer emby-server[7764]: at EmbyServer.Program.Main(String[] args) Oct 17 18:59:59 TServer systemd[1]: emby-server.service: Main process exited, code=dumped, status=6/ABRT Oct 17 18:59:59 TServer systemd[1]: emby-server.service: Failed with result 'core-dump'. Can anyone advise on what to do? Many thanks. Femo
  2. KRDucky

    Fedora Atomic setup?

    Would anyone be so kind as to show/write how to setup an Emby server using Fedora Atomic? I am fixing to upgrade my system to the new AMD Ryzen 5 2400G and plan to transition Fedora Atomic. Fedora Atomic includes the os-tree system along with live updates which is a nice touch. --From Fedora: "Atomic Host from Project Atomic is a lightweight, immutable platform, designed with the sole purpose of running containerized applications." https://getfedora.org/en/atomic/ I want to run my application stack in containers. All pulling from my library data pool. (LVM2 array) My stack is usually, Emby - Sonarr - Sabnzbdplus - Cockpit - Organizr - SFTP server As the AMD Zen architecture has a good memory cryptography solution that seems to eliminate the vulnerability to VMs and containers running on an AMD platform, I figured it would be a good idea to containerize my server's services. Does anyone have a walkthrough or guide for how to accomplish this on Fedora Atomic?
  3. Hello I've been stuck trying to add my library to Emby since installing two days ago. I used to use the app a few years ago without issue on a Fedora install and now it only ever loads locally-stored media. I have an NFS share on 192.168.1.254:/srv/media. Initially I tried mounting it and then pointing Emby to the local mountpoint. When I add 192.168.1.254:/srv/media to my fstab, the directory mounts on boot correctly and members of the :media group (of which the emby user is one) can write to the folder. Then I start emby and the share may as well have never been mounted because Emby sees nothing and processes nothing at all in that folder. So then I remove the share from my fstab and proceed to let Emby handle whatever mounting needs to be done by supplying the Network Path in the Library setup, at which point it complains about every path format I give it. These are the paths that do not work: nfs://192.168.1.254 nfs://192.168.1.254:/srv/media nfs://192.168.1.254/srv/media And all of them throw the "There was an error adding the media path." error Apparently Emby can't access my media on its own unless its on a local block device, so now I'm totally confused. Do i need another piece of software installed on 192.168.1.254 just to get the share to work with Emby? Running multiple "helper apps" across multiple machines on top of NFS is complete overkill. Any insight would be helpful, I feel like I'm wasting my time and would just like a straight answer as to whether Emby supports NFS without extra utilities or setup.
  4. Hello, after testing emby media server on a windows computer and falling in love with it I wanted to test it on my linux (Fedora 25) computer but I can't get it to start. Running systemctl status emby-server command I get this: ● emby-server.service - Emby Media Server Loaded: loaded (/usr/lib/systemd/system/emby-server.service; disabled; vendor preset: disabled) Active: failed (Result: exit-code) since Sat 2017-03-11 10:44:59 WET; 20min ago Process: 3806 ExecStopPost=/usr/lib/emby-server/emby-server.sh clear (code=exited, status=0/SUCCESS) Process: 3781 ExecStart=/usr/lib/emby-server/emby-server.sh start (code=exited, status=127) Main PID: 3781 (code=exited, status=127) Mar 11 10:44:59 localhost.localdomain systemd[1]: Started Emby Media Server. Mar 11 10:44:59 localhost.localdomain emby-server.sh[3781]: /usr/lib/emby-server/emby-server.sh: line 118: exec: su: not found Mar 11 10:44:59 localhost.localdomain systemd[1]: emby-server.service: Main process exited, code=exited, status=127/n/a Mar 11 10:44:59 localhost.localdomain systemd[1]: emby-server.service: Unit entered failed state. Mar 11 10:44:59 localhost.localdomain systemd[1]: emby-server.service: Failed with result 'exit-code'. Anybody has any ideas as why I'm getting error?
  5. prcutler

    emby-service won't start (Fedora 25)

    Hi all, I noticed a while back that emby-server isn't starting automatically in systemd for me and I finally had some time to troubleshoot. I'm running Fedora 25 and I've made sure dnf / yum are up to date and made sure I'm using the repos from this post in the Fedora thread: https://emby.media/community/index.php?/topic/13398-fedoracentos-rpm/page-15 emby-server does run if I start manually as sudo, but if I try to enable the service, I get the following error: systemctl status emby-server -l ● emby-server.service - Emby Media Server Loaded: loaded (/usr/lib/systemd/system/emby-server.service; enabled; vendor preset: disabled) Active: failed (Result: exit-code) since Wed 2017-02-01 07:19:08 CST; 27min ago Process: 26742 ExecStopPost=/usr/lib/emby-server/emby-server.sh clear (code=exited, status=0/SUCCESS) Process: 26718 ExecStart=/usr/lib/emby-server/emby-server.sh start (code=exited, status=127) Main PID: 26718 (code=exited, status=127) Feb 01 07:19:08 mythtv systemd[1]: Started Emby Media Server. Feb 01 07:19:08 mythtv emby-server.sh[26718]: /usr/lib/emby-server/emby-server.sh: line 118: exec: su: not found Feb 01 07:19:08 mythtv systemd[1]: emby-server.service: Main process exited, code=exited, status=127/n/a Feb 01 07:19:08 mythtv systemd[1]: emby-server.service: Unit entered failed state. Feb 01 07:19:08 mythtv systemd[1]: emby-server.service: Failed with result 'exit-code'. Doing a Google search on status=127, I found this on Github, but it's a status 126: https://github.com/MediaBrowser/Emby/issues/1419 From that thread, if I run: #!/bin/bash MAGICK_LIBRARY_PATH=$(find /usr/lib/emby-server/ -maxdepth 1 -mindepth 1 -type d| grep -v bin) MONO_EXEC_ENV="$MONO_ENV LD_LIBRARY_PATH=${MAGICK_LIBRARY_PATH}${LD_LIBRARY_PATH:+:}$LD_LIBRARY_PATH" echo "$MONO_EXEC_ENV" I get: [pcutler@[member="mythtv"] ~]$ echo "$MONO_EXEC_ENV" LD_LIBRARY_PATH=/usr/lib/emby-server/etc /usr/lib/emby-server/lib64 So I don't think it's embymagick as I see: Package embymagick-6.9.6+6-7.2.x86_64 is already installed. Since I'm able to run it as sudo normally, I don't see anything in the latest log file. At the top I see: 2017-02-01 07:27:03.3492 Info Main: Emby Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 4.8.16.300 64-Bit OS: True 64-Bit Process: True Mono: 4.6.2 (Stable 4.6.2.16/ac9e222 Tue Jan 3 11:51:14 UTC 2017) Processor count: 4 Program data path: /var/lib/emby-server Application directory: /usr/lib/emby-server/bin 2017-02-01 07:27:03.6990 Info ImageMagick: ImageMagick version: ImageMagick 6.9.6-6 Q8 x86_64 2016-12-12 http://www.imagemagick.org 2017-02-01 07:27:04.6188 Info App: Application version: 3.1.5.0 2017-02-01 07:27:04.7586 Info App: Application configuration: Any hints of what I should be looking for or trying to fix systemd? Is it related to the su not found message? (I'm not sure how to fix that). Thanks in advance. Paul
  6. spacekookie

    Emby in LXC & Chromecast

    This is my current server setup: _________________ | | | Fedora 24 | ____________________ | Nginx proxy | | | | LXC ------------| Debian Jessie | |________________| | Emby Server | |___________________| The outer nginx procy forwards port 80 (so I can just type in "mediapc/" into firefox for the UI, port 443 and the standard emby port for the Android apps to find the server. But I've noticed that it's not possible to Chromecast anything from this server. I suspect that it's because the port the chromecast protocol is using isn't port forwarded. I tried to Wireshark the connection and couldn't figure out what needed to be open. I hope you guys can help me with this Would be nice to use Chromecast again!
×
×
  • Create New...