Jump to content

Several features that are lacking in Emby.


leifrodhared
 Share

Recommended Posts

Do you have the meta-data providers setup for each library?

That should also pull down the images automatically if it can identify your movies and shows.

  • Like 1
Link to comment
Share on other sites

vdatanet
3 minutes ago, leifrodhared said:

How do I get the images to be pulled automatically? Nothing's happening I have to do all manual. In ver 4.5 there was a hidden option to search for an image on the web, in 4.6 there is a handy weblink option but I can't get the system to automatically download images.

Check naming conventions:

https://support.emby.media/support/solutions/articles/44001159102-movie-naming

Link to comment
Share on other sites

RanmaCanada

I love it when trolls come here and ask for things that they know can't/won't be done.

Link to comment
Share on other sites

leifrodhared
4 minutes ago, RanmaCanada said:

I love it when trolls come here and ask for things that they know can't/won't be done.

I'm not a troll, just a very picky user lol

Regarding features, every paid software developer needs to keep working on their product or they die out, users migrate when they get pushed.

That's why "woke" companies go bust, too much talk, too little work ;)

Link to comment
Share on other sites

arrbee99
12 hours ago, leifrodhared said:

 

Now que on backlash from my post ;)

 

Ok, you asked for the backlash, so get ready here it comes, hope you're prepared...

Its cue, not que 😀

Link to comment
Share on other sites

4 hours ago, leifrodhared said:

How do I get the images to be pulled automatically? Nothing's happening I have to do all manual. In ver 4.5 there was a hidden option to search for an image on the web, in 4.6 there is a handy weblink option but I can't get the system to automatically download images.

Hi, we'd have to look at an example in detail in order to determine why it's not happening for you automatically. Thanks.

Link to comment
Share on other sites

Guest
6 hours ago, leifrodhared said:

I'm not a troll, just a very picky user lol

Regarding features, every paid software developer needs to keep working on their product or they die out, users migrate when they get pushed.

That's why "woke" companies go bust, too much talk, too little work ;)

Don't take the bait.. stay on topic.. funny things is the haters all get the benefits.. We don't waste away our lives to improve something to jack things up or start wars.. It is the only way this even gets to us.. Because we try..

Good point about 'woke' companies.. I would say that the Devs here though do try and understand.. even reproduce issues and get to the cause of the issue within the code and additional parts of the server... Sometimes it's too much work and not enough time getting to enjoy or use it yourself to notice things that aren't working correctly.. or are only good for one scenario .. Working on it all day and even getting a few minutes enjoyment.. even when noticing an issue..at that point.. is exasperating to stop that yet again and begin working around the clock to chase it down.. then remember it and prioritize it all within regard to issues and attack it from that angle.. Most of the concentration winds being for videos.. Tons of variables.. misunderstandings and requests..

Feedback is essential... complaining about our work and not working to change it.. and hating all up on us for doing the work .. at all is must at best.. Everyone does have to work it over and still offer open friendly and free support as well as request changes and post issues.. Same thing for your government and your world... We left TROLLS back in '03 or '05.. at the peak..

If you love something...you put in the work.. Strive for existence.. excellence.. have something they quit believing in.. The mac-n-cheese trailer park.. with fall-apart disposable electronics and dumbed-up devices makes you wonder... other than whose buying it..

The again they say ignorance is bliss... I wonder where that truly leaves the rest of them?

Link to comment
Share on other sites

10 hours ago, leifrodhared said:

Regarding features, every paid software developer needs to keep working on their product or they die out, users migrate when they get pushed.

Can you go over the layout and file naming of a movie or two that isn't getting proper info and images?

We need to go over something specific to get started helping you.

Link to comment
Share on other sites

leifrodhared

I'm still experimenting with tagging but I'm doing it manually now.

I've noticed that even when there is an artist name the system does not fetch info when I refresh metadata.

Nothing changes.

I go to edit the metadata and paste in musicbrainz artist ID and ask the system to fetch missing metadata and replace images.

Nothing changes.

I've enabled debug logging but can't see anything like a request to fetch  metadata in the log at all.

Any clues?

Link to comment
Share on other sites

Can you show a screen shot of the tagging being used for an album?

FYI: Don't confuse ALBUM ARTIST with ARTIST tags.  Make sure you have the proper album artist tagged correctly.

Link to comment
Share on other sites

leifrodhared

image.png.ab487cf3ffa571ad92151c60b34b8c73.png

 

image.png.e07b745fd6017ffb2499ed8a873c9734.png

 

 

So what I have done.

Edit manually the metadata and add musicbrainz artist id to both album artist and artist sections.

Saved the entry.

Links to musicbrainz artist pop up on the song info screen.

Refresh metadata, does not matter if I choose keep or delete all same effect.

The effect is what you see, the ID's have been removed and nothing changed. No images downloaded , no extra info fetched.

Something does not work but I can't see anything in logs.

Link to comment
Share on other sites

leifrodhared

On the artist screen I can see backdrops , but the file itself does not inherit any images from the artist.

image.thumb.png.c1681b19a2b7131275b0d3374e803010.png

Link to comment
Share on other sites

No the tagging in the media itself as shown with a program such as mp3tag or Picard.

Link to comment
Share on other sites

leifrodhared
Posted (edited)
11 minutes ago, cayars said:

No the tagging in the media itself as shown with a program such as mp3tag or Picard.

Why does it matter if I force it by manually adding metadata?

The system should do what I tell it to do no?

It doesn't and it's not just this one file.

The item is not "locked" but still reverts to blanks after "metadata update".

But here you are, the metadata on the file is correct according to DeadBeef

image.png.a5a14c9f40bbaa2c2893fb1dfa0134ef.png

 

BTW correct permissions are in place for the root Music folder recursively for the emby user.

by running

setfacl -R -m u:emby:rwx /home/leif/Music 
 

Edited by leifrodhared
Link to comment
Share on other sites

Guest
Posted (edited)

ADJUSTED

image.png.a5a14c9f40bbaa2c2893fb1dfa0134ef.png.9458c0f494a7e7d3a33f8153bf22bb50.png

*Plus embedded art is a recommendation.

Edited by Guest
Link to comment
Share on other sites

1 hour ago, leifrodhared said:

Why does it matter if I force it by manually adding metadata?

The system should do what I tell it to do no?

It doesn't and it's not just this one file.

The item is not "locked" but still reverts to blanks after "metadata update".

But here you are, the metadata on the file is correct according to DeadBeef

image.png.a5a14c9f40bbaa2c2893fb1dfa0134ef.png

 

BTW correct permissions are in place for the root Music folder recursively for the emby user.

by running

setfacl -R -m u:emby:rwx /home/leif/Music 
 

Because if you make manual edits in emby, then do a refresh metadata, you may lose those manual edits.

So don't refresh metadata after doing that.

Link to comment
Share on other sites

leifrodhared

Uh so the logic is wrong, it should be - I provide data , go fetch according to what I've provided not go fetch "whatever".

Otherwise there is no way out of this as I change things and then the system changes it back.

The user action and preference should always trump whatever the system "wants" if it comes to logical metadata structures.

And if what you say is true why do you have 2 options for updating metadata? One to remove one to find missing?

Atm they both do the same thing, wipe my manual edits and then they still don't find the correct data.

They just leave the file as it was originally which I  have shown on screenshots.

Link to comment
Share on other sites

That is the logic.  YOU provide DATA by making sure YOUR files are TAGGED correctly.

Once the media is tagged correctly you could reload Emby a hundred times and it will always pull the same correct data in.

  • Like 1
Link to comment
Share on other sites

leifrodhared
2 minutes ago, cayars said:

That is the logic.  YOU provide DATA by making sure YOUR files are TAGGED correctly.

Once the media is tagged correctly you could reload Emby a hundred times and it will always pull the same correct data in.

Well you have seen the file I have tried giving it the correct data and it did not fetch anything so why???

Link to comment
Share on other sites

But it didn't. It didn't even have the album artist.

Compare what you posted to that of  @Hxemby001.

Link to comment
Share on other sites

Posted (edited)

Have you played the song? Does it show when you play the song?

I know with my usage the images are filled in on-the-fly as soon as I request them. I can see the little delay as it goes to fetch, once it has cached it sends to my device and it displays the images. Next time on that artist everything is fast as it is already downloaded and pre-cached in the size the app needs. Even with music poorly tagged I still get logos correct and album art. It just may lack the backdrop. Some artists lack logo. Not every artist will have every image unless you fill them in manually.

My belief here is if Emby was to grab all the images every scan for all your media at once and it did this for everyone it would be wasteful. There are some songs you will never play for years that never needed to consume that data yet. So this conserves the data from that provider and allows a sort of fair-access-policy so that everyone gets the images they need without running over any quota.

Edited by speechles
Link to comment
Share on other sites

leifrodhared
7 minutes ago, speechles said:

Have you played the song? Does it show when you play the song?

I know with my usage the images are filled in on-the-fly as soon as I request them. I can see the little delay before it goes to fetch then I can tell I know how it cached. Next time on that artist everything is fast. Even with music poorly tagged I still get logos correct and album art. It just may lack the backdrop. Some artists lack logo. Not every artist will have every image unless you fill them in manually.

My belief here is if Emby was to grab all the images every scan for all your media and it did this for everyone it would be wasteful. There are some songs you will never play for years that never needed to consume that data yet. So this conserves the data from that provider and allows a sort of fair-access-policy so that everyone gets the images they need without running over any quota.

You miss the point, I forced refreshed in various ways and even tried just saving with the musicbrainz ID in the artist and album artist.

Nothing changes, the file stays the same and no images appear after refresh/server reboot.

If I run a update metadata action it wipes everything apart from the artist and album artist fields.

So something is erroring but it does not show in the log.

 

Link to comment
Share on other sites

24 minutes ago, leifrodhared said:

image.thumb.png.087915bba713447d8c21ad7988ce23a4.png

 

I did

You are looking at values you edited in Emby vs. tags existing in the media itself.  Local metadata (being either tags within the media or an accompanying metadata - nfo - file) will always take precedence over values  you enter in the UI - unless you lock those values.  This is because the media tagging/local file should be the most accurate (from the standpoint of what the user wants) source.

Music is even more stringent to the above because music is very commonly tagged with all the proper metadata.

Also, you are saying "didn't fetch".  Exactly what were you expecting to be fetched and from where?  Did you enable metadata fetchers for your music library?  Even still, this will depend heavily on the tags in the music because that is the only accurate way to identify most music.

  • Like 1
Link to comment
Share on other sites

1 minute ago, leifrodhared said:

If I run a update metadata action it wipes everything apart from the artist and album artist fields.

So something is erroring but it does not show in the log.

Hi.  I don't think anything is "erroring".  It looks like your music doesn't have proper tags and, when you refresh, you are telling Emby to read those tags (which don't exist so nothing is read).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...