Jump to content

Plugin - Iconic Image Enhancer


roaku

Recommended Posts

arrbee99

Hokey dokey. Just bear in mind that if there's a wrong way to do something, I'll find it, and whats obvious to you is unlikely to be obvious to me, and etc etc...

  • Haha 1
Link to comment
Share on other sites

roaku
19 hours ago, arrbee99 said:

On the latest server beta the My Icon list is empty. Should it have icons in it or do I need to do more than change a few colours to get them to show up.

 

19 hours ago, cochize1 said:

it's a matter of colors. The icons are there just seem all white on the white background. When I used dark mode in my browser they showed up.

 

The Icon selector colors should be fixed with the latest beta build. Thanks for identifying this issue.
 

 

Link to comment
Share on other sites

arrbee99

Thanks for the update. The Resolution / 4K thing seems to work and the icon selector colours seem fine. The missing some audio items still seems the same, finds all TrueHD, misses some AC3 and DTS (so far).

Link to comment
Share on other sites

arrbee99

At the bottom, where you have the Icon Rules, with the Edit and the Dustbin, do you think it would be worth adding a slider, similar to at the top, to activate / de-activate individual Rules ?

or am I doing tings wrong...

Link to comment
Share on other sites

roaku
9 minutes ago, arrbee99 said:

At the bottom, where you have the Icon Rules, with the Edit and the Dustbin, do you think it would be worth adding a slider, similar to at the top, to activate / de-activate individual Rules ?

or am I doing tings wrong...

That's a good idea, but for now, I'd say just delete any rules you don't want. They're pretty easy to recreate if you decide you want them back in the future.

Once I get some of these other issues out of the way, that would be a good one to add.

  • Like 1
Link to comment
Share on other sites

roaku
1 hour ago, arrbee99 said:

Thanks for the update. The Resolution / 4K thing seems to work and the icon selector colours seem fine. The missing some audio items still seems the same, finds all TrueHD, misses some AC3 and DTS (so far).

Thanks for the update.

I've narrowed down the missing items to a stage before Iconic does the rule analysis, but I haven't figured out why it's behaving that way for some of you yet. It's tough because I can't recreate it on any of my systems yet.

Right now, I'm trying to fix the missing font icons on Windows. I've figured out that for some reason, the font file isn't getting loaded properly on Windows using the standard approach that's working on other platforms. It was working at one point on Windows, but I had to change the font file recently, and it looks like that's when it broke.

Link to comment
Share on other sites

arrbee99
3 minutes ago, roaku said:

Thanks for the update.

I've narrowed down the missing items to a stage before Iconic does the rule analysis, but I haven't figured out why it's behaving that way for some of you yet. It's tough because I can't recreate it on any of my systems yet.

Right now, I'm trying to fix the missing font icons on Windows. I've figured out that for some reason, the font file isn't getting loaded properly on Windows using the standard approach that's working on other platforms. It was working at one point on Windows, but I had to change the font file recently, and it looks like that's when it broke.

Fun fun fun.

Maybe Luke or someone knows if there's something in library.db thats confusing the issue. Who knows (I certainly don't).

Link to comment
Share on other sites

roaku

The Windows font rendering issue is fixed (hopefully for everyone) in the latest build.

The issue was that in the image processing, Windows was failing silently to load the woff font file Emby provides, so I've added a OTF font as a fallback option, which Windows seems to like better.

@arrbee99

 

 

Edited by roaku
Link to comment
Share on other sites

roaku
9 minutes ago, arrbee99 said:

That would be these new versions I presume -

1020622239_EmbyIconictesting6.JPG.392024ffd1f91f51b0956093df810da6.JPG

Excellent. Yes.

It's still on my list to shrink those badges down for landscaped views. 👍

  • Like 1
Link to comment
Share on other sites

roaku

@cochize1 and @arrbee99

I've attached a new beta version to the build post linked below that will hopefully solve the missing badges for both of you.

I found and removed some legacy code from the early days of the plugin that could cause Iconic to skip a Movie before analyzing the rules.

It's possible there are other reasons for some of your Movies getting skipped, but this was a likely culprit.

Thanks again for all your help in testing this.

 

 

  • Like 1
Link to comment
Share on other sites

roaku
1 minute ago, cochize1 said:

It's working like a charm. As for my needs it's a finished plugin, I'll give it 10/10.

Great work @roaku

That's awesome.

Thanks again.

 

  • Like 1
Link to comment
Share on other sites

cochize1

One small issue about opacity. I have my css set for the Watched/Count Indicator to 

background-color: rgba(82, 181, 75, 0.5)

So that make the green color 50% transparent while the count/tick stays in full opacity.

Would that be possible to set just the background color opacity and leave the icon and border in full color so that would match ones (mine :) ) css code?

An Example:

image.png.68fe1b219d06f909522f0a694e3ccc4e.png

Edited by cochize1
Link to comment
Share on other sites

roaku
17 minutes ago, cochize1 said:

One small issue about opacity. I have my css set for the Watched/Count Indicator to 


background-color: rgba(82, 181, 75, 0.5)

So that make the green color 50% transparent while the count/tick stays in full opacity.

Would that be possible to set just the background color opacity and leave the icon and border in full color so that would match ones (mine :) ) css code?

An Example:

image.png.68fe1b219d06f909522f0a694e3ccc4e.png

The background, border, and icon are all written by the image processor in separate passes, so that might be possible.

I'm also interested in adding a mode where you can have the icon only with no badge.

I'll work on both of those soon.

Right now, I'm fixing the badge sizes so they'll be consistent across all image types.

 

  • Like 1
Link to comment
Share on other sites

roaku
17 hours ago, arrbee99 said:

That would be these new versions I presume -

1020622239_EmbyIconictesting6.JPG.392024ffd1f91f51b0956093df810da6.JPG

 

Those badges should be less Kong and planetoid like for Thumb images with the latest beta 0.9.1.4.

 

 

Link to comment
Share on other sites

arrbee99

Thanks for the updates.

Far as I can tell, the icons are a much better size and it finds much more stuff than it used to, but I think it still misses out on some of the AC3 stuff (though a lot fewer are missing).

e.g. with Embys ac3 filter applied

621439812_EmbyIconictesting7.thumb.JPG.d29abadc8a759761c402008a7428fcdf.JPG

which has

662441905_EmbyIconictesting8.JPG.f2f430d0a505df87743616c026590665.JPG

using

961476073_EmbyIconictesting9.JPG.0871f4d9ecf735eabad5ef42754bf520.JPG

Also, I presume for two rules it will show items that has one or the other, as well as items that have both (it does seem to do that, just thought I'd check).

Also, its only showing one icon for those rules, is that because of the 'For this BETA, the Icon of the first matched Rule will be used for all badges. ' you mentioned in the plugin ?

Link to comment
Share on other sites

roaku
12 minutes ago, arrbee99 said:

Thanks for the updates.

Far as I can tell, the icons are a much better size and it finds much more stuff than it used to, but I think it still misses out on some of the AC3 stuff (though a lot fewer are missing).

e.g. with Embys ac3 filter applied

Ah, that's too bad. I'll have to look into that some more. Glad it's improved at least.

 

Quote

Also, I presume for two rules it will show items that has one or the other, as well as items that have both (it does seem to do that, just thought I'd check).

Also, its only showing one icon for those rules, is that because of the 'For this BETA, the Icon of the first matched Rule will be used for all badges. ' you mentioned in the plugin ?

This is a little hard to describe, but there are two things at play here.

The first is that if you make two different rules, each with the same icon, you will only ever see one of that icon on an image, whether both rules match or just one. This is intentional, because it saves space and there'd be no way to know which of the two rules matched anyway from looking at the rendered item image.

Now, all that goes out the window for the beta, because no matter what icons are configured for the rules, the beta will keep showing the icon of the first matched rule for that item.

Hope that at least made some sense.

Link to comment
Share on other sites

roaku
On 1/30/2021 at 2:36 PM, arrbee99 said:

Would it be possible to use it to mark an item only when it shows up in say Continue Watching ?

I think I managed to pull this off with the latest beta 0.9.2.0:

 

Edit: Nevermind, this has an issue with with user profiles. It looks like in the plugin context, the item *always* has an in progress playback state included when *any* user has watched part of a movie...so if one person's watched part of a movie, the item is saying *everyone* has watched to that part.

This means all users would see the continue watching icon when only one user should be seeing it.

And I'm not sure there's a way to associate an incoming image request to a current user, so this one might not work out, but I'll give it another try at some point.

 

Edited by roaku
Link to comment
Share on other sites

arrbee99
2 hours ago, roaku said:

I think I managed to pull this off with the latest beta 0.9.2.0:

 

Edit: Nevermind, this has an issue with with user profiles. It looks like in the plugin context, the item *always* has an in progress playback state included when *any* user has watched part of a movie...so if one person's watched part of a movie, the item is saying *everyone* has watched to that part.

This means all users would see the continue watching icon when only one user should be seeing it.

And I'm not sure there's a way to associate an incoming image request to a current user, so this one might not work out, but I'll give it another try at some point.

 

Ah well it was just a thought, and if it ever works out then great, but its certainly not a biggie.

Link to comment
Share on other sites

arrbee99
2 hours ago, roaku said:

Ah, that's too bad. I'll have to look into that some more. Glad it's improved at least.

 

This is a little hard to describe, but there are two things at play here.

The first is that if you make two different rules, each with the same icon, you will only ever see one of that icon on an image, whether both rules match or just one. This is intentional, because it saves space and there'd be no way to know which of the two rules matched anyway from looking at the rendered item image.

Now, all that goes out the window for the beta, because no matter what icons are configured for the rules, the beta will keep showing the icon of the first matched rule for that item.

Hope that at least made some sense.

Can I make two different rules with different icons at the moment then ?  ...or not yet ? It would be good if the rules at the bottom could show the icon that is associated with the relevant rule.

Link to comment
Share on other sites

roaku
15 minutes ago, arrbee99 said:

Can I make two different rules with different icons at the moment then ?  ...or not yet ? It would be good if the rules at the bottom could show the icon that is associated with the relevant rule.

Yes. The configuration ui is fully functional.

To change the icon of a rule, click the icon at the left of that rule row. An icon selector should pop up that allows you to search for one you like, then click on it to set it as the icon for that rule.

 

Check out 'Selecting a rule icon' here:

 

Edited by roaku
Link to comment
Share on other sites

arrbee99

Duh. Thanks. I don't think I even noticed that thing existed. Now for a few movies I get two icons (both the same of course). Yay. 😀

I must admit it makes me wonder about the necessity of the icon box thingy on the top right though...

Edit - and now I'm actually expected to read the instructions as well....sheesh, will it never end...

Edited by arrbee99
Link to comment
Share on other sites

roaku
2 minutes ago, arrbee99 said:

Duh. Thanks. I don't think I even noticed that thing existed. Now for a few movies I get two icons (both the same of course). Yay. 😀

I must admit it makes me wonder about the necessity of the icon box thingy on the top right though...

That one's there so you can load different icons into the big badge preview and get familiar with the available icons.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...