Jump to content


Photo

Titan skin

xbmc netflix xbmb3c gotham artwork kodi mediabrowser helix emby

  • This topic is locked This topic is locked
2284 replies to this topic

#41 marcelveldt OFFLINE  

marcelveldt

    Advanced Member

  • Developers
  • 1836 posts
  • Local time: 12:47 AM
  • LocationRosmalen, The Netherlands

Posted 03 August 2014 - 01:33 PM

I'll update the file later on, after that you can use the beta downloadlink again.

It will be available within an hour, I will let you know when. I try to fix the CovertArt support in the meanwhile.


  • xnappo likes this

#42 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 02:23 PM

I'll update the file later on, after that you can use the beta downloadlink again.

It will be available within an hour, I will let you know when. I try to fix the CovertArt support in the meanwhile.

 

Excellent. Just let me know when it's updated and I will download and play with it some more since I am home earlier than I thought I would be.

 

Here is my log from opening XBMC and then going into the Live TV tile.

 

http://pastebin.com/QNxcR8UD

 

Thanks!

 

-Jason


  • xnappo likes this

#43 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156815 posts
  • Local time: 06:47 PM

Posted 03 August 2014 - 02:26 PM

Don't forget the blog post:)

#44 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 02:45 PM

I have an update for you on the Live TV issue.

 

I was just playing around with it a bit and found the option under skin settings to turn off "Open Guide with the Button" under the Live TV gadget settings. 

 

When I turned that off, I can enter the Live TV tile and it opens to the Channels list screen. I can play live tv if I only use that screen.

 

If I use the arrow key and go to the left to open the side menu and then arrow down to the EPG Guide option it instantly freezes. It appears to be a problem with the EPG screen only, which is the screen I prefer to use anyway. 

 

Hopefully that narrows it down some at least!

 

-Jason


  • xnappo likes this

#45 marcelveldt OFFLINE  

marcelveldt

    Advanced Member

  • Developers
  • 1836 posts
  • Local time: 12:47 AM
  • LocationRosmalen, The Netherlands

Posted 03 August 2014 - 03:06 PM

Don't forget the blog post:)

:D  no, I won't. Finishing up some small issues and then it will be submitted in the repo. Together with a nice blog post off course ;-)


  • xnappo likes this

#46 marcelveldt OFFLINE  

marcelveldt

    Advanced Member

  • Developers
  • 1836 posts
  • Local time: 12:47 AM
  • LocationRosmalen, The Netherlands

Posted 03 August 2014 - 03:07 PM

If I use the arrow key and go to the left to open the side menu and then arrow down to the EPG Guide option it instantly freezes. It appears to be a problem with the EPG screen only, which is the screen I prefer to use anyway. 

 What default guide mode do you have selected in settings--> live TV ?

Also, what DVR plugin are you using ?


  • xnappo likes this

#47 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 03:15 PM

 What default guide mode do you have selected in settings--> live TV ?

Also, what DVR plugin are you using ?

 

I am not sure where you're pointing me to. If you mean the Live TV setting in XBMC under the EPG settings, it is set to Timeline. 

 

Here is a screenshot of that window so I can tell if that is where you meant to point me:

 

53de8a55d22cd_Capture.png

 

I am using NextPVR as my DVR and XBMC Gotham (I noticed you asked me that earlier and I never answered).

 

-Jason


Edited by jasonmcroy, 03 August 2014 - 03:16 PM.


#48 marcelveldt OFFLINE  

marcelveldt

    Advanced Member

  • Developers
  • 1836 posts
  • Local time: 12:47 AM
  • LocationRosmalen, The Netherlands

Posted 03 August 2014 - 03:45 PM

That's the setting I meant....

In the meanwhile i managed to reproduce the issue myself on my windows machine (the Linux machine doesn't have the problem)

Opening the "timeline view" will crash XBMC. I will investigate it.

 

In the meanwhile... could you test the new beta version ?

No fix for TV yet (am working on it now) but the first basics of other views....

 

http://marcel-rosmal...n.titan.1.8.zip


  • jasonmcroy likes this

#49 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 03:58 PM

Ok. If it matters for information, I am running Windows 8.1 as well.

 

 

The link you provided in your last post takes me to "unable to find page" screen.

 

The beta download link on the first page post works though, is that the same version in the above link?

 

-Jason



#50 marcelveldt OFFLINE  

marcelveldt

    Advanced Member

  • Developers
  • 1836 posts
  • Local time: 12:47 AM
  • LocationRosmalen, The Netherlands

Posted 03 August 2014 - 04:08 PM

Ok. If it matters for information, I am running Windows 8.1 as well.

 

 

The link you provided in your last post takes me to "unable to find page" screen.

 

The beta download link on the first page post works though, is that the same version in the above link?

 

-Jason

 

Yes link on first page (the beta one) is the correct one... Must be some typo in previous post.

 

Problem indead exists on win8.1 and not on other platforms.

 

Also I just figured out that enabling CoverArt on the server broke my "all movies" section again so that's something that needs to be addressed in the XBMBC3 plugin. Luckily I build support in the skin for the movie collections form MB so it isn't a real deal breaker.

 

@xnappo: Do you have any clue what that the problem can be ? Accessing xbmb3c.usr.movies.X.path is fine but xbmb3c.std.movies.0.path is dead for some reason. Error in xbmc log:

21:58:43 T:139763503838976   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'list' object has no attribute 'get'
                                            Traceback (most recent call last):
                                              File "/home/mediacenter/.xbmc/addons/plugin.video.xbmb3c/default.py", line 2325, in <module>
                                                getContent(param_url)
                                              File "/home/mediacenter/.xbmc/addons/plugin.video.xbmb3c/default.py", line 1112, in getContent
                                                validator = "_" + getAllMoviesCacheValidator(server,url)
                                              File "/home/mediacenter/.xbmc/addons/plugin.video.xbmb3c/default.py", line 1033, in getAllMoviesCacheValidator
                                                printDebug ("RecursiveItemCount: " + str(result.get("RecursiveItemCount")))
                                            AttributeError: 'list' object has no attribute 'get'
                                            -->End of Python script error report<--
21:58:43 T:139763451393792   ERROR: CCurlFile::FillBuffer - Failed: HTTP response code said error(22)
21:58:43 T:139763451393792   ERROR: CCurlFile::CReadState::Connect, didn't get any data from stream.

 



#51 xnappo OFFLINE  

xnappo

    Advanced Member

  • Developers
  • 4755 posts
  • Local time: 05:47 PM
  • LocationAustin, TX

Posted 03 August 2014 - 04:13 PM

I don't see how the CoverArt option could cause that error. Possibly try deleting the caches in the addon data directory.

xnappo

#52 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 04:15 PM

Ok. I downloaded the Beta version and installed it. I do indeed like the new view options! Great job.

 

However, the Banners view for TV Shows looks a bit squished from side to side rather than being longer as they look in other skins. Other than that it looks awesome!

 

I think I have a new skin!

 

-Jason



#53 marcelveldt OFFLINE  

marcelveldt

    Advanced Member

  • Developers
  • 1836 posts
  • Local time: 12:47 AM
  • LocationRosmalen, The Netherlands

Posted 03 August 2014 - 04:57 PM

Great to hear you like the extra banner views. I'm currently addressing the latest things with the images so that will all be fixed.

Also I've just fixed the issue with the EPG grid.

 

Could you please download the beta again and check if it's fixed now ?



#54 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 05:35 PM

Hi. I downloaded the Beta again and the EPG screen is still freezing XBMC for me. 

 

-Jason



#55 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 05:55 PM

Stepping out for the evening with the wife in case you need further testing I will be back in later on.

 

 

-Jason



#56 marcelveldt OFFLINE  

marcelveldt

    Advanced Member

  • Developers
  • 1836 posts
  • Local time: 12:47 AM
  • LocationRosmalen, The Netherlands

Posted 03 August 2014 - 05:57 PM

Hi. I downloaded the Beta again and the EPG screen is still freezing XBMC for me. 

 

-Jason

Sorry, my fault... I forgot to put the download in place :-) It's there now.



#57 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 06:01 PM

Ok. Will check it out later on.

By the way, Coverart is working correctly now as well.

-Jason

#58 jasonmcroy OFFLINE  

jasonmcroy

    Advanced Member

  • Super Testers
  • 1695 posts
  • Local time: 06:47 PM
  • LocationTampa, FL

Posted 03 August 2014 - 09:44 PM

Ok, I just installed the updated zip and EPG works just fine now!

Great job on this one so far!

-Jason

#59 marcelveldt OFFLINE  

marcelveldt

    Advanced Member

  • Developers
  • 1836 posts
  • Local time: 12:47 AM
  • LocationRosmalen, The Netherlands

Posted 06 August 2014 - 05:21 PM

Ok, I just installed the updated zip and EPG works just fine now!

Great job on this one so far!

-Jason

 

 

Jason, i've made things final now. See the updated downloadlink in the first post.

Everything is stable now (as far as I could test) and the extra views are also included.

Please let me know how you think about it and if you have any problems or suggestions to add.


Edited by marcelveldt, 06 August 2014 - 11:22 AM.


#60 SikSlayer OFFLINE  

SikSlayer

    Advanced Member

  • Alpha Testers
  • 723 posts
  • Local time: 06:47 PM
  • LocationEast Stroudsburg, PA

Posted 06 August 2014 - 07:34 PM

I dunno how I missed this for a week, but thank you for continuing development on the skin, and adding XBMB3C support on top!  :P  







Also tagged with one or more of these keywords: xbmc, netflix, xbmb3c, gotham, artwork, kodi, mediabrowser, helix, emby

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users