Jump to content

embyforkodi (next-gen) 6.X.X support


quickmic

Recommended Posts

Hi Quickmic, Thanks for the continuous development of the adddon, appearing to be stable so far, I am wondering if its possible to add Emby host name, instead of using IP address.

Thanks

Link to comment
Share on other sites

I'll give my contribution, sorry for the English.
I was testing the Emby Next v 5.1.17 plugin and I noticed a peculiarity. If you have a series divided into different HDDs, each Season in one HD the old plugin can see and joins normally in version 4.x.
Example - American Gods divided into 2 HDDs, Season 1 in HDD1 and Season 2 in HDD2, he cannot understand that it is the same. Emby is normal, in version 4.x also normal, in the NEXT version he cannot show the complete Season, just one of them. I have several series as soon as I put them on the NAS volumes and they work normally, it's not just a fluke. I can provide logs if needed, I hope it helps.

Link to comment
Share on other sites

@wanderjarra

Actually, the plugin shouldn't join or merge anything (with some exceptions like multipart videos etc.).

Emby server has full control over library management and the plugin just pulls the data. If the data is correct on the server, it should be correct for the plugin as well.

Anyway, I need more information to design a test case.

 

1. Are you using native or addon mode in Emby for Kodi

2. Is the split season (2 HDDs) loaded into one library on the server, or two different libraries?

 

If you load the split season into two different libraries on Emby server, have you synced both in Emby for Kodi?

 

Link to comment
Share on other sites

@quickmic tanks a lot for your efforts for developping this plugin.

Do you planed to add the ability to delete tvshow and movies at the  end of play-back like old plugin ? 

 

Edited by Beber2410
  • Thanks 1
Link to comment
Share on other sites

I understand that it was difficult to explain, I will document correctly to be able to help.

 

Within my single NAS I have different Raid, so in group 1 are the first 3 seasons and in group 2 is the 4 season. The emby sees this normally and assembles as if they were together.
I'm using Kodi + Emby addon in native mode all by default.
When I use addon 4.1.22 it does it correctly and shows all seasons, already in the version Emby NEXT GEN 5.1.17 it does not do it correctly, it shows me only part of the Series (Season 4) and ignores the other seasons.
I deleted the database and redid 3x, each time the result is the same with version 5.1.17 errors of grouping the information, in 4.1.22 it works.

 

 

ex4.JPG

ex3.JPG

ex2.JPG

ex1.JPG

Link to comment
Share on other sites

14 minutes ago, Beber2410 said:

@quickmic tanks a lot for your efforts for developping this plusieurs.

Do you planed to add the ability to delete tvshow and movies at the  end of play-back like old plugin ? 

 

 

I was not thinking about that feature. I can add it in one of the next releases. For the moment you can only delete items via context menu.

  • Thanks 1
Link to comment
Share on other sites

5 minutes ago, wanderjarra said:

If you need to generate some kind of log, let me know what I can do.

Thanks, for the offer. I come back to you, when I need logs.

Link to comment
Share on other sites

3 hours ago, quickmic said:

 

I was not thinking about that feature. I can add it in one of the next releases. For the moment you can only delete items via context menu.

Thank you very much this feature is very useful for me (and for others I think)

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

@quickmic

Thx for the addon. 

Tested the v17 beta on two ATVs with the v19 stable. Initial sync was ok, now testing further. 

Any hints when this will be available in the stable repo? 

Thx

Link to comment
Share on other sites

stable repo -> If there are no critical issues reported, next weekend.

Edited by quickmic
  • Thanks 1
Link to comment
Share on other sites

Hi. 

I am using 5.1.17 with CoreELEC 9.2.5 (Kodi 18.9). I am running an Emby beta 4.6.0.26 for a couple of days, but I think it was happening too with stable Emby 4.5.4.0. 

The thing is that it is continuously synchronizing all the libraries entirely, instead of only the changes. It takes many minutes. And, a couple of times, after watching something and coming back to the main menu, it is synchronizing again! 

Today I did a reset of Kodi local library, but, after turning it off and on, again it began to synchronize everything again... 

 

Link to comment
Share on other sites

2 hours ago, dml33 said:

Hi. 

I am using 5.1.17 with CoreELEC 9.2.5 (Kodi 18.9). I am running an Emby beta 4.6.0.26 for a couple of days, but I think it was happening too with stable Emby 4.5.4.0. 

The thing is that it is continuously synchronizing all the libraries entirely, instead of only the changes. It takes many minutes. And, a couple of times, after watching something and coming back to the main menu, it is synchronizing again! 

Today I did a reset of Kodi local library, but, after turning it off and on, again it began to synchronize everything again... 

 

 

Thanks for the log. Kodi is syncing Songs and that seems to be fine.

Emby beta 4.6.0.26 had main changes in the Music lib which requires a full sync: ->

 

I assume Emby server is exactly doing the Music sync at the moment and constantly sends the updates to Kodi.

Can you check if Emby server is running syncs at the moment?

Edited by quickmic
Link to comment
Share on other sites

13 minutes ago, quickmic said:

 

Thanks for the log. Kodi is syncing Songs and that seems to be fine.

Emby beta 4.6.0.26 had main changes in the Music lib which requires a full sync: ->

 

I assume Emby server is exactly doing the Music sync at the moment and constantly sends the updates to Kodi.

Can you check if Emby server is running syncs at the moment?

Thank you for such a quick answer :)

Now that you say it, yes, this Emby beta has been quite, quite busy with my music. In fact, some covers are still missing... It could be the reason, yes. Now, when I turned the device on to send you the log, the synchronization was much, much less than last days.

I'll keep you posted if I see something strange again.

Thanks!

Link to comment
Share on other sites

Hi

My shield automatically updated to kodi matrix today and now i cant get embyforkodi to work no longer, tried uninstalling it and when i went to reinstall it its giving errors and won't install.

lots of addons not available

 

anyone else run into this?

Link to comment
Share on other sites

You must install "Emby-next-gen" from the beta repository. NOT "Emby" from stable or beta repository.

And yes, Kodi 19 breaks all plugin from Kodi 18 if they are not migrated to python 3.

All addons which are not active supported/maintained or abandoned will probably never work again in Kodi 19+

 

 

Link to comment
Share on other sites

ok, then I'm not sure what's the actual problem. It was tested on Nvidia Shield 2019 Pro with Kodi 19 RC1 by @marcmv1

A complete new installation of Kodi might help. As you have lot's of incompatible add-ons, it's probably the best approach.

 

 

  • Like 1
Link to comment
Share on other sites

18 minutes ago, quickmic said:

ok, then I'm not sure what's the actual problem. It was tested on Nvidia Shield 2019 Pro with Kodi 19 RC1 by @marcmv1

A complete new installation of Kodi might help. As you have lot's of incompatible add-ons, it's probably the best approach.

 

 

ok thanks

edit- Reinstalling kodi worked :)

Edited by Grumpy1
more info
  • Like 1
Link to comment
Share on other sites

23 hours ago, quickmic said:

stable repo -> If there are no critical issues reported, next weekend.

Sadly faced an issue on my ATV. 

Just got a message 'item could not be played'. On every emby synced item. 

Sadly no debug log because WAF was very low. After kodi restart it worked again. 

Is there a reconnect approach implemented? 

Thx

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...