Jump to content

embyforkodi (next-gen) 6.X.X support


quickmic

Recommended Posts

quickmic
Posted (edited)
5 minutes ago, 7reddevil11 said:

addon  mode

no   transcoding      

and the kodi 19.4    coreelec 19.4 with same problem   

Ok, I'll check ass subtitles. Frankly, never used them. Obviously they are not embedded in the http stream, maybe I can use the same approach as for srt subtitles.

Edited by quickmic
Link to comment
Share on other sites

7reddevil11
3 minutes ago, quickmic said:

Ok, I'll check ass subtitles. Frankly, never used them. Obviously they are not embedded in the http stream, maybe I can use the same approach as for srt subtitles.

thank u so much!

Link to comment
Share on other sites

quickmic
Posted (edited)
1 hour ago, 7reddevil11 said:

thank u so much!

I added ass-subtitle support in the latest 7.x version.

I'll NOT backport this function due to a mandatory full Kodi database reset.

If you have Kodi 19 installed you can give it a shot. 7.x is still NOT fully tested! Test it first on a NON productive system (PC, Mac whatever).

Further support in the 7.x thread:

 

Edited by quickmic
Link to comment
Share on other sites

7reddevil11
1 hour ago, quickmic said:

I added ass-subtitle support in the latest 7.x version.

I'll NOT backport this function due to a mandatory full Kodi database reset.

If you have Kodi 19 installed you can give it a shot. 7.x is still NOT fully tested! Test it first on a NON productive system (PC, Mac whatever).

Further support in the 7.x thread:

 

thank u again quickmic!  problem solved   you made my day    hoping you have a good day:)

  • Like 1
Link to comment
Share on other sites

tr0nllam

I'm not seeing Specials appear within their display season, despite having it selected in Emby. They also properly appear within the season in the Emby web app.

I'm using Kodi 18.9 and Emby-next-gen 6.2.15.

Link to comment
Share on other sites

quickmic
5 hours ago, tr0nllam said:

I'm not seeing Specials appear within their display season, despite having it selected in Emby. They also properly appear within the season in the Emby web app.

I'm using Kodi 18.9 and Emby-next-gen 6.2.15.

There is another option in Kodi for that (not the plugin). Not sure where exactly, I think it was under Kodi's library or player settings.

Link to comment
Share on other sites

tr0nllam
3 minutes ago, quickmic said:

There is another option in Kodi for that (not the plugin). Not sure where exactly, I think it was under Kodi's library or player settings.

The only reference I see to Specials is under Media/Videos and it's just a reference to whether or not you want Kodi to select unwatched Specials, but that has nothing to do with displaying them within seasons.

Link to comment
Share on other sites

DiscoDuck79
22 minutes ago, tr0nllam said:

The only reference I see to Specials is under Media/Videos and it's just a reference to whether or not you want Kodi to select unwatched Specials, but that has nothing to do with displaying them within seasons.

If you select them in the "include all seasons and specials" they should be visible. I agree with you that it's looks like a sub-category for mark unwatched episode but that should be the setting (verified it on my own installation).

Link to comment
Share on other sites

tr0nllam
Posted (edited)
9 minutes ago, DiscoDuck79 said:

If you select them in the "include all seasons and specials" they should be visible. I agree with you that it's looks like a sub-category for mark unwatched episode but that should be the setting (verified it on my own installation).

I tried turning it on and they still don't show up. I even reset the database with the setting enabled, just to make sure, and nothing has changed.

If you aren't on 6.2.5, it may be different because I tested on the 7.x.x version in Kodi 19 and they do show up properly, but I have other issues with Kodi 19, so I can't use it right now.

Edited by tr0nllam
Link to comment
Share on other sites

quickmic
6 hours ago, tr0nllam said:

I tried turning it on and they still don't show up. I even reset the database with the setting enabled, just to make sure, and nothing has changed.

If you aren't on 6.2.5, it may be different because I tested on the 7.x.x version in Kodi 19 and they do show up properly, but I have other issues with Kodi 19, so I can't use it right now.

Well the specials should work with both versions. I'll check, but quite sure there is still something wrong in the Kodi settings.

Link to comment
Share on other sites

t123thomas

Hi Quickmic, I am seeing series of errors in the log report, so I thought I should seek  your thoughts  if they are due to E4K.

Attached is the log

Kodi Log

Link to comment
Share on other sites

quickmic
Posted (edited)
38 minutes ago, t123thomas said:

Hi Quickmic, I am seeing series of errors in the log report, so I thought I should seek  your thoughts  if they are due to E4K.

Attached is the log

Kodi Log

I don't see any E4K related issue. You have a lot of error msg from "multiprocessing" in your log, but they come from 3rd party plugin.

Could be issues from skin helper or metadata utils plugin.

 

Edited by quickmic
Link to comment
Share on other sites

t123thomas
1 hour ago, quickmic said:

I don't see any E4K related issue. You have a lot of error msg from "multiprocessing" in your log, but they come from 3rd party plugin.

Could be issues from skin helper or metadata utils plugin.

 

Thanks 

Link to comment
Share on other sites

Junias
On 1/11/2022 at 8:11 AM, Junias said:

Latest beta: No improvement, Kodi is still crashing after watching episodes.

I will try your test version too...

Info: Because Kodi was still crashing after watching episodes, even with the newest versions, I decided to use "Direct Pathes" in Emby. Now everything is allright.

  • Like 1
Link to comment
Share on other sites

markdj
On 4/2/2022 at 12:39 PM, quickmic said:

I'll perform a test in native mode. Maybe this causes the issue.

Hi! Have you ever tested this? It’s still an issue with movies (tested on 2 Shields in native mode). Stopping movies halfway or around three quarters marks the movie as watched.
Series seems to work fine I think.

Link to comment
Share on other sites

quickmic
Posted (edited)
4 hours ago, markdj said:

Hi! Have you ever tested this? It’s still an issue with movies (tested on 2 Shields in native mode). Stopping movies halfway or around three quarters marks the movie as watched.
Series seems to work fine I think.

Yes, but no issue found. What happens if you watch a movie on Embyserver via WebUI? Maybe the playback setting for this library is set to an odd value?

Actually it makes no sense to me, as the episodes are ok but movies are wrong. Both use exactly the same "mark as watched" code and both should be affected or correct.

There must a link I don't see yet. I'll check it again.

Edited by quickmic
Link to comment
Share on other sites

quickmic
4 hours ago, markdj said:

Hi! Have you ever tested this? It’s still an issue with movies (tested on 2 Shields in native mode). Stopping movies halfway or around three quarters marks the movie as watched.
Series seems to work fine I think.

I'll backport the progress update functions from 7.x.

There are many improvements and I think this could solve the issue.

  • Thanks 1
Link to comment
Share on other sites

quickmic
Posted (edited)
3 hours ago, quickmic said:

Yes, but no issue found. What happens if you watch a movie on Embyserver via WebUI? Maybe the playback setting for this library is set to an odd value?

Actually it makes no sense to me, as the episodes are ok but movies are wrong. Both use exactly the same "mark as watched" code and both should be affected or correct.

There must a link I don't see yet. I'll check it again.

 

New beta version available 6.2.17: (available in beta repo)

delta changelog:

fix delete option after playback
fix next episode node issue
backport 7.x progress update functions

 

@markdj

Please try this version.

Edited by quickmic
Link to comment
Share on other sites

markdj
On 5/29/2022 at 1:19 PM, quickmic said:

 

New beta version available 6.2.17: (available in beta repo)

delta changelog:

fix delete option after playback
fix next episode node issue
backport 7.x progress update functions

 

@markdj

Please try this version.

This seems to have worked for now. Will try a few more times and report back.

  • Like 1
Link to comment
Share on other sites

geaves

Music Playlists;

Having updated Kodi and added my music to Emby creating a playlist using Emby UI works great, but how/where do I access that playlist using the add-on. Emby is deployed via docker, in the dashboard I see the path as /config/data/playlist, (the container path being /AppData/Emby/config)

In Kodi I can locate the playlist by going through Music/Addons -> Emby-next-gen -> Playlists (server name) but that is as far as I've got

 

Link to comment
Share on other sites

quickmic
31 minutes ago, geaves said:

Music Playlists;

Having updated Kodi and added my music to Emby creating a playlist using Emby UI works great, but how/where do I access that playlist using the add-on. Emby is deployed via docker, in the dashboard I see the path as /config/data/playlist, (the container path being /AppData/Emby/config)

In Kodi I can locate the playlist by going through Music/Addons -> Emby-next-gen -> Playlists (server name) but that is as far as I've got

 

I haven't tested playlists for a long time. I'll check, btw. If you heavily use music content, try 7.x.

There are a gazillion improvements for music content. For videos, 6.x is also very good.

Link to comment
Share on other sites

geaves
29 minutes ago, quickmic said:

I haven't tested playlists for a long time. I'll check, btw. If you heavily use music content, try 7.x.

There are a gazillion improvements for music content. For videos, 6.x is also very good.

Tried that 🙂 I just assumed the/a playlist would appear when selecting playlists from the menu in Kodi.

The irony is if you go into playlists, select New Playlist -> Library -> Music add-ons -> Emby-next-gen -> Playlists (server name) 

-> Playlists -> select a playlist which has been created via the Emby UI and open it -> Save, enter a name, confirm it, message playlist saved 👍 but where, certainly doesn't appear in Playlist in the Kodi menu  

Link to comment
Share on other sites

quickmic
Posted (edited)

They will not appear as a Kodi playlist, cause this is actually a dynamic node and not synced content.

Not sure, but I assume Kodi uses (internally) standard m3u playlists (as a file) and surly not Kodi database records.

I don't wanna bother you with technical details, but Kodi content handled by files (like m3u) and not by Kodi's database is not really syncable (in a regular way).

It's more like downloading approach. However, if the playlist is actually correct (via plugin menu) you can and should use it this way. -> Adapt your skin and create a custom home menu item (or widget, whatever) viewing those lists.

btw, Kodi's (internal) Favorites have exactly the same design flaw.

 

 

Edited by quickmic
Link to comment
Share on other sites

geaves

OK, might have some more relevant info using Estuary skin, if you select movies then options under Actions there is a Go to playlist, whilst it doesn't show the playlist name it does show the content of the list I created, the same behaviour is on Tv Shows, but in Music there is no Playlist under Actions.

20 minutes ago, quickmic said:

However, if the playlist is actually correct (via plugin menu) you can and should use it this way. -> Adapt your skin and create a custom home menu item (or widget, whatever) viewing those lists.

That was another option I was going to work on, or at least try too 

 

Link to comment
Share on other sites

quickmic
1 minute ago, geaves said:

OK, might have some more relevant info using Estuary skin, if you select movies then options under Actions there is a Go to playlist, whilst it doesn't show the playlist name it does show the content of the list I created, the same behaviour is on Tv Shows, but in Music there is no Playlist under Actions.

That was another option I was going to work on, or at least try too 

 

Estuary (stock Kodi skin) cannot be customized. Use a custom skin, anyone you like.

If you like the stock design (as I do), use e.g. this skin:

Skin Estuary MOD V2 for KODI 19 Matrix KN Edition

On first sight, you will see no difference, but it's fully adjustable.

Install kodinerds repo -> https://repo.kodinerds.net/addons/repository.kodinerds/repository.kodinerds-7.0.1.2.zip and go from there.

For further details, please open a new thread cause it's going off topic.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...