Jump to content
CathMowr

Metadata Problems - Audio

Recommended Posts

CathMowr
Posted (edited)

Aloha community,

one giant emby noob speaking, and so I have a problem. I hope I am in the right place and find an answer here, if I missed crucial details in order to find a solution please tell me, if should post somewhere else tell me too!

So I want to set up Emby as my primary media player on OS X and IOS and started playing around with it. I set up my NAS with the server and whatnot and then started pulling some audio onto the server to see if Emby recognizes it. It does. But. The folder is called 20syl and emby does not want to make an artist out of it. Shows up under the Album (unclickable), but not in the artist section. So I pull out my ID3 Tag Editor to see if there is something wrong with the file. Nope. What's happening? Other artists work kind of fine. I had some problems with special signs like accents in french titles but hey. You cant have it all..

But! My guess is that the number in the beginning causes Problems but what can I do to make this work?

I'd be extremely happy if somebody could tell me a way of correctly preparing files for Emby so that it reliably works. Sorry if this might be an old question but i couldn't find any valuable information concerning this topic.

Thanks in advance!

EDIT : I noticed that when i try to edit the metadata in emby it doesnt show an artist or an album artist as well. When i write it down and save it just says okay but nothing happens. When i reopen the section its gone. Refreshing metadata via the 3 points does nothing as well.

 

Screen Shot 2020-06-21 at 22.16.08.png

Screen Shot 2020-06-21 at 22.15.48.png

Screen Shot 2020-06-21 at 22.18.58.png

Edited by CathMowr

Share this post


Link to post
Share on other sites
Luke

@CathMowr Emby doesn't create artists based on your folders, but rather it uses the embedded ID3 tags within the files. Does this answer your question?

If you're still having an issue can you provide a sample track for testing? Thanks !

Share this post


Link to post
Share on other sites
CathMowr

Hey Luke,

 

thanks for the answer. I know about the ID3 Tags and that Emby doesn't give a shit about the folders/files actual name (great!) but the problem was, as mentioned above, another one. 

The files were properly tagged, at least thats what iTunes and ID3 Tag editor showed me, but Emby seem to had problems recognizing some of them. 

Thats why I asked which software would be recommended to write proper ID3s in my files so that Emby is happy..

I kinda solved my problem, i work with MusicBrainz Picard now, but it can be a bit tedious at times, so i would be thrilled to know what an Emby official like you recommends to get those tags right.. Music Brainz is great for big Artists but its a bit annoying when you have to write an entry and wait for a week to get it verified in case you wanna have correct metadata for an underground artist. Or maybe I am just doing stuff wrong, idk.

Anyways, thanks for writing back.

Share this post


Link to post
Share on other sites
CathMowr

Ok, so I have another question

Why is Emby not showing any feature Artists on Tracks.. Today I tried some Albums with featured Artists on them and Emby just doesn't recognise them. They are labeled correctly on MusicBrainz under Artists, I tag my files with via MBP, import them into Emby and.. Nothing. When I try to edit Metadata via Emby there is nothing there.

Honestly, Emby works great for movies and TV series so far but organising my music has been a pain in the buttocks. Why is everything so dam complicated?

Share this post


Link to post
Share on other sites
Luke
On 7/10/2020 at 6:26 PM, CathMowr said:

Hey Luke,

 

thanks for the answer. I know about the ID3 Tags and that Emby doesn't give a shit about the folders/files actual name (great!) but the problem was, as mentioned above, another one. 

The files were properly tagged, at least thats what iTunes and ID3 Tag editor showed me, but Emby seem to had problems recognizing some of them. 

Thats why I asked which software would be recommended to write proper ID3s in my files so that Emby is happy..

I kinda solved my problem, i work with MusicBrainz Picard now, but it can be a bit tedious at times, so i would be thrilled to know what an Emby official like you recommends to get those tags right.. Music Brainz is great for big Artists but its a bit annoying when you have to write an entry and wait for a week to get it verified in case you wanna have correct metadata for an underground artist. Or maybe I am just doing stuff wrong, idk.

Anyways, thanks for writing back.

Around here Picard is the most recommended. @ginjaninja may have other suggestions.

Share this post


Link to post
Share on other sites
Luke
On 7/12/2020 at 6:16 PM, CathMowr said:

Ok, so I have another question

Why is Emby not showing any feature Artists on Tracks.. Today I tried some Albums with featured Artists on them and Emby just doesn't recognise them. They are labeled correctly on MusicBrainz under Artists, I tag my files with via MBP, import them into Emby and.. Nothing. When I try to edit Metadata via Emby there is nothing there.

Honestly, Emby works great for movies and TV series so far but organising my music has been a pain in the buttocks. Why is everything so dam complicated?

Best thing to do is make sure they are tagged this way with Picard, then run a library scan and emby server will pick up the changes. If you still have trouble after that then let's please go over an example. Thanks.

Share this post


Link to post
Share on other sites
ginjaninja
On 7/12/2020 at 11:16 PM, CathMowr said:

Ok, so I have another question

Why is Emby not showing any feature Artists on Tracks.. Today I tried some Albums with featured Artists on them and Emby just doesn't recognise them. They are labeled correctly on MusicBrainz under Artists, I tag my files with via MBP, import them into Emby and.. Nothing. When I try to edit Metadata via Emby there is nothing there.

Honestly, Emby works great for movies and TV series so far but organising my music has been a pain in the buttocks. Why is everything so dam complicated?

emby does not understand 'feat' (or any other  'connecting' words) in the Artist tag.

as well as supporting multiple artists in the  Artist tag separated by eg '/', emby does understand some or all* of ArtistS tag (eg. Robert Plant/Alison Krauss) and MUSICBRAINZ_ARTISTID tag (eg. bd53f9a7-8be9-46b0-bf7d-1deea3cb57bc/6b064ead-91a4-4ac8-8076-b1febe4f4aac)

these tags are both written by MBP. Its unclear to me on how these tags are used and which take priority, but the bottom line if the files are pushed through Picard multiple artists seem to work.  these 'MBP tags' do override the Artist tag.

for underground content (not indexed on mbz) i use Mp3tag and separate artists in the Artist tag with a '/' taking care to use a single tagging version in my files eg id3v2.3 UTF-16 for predictable results. You will have to accept the loss of connecting words like 'feat.' in tracks with multiple artists. YMMV on which of multiple artists are listed in which order on the track and the 'view artist' jump command only applies to the 1st artist.

this is what one of my multi artist (and multi albumartist) tracks looks like in mp3tag for comparisonCapture.JPG.e0adee977a8685e1abacbfe907f9e9d3.JPG

note on my system the artist [tag] "Robert Plant & Alison Krauss" is overridden by one or all of the Artists/MBZ_ARTISTID [tags], so Emby sees the track artist as two artists.

Capture.JPG.bcbcc1e3dd6567362052e018161c3edc.JPG

Share this post


Link to post
Share on other sites
CathMowr
Posted (edited)

Ok. So.

I tried 3 different versions this time. 

Version 1

2033893552_TESTING-01-MBP.thumb.png.a9c0039f9c67cf0b1cd8f1f031e0ffc4.png

The way MBP has this release in it's database. Note the feat. in Artist. Even if Emby doesn't care about this everything should be fine after Import because MBP ID is there and Artists differentiates the Artists correctly.

1259666769_TESTING-01-MP3TAG.thumb.png.cce4394a229ddf4667269e6a4c1f85b6.png

The way MP3Tag shows me the file. 

1916919457_TESTING-01-EMBY.thumb.png.ddcf213dba7e61242326fee26670e7cf.png

What Emby shows. No other Artists except Rocky.

Version 2

 1875180517_TESTING-02-MBP.thumb.png.3ecb0a0c57336d6c9a18dc2b7073799a.png

So i tried writing the artists in the "artist" section in MBP. Dirty but okay, i am not going to wait a week to get an edit approval on Music Brainz.

1867716761_TESTING-02-MP3TAG.thumb.png.d47e55614ad5e9d56b00a6f967ce1242.png

What MP3Tag shows me.

117527798_TESTING-02-EMBY.png.d5df5ffe70f1c04042f18ff637032a82.png

What Emby shows me. Nothing.

In Version 3 I tried the same dirty trick with "/" but still... Nothing. Please @Luke / @ginjaninja help me. If I can supply you with anything say so, but please help. I really want this to work.

Edited by CathMowr

Share this post


Link to post
Share on other sites
ginjaninja
53 minutes ago, CathMowr said:

Ok. So.

I tried 3 different versions this time. 

Version 1

2033893552_TESTING-01-MBP.thumb.png.a9c0039f9c67cf0b1cd8f1f031e0ffc4.png

The way MBP has this release in it's database. Note the feat. in Artist. Even if Emby doesn't care about this everything should be fine after Import because MBP ID is there and Artists differentiates the Artists correctly.

1259666769_TESTING-01-MP3TAG.thumb.png.cce4394a229ddf4667269e6a4c1f85b6.png

The way MP3Tag shows me the file. 

1916919457_TESTING-01-EMBY.thumb.png.ddcf213dba7e61242326fee26670e7cf.png

What Emby shows. No other Artists except Rocky.

Version 2

 1875180517_TESTING-02-MBP.thumb.png.3ecb0a0c57336d6c9a18dc2b7073799a.png

So i tried writing the artists in the "artist" section in MBP. Dirty but okay, i am not going to wait a week to get an edit approval on Music Brainz.

1867716761_TESTING-02-MP3TAG.thumb.png.d47e55614ad5e9d56b00a6f967ce1242.png

What MP3Tag shows me.

117527798_TESTING-02-EMBY.png.d5df5ffe70f1c04042f18ff637032a82.png

What Emby shows me. Nothing.

In Version 3 I tried the same dirty trick with "/" but still... Nothing. Please @Luke / @ginjaninja help me. If I can supply you with anything say so, but please help. I really want this to work.

your tags look ok and i would have thought would work, albeit you are using ';' as separator in Artists and MBZ_ARISTID tags, i use '/' but i think ';' should also work.

maybe there is a refresh/scanning/ffprobe issue.. i would zip up a multi artist track or two and pm them will see if they work on my system.

Share this post


Link to post
Share on other sites
CathMowr

";" should work, got recommended somewhere here on the forums.

Check your inbox, you got a DM.

 

Share this post


Link to post
Share on other sites
Luke

@ginjaninja were you able to try them?

Share this post


Link to post
Share on other sites
ginjaninja
22 hours ago, Luke said:

@ginjaninja were you able to try them?

tried a few files and i can make them work by tagging them properly, @cathmowr is trying a couple of suggestions to track down where things are falling over...looks like its tagging understanding/configuration than any issue but well see.

Share this post


Link to post
Share on other sites
Luke

Great, thanks !

Share this post


Link to post
Share on other sites
CathMowr

Problem (kind of) solved! It seems like I was tagging wrong, even if I don't know why..

Big ups to @ginjaninja !

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites
AVRider

Windows environment: For the majority of my Music library Emby has monitored and retrieved all pertinent info - images, artist, contributing artists, dates, etc. I utilize the NFO option for storing all metadata. All metadata stored within the media folder. 

Well done!

Currently, I am struggling with the retrieval of certain metadata. Emby is not retrieving fundamental data and or rewrites manual input data upon real time monitoring.  I mention the latter only as my test to see if Emby was recognizing the "field" parameters at all. What I found was when rewriting the album.nfo file the same missing parameters occurred. Specifically, I have found that Emby is not writing basic data within album.nfo, for example, "artist". I say this because I have compared with those artists where the album.nfo file has this data present. 

These are not obscure artists.

This is not only happening for this artist, Joe Sample, but others as well in my library. I suspect once I pinpoint the culprit here it will lead to a fix for the other albums and artists. The NFO files, album.nfo, do not not contain "albumartist", "artist", and "year" parameters for the Joe Sample albums below. One album may have the "year" parameter, or not. This occurs for all of the albums below.

Joe Sample's

The Best of Joe Sample

Old Places Old Faces

Invitation

Sample This

 

Thanks in advance for your help! See below...

 

"Sample This" album.nfo file contents below:

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<album>
  <review />
  <outline />
  <lockdata>false</lockdata>
  <dateadded>2016-10-08 13:23:27</dateadded>
  <title>Sample This</title>
  <year>1997</year>
  <runtime>0</runtime>
  <audiodbartistid>130878</audiodbartistid>
  <audiodbalbumid>2214335</audiodbalbumid>
  <musicbrainzalbumid>96d904b7-4863-481e-8c6a-d3844754d750</musicbrainzalbumid>
  <musicbrainzalbumartistid>526a6127-7f4e-4797-8ae9-927a6e29e2d0</musicbrainzalbumartistid>
  <musicbrainzreleasegroupid>aa24887a-02bf-3c71-b14e-fd2fa3ce6c1f</musicbrainzreleasegroupid>
  <art>
    <poster>C:\Users\ADMIN\AppData\Roaming\Emby-Server\metadata\library\ef\efc8f7749be142b0214e9e224189d1dd\folder.jpg</poster>
  </art>
</album>

 

Screenshot: 

Note that artist "Joe Sample" is missing on Sample This. Also, on the same screenshot - Hall and Oates data missing as well.

image.thumb.png.98a34252abf2bc5519842ca46d773547.png

 

 

Share this post


Link to post
Share on other sites
CathMowr

It seems that my problem was a combination of a couple things. MBP and MP3Tag showed me tags that weren't there according to FFProbe, as @ginjaninja showed me. An important thing seems to be to set up both taggers to remove all old tags and to just use one of them or this can lead to confusion for Emby. 


A really strange thing is that after I changed from converting my .wav files into .alac (mp4) to converting them into .flac i didn't encounter anymore problems. I don't know what to make of this but as long as it works it's fine for me. I currently write all the tags just via MBP and everything seems to work properly.
 

Honestly I still don't know what happened exactly and why some things worked and some don't. I more or less understand the system of prioritization now and I am looking forward to restoring my old music library I had in iTunes.

 

But to give some constructive feedback I want to say that I encountered a lot of problems I didn't see coming and I had to rethink my workflow of setting up files quite a bit coming from iTunes. Emby seems pretty straightforward in its marketing but in it's use it sometimes is not. I don't want to compair Emby too much to it's competitors because it seems to be a way smaller company but coming from other media centers it can be a little rough for a consumer with no background in networking and file preparation, from the audio point if view. To end this on a positive note I want to say that I really appreciate the service Emby offers me, the direct connection to developers via the forum and a lot of other stuff, and hope that I do not ever have to use something else again. Keep on going people, Emby could be THE SHIT one day for people who want to host their own media. I will try to contribute to this wonderful thing as good as i can in the futur, so see you in the forums!

Share this post


Link to post
Share on other sites
AVRider

I have never utilized MBP and MP3Tag. All of my CDs were ripped via Exact Audio Copy (EAC) to FLAC files. All tags written directly from the source CD and associated album library.  Recall, the vast majority of my music library is fine. Emby records the metadata as required. There is something unique about certain albums and artists. I do not know what the specific differences are with these albums that are causing the problem. The tags are there (albumartists, artist, year) but they are not utilized.  I am looking for guidance.

Share this post


Link to post
Share on other sites
CathMowr

I am sorry @AVRider I can't really help you with this. I rip everything as .wav in iTunes and convert it afterwards to .flac so I have no experience with directly writing tags from whatever library EAC uses.

From the looks of your screenshots I'd say your files have contradicting tags in some sections, that's what happened to me and it looked the same in Emby. No artist shown at all. The best advice I can give is to recheck the problematic files in MP3Tag and see if there is anything wrong with the tags. If yes, rewrite them but be careful to remove the old ones.

Except from a few hickups in the beginning and a phase of getting used to it I can absolutely recommend MBP and MB to tag your files if you care about tags like ISRC, Version etc. I mostly use MP3Tag just as second instance to check if the tags seem OK. I got used to working with MusicBrainz and MBP kinda quickly, it's a great plattform, kind of like discogs for metadata. I didn't have to pull out MP3Tag for weeks now..

All the best, I'll keep my eyes on the thread and add if I feel like knowledge could be needed.

Share this post


Link to post
Share on other sites
AVRider

CathMowr, thank you for being persistent on the tags. I installed MP3Tag and chose an album folder. Much to my surprise what I found was that Musicbrainz is incorrect. On one of the albums I tested the year is incorrect in Musicbrainz. All fields are incorrect as Emby pulls the metadata, Albumartist ID, Album ID, Album Release Group

How does one go about addressing and getting this fixed?

Thanks again.

Share this post


Link to post
Share on other sites
Luke

Why do you feel MusicBrainz is incorrect?

Share this post


Link to post
Share on other sites
Happy2Play
11 minutes ago, AVRider said:

On one of the albums I tested the year is incorrect in Musicbrainz. All fields are incorrect as Emby pulls the metadata, Albumartist ID, Album ID, Album Release Group

Maybe as we do not know what tags are present within your media, but can you go over a specific example.  Are you saying Emby has different information then what you see on Musicbrainz?

Share this post


Link to post
Share on other sites
AVRider

To clarify, the year of the album in question is incorrect within MB. The write up of the release is correct at 1993. The release date listed for the album is 1995.

Upon MP3Tag retrieving the data there is a mismatch. My rip of the CD has the correct date - 1993. Also, I searched separately for the release date and it is 1993.

The album is Joe Sample's "Invitation".

In addition, as pointed out initially there seems to be a problem with this artist. Something unique? Album data retrieved but artist name not displayed under album info for all albums by him.

I hope this is helpful. 

Share this post


Link to post
Share on other sites
AVRider

Here is the "album.nfo" file for Joe Sample - Sample This. Note: <artist> and <albumartist> missing. The tags are there in the album folder. They were written by MP3Tag. See screenshot below.

I have inserted both artist and albumartist manually into the album.nfo file. When Emby rewrites the album.nfo file it removes my manual input and does not write artist or albumartist.

The MB data is accurate for this album. Both MB and audiodb IDs are accurate in the album.nfo file below. 

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<album>
  <review />
  <outline />
  <lockdata>false</lockdata>
  <dateadded>2016-10-08 13:23:27</dateadded>
  <title>Sample This</title>
  <year>1997</year>
  <language>en</language>
  <countrycode>US</countrycode>
  <runtime>0</runtime>
  <audiodbartistid>130878</audiodbartistid>
  <audiodbalbumid>2214335</audiodbalbumid>
  <musicbrainzalbumid>96d904b7-4863-481e-8c6a-d3844754d750</musicbrainzalbumid>
  <musicbrainzalbumartistid>526a6127-7f4e-4797-8ae9-927a6e29e2d0</musicbrainzalbumartistid>
  <musicbrainzreleasegroupid>aa24887a-02bf-3c71-b14e-fd2fa3ce6c1f</musicbrainzreleasegroupid>
  <art>
    <poster>E:\Music\Joe Sample\Sample This\folder.jpg</poster>
  </art>
</album>

 

image.thumb.png.502981ea4e9c81ca26485e28775a7126.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...