Jump to content

Check for plugin updates failed and no Plugin Catalog


nurgemedia
 Share

Go to solution Solved by bigjohn,

Recommended Posts

9 minutes ago, Hakun0ar said:

Sure thing. I've zipped it due to the original size > 20MB, hope that's okay.

My assumption that it's still about an SSL / Trust issue.

Thanks for looking into this.


    System.Net.WebException: System.Net.WebException: Error: TrustFailure (Authentication failed, see inner exception.) ---> System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. ---> Mono.Btls.MonoBtlsException: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED

 

embyserver.zip 449.73 kB · 0 downloads

Did you take a look at this?

 

Link to comment
Share on other sites

On 8/24/2020 at 9:31 AM, Luke said:

Did you take a look at this?

 

I did, but it looks like I'm going to wait since the beta is not available for my CPU architecture.

Have the same CPU as this post

So I'm stuck until the new package becomes available for Arm5, as far as I understand

Synology Armv5 / X86

Introduction

An Emby supported package is now available for all Synology* (and XPEnology) platforms!

The package is supported on systems running DSM 5.2-5967 or later.

Link to comment
Share on other sites

True, although if you can help out here that would be much appreciated and it would help us solve it for armv5:

 

Thanks.

Link to comment
Share on other sites

1 minute ago, Hakun0ar said:

Will PM him (and you) and gladly help to figure this out. Thanks for the hint.

Great, thanks !

Link to comment
Share on other sites

  • 1 month later...

Hello,

I'm still running into this issue.

Following instructions on https://emby.media/synology-server.html I manually upgraded EmbyServer to version 4.5.2.0 (emby-server-synology-mono_4.5.2.0_armv5.spk)

Overall issue is still the same (no plugins update, no metadata fetch, ...) but the exception in logs is different:

    System.Net.WebException: System.Net.WebException: Error: SecureChannelFailure (Authentication failed, see inner exception.) ---> System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. ---> System.DllNotFoundException: /volume1/@appstore/mono/lib/../lib/libmono-btls-shared.so

Note that I tried Beta version 4.6.0.2 but for some reason package refuse to start.

So now I have:

  • EmbyServer 4.5.2.0
  • Synology DS212+
  • DSM 6.2.3-25426 Update 2
  • Marvell Kirkwood 88F6282

And BTW still no VPN in use and no quickconnect.

Any help on this issue would be greatly appreciated.

Thanks in advance.

 

embyserver.txt

Edited by baad5eed
Link to comment
Share on other sites

6 hours ago, baad5eed said:

Hello,

I'm still running into this issue.

Following instructions on https://emby.media/synology-server.html I manually upgraded EmbyServer to version 4.5.2.0 (emby-server-synology-mono_4.5.2.0_armv5.spk)

Overall issue is still the same (no plugins update, no metadata fetch, ...) but the exception in logs is different:


    System.Net.WebException: System.Net.WebException: Error: SecureChannelFailure (Authentication failed, see inner exception.) ---> System.Security.Authentication.AuthenticationException: Authentication failed, see inner exception. ---> System.DllNotFoundException: /volume1/@appstore/mono/lib/../lib/libmono-btls-shared.so

Note that I tried Beta version 4.6.0.2 but for some reason package refuse to start.

So now I have:

  • EmbyServer 4.5.2.0
  • Synology DS212+
  • DSM 6.2.3-25426 Update 2
  • Marvell Kirkwood 88F6282

And BTW still no VPN in use and no quickconnect.

Any help on this issue would be greatly appreciated.

Thanks in advance.

 

embyserver.txt 38.58 kB · 0 downloads

Hi, regarding armv5, please see here:

 

Link to comment
Share on other sites

  • 2 months later...

Is this still an issue because I just started having it with v4.5.4.0 where I cannot get updated Plugin's on my Sysnology NAS with Emby and my scans won't finish and I have to update stuff with Identify and usually add the photo manually as well, if even the Identify works.

	*** Error Report ***
	Version: 4.5.4.0
	Command line: /volume1/@appstore/EmbyServer/system/EmbyServer.dll -programdata /volume1/Emby -ffdetect /var/packages/EmbyServer/target/bin/ffdetect -ffmpeg /var/packages/EmbyServer/target/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/bin/ffprobe -nolocalportconfig -ignore_vaapi_enabled_flag -updatepackage emby-server-synology_{version}_x86_64.spk -noautorunwebapp
	Operating system: Linux version 4.4.59+ (root@build3) (gcc version 4.9.3 20150311 (prerelease) (crosstool-NG 1.20.0) ) #25426 SMP PREEMPT Mon Dec 14 18:48:50 CST 2020
	Framework: .NET Core 3.1.8
	OS/Process: x64/x64
	Runtime: volume1/@appstore/EmbyServer/system/System.Private.CoreLib.dll
	Processor count: 4
	Data path: /volume1/Emby
	Application path: /volume1/@appstore/EmbyServer/system
	MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: Connection to http://api.thesubdb.com/?action=search&hash=5421A9389BE8033CC74BF6C3D79878C9 timed out
	 ---> System.Threading.Tasks.TaskCanceledException: The operation was canceled.
	   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.ConnectAsync(HttpRequestMessage request, Boolean allowHttp2, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.CreateHttp11ConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.GetHttpConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
	   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DecompressionHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DiagnosticsHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpClient.FinishSendAsyncUnbuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	   --- End of inner exception stack trace ---
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
	   at SubDb.SubDbSubtitleProvider.Search(SubtitleSearchRequest request, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Subtitles.SubtitleManager.SearchSubtitles(SubtitleSearchRequest request, CancellationToken cancellationToken)
	Source: Emby.Server.Implementations
	TargetSite: Void MoveNext()
	InnerException: System.Threading.Tasks.TaskCanceledException: The operation was canceled.
	Source: System.Private.CoreLib
	TargetSite: Void Throw()
	   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.ConnectAsync(HttpRequestMessage request, Boolean allowHttp2, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.CreateHttp11ConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.GetHttpConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
	   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DecompressionHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DiagnosticsHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpClient.FinishSendAsyncUnbuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)

 

Edited by Tolerant
add log
Link to comment
Share on other sites

2 hours ago, Tolerant said:

Is this still an issue because I just started having it with v4.5.4.0 where I cannot get updated Plugin's on my Sysnology NAS with Emby and my scans won't finish and I have to update stuff with Identify and usually add the photo manually as well, if even the Identify works.


	*** Error Report ***
	Version: 4.5.4.0
	Command line: /volume1/@appstore/EmbyServer/system/EmbyServer.dll -programdata /volume1/Emby -ffdetect /var/packages/EmbyServer/target/bin/ffdetect -ffmpeg /var/packages/EmbyServer/target/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/bin/ffprobe -nolocalportconfig -ignore_vaapi_enabled_flag -updatepackage emby-server-synology_{version}_x86_64.spk -noautorunwebapp
	Operating system: Linux version 4.4.59+ (root@build3) (gcc version 4.9.3 20150311 (prerelease) (crosstool-NG 1.20.0) ) #25426 SMP PREEMPT Mon Dec 14 18:48:50 CST 2020
	Framework: .NET Core 3.1.8
	OS/Process: x64/x64
	Runtime: volume1/@appstore/EmbyServer/system/System.Private.CoreLib.dll
	Processor count: 4
	Data path: /volume1/Emby
	Application path: /volume1/@appstore/EmbyServer/system
	MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: Connection to http://api.thesubdb.com/?action=search&hash=5421A9389BE8033CC74BF6C3D79878C9 timed out
	 ---> System.Threading.Tasks.TaskCanceledException: The operation was canceled.
	   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.ConnectAsync(HttpRequestMessage request, Boolean allowHttp2, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.CreateHttp11ConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.GetHttpConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
	   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DecompressionHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DiagnosticsHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpClient.FinishSendAsyncUnbuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	   --- End of inner exception stack trace ---
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsync(HttpRequestOptions options, String httpMethod)
	   at SubDb.SubDbSubtitleProvider.Search(SubtitleSearchRequest request, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Subtitles.SubtitleManager.SearchSubtitles(SubtitleSearchRequest request, CancellationToken cancellationToken)
	Source: Emby.Server.Implementations
	TargetSite: Void MoveNext()
	InnerException: System.Threading.Tasks.TaskCanceledException: The operation was canceled.
	Source: System.Private.CoreLib
	TargetSite: Void Throw()
	   at System.Net.Http.ConnectHelper.ConnectAsync(String host, Int32 port, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.ConnectAsync(HttpRequestMessage request, Boolean allowHttp2, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.CreateHttp11ConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.GetHttpConnectionAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpConnectionPool.SendWithRetryAsync(HttpRequestMessage request, Boolean doRequestAuth, CancellationToken cancellationToken)
	   at System.Net.Http.RedirectHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DecompressionHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.DiagnosticsHandler.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
	   at System.Net.Http.HttpClient.FinishSendAsyncUnbuffered(Task`1 sendTask, HttpRequestMessage request, CancellationTokenSource cts, Boolean disposeCts)
	   at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.SendAsyncInternal(HttpRequestOptions options, String httpMethod)

 

Hi, what you've posted above is a subtitle search and is not related to the plugin catalog. Please attach the complete emby server log. thanks.

Link to comment
Share on other sites

Okay.

I have since uninstalled the OMDb plugin, and disabled TheMovieDB for Metadata and images.  Things are quicker now that they are not failing but obviously some connection issue I can't figure out.

embyserver.txt

Link to comment
Share on other sites

Something is blocking the server's access to these external domains. Typical causes are firewall, security software, or VPN. I would look into that. You could also try disabling ipv6 in your router.

  • Thanks 1
Link to comment
Share on other sites

9 hours ago, Luke said:

Something is blocking the server's access to these external domains. Typical causes are firewall, security software, or VPN. I would look into that. You could also try disabling ipv6 in your router.

I can't imagine because I have tried with and without the VPN connection on my NAS on/off. Restarted NAS, Emby, Router, etc.

I had recently set the local IP address of the server to a 192.168.1.101 address for the local lan because of adding a Fire Stick 4k, and I had also turned off "External Incoming" connections.  Since I have removed the local IP setting back to blank default and re-enabled external connections. However with NAS VPN on or off, still no luck with Emby connecting for Plugins or those few sites. :(

What do I try next?

Edit: I think I need IPV6 to get to places like "The Tribez" a Microsoft Store (and more) game. If I use Windscribe I can't connect to it and I know they don't support IPV6. But that shouldn't be affecting the NAS if the VPN isn't on and it was always connecting before with it on. It all started after I swapped off external and set local ip.

 

Edited by Tolerant
Link to comment
Share on other sites

43 minutes ago, Luke said:

I'll not sure. Those are the only potential causes that I'm aware of right now.

Think I got it solved for now but not 100% sure how. I did go into NAS Control panel and change IPV6 to use DCHP instead of Auto. And Removed the VPN totally, then rebooted the NAS. Put the OMDb Plugin back in (it worked) and updated TVDb Plugin (it worked), added the two back to MetaData providers, etc.

Seems like after a long refresh missing metadata scan things are working again. I have not since turned on the newly added VPN i put back but I will let ya know after if I loose connectivity. Hopefully not.

Link to comment
Share on other sites

1 minute ago, Tolerant said:

Think I got it solved for now but not 100% sure how. I did go into NAS Control panel and change IPV6 to use DCHP instead of Auto. And Removed the VPN totally, then rebooted the NAS. Put the OMDb Plugin back in (it worked) and updated TVDb Plugin (it worked), added the two back to MetaData providers, etc.

Seems like after a long refresh missing metadata scan things are working again. I have not since turned on the newly added VPN i put back but I will let ya know after if I loose connectivity. Hopefully not.

Thanks for the feedback. @FrostByte FYI.

Link to comment
Share on other sites

  • 1 month later...

I wish to report that I was having many, many issues with my emby server (4.5.4.0) on windows 10 since I made some changes in my router trying to skip the CGNAT restriction to share my media.

Issues like:

  1. Identify option not working 😐
  2. Subtitles download not working 🤔
  3. Plugins catalog never loading 🤐
  4. Movies always transcoding (Never direct playing) 🥴
  5. Backward and Forward buttons not working and always starting from the begining (In my old Samsung TV UN46F8000) 😩. This make that no one could touch the remote control or the entire movie will start again. So frustrating.

BUT, after taking the @Luke advice, I disabled the IPV6 feature in my router and... 🥁... I am happy to say that the issues 1, 2 and 3 were solved. Thank you Emby support team for enlighten me the path to start solving those issues.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...