Jump to content


Photo

How to set up Emby Library with different NTFS drives? Linux Newbie :(

debian library setup Linux

  • Please log in to reply
9 replies to this topic

#1 AbirX OFFLINE  

AbirX

    Member

  • Members
  • 13 posts

Posted 02 November 2019 - 03:19 AM

Hi, I am a complete noob! Recently switched from Windows to Linux. I'm having trouble setting up my library with the files from NTFS drives created using windows. Can anyone tell me how to add files from other drives to my emby library? I'm using deepin x64bit (debian 9 based).



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142429 posts
  • Local time: 10:35 PM

Posted 02 November 2019 - 09:12 AM

Hi there, are these drives on the same machine?


  • AbirX likes this

#3 AbirX OFFLINE  

AbirX

    Member

  • Members
  • 13 posts

Posted 02 November 2019 - 10:31 AM

Hi there, are these drives on the same machine?

Yes. I had 5 drives on windows. C, D,E, F & G drives. Same hard disk, 5 Partitions. I just formatted C (windows) drive and installed Linux on it. But my media files are on other drives. How can I add them to my emby library?


Edited by AbirX, 02 November 2019 - 10:36 AM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142429 posts
  • Local time: 10:35 PM

Posted 02 November 2019 - 11:41 PM

Are you able to access them from the linux OS?



#5 AbirX OFFLINE  

AbirX

    Member

  • Members
  • 13 posts

Posted 03 November 2019 - 02:39 AM

Are you able to access them from the linux OS?

Yes, I can access them via linux file manager. But I can't access them from emby, when I type the path to create my library, it says no such directory or something! :(



#6 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2838 posts
  • Local time: 10:35 PM
  • LocationLong Island, NY

Posted 03 November 2019 - 08:48 AM

Yes, I can access them via linux file manager. But I can't access them from emby, when I type the path to create my library, it says no such directory or something! :(

You need to give emby access to the drives.  Google "how to set permissions in linux"



#7 AbirX OFFLINE  

AbirX

    Member

  • Members
  • 13 posts

Posted 03 November 2019 - 11:33 AM

Basically the NTFS drives remain unmounted at startup. When I double click on it, the are mounted as "/media/username/drivename". But emby doesn't show this path.



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142429 posts
  • Local time: 10:35 PM

Posted 03 November 2019 - 05:34 PM

 

 

But emby doesn't show this path.

 

That's OK, you can still enter the path manually into the directory picker. Have you tried that? If this is not working then it means the server doesn't have permissions for the path. Have you checked this?



#9 AbirX OFFLINE  

AbirX

    Member

  • Members
  • 13 posts

Posted 03 November 2019 - 11:08 PM

Yes tried that & didn't work. Now, editing fstab and setting the drives to auto-mount at startup seem to solve the problem. I set the default mount location to /media/NTFS, and emby recognized this path. Is this okay or does it have any side effect? Thank you all for your support!


Edited by AbirX, 04 November 2019 - 05:28 AM.


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142429 posts
  • Local time: 10:35 PM

Posted 04 November 2019 - 12:56 AM

Sounds good to me. Thanks for the feedback.


  • AbirX likes this





Also tagged with one or more of these keywords: debian, library, setup, Linux

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users