Jump to content

New Sonos Plugin


Luke

Recommended Posts

@@Spaceboy then there is something in your network block this kind of traffic.

 

@@Luke

I found the problem.

 

It's in the Emby settings: Local networks

 

Can you make a sample use case for this setting? I'm not sure if I understand it 100% correct. Probably I don't need it.

  • Like 1
Link to comment
Share on other sites

Because I was thinking it sounds good and it makes everything around emby more secure.

 

The LAN networks setting gives you that impression?

Link to comment
Share on other sites

Yes just a little bit of course.

 

If I add there IP address the network bandwith limitations are respected. So that's why I was thinking maybe a good Idea to add some IP'adresses there. But yes if you ready correctly probably it has not much to do with security.

Edited by hispeed
Link to comment
Share on other sites

Yes it's something we're interested in for the future, but that's different development. That will require a Sonos app and then submission to them.

Link to comment
Share on other sites

That would be really fantastic. I love emby and if sonos could locally use the emby-server without any internet connection i'll simply say "yes" for life :)

 

Plug-In works like a charm

Link to comment
Share on other sites

That would be really fantastic. I love emby and if sonos could locally use the emby-server without any internet connection i'll simply say "yes" for life :)

 

Plug-In works like a charm

I already bought Emby premium because I like it so much.  Being able to replace SubSonic for use with Sonos would be even better!

Link to comment
Share on other sites

  • 1 month later...

I think i have found a bug in the Sonos plugin.

 

I have noticed that in my user settings, if i set Enable Access From All Devices, i have no problems seeing the Sonos as a casting target from either Chrome or the Android or IOS apps. As soon as i untick this and manually select which users can access Emby from which devices, for example selecting all devices except for one in the list of devices, i have no access to the Sonos as a casting target.

embyserver.txt

Link to comment
Share on other sites

Thanks for reminding me, I’d also like to revisit this. The plugin has never properly worked for me

 

What do you mean by "this"?

Link to comment
Share on other sites

What do you mean by "this"?

This was just that I never got this to work, nor really understood what was supposed to happen. only one of my sonos players would show up in emby. i'm not sure if any of the updates to the plugin since then have corrected tis but i can now see and play to both devices.

 

What i'm still not clear on is how emby deals with grouped Sonos devices which is surely the biggest potential for this. my two sonos players are grouped in the Sonos app but appear separated in emby. what are the expectations here?

Link to comment
Share on other sites

I think i have found a bug in the Sonos plugin.

 

I have noticed that in my user settings, if i set Enable Access From All Devices, i have no problems seeing the Sonos as a casting target from either Chrome or the Android or IOS apps. As soon as i untick this and manually select which users can access Emby from which devices, for example selecting all devices except for one in the list of devices, i have no access to the Sonos as a casting target.

 

Should i open this as a separate issue?

Link to comment
Share on other sites

thanks to the slightly angry guy in the other thread i resolved my issue. perhaps its me but i don't see anywhere saying you need the sonos controller installed on the same pc as emby. once i did that it all works. cheers

Link to comment
Share on other sites

thanks to the slightly angry guy in the other thread i resolved my issue. perhaps its me but i don't see anywhere saying you need the sonos controller installed on the same pc as emby. once i did that it all works. cheers

 

Ah yes I'm sorry that was missed in setup instructions. I will added that to the plugin description.

  • Like 1
Link to comment
Share on other sites

I have the client on my desktop (windows 10) firewall turned off, and when I click the cast button in Emby it just says Play On. 

Link to comment
Share on other sites

  • 2 weeks later...

Is there any possibility of being able to manage sonos grouping through emby? or at the very least be able to select from either the group or any of the group constituents without using the sonos controller to group or separate them. currently you have to change the setup in the sonos controller before selecting the target in emby.

Link to comment
Share on other sites

Is there any possibility of being able to manage sonos grouping through emby? or at the very least be able to select from either the group or any of the group constituents without using the sonos controller to group or separate them. currently you have to change the setup in the sonos controller before selecting the target in emby.

 

At this point I would say unlikely as that would probably be going too far into sonos-specific development, at least in my opinion.

Link to comment
Share on other sites

At this point I would say unlikely as that would probably be going too far into sonos-specific development, at least in my opinion.

no problem, i thought that might be the case. Slight follow up question. I think i understand that for the grouped devices you are using the sonos api, but for standalone devices you can use dlna. So forget about managing sonos groups, is there a possibility of being able to have both methods available at once, it would allow us to achieve almost the same thing.

Link to comment
Share on other sites

  • 3 weeks later...

Trying Emby Premiere (unRaid 6.8.3, and the latest Emby docker from linuxserver) out on my unRaid server.  I also have Plex and Jellyfin installed.  Both Plex and Jellyfin show my sonos speakers as soon as I click on the "cast" button.  Both instantly play to them.  Emby the cast button just says play on.  I think jellyfin was using DLNA which is fine but nothing ever comes up on the button in Emby, it just says Play On.  

 

What else could I try?

 

EDIT - wanted to add as well, that it found my Sonos speakers with Jellyfin app on my iPhone as well.  The Emby app does not.

Edited by NitroNine
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...