Jump to content

Accessing Emby Remotely (and adding new videos on server)


hollerme
 Share

Recommended Posts

hollerme

Yes, this is amazingly helpful!

 

I haven't successfully done it yet but hope to this week as the screenshots have really aided me, and want to thank everyone again for all your support throughout.

 

@@yarez0 that's great, thanks for the info ! @@hollerme has this information helped?

  • Like 1
Link to comment
Share on other sites

yarez0

Yes, this is amazingly helpful!

 

I haven't successfully done it yet but hope to this week as the screenshots have really aided me, and want to thank everyone again for all your support throughout.

You have to know that most ISP routers does not have loopback address so internally if you use dns name traffic will go outside to go back inside. In other words you pass through internet to go to your internal syno.

 

Try to ping your ddns name and look what ip is returned. If you want to use dns name inside you have to configure syno dns service to resolve external address as internal

 

I can show you later

 

 

With ddns you have specify 443 port on all apps (emby, ds vidéo, ds file etc) for syno app to specify port add :443 at the end of your ddns address. For example ds video app adress will ne XXX.ddns.net:443

  • Like 1
Link to comment
Share on other sites

hollerme

Thanks for this,

 

I've decided to wait for this weekend to try because I am switching ISP tomorrow so have to set everything up again before I am set to travel.

 

You have to know that most ISP routers does not have loopback address so internally if you use dns name traffic will go outside to go back inside. In other words you pass through internet to go to your internal syno.

Try to ping your ddns name and look what ip is returned. If you want to use dns name inside you have to configure syno dns service to resolve external address as internal

I can show you later


With ddns you have specify 443 port on all apps (emby, ds vidéo, ds file etc) for syno app to specify port add :443 at the end of your ddns address. For example ds video app adress will ne XXX.ddns.net:443

Link to comment
Share on other sites

hollerme

So it turns out switching broadband providers has caused significant issues and I can't even connect to Synology (can't find it). If anyone has any tips it would mean the world as the day has been very boring without Emby.

Link to comment
Share on other sites

  • 2 weeks later...
yarez0

So it turns out switching broadband providers has caused significant issues and I can't even connect to Synology (can't find it). If anyone has any tips it would mean the world as the day has been very boring without Emby.

 

look at the DDNS setting in your synology to find if your IP is up to date (STEP 3)

Link to comment
Share on other sites

  • 1 month later...
hollerme

Hi all,

 

I have just returned from abroad and am due to fly out next week again.

 

Unfortunately since going abroad I have been unable to access my Emby. My family are still able to use Emby at home so it works fine but unfortunately it looks like being able to access it remotely has failed making this past month extremely bland (although Netflix has helped). Can anyone provide advice as to what may have gone wrong to see if I can fix this before I fly out again?

Link to comment
Share on other sites

Hi all,

 

I have just returned from abroad and am due to fly out next week again.

 

Unfortunately since going abroad I have been unable to access my Emby. My family are still able to use Emby at home so it works fine but unfortunately it looks like being able to access it remotely has failed making this past month extremely bland (although Netflix has helped). Can anyone provide advice as to what may have gone wrong to see if I can fix this before I fly out again?

 

What happens when you try?

Link to comment
Share on other sites

@yarez0 this has been very helpful, much appreciated! Unfortunately I still have not been able to connect remotely using this. My DDNS works, cert is working and I CAN connect remotely using my XXXX.ddns.net with the iOS app if I port forward 8096 in my router and set a firewall rule for 8096 in the synology. I have my reverse proxy to redirect to http 8096 (since I assume you have a cert profile setup in your Emby settings to make the https 8920 work?!) Any ideas/help would be greatly appreciated. Also, I can't "activate a personal domain" in the DSM setting for some reason (pic attached) and I assume this doesn't make a difference as I was still able to connect without that (as I mentioned above)

Edited by jbsdma
Link to comment
Share on other sites

yarez0

Your family can connect using 8096 because you are in your local network

 

If you can use remotely by redirect 8096 your reverse proxy does not work

Link to comment
Share on other sites

Here is the error dialog from DSM settings when trying to add the customized domain:5d59efd797ffc_DSMError.jpg

 

I DO have port 443 on the router pointing to the synology - it is only the TCP protocol (which I assume is ok, should it be TCP+UDP??)

 

I wasn't connecting locally on 8096, I was connecting remotely though the iOS App. When the secure way you posted above didn't work I tried forwarding 8096 on my router and creating the firewall rule for 8096 also on the Synology .... this worked! (see below):

5d59f0bc267aa_IMG_0120.png

 

I assume when I try to connect securely I would use port 443 correct?

 

Here is my reverse proxy settings:

5d59f129a1fbf_ReverseProxy.jpg

 

I set the destination to http and local 8096 because I assume I would need to set up a certificate in Emby (I didn't do this because the Synology is providing this through my DDNS + Let's Encrypt cert.

 

Another thing, I cannot connect securely through LAN (I assume this is also because of needing the cert setup in Emby?!):

5d59f1f0020ab_LocalhttpsError.jpg

 

5d59f203a0c1f_EmbyDashboardStatus.jpg

 

Again, thanks so much for the help!!!!!!!!!!!!

Link to comment
Share on other sites

yarez0

Localy you have to use 8096. This is normal. If you want secure connection you have to use secure port (don’t remember the port) and if you want secure + certificate you have to configure local dns server (like the synology dns server) to localy resolve your external dns name has your local dns name (to resume localy xxx.ddns.net will resolve internal ip 192.168.x.y)

 

Let the mouse on the dns name in dsm config. A message will pop up with the error

 

Your reverse proxy config is ok. Tcp only. As you see my router has only 443 open (80 for let’s encrypt)

 

Try, if you can, a telnet session on your ddns name port 443 (with putty)

 

Host : your domain

Protocol : telnet

Port : 443

 

If port 443 is open you will have a black screen. Maybee with a message

 

If not, the connection will close

 

Maybee you have a synology app which already using hte 443 port. We have to check which one. Maybee that is the reason why the local domain config with hsts can’t be done in dsm

Link to comment
Share on other sites

Here is the error:

5d5a0a3f82472_DSMSettingsError02.png

 

You may be right about the port 443 thing ... I noticed I have a virtual host for my DDNS running in Synology's Web Station ... I remember this being for setting up the DDNS & Let's Encrypt cert verification ... should I turn that off, I''m not hosting any websites or anything. Also, if I do would that shut down the Let's Encrypt cert automatically renewing?

Link to comment
Share on other sites

yarez0

Let’s encrypt need port 80 open to do the renew, if you are not hosting any website clear the config or delete web station. WS change the entire port and ngynx. I prefer using docker for hosting apps and webapp

Link to comment
Share on other sites

YES!! Turning off Web Station allowed me to "Enable a Customized Domain" and I was able to login remotely. I used the https://XXXX.ddns.net:443 and this is what I got:

5d5c1ccf45744_RemoteEmbyChrome.jpg

 

Though if you see the circle above, it's reporting "not secure" (I assume because the Reverse Proxy is set to http 8096)??

 

Also, I still am UNABLE to login with the iOS App (which seems weird as it's now working in a browser?!):

5d5c1d6ed2208_IMG_0126.png

 

I will try resetting the Reverse Proxy from http 8096 to https 8920 and retest. As a reminder, I am testing all this remotely.

Link to comment
Share on other sites

So I switched the Reverse Proxy back to https 8920 and I was NOT able to login remotely:

5d5c2009773d2_RemoteEmbyChromeErrorhttps

 

Here are the packages installed (Web Station is no longer running) as it seems maybe something else is also using port 443?? If that error above helps you pinpoint what this is I can start setting up Reverse Proxies for everything else as you have done!

 

5d5c217853e12_SynoPackages.jpg

Link to comment
Share on other sites

  • 2 weeks later...
yarez0

hi, sorry, holliday time

 

photo station and anything else station use custom port, you can specify url in reverse proxy settings with custom url settings like domain_name/audio for audio station, /video for video station etc. I did not used photo station, I prefer using piwigo in docker so I don't know, maybe you have to delete the app but I dont think so :

 

if you can connect to emby through port 443 it is because the port is free, the unsecure connection is another problem, a certificate problem.

 

let's take a look step by step. 

 

first if you are conecting througt https:// you do not need to specify :443 at the end of the url, https means port 443 like http means 80

 

second, iOS app, you have to set

 

that's my configuration, embeded reverse proxy will do the rest. If you can connect through the web you can connect with mobile apps

 

then the unsecure message, this message means that the using dns name does not correspond with the name or alternate name in your certificate. click on the unsecure message to display the certifiacte and go to DETAILS - then scroll back to ALTERNATE NAME or OTHER NAME (I don't know in english). take a look in my STEP 5, when you create a new let's encrypt certificate to replace the existing, ou have to add additionnal names, if multiple names, use ";"  without "space"

 

you are barely at the end of the configuration ! using reverse proxy to 8096 or 8920 will do the same, as a reverse proxy point of view, the important is the incomming port 443, that's its port which make the secure connection

Link to comment
Share on other sites

  • 1 month later...

Hi Luke,

 

Sorry for the late response, my internet has been awful since I came back and I'm moving to a new apartment (which I writing this message in - the internet is fortunately much better).

 

What happens when you try?

 

When I open Emby I get the following with the server 'Tong' on there - that server hasn't worked for almost as long as I've had Emby so I never use it when accessing my collection.

 

5d91b1f705a43_EmbyOpeningScreen.jpg

 

If I do click it will read Connection Failure.

 

5d91b21b92f39_EmbyifyouclickTong.jpg

 

If I sign in to Emby Connect it just takes me to the first screen again (a neverending loop).

Link to comment
Share on other sites

I believe I did albeit a while back (June/July) however can try again. How would I find out the host (the port is pre-populated)? I'm in Hong Kong however my family in the UK can take any recommended steps.

 

Have you tried clicking the add server button and entering the connection information manually?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...