Jump to content


Photo

Missing or Misplaces Series folder artwork for Series with Season Sub-Folders

series season subfolder artwork nfo library scan image sub-folder

  • Please log in to reply
5 replies to this topic

#1 JulsPlus OFFLINE  

JulsPlus

    Member

  • Members
  • 14 posts
  • Local time: 03:51 PM

Posted 29 April 2019 - 11:52 PM

Hello,

             I’ve searched the Emby forums and have found very similar postings but without the clear answer I am searching for. My TV library stores each episode into a separate season sub-folder. So my library folder structure is similar to what is shown below. The parent series folder (Star Trek) has no actual episode files directly in it. Instead, the season sub-folders (Season 1) contains the individual episodes. When Emby goes to work on scanning the library: nfo files (i.e. tvshow.nfo) and image files are populated within the season sub-folders (Season 1). There are no nfo or image files in the parent series folder (Star Trek). As a result, Emby does not display the series folder art work for the series (Star Trek).

 

             As an experiment and to prove my theory: I manually copied a single episode from one of the season folders into the parent series folder and rescanned. Bingo, I got folder art work. So either I’m missing an important setting/configuration or Emby doesn’t support folder artwork for series and season sub-folders. I’m hoping someone can point out the missing configuration or tell me “No, your out of luck” so that I can stop spinning my wheels.

 

TV Library

....Star Trek The Next Generation

.......Season 1

.......Season 2

......etc..

....Star Trek

 .......Season 1

.......Season 2

......etc..

 

As Always

Thank you in advance,

Julie


Edited by JulsPlus, 29 April 2019 - 11:53 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 128908 posts
  • Local time: 06:51 PM

Posted 30 April 2019 - 01:19 PM

Hi, your folder structure looks ok to me. I would try refreshing metadata on the series and see if that pulls in artwork. Thanks.



#3 JulsPlus OFFLINE  

JulsPlus

    Member

  • Members
  • 14 posts
  • Local time: 03:51 PM

Posted 30 April 2019 - 02:34 PM

Hello Luke,

 

             Thank you for the quick response, always appreciated. I’m very glad to hear you think the folder structure looks good. That must mean it is possible and that I have just missed some important configuration.

 

             Using the Metadata Manager, I’ve tried refreshing the metadata for an individual series folder (Arrow) with all three options (scan for new…, search for missing…, and replace all…) with no luck. I’ve enabled almost every option (advanced settings too) for the library. Is there a configuration file or debug log that I may provide in order to assist with identifying  the missing configuration or setting? I found the log entries (attached and below) were created while I was trying to refresh metadata for the parent series folder (Arrow). It only indicates the sub-season folders (Arrow\Arrow - 07) and not the series folder (Arrow).

 

2019-04-30 11:16:31.699 Info MediaEncoder: ProcessRun 'extract-image' Execute: C:\Users\MyUser\AppData\Roaming\Emby-Server\system\ffmpeg.exe -ss 00:04:14.240  -f matroska -i file:"C:\_Media\TV\Arrow\Arrow - 07\S07E15 - Training Day.mkv" -an -sn -threads 0 -vframes 1 -vf "scale=600:trunc(ow/a/2)*2,thumbnail=24" -f image2 "C:\Users\MyUser\AppData\Roaming\Emby-Server\programdata\cache\temp\1f629940-f8b8-4e1e-97ba-d30c5ca335b5.jpg"

2019-04-30 11:16:31.751 Info MediaEncoder: ProcessRun 'extract-image' Started.

 

Any help is greatly appreciated.

 

Juls

Attached Files



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 128908 posts
  • Local time: 06:51 PM

Posted 02 May 2019 - 11:25 PM

Based on the log I would suggest checking the settings for this Emby library and making sure that you've enabled internet metadata features. It looks like you may have turned them off because normally when you do those refreshes you would see activity with tvdb in the server log, but there is none here.



#5 JulsPlus OFFLINE  

JulsPlus

    Member

  • Members
  • 14 posts
  • Local time: 03:51 PM

Posted 07 May 2019 - 01:16 PM

Hello Luke,

 

I’ve selected the download internet option as you had suggested and started over with a new library. I have approx. two dozen TV series and only 4 were automatically identified, downloaded metadata, downloaded poster.jpg, and displayed correctly. Not a very high success rate.

 

I found that the external Ids (i.e IMDb Id, TheMovieDb Id, TheTVDb Id) for the problematic series’ were not populated within the metadata manager of the season folder. In contrast, the successful series’ had the external Ids automatically identified and populated to the season folders. I was able to select identify, type in the series name, search, select, and bingo: everything populated and displayed correctly for that season folder. However, I’m hoping not to have to do this manually for each  series/season folder.

 

I began to compare the successful and problematic series’ to see what might be different about them. IT’S THE YEAR!!!! The successfully identified series’ contain the year in the series folder name, the ones that failed did not. (i.e. The Flash (2014) vs Arrow). I had 4 series that had the year and those were the successful ones. So now what?

 

Is there a process that I can perform to create a log that will help you identify the issue and potential solution?

 

Thank you in advance,

Julie



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 128908 posts
  • Local time: 06:51 PM

Posted 07 May 2019 - 02:22 PM

Seasons don't need to have external IDs.

Your flash example is normal. There are multiple series called the flash and if your series folder does not contain the name, then you could end up with the wrong result.
  • laie_techie likes this





Also tagged with one or more of these keywords: series, season, subfolder, artwork, nfo, library, scan, image, sub-folder

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users