Jump to content
VaporTrail

"Midnight Campfire" Web App Styling

Recommended Posts

kesm

I just test it and it works

You can find more info there : https://pages.github.com

 

All you need is create the css file and after all the configuration, it will be accessible through https://yourusername.github.io/yourproject/your.css

then you just have to put 
 

@import url(https://yourusername.github.io/yourproject/your.css);

 in Custom CSS in settings and that's it all your future modifications in github will be automatically updated

Share this post


Link to post
Share on other sites
VaporTrail

That's really interesting @@kesm, I'll think about it!  :)

Share this post


Link to post
Share on other sites
VaporTrail

Version 8 is available. Main improvements include Cast & Crew and Login Form styling.

 

@@kesm, I don't think I'll host this on Github, but appreciate your help. Main reason being it would require internet access to function.  ;)

Share this post


Link to post
Share on other sites
igeoorge

Sem-t-tulo.png

 

 

Hi friends.
 
First congratulations for your work @@VaporTrail.
 
I liked how the Cast and Team pictures stayed.
 
Is it possible to have a link to Instagram?
 
Make a link between each character and the History of the instagram through API.
 
I'm new to the subject and I do not understand much. Would it be possible?
Edited by igeoorge

Share this post


Link to post
Share on other sites
igeoorge
I liked the cast and crew round.

 

I do not understand CSS. Could someone pass me the code to only change this for now?

Share this post


Link to post
Share on other sites
Happy2Play

 

I liked the cast and crew round.
 
I do not understand CSS. Could someone pass me the code to only change this for now?

 

 

 It is in the file in the first post, the "CAST & CREW THUMBNAILS" section.

  • Like 1

Share this post


Link to post
Share on other sites
VaporTrail

Thanks for the kudos @@igeoorge:)  I do not have ability to link to Instagram profiles. Apologies!

Share this post


Link to post
Share on other sites
kesm

Version 8 is available. Main improvements include Cast & Crew and Login Form styling.

 

@@kesm, I don't think I'll host this on Github, but appreciate your help. Main reason being it would require internet access to function.  ;)

You also could add the link to the css in the first post and users would have to choose between two options : 

 

- Add the import url 

- Explain that users with an Emby without internet would have to copy all the code from the link instead of using the import url

 

:)

Share this post


Link to post
Share on other sites
hshah

I've been trying this theme out for a bit and whilst I initially didn't like the red, it is begging to grow on me.  I've noticed that under each library settings, you cannot the text in the bottom three fields.  If I drag the cursor over the text, the numbers get highlighted and then can be seen.

 

5cf6b646bd804_Annotation20190604191524.p

Share this post


Link to post
Share on other sites
Happy2Play

I've been trying this theme out for a bit and whilst I initially didn't like the red, it is begging to grow on me.  I've noticed that under each library settings, you cannot the text in the bottom three fields.  If I drag the cursor over the text, the numbers get highlighted and then can be seen.

 

5cf6b646bd804_Annotation20190604191524.p

 

Are you on the most updated version 8?

 

 

 

5cf6d06ea07be_image.jpg

 

 

Okay I see what you mean as it is theme relevant.  If you are on the Light theme you see the issue you describe.

 

Looks like removing or commenting this out resolves the issue on the "Light" theme.  Didn't notice any side effect on Dark them, but didn't look very hard.

/*.dialog-content-centered {
   color: rgba(255, 255, 255, 0.87) !important;
}*/
Edited by Happy2Play

Share this post


Link to post
Share on other sites
Senna

Version 8 is available.

Tested this version in Edge and Firefox with user display set to Dark themes.

 

Edge: doesn't seem to work, even after log out and log in

Firefox: Manual login and Forget password buttons don't appear at Emby login screen.

Share this post


Link to post
Share on other sites
Happy2Play

Tested this version in Edge and Firefox with user display set to Dark themes.

 

Edge: doesn't seem to work, even after log out and log in

Firefox: Manual login and Forget password buttons don't appear at Emby login screen.

Edge shows the same as Chrome for me.

 

Manual login and Forget password buttonsBy design removed.

#loginPage .raised.cancel.block.btnManual.emby-button {
   display: none;
}
#loginPage .raised.cancel.block.btnForgotPassword.emby-button {
   display: none;
}
  • Like 1

Share this post


Link to post
Share on other sites
hshah

Are you on the most updated version 8?

 

Okay I see what you mean as it is theme relevant.  If you are on the Light theme you see the issue you describe.

 

Looks like removing or commenting this out resolves the issue on the "Light" theme.  Didn't notice any side effect on Dark them, but didn't look very hard.

/*.dialog-content-centered {
   color: rgba(255, 255, 255, 0.87) !important;
}*/

 

 

Under Display settings, I had set the theme as Dark but Dashboard as Light, because that is what it said in the first post.  That is what I had understood the below to mean.  Having read it again though, and noticed "This feature requires an active Emby Premiere subscription" below the Dashboard theme dropdown, I guess that information was meant for the non-Premier users.  I have gone and set my Dashboard theme to Dark as well now and it looks even better... not sure why I hadn't bothered trying it in the first place lol.

 

 

As a solution, download and apply the custom CSS attached to this post in Admin Dashboard > Settings > Custom CSS. The "Midnight Campfire" web app styling can be used with the free or premiere version of Emby. You'll need to use the "Dark" theme and "Light" server dashboard theme for changes to apply correctly in User Settings > Display.

Share this post


Link to post
Share on other sites
Senna

Edge shows the same as Chrome for me.

My bad, Edge has bad refresh it seems.

 

Manual login and Forget password buttons

 

By design removed.

 

#loginPage .raised.cancel.block.btnManual.emby-button {
   display: none;
}
#loginPage .raised.cancel.block.btnForgotPassword.emby-button {
   display: none;
}

Thanks for pointing me in right direction to comment those lines :)

Share this post


Link to post
Share on other sites
kesm

Got an issue when I tried to copy API key from Security, since API key is uppercased by the theme it wasn't recognized by Organizr, I had to remove the theme and copy the key to have it working

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...